none
Full Duplex setting

    Question

  • Based on thread  http://forums.technet.microsoft.com/en-US/winservercore/thread/4dc954dc-c0a9-43c0-98a4-6ee90789b7ce

    I'm unable to get these steps to work:
    - I don't have a Full Edition to export a registry section, nor is that a pallitable solution for a large company as we are.
    - While I have found the key necessary for the changes, it's not clear exactly where to create the new entry (at the VEN level or lower?) or what type (DWORD, String, etc.). I assume one level lower than VEN and a String??
    - The key will not let even an Administrator create anything in this hive. "Administrator(s)" does not have Full Control, nor can I seem to grant it. Only SYSTEM has Full Control.

    Any ideas?
    Monday, August 11, 2008 4:49 PM

Answers

  • My guess is that you'd need to use the NIC-specific registry key to set this under:
    HKLM\SYSTEM\CurrentControlSet\Control\Class\GUID\INTNUM\Vendor-specific-registrykey

    I needed to do this for a couple of different registry keys to get 802.1Q VLAN tagging to work. 

    The GUID seems to be different between server to server, but the first part of the GUID is always {4D36E972 so I used the following code to set my parameters:

    @ECHO OFF
    FOR /F "usebackq" %%a IN (`REG query HKEY_LOCAL_MACHINE\SYSTEM\CurrentcontrolSet\Control\Class /f {4D36E972*`) DO CALL :LOOP %%a
    GOTO END

    :LOOP
    IF NOT [%1]==[End] (
     REG ADD %1\0007 /v VlanFiltering /t REG_SZ /d 0 /f
     REG ADD %1\0012 /v VlanID /t REG_SZ /d 1 /f
     )
    EXIT /B
    GOTO END

    :END

    It is not pretty and I still haven't found an automatic way of matching particular interfaces of a dual port card to which number they are expect handrollicly.

    For my on board HP DL 380G5 NIC the setting was *SpeedDuplex, REG_SZ where:
    0=Auto
    1=10 Half
    2=10 Full
    3=100 Half
    4=100 Full
    2164261634=1Gb Full Auto

    Cheers,
    Jeremy.

    Thursday, August 14, 2008 11:04 PM

All replies

  • Hi,

    You should be able to take ownership of the key and change the permissions on it. The key should be created at the same level as the full installation.

    Depending on the NIC you are using, the NIC vendor may have a command line tool that you can use to set this.

    Andrew
    Tuesday, August 12, 2008 11:16 PM
  • "Administrator" is already the owner. I am logged in as Administrator and it won't let me change any permissions on the key.
    This is a clean install and is like this on all clean installs we've done (no cloning).
    Wednesday, August 13, 2008 7:47 PM
  • My guess is that you'd need to use the NIC-specific registry key to set this under:
    HKLM\SYSTEM\CurrentControlSet\Control\Class\GUID\INTNUM\Vendor-specific-registrykey

    I needed to do this for a couple of different registry keys to get 802.1Q VLAN tagging to work. 

    The GUID seems to be different between server to server, but the first part of the GUID is always {4D36E972 so I used the following code to set my parameters:

    @ECHO OFF
    FOR /F "usebackq" %%a IN (`REG query HKEY_LOCAL_MACHINE\SYSTEM\CurrentcontrolSet\Control\Class /f {4D36E972*`) DO CALL :LOOP %%a
    GOTO END

    :LOOP
    IF NOT [%1]==[End] (
     REG ADD %1\0007 /v VlanFiltering /t REG_SZ /d 0 /f
     REG ADD %1\0012 /v VlanID /t REG_SZ /d 1 /f
     )
    EXIT /B
    GOTO END

    :END

    It is not pretty and I still haven't found an automatic way of matching particular interfaces of a dual port card to which number they are expect handrollicly.

    For my on board HP DL 380G5 NIC the setting was *SpeedDuplex, REG_SZ where:
    0=Auto
    1=10 Half
    2=10 Full
    3=100 Half
    4=100 Full
    2164261634=1Gb Full Auto

    Cheers,
    Jeremy.

    Thursday, August 14, 2008 11:04 PM