locked
System error 64 - the specified network name is no longer available

    Question

  • I'm having a problem connecting to Windows 2008 Server shares, administrative or explicit.  I have an account that is a member of the Administrators group on the target machine.  I can't enumerated the shares using NET VIEW \\<server> from the command prompt (WinXP workstation and Win2003 server clients).  I've checked the firewall settings (all off) and UAC is also off.  Other people seem to be able to access the share.  The share I'm trying to access has the Everyone group (I know BAD idea but I didn't go this) with READ control share permissions and the NTFS permissions give Domain Users Read/Execute control.  I've also created an explicit share for the IIS logs and given Domain Users Full Control via share permissions and Domain Users Read/Execute via NTFS and still can't see or connect to the share I just created.

    I didn't set the machine up so I don't have a lot of detail about the configuration but it *should* be pretty vanilla.  Has anyone else seen anything like this?
    Tuesday, March 31, 2009 9:20 PM

Answers

  • I agree with Sainath,  Perform test that he had recommended.  The earlier version of Legacy OS such as Win XP or Server 2003 uses SMB1.  I had experienced in issue very similar recently.  Disabling SMB2 unfortunately didnt resolve the issue for me.  I am not saying you shouldnt attempt it, because it could be a valid resolution.  I had to "Maximize the throughput for File Sharing and Network Applications.  Pleas be sure the backup/export you registry keys prior to proceeding with any modifications. 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\size

    Your choices for this registry key are 1,2 and 3.

    1 = Minimize Memory Used
    2 = Balance
    3 = Maximize Throughput for File Sharing and Maximize Throughput for Network Applications

    Be sure to set this to (3). By default it is configured to 1.

    I hope this helps,

    Thank you,

    Aaron Griffin
    Friday, April 03, 2009 10:46 PM

All replies

  • hi there,

    i would like you to conduct few test case scenarios

    a) are you able to perfrom file sharing between windows 2008 --windows 2008 ?

    b) are you able to access shares from windows 2008 --> any other Os ?

    c) can you map a drive without error from windows 2003, windows xp to -- windows 2008 ?

    you can test your issue by disabling smb2 protocol on windows 2008 server. ( windows 2008 , windows vista, windows 7 supports smb 2 protocol for filesharing , but windows 2003, xp and earlier versions of OS doesnt support smb 2 protocol )

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    Edit menu, point to New , and then click DWORD Value, Type SMB2 , set value to "0" (zero).


    hope it helps


    sainath Windows Driver Development
    Wednesday, April 01, 2009 4:10 AM
  • I agree with Sainath,  Perform test that he had recommended.  The earlier version of Legacy OS such as Win XP or Server 2003 uses SMB1.  I had experienced in issue very similar recently.  Disabling SMB2 unfortunately didnt resolve the issue for me.  I am not saying you shouldnt attempt it, because it could be a valid resolution.  I had to "Maximize the throughput for File Sharing and Network Applications.  Pleas be sure the backup/export you registry keys prior to proceeding with any modifications. 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\size

    Your choices for this registry key are 1,2 and 3.

    1 = Minimize Memory Used
    2 = Balance
    3 = Maximize Throughput for File Sharing and Maximize Throughput for Network Applications

    Be sure to set this to (3). By default it is configured to 1.

    I hope this helps,

    Thank you,

    Aaron Griffin
    Friday, April 03, 2009 10:46 PM