none
Error: A connection was successfully established with the server, but then an error occurred during the login process.

    Question

  • Hi There,
    I have MsSql running in clustering environment and recently am facing the problem where there is a security agent installed in MsSql server, whereby the agent does nothing but to only capture local database activity. The error prompted is as below:

    Step ID             1

    Server               NIBKSQLCLUST

    Job Name                      LSBackup_DRIB

    Step Name                    Log shipping backup log job step.

    Duration                        00:00:02

    Sql Severity                   0

    Sql Message ID             0

    Operator Emailed                      

    Operator Net sent                     

    Operator Paged            

    Retries Attempted                      0

     

    Message

    2011-03-21 08:00:02.62  *** Error: Could not retrieve backup settings for primary ID '26f46141-a676-41b2-8653-11f1b13de43a'.(Microsoft.SqlServer.Management.LogShipping) ***

    2011-03-21 08:00:02.63  *** Error: Failed to connect to server NIBKSQLCLUST.(Microsoft.SqlServer.ConnectionInfo) ***

    2011-03-21 08:00:02.63  *** Error: A connection was successfully established with the server, but then an error occurred during the login process. (provider: Named Pipes Provider, error: 0 - No process is on the other end of the pipe.)(.Net SqlClient Data Provider) ***

    2011-03-21 08:00:02.63  ----- END OF TRANSACTION LOG BACKUP   -----

     

    The process run successfully when I have turned the security agent off. Kindly advice the cause for this issue and is there any configurations need to be set/changed in MsSql server.

     

    Thanks,

    Boonlep Chua

    Tuesday, October 04, 2011 10:12 AM

All replies

  • I have exactly the same error. Please help.
    Friday, December 09, 2011 7:16 PM
  • If you have clone/copy the server instalation fron one server to another, you have to change se the machine name in the database tables.

     

    Otherwise the SQl agent job log shipping job keeps on saying " *** Error: Could not retrieve backup settings for primary ID ' ..."

     

    Read this article http://technet.microsoft.com/en-us/library/ms143799.aspx

     

    It took me 8 hours to figure it out.

     

    Best regards

    Wednesday, December 28, 2011 5:10 PM
  • Hi There,
    I have MsSql running in clustering environment and recently am facing the problem where there is a security agent installed in MsSql server, whereby the agent does nothing but to only capture local database activity. The error prompted is as below:

    Step ID             1

    Server               NIBKSQLCLUST

    Job Name                      LSBackup_DRIB

    Step Name                    Log shipping backup log job step.

    Duration                        00:00:02

    Sql Severity                   0

    Sql Message ID             0

    Operator Emailed                      

    Operator Net sent                     

    Operator Paged            

    Retries Attempted                      0

     

    Message

    2011-03-21 08:00:02.62  *** Error: Could not retrieve backup settings for primary ID '26f46141-a676-41b2-8653-11f1b13de43a'.(Microsoft.SqlServer.Management.LogShipping) ***

    2011-03-21 08:00:02.63  *** Error: Failed to connect to server NIBKSQLCLUST.(Microsoft.SqlServer.ConnectionInfo) ***

    2011-03-21 08:00:02.63  *** Error: A connection was successfully established with the server, but then an error occurred during the login process. (provider: Named Pipes Provider, error: 0 - No process is on the other end of the pipe.)(.Net SqlClient Data Provider) ***

    2011-03-21 08:00:02.63  ----- END OF TRANSACTION LOG BACKUP   -----

     

    The process run successfully when I have turned the security agent off. Kindly advice the cause for this issue and is there any configurations need to be set/changed in MsSql server.

     

    Thanks,

    Boonlep Chua

    Follow the link. and run the Script..  fix for this issue.
    Wednesday, January 04, 2012 5:23 PM