none
Regrading full windows drag in remoteapp

    Question

  • Hi,

    I've set up the "disable full window drag:i:1" setting in the rdp file for a remoteapp program, but it does not work.

    Using windows 7, RDP 7.1 (haven't upgraded to 8.0).

    Doesn't this setting work for remoteapps?

    Thanks

    Friday, November 23, 2012 11:33 AM

All replies

  • Anyone wanna take a shot at this one? I've tried everything :P
    Sunday, November 25, 2012 4:48 PM
  • Hi,

    Thank you for your question.
    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,
    Aiden

    If you have any feedback on our support, please click here


    Aiden Cao
    TechNet Community Support

    Wednesday, November 28, 2012 1:45 AM
    Moderator
  • Hi,

    Wish below posts can help you:

    http://helpdesk.yourofficeanywhere.co.uk/KB/a81/how-to-configure-custom-rdp-settings-windows-2008-remoteapp.aspx

    http://social.technet.microsoft.com/Forums/sa/winserverTS/thread/c2af56f8-0655-456a-94c1-d2edb0c69281

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, November 28, 2012 9:49 AM
  • Hi,

    Regarding your second post, as i stated in the post i've tried setting it on the remoteapp custom settings, without any effect.

    I've also read the first post, and I find it a bit troublesome that to be able to disable "full windows drag" I need to disable it for all my local programs also.

    I know i can set this in the Advaned performance settings on my client, or even code it using something like http://support.microsoft.com/kb/185637, however, I want to be able to disable it only for the remoteapps.

    I reckon this is not possible then?

    Wednesday, November 28, 2012 9:55 AM
  • Hi,

    The setting(disable full window drag:i:1) is used to determine whether folder contents appear when you drag the folder to a new location. This setting corresponds to the selection in the Show contents of window while dragging check box on the Experience tab of Remote Desktop Connection Options.

    Now I advise you do the following test:

    ============================

    a. Set up a RDWeb server, then publish the RemoteApp via RDWeb.

    b. On the Windows 7 client, set up RemoteApp and Desktop Connections in Control Panel. Then by default the published RemoteApp applications RDP shortcut will be copied to c:\users\<username>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\RemoteApp and Desktop Connections\Work Resources.

    c. Use notepad to open these RDP shortcut, add "disable full window drag:i:1" enter in it. Then try to reproduce the issue and check whether it works.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, November 29, 2012 8:55 AM
  • Hi,

    That's what i did in the first place:

    "..I've set up the "disable full window drag:i:1" setting in the rdp file for a remoteapp program, but it does not work."

    What works is the following:

    On the client computer, go to "System"->"Adjust the appearance and performance of Windows" and disable the "Show windows contents while dragging".

    But like i said the earlier response, that disables it for all windows, both local and remoteapp. So basically, I'm asking, is it possible to do it for only the remoteapp windows?

    As you can see in the 2nd post you added in your response, he also had to set it up on the client.

    Regards,

    Thursday, November 29, 2012 9:05 AM
  • Hi,

    Generally, we just treat RemoteApp as a RDP session, for RDP session, the recommanded way to set "disable full window drag:i:1" is the setting in RemoteApp program.

    Based on my research and test result, I am afraid that there is not a solid solution that only set "disable full window drag:i:1" for RemoteApp windows.

    Thanks for your understanding.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, December 03, 2012 5:18 AM