none
Add New Virtual Network Interface to RRAS

    Question

  • In the past (W2k3), adding an interface to the OS would also cause that interface to be added to RRAS.  I have a server running RRAS and it has multiple VMs running in Hyper-V.  I want to add an isolated VM that has a single port available from the Internet to that VM.  I have added an Internal Virtual Network and configured it with a static IP (in the host OS) (same configuration (except IP address) as my other virtual network interfaces).  The new interface does not show up in RRAS even after restart.  In W2k3, you could add an interface in the Network Interfaces area.  In W2k8, the only interface you can add is a demand-dial interface.

    In the past, I had to delete the RRAS server and reinstall it to see the new interface.  This is ugly as it removes, for an extended time, all of the mappings, filters, etc. that I have in place.

    Any ideas on how to manually add a new interface to RRAS either by registry, powershell, script, etc.?
    Pete
    Friday, November 21, 2008 7:48 PM

All replies

  • I take it by the deafening silence that this is a bug in W2k8 RRAS.  I hope that Microsoft revisits this and reinstitutes the ability to "dynamically" add and delete network interfaces in RRAS as was the ability in W2k3.  Hyper-V makes this capability even more important as we now have the ability to add and delete network interfaces almost at-will.

    Pete
    Pete
    Sunday, January 04, 2009 1:57 PM
  • Hi Pete,

        I faced the same problem. "Disabling RRAS" & "Configure & Enabling RRAS" resolves the problem.
    You need not to remove RRAS role and add it again.

        But first save the RRAS configuration using "netsh ras dump > RRASBackUp.cmd" and use the command
    file to configure RRAS in same state "netsh -f RRASBackUp.cmd"

    Thanks 
    Tuesday, January 06, 2009 3:37 PM
  • Hi everyone,

    This major problem still occur on 2008 R2.
    Removing RRAS role and adding it again doesn't solve the problem.
    Disabling RRA role and enabling it doesn't solve the problem.

    In the two cases, you need, before re-adding role or re-enabling service, to :

    1. Administrator tool > Routing and remote access > Routing and remote console select your server name

    2. Right click > Disable routing and remote access

    3. Open RRAS > File > option > delete file

    4. Restart system


    Anyone have news about this problem ?

    Thanks,

    Patrick.
    Wednesday, November 04, 2009 3:09 PM
  • I can confirm that the solution posted by P. Raujol works fine :)
    Friday, December 11, 2009 10:39 PM
  • > I can confirm that the solution posted by P. Raujol works fine :)

    I can confirm it too :)


    http://www.sysadmins.lv
    Monday, April 19, 2010 11:41 AM
  • I've got the same problem on VMWare 4.01 farm with 2008R2 and TMG. I add another adapter and I can't see it in RRAS. I had the same problem with TMG until I installed rollup 1.

    I fixed it without removing RRAS or disabling and deleting stuff. You have to use regedit  -- only do this if you know what you're doing --

    Open HKLM\SYSTEM\CurrentControlSet\services\RemoteAccess\Interfaces in regedit

    locate the last interface, in my case it was interface 8.

    Right click 8 and select export.

    Save the export to the desktop.

    Right click the file you saved on the desktop and select edit

    everywhere it says "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RemoteAccess\Interfaces\8" change the 8 to 9 (or whatever the next available number is for you)

    Go back to regedit and open HKLM\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces look through each interface until you find the one that is missing from RRAS. Copy the GUID for the missing interface.

    Replace the GUID in InterfaceName in the exported file that you have open in notepad with the GUID you copied from the previous step

    Save the export file

    Click 'Import' in the File Menu in Regedit and select the file on your desktop

    In RRAS msc right click the server and select 'Restart' in the all tasks menu.

    Your interface should now be available :)

    Might seem complicated but it's not. 

     


    • Edited by qldscottie Tuesday, April 19, 2011 6:22 AM clarification
    • Proposed as answer by qldscottie Tuesday, April 19, 2011 6:26 AM
    Tuesday, April 19, 2011 6:20 AM
  • qldscottie, thanks! That was always ticking me off after each virtualbox upgrade - it deletes and recreates the host-only interface and I had to reconfigure RRAS every time. Your method works! Just two notes - 1. export LAN interface. Or in regedit after import set type of new interface to 3 (=LAN). If you export/import dialup interface it would be equal to 4 and won't work. 2. after import - check new network parameters and static routes in RRAS MMC. Everything will be duplicated from exported interface - meaning you could get two 0.0.0.0/0.0.0.0 routes with same metric.
    Saturday, May 14, 2011 2:35 PM
  • In our case, it was required to open regedit and navigate to: "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RemoteAccess\Interfaces\" and deleting the missing interface (exporting the interface before purging, of course).

    We had the typical 0=Loopback & 1=Internal and 3={GUID} was present but not showing up.

    Tried what P.Raujol suggested regarding disabling and restarting but unfortunately it didn't resolve the issue.  Even tried adding a new interface "Local Area Connection 2" to the VM host but it too did not show up under RRAS ... err?

    So in regedit under "HKLM\...\RemoteAccess\Interfaces\", we exported and purged interface 3 and rebooted.  If I recall it correctly, even after the reboot, a bit more tinkering (or time) was required to "encourage" the "Local Area Connection" to show up (or again, it took sometime to realize it was there).

     

    NOTES: Infrastructure: VMWare vSphere ESX 4.1  --- This VM host with the RRAS issue is a Windows 2008 R2 SP1.

    • Proposed as answer by mamadoubila Saturday, May 12, 2012 10:36 PM
    Monday, September 12, 2011 5:39 PM
  • Disabling RRAS every time is not a valid solution. It is not acceptable to reconfigure everything and for anything but the most basic configuration means a lot of work, e.g. if you have an established production virtualized router or remote access server and want to add a NIC to scale-up it means a risky task of reconfiguring everything and hoping you didn't miss something.

    The problem is every time MS suggests this they forget about fixing the CAUSE of the problem. I saw an MS connect item about this on Windows Server 2003 and I know RRAS has terrible reliability since 2000, we now have 2012 server and that still has the problem!

    Can somebody at MS please address this issue. It also affects adapters added via Hyper-V not just VMware and I would also imagine adapters added by any other virtual device driver, e.g. perhaps modems and other add-on devices.

    How about at least providing a NetSh or PowerShell command to cause RRAS to go through the detection of network adapters without wiping the configuration first?


    Key Artefacts

    Wednesday, October 31, 2012 11:08 AM
  • I found a new way around this which should work for everyone, a twist on the existing registry solution:

    1. Open RegEdit.exe.
    2. Go to "HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces" where each of your network adapters (physical or virtual) has a GUID named sub-key. Identify which one is your network adapter (look at the IP or DHCP settings in the child key=values or configure a temporary address so you can find it). Now you have discovered the GUID. Click the GUID key then hit F2 to goto rename mode and highlight the whole key, hit CTRL+C to copy to the clipboard.
    3. Go to "HKLM\System\CurrentControlSet\Services\RemoteAccess\Interfaces". Add a new sub-key which is the next in sequence, for example I had 1...6 so I added "7". This is key add the following...
    4. A DWORD32 (32bit integer) called "Enabled" set to 1.
    5. A REG_SZ (string) called "InterfaceName" then paste your interface GUID, e.g. set to "{XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}".
    6. A DWORD32 called "Stamp" set to 0.
    7. A DWORD32 called "Type" set to 3 (LAN).
    8. Restart RRAS, the interface will appear!
    9. Right click each protocol, e.g. IPv4, IPv6 then you can right click "General" to add a "New Interface..." and your interface will then be enabled for that protocol.

    I'm happy I played around a bit more to find that now. But MS even though we have a solution which does not require us to lose our configuration, please fix the source of this problem!


    Key Artefacts

    Wednesday, October 31, 2012 11:32 AM
  • Disabling RRAS every time is not a valid solution. . . .

    The problem is every time MS suggests this they forget about fixing the CAUSE of the problem. I saw an MS connect item about this on Windows Server 2003 and I know RRAS has terrible reliability since 2000, we now have 2012 server and that still has the problem!

    Can somebody at MS please address this issue. It also affects adapters added via Hyper-V not just VMware and I would also imagine adapters added by any other virtual device driver, e.g. perhaps modems and other add-on devices.

    How about at least providing a NetSh or PowerShell command to cause RRAS to go through the detection of network adapters without wiping the configuration first?

    I am sure everyone will be happy to know that Server 2012 R2 RTM (build 9600) still has the same issue.
    Saturday, October 26, 2013 10:18 PM
  • Yeah I agree.... Windows Server 2012 and 2012 R2... anyway disabling and settting up the service again works like a charm.... good job MS!!!!! you keep a product on your server systems that needs to be "reset to factory settings" (like a 10 years old adsl router, oh wait... the rras core has been the same for years). If someone at Microsoft reads this... please... DNS, DHCP and RRAS are core services... rewrite them... transform them into good networking services at least if you do not plan to sell cheaper OSes.

    Thursday, April 24, 2014 5:26 PM