none
VDI trust publisher

    Question

  • Hi all

    i've setup VDI using RDS and working 100 % but when try to access to my Pool faced this notification

    also i set this certificate in trusted and all machines joing domain (trusted) and set this certificate in "Digital Certificate "  in RDS Connection Manager

    Aslo the same notification faced in Remote App server (another Server)

    is this is the default or any additional configuration required ?

    Thanks for support

    ********************************

    Another issue

    when i try to remote RDS server host (Remote App - Connection Broker installed ) faced this error .

     this happened because this server running in redirection mode but i still can't access remotly to this server

     if i add another NIC and access using new NIC

    or

    any additional configurations ?

    Thanks Again

    Thursday, February 23, 2012 9:07 AM

Answers

  • Hi,

    The warning you are seeing is normal. 

    When logging on to RD Web Access please select This is a private computer option (assuming it is not a public computer).  When a user first launches a RemoteApp they will receive the prompt:

    A website wants to run a RemoteApp program. Make sure that you trust the publisher before you connect to run the program.

    Select Don't ask me again for remote connections from this publisher to prevent the prompt from being displayed in the future.  It will be displayed again if you add more redirection options later in RemoteApp Manager.

    For PCs that are members of your domain you may enable the group policy setting Specify SHA1 thumbprints of certificates representing trusted .rdp publishers to disable the warning prompt.  You want to enter the thumbprint from the details tab when you are viewing the certificate, however, you must remove the spaces.  Below is a sample thumbprint:

    E23FE25A13F8F1ED1CA8EA4C6F0E8A47C39EF162

    You may also want to consider applying the following hotfix to your Windows 7 client PCs:

    The single sign-on feature does not work in Windows 7 or in Windows Server 2008 R2 when you try to start a full remote desktop connection through RD Web Access

    http://support.microsoft.com/kb/2524668

    ******************************** Second Issue

    When connecting to your server that is in redirection mode please use the /admin command line switch, like this:

    mstsc /admin

    Thanks.

    -TP

    • Marked as answer by Some1Hard Sunday, February 26, 2012 8:47 AM
    Thursday, February 23, 2012 9:52 AM

All replies

  • Hi,

    The warning you are seeing is normal. 

    When logging on to RD Web Access please select This is a private computer option (assuming it is not a public computer).  When a user first launches a RemoteApp they will receive the prompt:

    A website wants to run a RemoteApp program. Make sure that you trust the publisher before you connect to run the program.

    Select Don't ask me again for remote connections from this publisher to prevent the prompt from being displayed in the future.  It will be displayed again if you add more redirection options later in RemoteApp Manager.

    For PCs that are members of your domain you may enable the group policy setting Specify SHA1 thumbprints of certificates representing trusted .rdp publishers to disable the warning prompt.  You want to enter the thumbprint from the details tab when you are viewing the certificate, however, you must remove the spaces.  Below is a sample thumbprint:

    E23FE25A13F8F1ED1CA8EA4C6F0E8A47C39EF162

    You may also want to consider applying the following hotfix to your Windows 7 client PCs:

    The single sign-on feature does not work in Windows 7 or in Windows Server 2008 R2 when you try to start a full remote desktop connection through RD Web Access

    http://support.microsoft.com/kb/2524668

    ******************************** Second Issue

    When connecting to your server that is in redirection mode please use the /admin command line switch, like this:

    mstsc /admin

    Thanks.

    -TP

    • Marked as answer by Some1Hard Sunday, February 26, 2012 8:47 AM
    Thursday, February 23, 2012 9:52 AM
  • Thanks TP

    for you replaying :)

    Sunday, February 26, 2012 8:48 AM