none
RDC for MAC cannot connect to TS server with error message "You were disconnected from the Windows-based computer because of problems during the licensing protocol".

    Question

  • the mac clients are running RDC for mac version 2.1 and they cannot connect to Windows 2008 R2 TS server. They get the error "You were disconnected from the Windows-based computer because of problems during the licensing protocol".

    really appreciated if someone have a fix for this.

     

    thanks,

    /dan

     

    Wednesday, November 09, 2011 10:53 PM

Answers

All replies

  • Hi,

    Please check the following:

    1. On your RD Licensing Server, please open RD Licensing Manager (licmgr.exe) and verify that the server is activated, your purchased RDS CALs are installed, and there are RDS CALs available.  You may install the RD Licensing Role Service on the same server as the RD Session Host Role Service if desired.

    2. In RD Session Host Configuration (tsconfig.msc), please make sure that your RD Licensing server is Specified and the Licensing mode matches the type of RDS CALs you purchased.  For example, if you purchased/installed Per User RDS CALs, make sure that it is set to Per User.

    3. After verifying the above is correct, please try to connect from a mac again.

    Thanks.

    -TP

    Wednesday, November 09, 2011 11:24 PM
    Moderator
  • TP,

    thanks for the tips but it does not help. ts cal license config on the server is not the issue. the server obtains user CAL from valid TS lic servers and it works for windows clients but not for mac.  the mac clients were connecting to 2003 TS server also running user CAL and they work fine. I think the mac clients cached the TS cal locally for 2003 TS server and the CAL token is not compatible with 2008 TS server so it needs to be flushed out and get a new one from 2008 TS server. I just cannot find a way to flush it out for mac clients. this MS KB http://support.microsoft.com/kb/187614  talks about the location to get rid of it but the mac user stated directory is not found on the mac.

     

    Thursday, November 10, 2011 3:20 AM
  • Hi,

    Per User RDS CALs are not stored on the client regardless if the client is windows, mac, linux, iOS, etc.  This is true for 2003 as well as 2008.

    1. In RD Session Host Configuration (tsconfig.msc) is the licensing mode set to Per User?  If yes, how are you setting the mode, via Group Policy or manually in RD Session Host Configuration?  If you are setting it via GP, please temporarily change the GP setting to Not configured, run gpupdate /force on your server, then attempt to set the mode via RD Session Host Config.  After setting mode via RD Session Host Config, close and then reopen RD Session Host Config and check that it still says Per User.

    2. Please check the server's logs for errors/warnings relating to licensing and post them here.  When a Mac user attempts to connect there should be a corresponding error message logged on your server.  Additionally look for errors/warnings from Source TerminalServices* at server startup relating to licensing issues.

    3. In RD Licensing Manager, have any temporary RDS Per Device CALs been issued?  Please create a Per User Usage report, right-click on the report and choose to Save as a .csv file, and then open the file in Notepad.  Have Per User RDS CALs been issued to your users?

    4. Are you able to connect from the Mac using CoRD?

    5. If possible are you using version 2.1.1 of the Mac RD Client?

    Thanks.

    -TP

    Thursday, November 10, 2011 8:02 PM
    Moderator
  • Hi TP,

    below are the answers to your questions.

    1. TS lic mode is set to per user confirmed it works for windows clients.

    2. the TS server's system log logged error "The Terminal Server security layer detected an error in the protocol stream and has disconnected the client".

    3. the reports shows per user cal has been issued to users. no temp per device cal has been issued.

    4. yes, CoRD works .

    5. we tried version 2.1.1 of the Mac RD Client but it also does not work.

     

    Thanks.

     

     

     

    Wednesday, November 16, 2011 7:40 PM
  • Hey,

    Any proposed answer for this ?

    I face the same problem and my environment 

    and I've got same results as dle2k

    1. TS lic mode is set to per user confirmed it works for windows clients.

    2. the TS server's system log logged error "The Terminal Server security layer detected an error in the protocol stream and has disconnected the client".

    3. the reports shows per user cal has been issued to users. no temp per device cal has been issued.

    4. yes, CoRD works .

    5. we tried version 2.1.1 of the Mac RD Client but it also does not work.

     

    Sunday, February 26, 2012 8:17 PM
  • I'm having the same problem with error "You were disconnected from the Windows-based computer because of problems during the licensing protocol". Running 2.1.1 of the Mac RD Client. CoRD also works here, but can't get CoRD to forward printers, therefore I would like the Mac RD Client to work. Anyone who has found a solution?
    Monday, May 07, 2012 9:26 AM
  • I have been working with MS Technet support on this for 3 weeks, have the same problems.  No one there seems to know how to fix this. Very frustrated with MS Support.  They even tell me things like, "You should contact Apple"  I will keep you posted, but I have talked with close to 10 people there so far and still no results. 

    We have been using terminalworks as a temporary solution, which also prints.  So yes CoRD works for us too. We have tried every different version of RDC and nothing works.  We migrated from a 2003 TS and everything worked fine there.  Try a trial of www.terminalworks.com as a short term solution if nothing else.  

    Support has had us capture network packets on the client and server and forward them, as well as running procmon on both client and server.  Still no fixes.  I think it has to do with a certificate.  We don't have a certificate installed. Hanz0y.. do you have a certificate on your server?


    Saturday, June 02, 2012 6:34 PM
  • I have been working with MS Technet support on this for 3 weeks, have the same problems.  No one there seems to know how to fix this. Very frustrated with MS Support.  They even tell me things like, "You should contact Apple"  I will keep you posted, but I have talked with close to 10 people there so far and still no results. 

    We have been using terminalworks as a temporary solution, which also prints.  So yes CoRD works for us too. We have tried every different version of RDC and nothing works.  We migrated from a 2003 TS and everything worked fine there.  Try a trial of www.terminalworks.com as a short term solution if nothing else.  

    Support has had us capture network packets on the client and server and forward them, as well as running procmon on both client and server.  Still no fixes.  I think it has to do with a certificate.  We don't have a certificate installed. Hanz0y.. do you have a certificate on your server?



    Nope, we don't have a certificate on our server. I have also opened a ticket at Microsoft support, for about 2 weeks now and haven't got it fixed. Thank you for the temporary solution. We have also used a temperary solution, iTap Mobile RDP which also supports print. I will post my updates in here.
    Tuesday, June 05, 2012 2:09 PM
  • Did you try to use a trusted certificate on the server side ?

    Ps: I have seen this problem both when trying to connect from Mac to Windows server and Mac to Mac server(running Microsoft RDP).

    • Edited by dragos3 Wednesday, June 06, 2012 12:13 PM
    Wednesday, June 06, 2012 12:10 PM
  • No we haven't. Just got a call from an Microsoft Support Engineer, it seams that this is a known issue for the Remote Desktop Connection Client for Mac and there will be an update, but he couldn't say when.
    They did have a temporary workaround though http://www.formaceyesonly.com/2009/07/28/rdc-licensing-and-the-mac/
    But sadly it didn't work for me, because the old 1.0.3 version of RDC Client for Mac supports only up to Server 2003.
    I will have to stick to iTap Mobile RDP until Microsoft releases a new version which fixed the issue.

    Wednesday, June 06, 2012 2:22 PM
  • Same problem here.

    Just bought 186 licences and it no worky

    any idea when the update will be released?


    • Edited by Kirbies Tuesday, June 12, 2012 3:21 PM
    Tuesday, June 12, 2012 3:21 PM
  • Same problem here.

    Just bought 186 licences and it no worky

    any idea when the update will be released?



    Unfortunaly no. The guy i talked to had no idea when the new update will be released.
    Wednesday, June 13, 2012 11:40 AM
  • I have fixed this for you

    You can find the fix here http://www.mydanat.co.uk/blog

    Please leave usefull comments to make the quick fix better


    • Edited by Kirbies Thursday, June 14, 2012 12:42 PM
    • Proposed as answer by forusfirst Saturday, August 04, 2012 5:44 PM
    Thursday, June 14, 2012 12:36 PM
  • I have fixed this for you

    You can find the fix here http://www.mydanat.co.uk/blog

    Please leave usefull comments to make the quick fix better


    Thank you S.Logan, but sadly your fix didn't worked for me.
    Friday, June 15, 2012 8:19 AM
  • We have tested this on 5 versions of mac osx and all were fine

    We have just updated the blog to include even more notes about the problem and the actual cause of the issue.

    Have another look and try.

    Good Luck

    Friday, June 15, 2012 8:32 AM
  • We have tested this on 5 versions of mac osx and all were fine

    We have just updated the blog to include even more notes about the problem and the actual cause of the issue.

    Have another look and try.

    Good Luck

    Tried again, still no luck. I have even set "everyone" to "read & write" on the Users, Shared, Microsoft and RDC Crucial Server Information folder and also on the files inside the RDC Crucial Server Information folder.
    Friday, June 15, 2012 11:44 AM
  • Backup and then trash the files inside the RDC.. folder.

    Run RDC again so it makes the folder structure.

    Change the permissions as per the article

    run RDC again

    You should get a file turn up in the RDC... folder eventually.

    does that file turn up? if so name?

    If this still does not work i would double check your licence server. Have you got active licences on there or are you still using the 90 tempory ones? if you are using the 90 day tempory ones still then it will stay expired no matter what.

    Does it work on windows clients?

    are you using remoteApp?

    are you using 2008 R2 licence server?

    What is the name of the licences you have bought?

    what mac os is it?

    what RDC version is it?

    cheers


    • Edited by Kirbies Friday, June 15, 2012 11:58 AM
    Friday, June 15, 2012 11:55 AM
  • We have the exact same issue.

    Has anyone have a solution yet?

    The problem came when we filled in the license servers on our RDC servers.

    Before that we tested and used the servers with the 90 day trial.

    The above solutions do not work.

    Connections from MAC clients gives the error.

    Windows clients are still able to connect.

    We only use RDC

    License Servers are 2008 R2

    RDC servers are 2008 R2

    License Version and Type: Windows 2008 or Windows 2008 R2 : Installed TS or RDS Per User CALs

    License program: Volume License

    we do not use RemoteAPP only RDC

    MAC version is OSX 10.7.4

    RDC version is 2.1.1

    Monday, July 02, 2012 2:54 PM
  • Has someone found a solution? still having problems with the same issue!

    Windows 2008 R2 SP1 as RDP server, no remoteapp

    Mac OS X 10.7.4 with MS RDC 2.1.1 client

    Any fix or suggestion?

    Friday, July 06, 2012 10:05 PM
  • The fix on the blog link above has fixed it for many people however for those of you still having issues I will give you some suggestions on what might be wrong;

    Make sure your firewall on 2008 R2 is not blocking them.

    Make sure you allowed the macs to connect via RDC in the local security of the server by adding them to groups or what ever

    Make sure the macs and the server are using the same connection security settings. (2008 R2 defaults to high, stops XP clients connecting for example)

    Basically in my experience it all comes down to security. Either the mac cannot do things because it doesnt have enough security to do things on its own computer or enough security to connect to the server. Your best tool is Netmon. Setup a computer with 2 network cards and bridge them. Then connect server to the computer and the mac to the computer. Then run Netmon in p-mode to listen to the traffic.

    Try using bing to find info about best practices for allow macs to RDP to Windows.

    Hope this helps

    Saturday, July 07, 2012 10:15 AM
  • I came up against the same problem recently, and the only way that I could find to get around it was to abandon the Microsoft RDP Client and install the free opensource RDP program for Macs - called CoRD (http://cord.sourceforge.net/). Works a treat. Shame to have to rely on a 3rd Party to such a core service, but it works! Will save you a log of messing around trying to fix....at least until MS release a new version which fixes the issue.

    Hope this is of help.

    Nick

    Wednesday, July 11, 2012 1:13 PM
  • We have the same problem. 

    RDC on the Macs in our office were working fine, until we went from Demo mode and added our licenses for Windows 2008 Terminal Server. Now, RDC does not work, although coRD and iTap do work (although they don't have the same functionality as RDC had - especially with importing documents and printing.)

    What is Microsoft doing about this. Some help would really be appreciated!

    Thursday, July 12, 2012 8:56 PM
  • Same issue here. After installing official RDS CAL licenses, Microsoft RDC for Mac 2.1.1 stopped connecting.

    iTap is working fine, CoRD isn't but could be I'm missing something on OSX Leopard 10.6.7.

    Tried the fix proposed above but didn't work for me. Tried also downgrading the MS RDC Client to 2.0.1 and 1.0.3. No version is working.
    It's a shame Microsoft didn't fix this yet.

    Friday, July 13, 2012 1:36 PM
  • I have an interesting addition to note. When running a VMWare Fusion windows client and connecting to a windows 2008R2 TS Server I get the same error as if I try to connect using the Microsoft RDC client form the mac. I find it unusual that it happens coming from the mac in any way. 
    Tuesday, July 17, 2012 6:29 AM
  • Exactly the same problem here too.

    Steve

    Monday, July 23, 2012 10:33 PM
  • ditto ... bought licenses and then the thing stopped working.
    • Proposed as answer by James Yen Wednesday, July 25, 2012 7:49 AM
    • Unproposed as answer by James Yen Wednesday, July 25, 2012 7:49 AM
    • Proposed as answer by James Yen Wednesday, July 25, 2012 7:49 AM
    • Unproposed as answer by James Yen Wednesday, July 25, 2012 7:49 AM
    Wednesday, July 25, 2012 12:05 AM
  • Same here !

    Nobody have any idee on how to fix it ?
    Thursday, August 02, 2012 9:23 AM
  • Same issue here and none of the solutions above work. Windows Machines work, windows RDP using Windows 7 through Parallels virtual machine works and CORD works. Definitely seems to be an issue specific to the MS client. 
    Thursday, August 02, 2012 10:04 AM
  • Thursday, August 02, 2012 12:13 PM
  • Same here,  Nothing seems to work, although it does work on my ipad, iphone, windows XP, windows 7 and even CentOS linux thinClient.

    Has to be something in the OSX Client.

    Friday, August 03, 2012 2:36 PM
  • Same here. I'll ask our guys to try CoRD or iTap in the meantime.
    Friday, August 03, 2012 2:49 PM
  • Thanks to http://mydanat.co.uk/blog/?p=59#comments I fixed our MAC's

    The problem for us was not as stated orginally in the blog but I worked it out via the comments under it.

    After that I then still had the issue but the original blog fixed it for us.

    Basically our 2008 R2 server was blocking the macs connecting via firewall and the server security settings. I had to lower the security as stated in many online resources of how to connect macs to windows 2008 R2. This including updating the schema.

    Trying to bodge the job without really knowing what your doing is where we fell over and proberly where you guys have to.

    All the information you need is in the blog and comments you just have to find your eureka moment.

    Its defo down to security settings on the two systems not being compatible. But can be fixed.

    My Vote is with Kirbies

    (btw well done on the directaccess stuff, a very interesting read. Will look at implementing that down our site)

    thanks man this has bugged us for months

    Saturday, August 04, 2012 5:43 PM
  • This is what fixed the same exact issue for me: http://support.microsoft.com/kb/2477133, specifically the section that deals with removing registry keys for licenses.

    Our licensing server is on a separate machine from RDS. So I had to remove these keys on both servers,and  keep RDS powered off while reactivating the licensing server. Once RDS came back up, everything started to work and i could connect from RDC 2.1.1 to Windows 2008 R2 SP1 with no problems.

    Hope this helps someone...

    • Proposed as answer by Martijn Huizer Thursday, August 09, 2012 9:42 AM
    Wednesday, August 08, 2012 7:33 AM
  • Thanks vezard, that solved the problem for us!!!

    Followed the link http://support.microsoft.com/kb/2477133 and executed the following steps:

    NOTE: Perform the following procedure on each of the terminal servers.

    1. Make sure that the terminal server registry has been successfully backed up.
    2. Start Registry Editor.
    3. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM
    4. On the Registry menu, click Export Registry File.
    5. Type exported- Certificate in the File name box, and then click Save.

      NOTE: If you have to restore this registry subkey in the future, double-click the Exported-parameters.reg file that you saved in this step.
    6. Right-click each of the following values, click Delete, and then click Yes to confirm the deletion:

      Certificate
      X509 Certificate
      X509 Certificate ID
      X509 Certificate2
    7. Quit Registry Editor, and then restart the server.
    8. Reactivate the Terminal Services Licensing server by using the Telephone connection method in the Licensing Wizard.

    We have the licensing server on a separate server then the RDS server and followed the order of removing de keys as vezard explains.


    • Edited by Martijn Huizer Thursday, August 09, 2012 9:49 AM
    • Proposed as answer by blackS4 Monday, August 13, 2012 7:51 PM
    Thursday, August 09, 2012 9:48 AM
  • Howdy all,

    Just wanted to second what Hanz0y mentioned earlier in the thread, Microsoft has confirmed
    that this is a known issue with the Mac 2.1.1 RDP client and a fix is in the
    works, but with no ETA currently...

    I wish to ask; those who are experiencing this issue and are using CoRD as a workaround, are
    your RD Session Hosts running in a farm?

    My experience has been that CoRD will not support IP address redirection when using a RD
    Connection Broker and round robin DNS. Furthermore, has anyone had success with
    the iTap client in such an environment?

    Cheers,

    Friday, August 10, 2012 11:31 PM
  • THANKS GUYS! Deleting the registry keys and re-registering via phone fixed our problem and now Macs can connect. So Awesome.

    Cheers!

    Steve

    Monday, August 13, 2012 7:52 PM
  • @Vezard @Martijn Huize

    Thanks for the tips - life saver if it works.

    Question: Any reason to activate via phone ? Or can it be done via the web ?

    Thanks.


    • Edited by _TC Wednesday, August 15, 2012 12:52 PM
    Wednesday, August 15, 2012 12:51 PM
  • Worked for me 2 :))))))
    Thursday, August 16, 2012 2:10 PM
  • @_TC,

    For us, the actvition via web also worked.

    Martijn

    Monday, August 20, 2012 11:35 AM
  • @Martin

    Thanks Martin - Did the phone reg and it worked fantastic.

    Great help.

    Monday, August 20, 2012 11:59 AM
  • The fix on the blog link above has fixed it for many people however for those of you still having issues I will give you some suggestions on what might be wrong;

    Make sure your firewall on 2008 R2 is not blocking them.

    Make sure you allowed the macs to connect via RDC in the local security of the server by adding them to groups or what ever

    Make sure the macs and the server are using the same connection security settings. (2008 R2 defaults to high, stops XP clients connecting for example)

    Basically in my experience it all comes down to security. Either the mac cannot do things because it doesnt have enough security to do things on its own computer or enough security to connect to the server. Your best tool is Netmon. Setup a computer with 2 network cards and bridge them. Then connect server to the computer and the mac to the computer. Then run Netmon in p-mode to listen to the traffic.

    Try using bing to find info about best practices for allow macs to RDP to Windows.

    Hope this helps

    Make sure the macs and the server are using the same connection security settings. (2008 R2 defaults to high, stops XP clients connecting for example)

    What do you mean by this?

    Thursday, August 23, 2012 5:26 PM
  • Ochieman2000

    On your 2008 R2 domain controller go to local security Policy > Local Polices > Security Options. Play around in there. If you have more than one Domain controller may be better using GPO to change them for all domain controllers.

    Thursday, August 23, 2012 7:01 PM
  • Hi,

    Has somebody a better solutions as the phone reg? What is exactly the problem when I activate the server (install per User license) and then no older client then Windows XP SP3 can connect to server - is this a MS bug??? Is this an encryption problem (protocol) or a certificate installation problem (RDP license)?

    I've exactly the same problem with a W2k8 R2 with RDP 7.1 and licensing is running on the same machine. If I activated the server then no old clients and no MAC's with RDC 2.1.1 can connect to server - error message. The minimum requirement for successful connection is Windows XP SP3!!

    Is there any solution from MS or a hint for a workaround?

    Tuesday, September 04, 2012 3:57 PM
  • I'm having the exact same problem:

    - RDC version 2.1.1

    - OS X 10.6 / 10.7 / 10.8

    - Windows Server 2008, SP2

     

    Symptoms:

    * After activating TS Licenses on the server, Microsoft RDC for Mac clients cannot connect anymore: "You were disconnect .... because of problems during the licensing protocol"

    * Connecting with CORD works

    * Connecting to a Windows Server 2008 with TS configured for Administration mode works!

    * There is NO directory under /Users/Shared/Microsoft to be deleted on the clients as suggested by some.

    * Windows XP / Vista / 7 clients can connect

     

    QUESTION:  I'm currently using a self-signed security certificate on the TS and I'm pondering whether this plays a part of the problem. What kind of certificates are you guys using while having this problem?







    • Edited by DonFuego2134 Monday, September 10, 2012 10:43 AM
    Monday, September 10, 2012 10:39 AM
  • The SSL on TS (self-signed or not) has nothing to do with the Mac OS X RDC client not connecting.

    The SSL certificate signed by a CA must include the X.509 certificate intended purpose "Server Authentication". That is mandatory for RD Gateway services. The EKU related to this feature is: EKU 1.3.6.1.5.5.7.3.1

    I used RapidSSL to sign my certificates and they worked fine. Others CAs and SSL certs providers are also ok.

    HTH


    David La Monaca Press4Web

    Monday, September 10, 2012 12:11 PM
  • I am not using a DC. Its just a Bare not AD install of Windows Server. AD cant be used in this environment because of reasons I am not allowed to change. 

    If there is something in  local security Policy > Local Polices > Security Options. Id love to know what to change as I have now read nearly each ones description but I am 1000 miles away from the server and don't like the idea of randomly testing "security settings" for a production machine. 

    =( So throw me a bone ..

    Monday, September 10, 2012 6:15 PM
  • Has anyone found a solution for this yet?  I've tried everybit of different solutions listed in this and multiple other articles.

    Regarding the clearing of the files in /users/shared/microsoft/rdp folder... I did that and no files ever come back.  I've tried recreating them myself, i've tried reinstalling the app, i've tried the registry delete and reactivate on the server....

    I've got the user using Cord for now, but he is the owner of the company and Cord doesn't seem to support his printer or anything, so I really need a better solution to this license issue.  Please help.

    Monday, September 10, 2012 6:46 PM
  • I tried deleting the registry keys on the server and reactivation the server.  I also tried changing the permissions on the client of the /users/shared/microsoft/rdp folder including deleting that folder.  I also removed the rdp 2.1.1 with app cleaner.  Nothing has worked.  Cord does work, just not the Microsoft remote desktop client version 2.1.1.

    Does anyone have any other clues or resolution on this?  It will become a big issue with a lot of Mac clients.


    Network Touch

    Tuesday, September 18, 2012 1:27 PM
  • any Microsoft techs monitoring this thread?

    Network Touch

    Wednesday, September 19, 2012 4:13 PM
  • I'm having the same issue as I posted in this thread. http://social.technet.microsoft.com/Forums/gl-ES/winserverTS/thread/94cc68a6-a02a-45c7-b0f5-ad32d2b37218

    Setting the security layer on the Remote Desktop Session Server from negotiate to RDP Security Layer gets around the "problems during the licensing protocol."

    I'm having difficult time with "Remote Desktop Connection cannot verify the identity of the computer to which you want to connect.". So far I narrowed it down to Microsoft RDP 7.1 causing this issue for the RDC Mac 2.1.1 client not connecting.  The mac client connects fine to the same server with remote desktop session role turned off but with the server setup for remote administration. Weird!.

    Here is what I wrote in a different thread:

    I'm having the same issue and narrowed down the possible cause.  I posted this in a different forum "Microsoft Answers".

    I have a data server with administrative remote desktop on, and a Hyper-V RD/VPN server.  Both servers are identical in 2008 R2 SP1 version with the latest patches & updates as of 9-16-12.  The data server with administrative remote desktop works with 2.1.1 RDC Mac Client, the remote desktop/vpn server does not work with the mac RDC client.  So it has to do with the Remote Desktop Session Server running Microsoft RDP 7.1.  These are identical operating system versions and latest updates, just setup with different roles.

    In a different location, I have a 2008 R2 (without SP1) RD/VPN server running RDP 6.1 (7.0), it works fine with the RDC 2.1.1 mac client, this server has not been updated with the latest patches and updates.

    My only guess is, it has to do with something in RemoteFX since this is the major new feature with RDP 7.1.  I would like this to be resolved soon as possible since I have several OSX notebooks that VPN/RD into the server outside the office, as of now they are unable to connect using the Microsoft Remote Desktop client and temporary using CoRD as a band-aid.

    I have disabled RemoteFX on the RD/VPN server, and the RDC Mac client still does not connect. I doubt RemoteFX is the cause.

    It would be excellent if I can downgrade RDP 7.1 into 7.0, is there a way to downgrade so I can move on from this headache?.

    Add on: I also have a different 2008 R2 SP1 server I installed in June, this setup is a replica of the server installed this week.  This server is running RDP 7.1 and has the same issue with the Mac client not logging on.


    Wednesday, September 19, 2012 7:50 PM
  • I tried setting to security to "RDP Security Layer" and it did get rid of the licensing error.  I still cannot get in though and get the same error as you "remote desktop connection cannot verify the identity of the computer to which you want to connect".

    Network Touch


    • Edited by NetworkTouch Wednesday, September 19, 2012 8:14 PM
    Wednesday, September 19, 2012 8:14 PM
  • Same here.  Maybe getting an actual certificate would make the difference now?

    Steve

    Wednesday, September 19, 2012 8:15 PM
  • My guess it's a registry or group policy setting blocking out the Mac client.  I turned off RemoteFX as a test, turned off the firewall and still have the problem.  It is not the Mac client 2.1.1 having a issue since it works fine connecting to the same exact server without remote desktop services role on.  It connects fine when the server is setup for remote administration.  Something is odd with Microsoft RDP 7.1. RDP 7.0 on 2008 R2 works fine with the Mac client.

    As of now, I'm currently building a dummy server with 2008 R2 SP1.  I'm going to test different methods of connecting to this server, hopefully I will luck into something.

    I'm using OS X 10.5.8, This issue is the same with 10.6 and 10.7.

    Wednesday, September 19, 2012 8:44 PM
  • Bumping this up, seems like Microsoft techs does not give a sh*t about this.

    Typical.

    Thursday, September 20, 2012 7:09 PM
  • Bumping again.  Microsoft, anyone home?  This is a real problem!  I am using 10.8.2.  We have a lot of Macs trying to connect. Currently they have been forced to use Cord due to this issue. Microsoft, you need to resolve or patch your own Mac Remote Desktop Client to work with Win2008 R2 SP1 with "real" licenses!

    Network Touch

    Thursday, September 20, 2012 7:49 PM
  • RESOLVED!  I was able to get my hands on the new Mac Rdp Client and it resolves this issue.  This is direct from Microsoft support.  I hope Microsoft does not get mad at me for posting this.  After all, this will be released in a near future update.

    I present Mac RDP Client Version 2.1.2

    https://dl.dropbox.com/u/18309066/rdc_2.1.2_120917_release_enu_ship_clean_standard_retail_redlab_120917-apex-build-XS26-.dmg


    Network Touch

    • Proposed as answer by Steve Boer Friday, September 21, 2012 4:27 PM
    Friday, September 21, 2012 4:06 PM
  • Yes! It works finally, thank you for posting this!

    Steve

    Friday, September 21, 2012 4:27 PM
  • At last! At last! At last!

    Thanks NetworkTouch! It worked great for me!


    David La Monaca Press4Web

    Friday, September 21, 2012 7:14 PM
  • Not a day too early. I will try this...

     

     

    It's sad to see that this fix eventually had to be communicated through another user and not from Microsoft themselves. 

     

    Come on Microsoft, you can do better than this for your customers, can't you?

    Wednesday, September 26, 2012 5:28 AM
  • Yep, allows me to log in now but users from MAC to Windows Server 2008 R2 cannot type....they can press enter and skip lines and can do shortcut keys but characters don't appear on the screen. 
    Wednesday, September 26, 2012 5:38 PM
  • This worked great. TY
    Friday, September 28, 2012 9:53 PM
  • Worked for me!!!

    THANK YOU!!

    Only one.

    I stop the TDS, delete keys and start TDS.

    nothing more



    Monday, October 01, 2012 6:48 PM
  • v2.1.2 worked ... saved my day.. Thanks a lot.
    Tuesday, October 02, 2012 1:08 AM
  • Martijn Huizer

    Thank you so much, It worked for us.

    Tuesday, October 02, 2012 7:42 PM
  • Fantastic! Works great. Thanks
    Tuesday, October 09, 2012 9:02 PM
  • Work well!

    Thanks!!!

    • Proposed as answer by Frank Fallon Friday, October 19, 2012 7:30 PM
    • Unproposed as answer by Frank Fallon Friday, October 19, 2012 7:31 PM
    Friday, October 19, 2012 3:33 AM
  • Thank you. The new Mac RDP Client 2.1.2 worked immediately in our organization. No more troubleshooting needed.


    Frank Kyosho Fallon Zen Mt. Monastery

    • Proposed as answer by Frank Fallon Friday, October 19, 2012 7:32 PM
    Friday, October 19, 2012 7:32 PM
  • Thanks, Network Touch!

    After trying all the other solutions - 2.1.2 was the only fix that worked for me.

    Setup in our site:
    Client: OS X 10.8.2 (Mountain Lion)

    Server: 2008R2 sp1 with "per user" licenses activated by phone.

    [!-- Rant

    I wonder how  long Microsoft will keep abusing us admins/clients/customers with this bug until they decide to officially release the client (file properties show it was built on 2010!).

    --]


    • Edited by Roy Erez Wednesday, November 07, 2012 4:16 PM
    Wednesday, November 07, 2012 4:14 PM
  • Awesome!, this 2.1.2 version works PERFECT!. I gave up on this project and moved into a alternative solution.  Now why is this version not on microsoft.com/mac/downloads section yet?.

    Thank You!.

    Wednesday, November 07, 2012 5:30 PM
  • I am still receiving the error and I am wondering if it is because I am using a Windows Server 2012 RDP license server.  The RDP server itself is 2008 R2.  Is anyone here using a 2012 license server?

    Thanks

    Wednesday, November 07, 2012 10:52 PM
  • I found that the Mac devices on our network needed to be bound to our Active Directory to connect to the TS. I tried changing permissions, installing the new beta RDC client nothing (aside from manually copying the license file) worked.

    Binding to the AD = fixed.

    Monday, November 12, 2012 4:14 AM
  • Kirbies permission fix fixed it for me:

    "Go to Macintosh HD > Users > Shared > Microsoft.
    Click on “RDC Crucial Server Information” and then click file > Get Info
    Under Sharing & Permissions select “everyone” and change it to “Read & Write”

    New Remote Desktop Client didn't fix it for me.

    Windows Server 2008R2 new, no AD - single machine in workgroup as licence and RDP server, client MacOS 10.6.8 with Remote Desktop 2.1.2 (thanks Network Touch).

    Event Viewer>Windows>Security logs - reports 4 Audit Successes:

    Audit Success    13/11/2012 2:27:48 PM    Microsoft Windows security auditing.    4634    Logoff
    Audit Success    13/11/2012 2:27:47 PM    Microsoft Windows security auditing.    4624    Logon
    Audit Success    13/11/2012 2:27:47 PM    Microsoft Windows security auditing.    4672    Special Logon
    Audit Success    13/11/2012 2:27:47 PM    Microsoft Windows security auditing.    4776    Credential Validation

    Resulting in the error in the thread title. Another machine running Windows Server 2008R2 as client will connect fine. Windows 7 client works fine.

    Win7 client generates different audit log:

    Audit Success    13/11/2012 2:52:11 PM    Microsoft Windows security auditing.    4634    Logoff
    Audit Success    13/11/2012 2:52:06 PM    Microsoft Windows security auditing.    4672    Special Logon
    Audit Success    13/11/2012 2:52:06 PM    Microsoft Windows security auditing.    4624    Logon
    Audit Success    13/11/2012 2:52:06 PM    Microsoft Windows security auditing.    4648    Logon
    Audit Success    13/11/2012 2:52:06 PM    Microsoft Windows security auditing.    4776    Credential Validation
    Audit Success    13/11/2012 2:52:05 PM    Microsoft Windows security auditing.    4624    Logon
    Audit Success    13/11/2012 2:52:05 PM    Microsoft Windows security auditing.    4672    Special Logon
    Audit Success    13/11/2012 2:52:05 PM    Microsoft Windows security auditing.    4776    Credential Validation
    Audit Success    13/11/2012 2:52:04 PM    Microsoft Windows security auditing.    4634    Logoff
    Audit Success    13/11/2012 2:52:04 PM    Microsoft Windows security auditing.    4624    Logon
    Audit Success    13/11/2012 2:52:04 PM    Microsoft Windows security auditing.    4672    Special Logon
    Audit Success    13/11/2012 2:52:04 PM    Microsoft Windows security auditing.    4776    Credential Validation

    CoRD also work great. (Why a third party should know MS better than MS is beyond me.)



    • Edited by cheongi Tuesday, November 13, 2012 5:29 AM amended
    • Proposed as answer by Nino-Endeavour Tuesday, May 14, 2013 6:22 AM
    Tuesday, November 13, 2012 4:57 AM
  • Just to add some more info to this:

    If I try a user that has logged on previously to the RDP server I get the Licensing protocol error.  If I try to log into the RDP server with an account that hasn't logged into the RDP server yet, i get the error "The remote computer is not allowing connections from the Mac".

    I have tried versions 2.0.1, 2.1.1, and 2.1.2 of the RDP for MAC with the same result.  the RDP server is set to allow connections from any client.

    I also do not see the Microsoft folder when I go to Macintosh HD\Users\Shared.  Binding the MAC may not be an option for me as its a remote user who VPN's in.

    CoRD works but I cannot get the printers to forward in the session and would prefer to use the Microsoft client.  I have migrated the RDP license server to 2008R2 from 2012 with no luck.  We are using User CAL's which register fine.

    Thanks,

    Rich

    Thursday, November 15, 2012 7:08 PM
  • I am still receiving the error and I am wondering if it is because I am using a Windows Server 2012 RDP license server.  The RDP server itself is 2008 R2.  Is anyone here using a 2012 license server?

    Thanks

    We're using a 2012 Licensing and RDP server (single server) and the 2.1.2 client does not work.  Regardless of user security level on the Mac, the Microsoft folder structure is not created.  Even creating it manually and granting everybody full access to it does not result in any files being created.

    Binding the Mac machines to the AD is not an option - the whole point of RDP is "Remote".  I can't run around bringing in peoples computers to join them to the domain.  Kind of defeats the whole idea of "remote" 

    Would like to post what I really think about this issue and the fact it's taken Microsoft so long to... well, not really do anything about it.  But better not, this is a company account. 


    • Edited by TONCC Wednesday, November 21, 2012 4:21 AM
    Wednesday, November 21, 2012 4:20 AM
  • I can reproduce the problem from another server by activating the license server, but I can't reverse it once I break it.

    It works on a server that hasn't been activated, but I suppose this has to do with the cached license on the mac client.

    Changing the security doesn't work for me.

    Has MS released a known issue bulletin on this?

    It looks like its effecting a lot of people who have opened tickets, but are those tickets still open?  What the response from MS?

    Wednesday, November 21, 2012 3:41 PM
  • This is a user-to-user forum, and Microsoft is obviously not reading this thread.

     

    To have Microsoft realize that this is a major problem they first need statistics and feedback data, and the only data they respond to is Support tickets/incidents.

     

    I suggest that everyone with a support account of some sort do this if you haven't done so already:

     

     1. Choose product: https://support.microsoft.com/oas/default.aspx?&gprid=1163&st=1&wfxredirect=1&sd=gn

     2. Problem Type: select "Remote Desktop Services and Terminal Server"

     3. Category: select "Connecting to a session or desktop"

     4. Start a Request and select your account type, then follow through with the ticket.

    Friday, November 23, 2012 3:55 AM
  • If you are experiencing this issue, please open a case with Microsoft Support and the Mac Office team as they provide support for the MAC RDC client.

    Don Geddes - SR Support Escalation Engineer - Remote Desktop Services - Printing and Imaging



    Friday, November 23, 2012 2:33 PM
  • Strangely, I had no problems with 3 other Macs 10.5.x RDP 2.1.1 without changing anything.

    Had trouble connecting with thin clients too but only to one RDP/licencing server and no the other. Strange.

    Fixed this following the recipe here to redo licensing using web and delete/refresh licensing registry keys.

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/e172f4c6-dbd1-4aa1-b6d7-ffff06b40a17

    Possibly this may have helped the Mac RDP problem???? Anyway, my system i all working now.

    Sunday, November 25, 2012 10:09 AM
  • I tried the 2.1.1 client on ML and had crashes.  I downloaded the 2.1.2 client as described and it has not crashed as of yet.  

    Thanks Network Touch!

    Thursday, December 06, 2012 1:11 AM
  • I'm having the same problem as others. CoRD works, updating to 2.1.2 does not, and I don't see the structure in /Users/Shared. I tried creating the Microsoft subdirectory under /Users/Shared and opening the rights as documented, as well as creating the RDC Crucial Server Information subdirectory under ../Microsoft. I can't make changes to the server as I am working on a client's environment and am not authorized to make changes to the servers.

    Thanks for the submitting a ticket and giving the pointers to submitting a case. Unfortunately Microsoft wants me to pay to submit a case - I'm sorry I won't. I just wish they would fix the software. If this is Microsoft's idea of giving feedback then I'm left to use CoRD exclusively - basically because their software doesn't work. This really blows as I have no other way of fixing this.






    • Edited by Blockfish Thursday, December 13, 2012 4:58 PM
    • Proposed as answer by Steve Farmer Wednesday, January 30, 2013 10:27 PM
    • Unproposed as answer by Steve Farmer Wednesday, January 30, 2013 10:27 PM
    Thursday, December 13, 2012 3:47 PM
  • Sorry but I reported Don Geddes post as borderline SPAM as there is no way to submit this as a problem without paying. I'm disappointed that this problem will go on being ignored.

    • Edited by Blockfish Thursday, December 13, 2012 5:38 PM
    Thursday, December 13, 2012 4:10 PM
  • Hey,

    Found the solution to my problem. I too tried 2.1.2 and also noticed that I did not have the /Users/Shared/Microsoft sub directory and ancillary files.

    For me the fix was simple: When I had installed the old version I had moved the 2.1.1 Remote Desktop Connection.app to an /Applications/Network sub directory. During the "greymarket" 2.1.2 version install, I left it under /Applications. After install 2.1.2 refused to work as I kept getting the dreaded license protocol error. Checking under RDC.., About Remote Desktop Connection.. showed version 2.1.2, so I am fairly certain I was running the new version.

    The fix: After I moved the new 2.1.2 version to my /Applications/Network sub directory – thus completely replacing and completely eradicatiing the 2.1.1 version – I could connect.

    I’m stumped why that would make a difference, unless 2.1.2 was using the old framework libraries in the 2.1.1 ../Contents/Frameworks. But that doesn’t make sense, unless ~/System/Caches was screwing with me.

    Kind Regards,

    Blockfish












    • Proposed as answer by Blockfish Thursday, December 13, 2012 4:53 PM
    • Unproposed as answer by Blockfish Thursday, December 13, 2012 5:06 PM
    • Edited by Blockfish Friday, December 14, 2012 9:25 AM
    Thursday, December 13, 2012 4:51 PM
  • Hello,

    Thanks to Network Touch as well. In my case 2.1.2 didn't work until I completely replaced the 2.1.1 version (look back in the posts a bit).

    Regards,

    Blockfish


    • Edited by Blockfish Thursday, December 13, 2012 5:38 PM
    Thursday, December 13, 2012 5:04 PM
  • Kirbies,

    Thanks, it worked right after i followed your link...thanks much!!

    Shri

    Wednesday, December 26, 2012 10:42 PM
  • Sorry but I reported Don Geddes post as borderline SPAM as there is no way to submit this as a problem without paying. I'm disappointed that this problem will go on being ignored.


    Please understand that Microsoft Support does not make the decision on whether a fix is released.  If enough people open cases, perhaps those that do will reconsider that decision.  Microsoft Support should refund your charges for the incident if you are requesting a hotfix.

    Don Geddes - SR Support Escalation Engineer - Remote Desktop Services - Printing and Imaging

    Thursday, December 27, 2012 5:20 PM
  • I too have had this issue for some months running OS X 10.8.2 and with no official release of RDC 2.1.2, I was hesitant about that link and after researching the file name. My Windows 2008 R2 server is in a DMZ, but I could connect no problem from XP and 7. My simple fix with RDC 2.1.1 was:

    At the RDP login

    User name: DMZ Domain\UID

    Password: your password

    Domain: primary domain

    Don't know if this helps anyone, but it certainly worked for me. If your server is in your primary domain, you could try: Domain\User name, but I have not had to try that one because with servers in my primary domain, this is not an issue for me. 

     
    Monday, January 07, 2013 3:35 PM
  • THANKS!!!!! worked right away!!
    Monday, January 14, 2013 3:22 PM
  • From http://www.mydanat.co.uk/blog

    1. aquarz wrote:

      problem starts on 2008r2 sp1

      “NOTE: Perform the following procedure on each of the terminal servers.
      Make sure that the terminal server registry has been successfully backed up.
      Start Registry Editor.
      Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM
      On the Registry menu, click Export Registry File.
      Type exported- Certificate in the File name box, and then click Save.

      NOTE: If you have to restore this registry subkey in the future, double-click the Exported-parameters.reg file that you saved in this step.
      Right-click each of the following values, click Delete, and then click Yes to confirm the deletion:

      Certificate
      X509 Certificate
      X509 Certificate ID
      X509 Certificate2
      Quit Registry Editor, and then restart the server.
      Reactivate the Terminal Services Licensing server by using the Telephone connection method in the Licensing Wizard.”
      I did’nt reactivate my licensing server over the phone, i just re-activated it online and all was fine.
      reboot…
      and I connected to server by MS RDC 2.1.2
      I didn’t try 2.1.1
      good luck…

      Posted <abbr class="comment-published" title="2012-06-14T12:33:59+0000">08 Jan 2013 at 5:48 pm</abbr>

    I had this problem on a Windows 2008 Server (not R2) from a Mac client using 2.01. This solution worked perfectly and my Mac users are back up to speed on this server.

    Wednesday, January 30, 2013 10:29 PM
  • NetworkTouch - you saved us from scrapping our jump server for our Helpdesk to prevent them from logging onto our production servers directly.  You should get a medal.  For real.  Thank you thank you thank you, from an NFL football team :)
    Monday, February 11, 2013 4:03 PM
  • We had this error:

    Remote Desktop Connection cannot verify the identity of the computer that you want to connect to.Try reconnecting to the Windows-based computer, or contact our administrator

    And it was solved by installing the 2.1.2 version of client.

    Thank you for the link NetworkTouch.

    Thursday, February 14, 2013 12:45 PM
  • This solution worked for me.

    Standalone Server Windows 2012 with RDS and Licensing-Server, no AD, 6x  OSX 10.8.2 with RDC 2.1.1 and 2.1.2 and some Windows-clients were running several weeks witout problem. Yesterday, while working the mac-clients got this error-message. The windiows-clients still running fine. The licensing-server-diagnostics stated no problem.

    After reactivating the licensing-server online,  I made an update to rdc 2.1.2 an deleted the directory /Users/Share/Microsoft/RDC.. , but I don't know if it was necessary.  Then connected to RDS again. :)

    THANKS a lot !!
    Tuesday, February 19, 2013 2:29 AM
  • Update:

    This solution worked only once in our environment. Deleting the registry keys only allowed for one Mac connection. Once that connection was closed, it no longer functioned. I can delete the keys again, restart and connect one time again.

    This did not solve our issue permanently.

    Wednesday, February 20, 2013 9:25 PM
  • Wow. 

    How is 2.1.2 NOT on the microsoft website for RDP yet??

    This worked perfectly.



    • Proposed as answer by JesseStarks Friday, March 01, 2013 9:33 PM
    • Edited by JesseStarks Friday, March 01, 2013 9:37 PM
    Friday, March 01, 2013 9:31 PM
  • Is there an official download link from Microsoft for that updated RDC 2.1.2 client? Or at least an official statement from Microsoft about when or if RDC for the Mac ever will get updated?

    Don't get me wrong, but I just don't like the idea of downloading and installing that supposedly official 2.1.2 client form NetworkTouch's Dropbox account, even thou it "is direct from Microsoft support" and "will be released in a near future update".

    Cheers,
    Thomas

    Tuesday, March 19, 2013 10:35 AM
  • Possible fix for those who run into this issue where it's just on a single Mac, where the user hasn't accessed the Win 2008 remote server before (where it's not a server-side issue but you receive the same "because of problems during the licensing protocol" error):

    remove: ~/Library/Preferences/Microsoft/ (or just remove the RDC-related items, but it's cleaner to remove everything)

    I ran into this issue today and removing the RDC data from this folder fixed the problem right away. I first isolated the issue to the user's account (ie.. same server connection worked under local admin using their domain profile).

    The user in question had gone through 3 revisions of Office for Mac on their machine with no cleanup between versions, and apparently some old lingering data caused this issue... a nice reminder to properly remove Office applications :)

    Friday, April 05, 2013 6:46 PM
  • Just FYI, information security is an increasing and perpetual challenge. There are legal and personal ramifications to breaches in information security. Downloading a "leaked" copy of a software from an untrusted third party is unwise. It could be tweaked to include malware/spyware, let alone it is illegal. This puts you, your end-users and customers at risk and you as the IT admin may be personally liable for damages if you use pirated software knowingly. 


    Wednesday, April 24, 2013 4:33 PM
  • Maybe true, but you can't argue with the results that myself and a number of other people have gotten by using it. 

    And just FYI, you posted the exact same message SIX times...


    Steve

    Wednesday, April 24, 2013 4:53 PM
  • I am a security professional and opened a ticket with Microsoft.  They sent me the beta version of the Mac RDP client.  This is not a leaked copy as it is direct from Microsoft.  I understand your concern about using software that you really do not know where it came from, but in this case it was straight from Microsoft.  I do not know why Microsoft has not released it yet.

    thanks,

    H


    Network Touch

    Thursday, April 25, 2013 2:15 PM
  • Hello,

    I had the same issue and tried most of the methods mentioned above but nothing worked which surprised me since the Registry Key Deletion worked form most people. I deleted the registry keys a few times but after restart, the keys would appear as if they were never deleted.

    While messing around I saw an option to re-activate the licensing server and during the re-activation, it asked the reason and one of the reason was:

    "The license server certificate has become corrupted"

    I choose that option and the License was successfully re-activated and the MAC RDC 2.1.2 started working. Before this exercise, the MAC 2.1.1 or 2.1.2 would not work.

    I hope this helps!

    Sincerely,

    Salman Maqsood

    Saltech Systems


    Friday, May 31, 2013 4:48 AM
  • I had this error in last year. I read all blogs an suggestions.

    Updating the RDP-Client on the Mac to version 2.1.2 helped.

    On the Mac everyone has read and write right on the folder "RDC Crucial Server Information".

    Meanwhile the license servers changed from 2008R2 to 2012, the Mac had no problems. Licenses are per device.

    But now I have the error again, and I have it only on one new farm. I can connect to all other farms. The Mac got a license from the license server, the license server shows this. The license is written to "RDC Crucial Server Information".

    I have a Mac OS X 10.8.2-Client and a 2008R2SP1-Server Farm with Dedicated Redirector.

    All Servers have valid certificates.

    NLA is enabled.

    I installed Wireshark on the Mac and so far I can see the communication between the Mac and the License Server and the Mac and the Terminalserver is ok. All Servers send  ACK-packets. But in the end I get the error message "You were disconnected from the Windows-based computer because of problems during the licensing protocol". So I'm sure the problem is the client not the server.

    Reinitialising the license servers every time a Mac has a problem is not an option. Too many terminal servers are connected to them. (We have lots of single terminal servers, every group has its own.)

    The question is: Why use the client not the license it have?

    I deleted the folder "RDC Crucial Server Information" and connected to a farm where a get every time a connection (the farm is 2008R2 too, NLA enabled, but loadbalancing over F5). The license information was created again. No problem.

    Any ideas?

    Barbara

    • Proposed as answer by SBDas Friday, June 21, 2013 8:07 AM
    • Unproposed as answer by SBDas Friday, June 21, 2013 8:07 AM
    Friday, May 31, 2013 9:50 AM
  • Guys, I have read through all the posts. Only thing that worked for me is installation of the new Mac RDP Client Version 2.1.2

    https://dl.dropbox.com/u/18309066/rdc_2.1.2_120917_release_enu_ship_clean_standard_retail_redlab_120917-apex-build-XS26-.dmg


    Friday, June 21, 2013 8:08 AM
  • I couldn't use your link. Found it here though

    http://www.trailblz.com/kb/?action=view&kb=175&cat=12

    Wednesday, July 03, 2013 12:19 PM
  • mac OSX, w2k8r2 TS server: "you were disconnected from the windows-based computer because of problems during the licensing protocol". M$ mac RDP client 2.1.2, which appears to be a Microsoft release, fixed my problem. The problem is that you cannot download it from Microsoft! I think it’s a requested hotifx. But I found it on these 3rd party links:

    http://www.trailblz.com/kb/?action=view&kb=175&cat=12

    http://www.taribo.co.uk/Software/rdc_2.1.2.zip

    ttps://dl.dropbox.com/u/18309066/rdc_2.1.2_120917_release_enu_ship_clean_standard_retail_redlab_120917-apex-build-XS26-.dmg

    it’s a shame M$ doesn’t release the file here. Once again, M$ is losing its edge! Post the freakin file M$!:

    http://www.microsoft.com/en-us/download/search.aspx?q=microsoft%20remote%20desktop%20connection%20for%20mac&p=0&r=10&t=&s=Relevancy~Descending

    Monday, July 08, 2013 6:17 PM
  • Wow, finally... This is very helpful. Thanks a lot!

    Not sure why MS is ignoring customer and does not release it to the public. What is the secret??

    Wednesday, July 10, 2013 1:22 AM
  • Well, there is a better solution than to use some leaked RDC client.

    Remotix application (paid) work just fine and has much better functionality (+VNC + SSH built-in). I've got this issue with 2.1.2 also, tried Remotix and it works perfect.

    Friday, July 19, 2013 1:32 AM
  • Anybody with Server 2012 have a fix, I have the same issue here.  Mac users cannot connect, new 2.1.2 version of rdp does not work.  Windows users are up and functioning.  Need help quick here.  
    • Proposed as answer by ginsuedog Thursday, September 12, 2013 6:41 PM
    • Unproposed as answer by ginsuedog Thursday, September 12, 2013 6:41 PM
    Friday, August 30, 2013 8:19 PM
  • Anybody with Server 2012 have a fix, I have the same issue here.  Mac users cannot connect, new 2.1.2 version of rdp does not work.  Windows users are up and functioning.  Need help quick here.  

    Same problem for me with Windows Server 2012 and RDC 2.1.2 installed. Read the whole thread, tried nearly everything, removed all relics from previous RDC versions and such but it doesn't work. 

    "..problems during the licensing protocol."

    http://picload.org/image/ooldgri/screenshot2013-0.png

    Any ideas, except of "install iTap_mobile from the AppStore".

    thanks

    Wednesday, September 11, 2013 11:19 AM
  • I have found that i CAN connect if i add a "/console" statement after the server name. using MS Mac RDP.

    May make sense from a licensing standpoint from Microsofts POV but should not be this hard to find an answer.

    Eric W

    • Proposed as answer by CISNOC Wednesday, September 11, 2013 8:58 PM
    Wednesday, September 11, 2013 5:41 PM
  • Anybody with Server 2012 have a fix, I have the same issue here.  Mac users cannot connect, new 2.1.2 version of rdp does not work.  Windows users are up and functioning.  Need help quick here.  

    Same problem for me with Windows Server 2012 and RDC 2.1.2 installed. Read the whole thread, tried nearly everything, removed all relics from previous RDC versions and such but it doesn't work. 

    "..problems during the licensing protocol."

    http://picload.org/image/ooldgri/screenshot2013-0.png

    Any ideas, except of "install iTap_mobile from the AppStore".

    thanks

    We were having the same problem on a set of load balanced 2012 RDP servers.  The solution for our users using OSX was to have them install 2X which is a free RDP client available on the App store for OSX.  I hope that helps.
    Thursday, September 12, 2013 6:44 PM
  • I have found that i CAN connect if i add a "/console" statement after the server name. using MS Mac RDP.

    May make sense from a licensing standpoint from Microsofts POV but should not be this hard to find an answer.

    Eric W

    Great - it works for me - thanks a lot Eric.
    Monday, September 16, 2013 3:34 PM
  • The only thing that worked for me after having tried everything on this page - including cleaning up my terminal services servers - was to do the following:

    I used the primary OSX account to delete the files under USERS/SHARED/MICROSOFT/RDC Crucial Server Information again. I then created a temp Admin account and logged into it. I used the temp account to successfully connect to the terminal services servers and then, after leaving the connections in a "disconnected" state instead of "logging off", I logged out of the OSX temp Admin account I had just created. I then logged back into my OSX machine with the primary account and was able to "reconnect" to the disconnected terminal server connections. After logging out of the terminal server connections, rebooting OSX and then RDP back into the terminal servers, I concluded that the fix was:

    1. Delete the files in the USERS/SHARED/MICROSOFT/RDC Crucial Server on the OSX machine.

    2. Use an OSX temp account on to create "live" connections and then leave them in a "disconnected" state.

    3. Use the primary OSX account to log into those disconnected connections.

    Tuesday, September 17, 2013 9:09 PM
  • New post on http://mydanat.co.uk/blog/?p=59 which has helped some users
    Tuesday, September 24, 2013 8:01 AM
  • The /console suffix worked for us on Win2012 RDS. The Mac RDP 2.1.2 update did not. Thanks Eric W.

    Dale Smith

    Thursday, September 26, 2013 9:20 PM
  • this might solve all of our issues :D

    this is the Mac remote desktop update we have been waiting for!

    Microsoft brings its Remote Desktop app to OS X. You can now access your PC from any Mac
    http://thenextweb.com/apps/2013/10/18/microsoft-brings-remote-desktop-app-os-x-can-now-access-pc-mac/


    Network Touch

    Friday, October 18, 2013 1:18 PM
  • Hi,

    If possible, please try the new Microsoft Remote Desktop app, available in the Mac App Store:

    https://itunes.apple.com/us/app/microsoft-remote-desktop/id715768417

    Getting Started with Remote Desktop Client on Mac

    http://technet.microsoft.com/en-us/library/dn473012.aspx

    Thanks.

    -TP

    Friday, October 18, 2013 1:46 PM
    Moderator
  • Bingo !
    No more "..problems during the licensing protocol." and still no crash since 8 days.

    Thanks.

    Thursday, October 31, 2013 1:16 PM
  • This is not a relevant solution

    Wednesday, December 11, 2013 5:53 AM
  • Same results for my users who upgraded their own personal iPhone and Max OS X computers, and then wanted the Hospital IT Staff to fix the problem for them.

    Once they understood the difference between THEIR devices and HOSPITAL devices (and then applied these updates to THEIR systems) then they began working just fine.



    Randall

    Friday, February 07, 2014 5:42 PM