none
How to avoid Exchange server logs truncation when Hyper-v guest OS gets backed up?

    Question

  • Hi,

    Is there any way to restrict Hyper-v VSS writer to truncate the Exchange server logs?. I have a VM with Backup Integration services Installed. When i Issue snapshot of VM, logs gets truncated and a full backup entry is created in the Exchange server. This is happening even i call VSS COPY only snapshot.

    Can anyone please tell me solution for this ?

    Thanks in advance,

    -Ilavaa


    ilavaa

    Thursday, March 01, 2012 10:52 AM

Answers

  • So we have the situation that you make an internal snapshot inside the vm through the vm additions. So the behavior is as expected. You could try to make a backup by setting the vm offline and then only copiing the vm data without using the hyper-v Backup mechanism.
    Monday, March 05, 2012 12:25 PM

All replies

  • Are you using windows backup on the hyper-v host?
    Friday, March 02, 2012 8:18 PM
  • NO, I'm using VSS API's for taking snapshot.

    ilavaa

    Monday, March 05, 2012 10:52 AM
  • So we have the situation that you make an internal snapshot inside the vm through the vm additions. So the behavior is as expected. You could try to make a backup by setting the vm offline and then only copiing the vm data without using the hyper-v Backup mechanism.
    Monday, March 05, 2012 12:25 PM
  • hmmm. I want to do snapshot when vm is on or off. My only concern is, whether it can be possible to avoid taking snapshot of applications like Exchange or SQL if it is installed inside the VM. Is there any registry entries or any configurations need to change?

    ilavaa

    Wednesday, March 14, 2012 8:06 AM
  • Well, if it`s okay for you to shutdown the vm you can copy the vm to another target by console. So you don`t need the snapshot in this case.

    http://www.bunkerhollow.com/blogs/matt/archive/2008/09/24/hyper-v-vm-backup-script-batch-file.aspx is a good guide how to do this.

    Cornelius

    Wednesday, March 14, 2012 8:12 AM
  • Thnx Cornelius for the Quick reply.. The problem is they are all running VMs which we dont want to shutdown. Let me clearly explain the problem,

    1. Issuing snapshot for the Guest os which has Exchange for example using the VSS API.

    2. It triggers the guest os VSS and it quiesce the Exchange server logs and put as a full backup is done for the Exchange server.

    3. Then it takes snapshot for the guest os. The problem comes in step 2. if i have any application inside the guest os, it thinks that other than that sofware some other application took full snap. so the application fails.

    So I need solution to avoid step2 i.e., without truncating exchange server logs i want to take guest os snapshot.. please let me knw if you have any suggestion for this

    Thnkx

     


    ilavaa

    Wednesday, March 14, 2012 9:39 AM
  • Did you ever get this figured out? I'm having the same issue in which performing a Hyper-V based snapshot backup of the volumes on my Exchange server causes Exchange to truncate the log files and as a result my regularly scheduled incremental Exchange backups fail due to a log file discontinuity. The only workaround I've been able to come up with is avoiding Hyper-V based backups entirely.

    (Thread here: http://social.technet.microsoft.com/Forums/en-US/dpmexchbackup/thread/5035ed8e-7bd4-43f5-ab16-2c319be50c9c)

    Tuesday, October 23, 2012 5:21 PM
  • I may have found the answer. See this KB article: http://support.microsoft.com/kb/975354

    Specifically, adding this registry key seems to have resolved the issue for me:

    ==========================

    Location: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Virtualization\VssRequestor
    Name: BackupType
    Type: REG_DWORD
    Value: 0 or 1

    If this registry entry is created and its value is set to 1, application backup will not be affected by the virtual machine backup operation on the server  that is running Hyper-V.  If this registry entry does not exist, or if its value is 0, issue 3 occurs.

    ==========================

    I hope this helps you as well...

    Wednesday, October 24, 2012 4:51 PM