none
setting default printer in group policy using computer configuration (server 2008 R2)

    Question

  • Hi,

     

    Basically, what I have done is install a fresh go of server 2008 R2 on to a machine, assign the print services role, and then go through adding a couple of printers, and deploying them using Group Policy. That is all fine, works great for getting them on the machines I'm deploying to, happy days. However, I need to make sure that, for example, the black & white printer is the one that gets used and not the colour ones. I also want to try to do all of it through the computer configuration side of the group policy object, because I'm keen on not letting people start to shift around default printers if I can get away with it. So, in deployed printers, I've got my list there, thats fine. I go to preferences\control panel settings\printers and there is nothing there. Fair enough, not a problem, there aren't any settings in there yet. I then decide to add the printers in (TCP/IP printers is what I'm working with), see if I can set the default in there. The box to set it is there, but it is greyed out for some reason that is beyond me. I really don't want to be using the user config, so I'm wondering if there is anything someone can suggest to me to get this to work? I've got another whole heap of offices to set up with this, so once I get the basics done, then I should be ok with it all (I hope!)

     

    many thanks

     

    Stephen

    Thursday, March 31, 2011 2:11 PM

Answers

  • Unfortunately, when pushing printers with GPP at Computer level, there is no way to set the default printer (at least not one that I know about). You should use either logon scripts to set the default or GPP at User configuration level to set the default one.


    " Never panic before reboot ! "
    Thursday, March 31, 2011 11:49 PM

All replies

  • Unfortunately, when pushing printers with GPP at Computer level, there is no way to set the default printer (at least not one that I know about). You should use either logon scripts to set the default or GPP at User configuration level to set the default one.


    " Never panic before reboot ! "
    Thursday, March 31, 2011 11:49 PM
  • default printer can be set with GPO.

    User Configuration ->> Control Panel Settings ->> Printers

    On the General Tab Select "Set this printer as the default printer"

     

    Erik

     

    Tuesday, May 03, 2011 6:54 AM
  • I think he is seeing the same problem I'am. 

    Under Computer Configuration->>Control Panel settings->>Printers    the "Set this printer as the default printer" is grayed out.  but I see under User configuration I'am able to select the "set as deafult".  Is this by design? in that you can set it to user but not computer?  I would rather set it as computer not user since my users move from room to room but the computers stay where the printer is. 

    thought...If I create a printer policy that had all 30 printers in it under the user config. and then set the item level targeting for the indiviual printers to only apply to the specific workstations. would it then work?  Is this the best practice or should I have a policy for each printer?

     

     

     

    Tuesday, May 17, 2011 3:11 PM
  • I think he is seeing the same problem I'am. 

    Under Computer Configuration->>Control Panel settings->>Printers    the "Set this printer as the default printer" is grayed out.  but I see under User configuration I'am able to select the "set as deafult".  Is this by design? in that you can set it to user but not computer?  I would rather set it as computer not user since my users move from room to room but the computers stay where the printer is. 

    thought...If I create a printer policy that had all 30 printers in it under the user config. and then set the item level targeting for the indiviual printers to only apply to the specific workstations. would it then work?  Is this the best practice or should I have a policy for each printer?

     

     

     


    Your solution will work without problems (use Computer groups >>> If ComputerName is in GroupName)
    " Never panic before reboot ! "

    Tuesday, May 17, 2011 5:48 PM
  • we need it to work under "Computer Configuration" not user config.
    Monday, February 11, 2013 1:31 AM
  • Can you please elaborate on this workaround. IE what is meant by: "and then set the item level targeting for the indiviual printers to only apply to the specific workstations."

    Monday, February 11, 2013 1:33 AM
  • Old thread but common problem.

    Find the Unique ID of the policy you're working with by single clicking on it and looking at the Details tab.

    Then go to c:\windows\sysvol\sysvol\<domain name>\Policies\<Unique ID>\machine\preferences\printers

    there you will find a Printers.xml. open this with notepad, find the printer that you want as default and follow the xml code till you find default="0". change the 0 to 1 and save the file. 

    now check the policy from within gp manager and the default option will be ticked but still grayed but performs the function required.

    Enjoy

    Thursday, October 17, 2013 2:55 AM
  • Unfortunately, this does not work in 2012. I did as you instructed (btw. I had to change the security options to allow me to edit the xml), changed the value from 0 to 1 in the xml file. However, when I open the printer settings in GPP, it is still un-ticked as default printer and will change the value back to 0 when I close the dialog.

    I also checked whether it might work after setting the value to 1 and rebooted a computer - nope :-/

    Sunday, October 20, 2013 3:27 PM
  • If you order the printer the last printer installed will be the default. Next keep in mind that I have found that if you deploy at the Computer level there is no option to using the print server to spool jobs, printers are directly connected once installed.
    Tuesday, May 13, 2014 6:47 PM