none
DHCP is disabled on LAN adapter and there is yellow exclamation mark-shows no internet access on DHCP server

    Question

  • Dear All,

    I have installed AD , DNS , DHCP on a single server machine -platform Win Server 2008 R2.

    There is no antivirus installed on this server and firewall management is done by TMG 2010 which is installed on another machine in my network.

    The ipconfig /all result of AD , DNS , DHCP server is mentioned below (static ip is configured on LAN Adapter)

     

    Windows IP Configuration

     

       Host Name . . . . . . . . . . . . : phepsvr

       Primary Dns Suffix  . . . . . . . : phep.com

       Node Type . . . . . . . . . . . . : Hybrid

       IP Routing Enabled. . . . . . . . : No

       WINS Proxy Enabled. . . . . . . . : No

       DNS Suffix Search List. . . . . . : phep.com

     

    Ethernet adapter Local Area Connection:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Intel(R) 82579LM Gigabit Network Connecti

    on

       Physical Address. . . . . . . . . : 78-2B-CB-B7-19-5C

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       IPv4 Address. . . . . . . . . . . : 192.168.1.3(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 192.168.1.7

       DNS Servers . . . . . . . . . . . : 192.168.1.3

                                           202.144.128.214-->DNS of ISP

                                           202.144.128.228-->DNS of ISP

       NetBIOS over Tcpip. . . . . . . . : Enabled

     

    Tunnel adapter isatap.{3C6436C7-B145-4D94-990E-038A0588E2DB}:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2

       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.3%12(Preferred)

       Default Gateway . . . . . . . . . :

       DNS Servers . . . . . . . . . . . : 192.168.1.3

                                           202.144.128.214

                                           202.144.128.228

       NetBIOS over Tcpip. . . . . . . . : Disabled

     

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

     

       Media State . . . . . . . . . . . : Media disconnected

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

     

    The DHCP is running fine but overall this machine has no internet access.

    I am able to ping my DG-192.168.1.7 (i.e. TMG Server) from the DHCP Server.

    When I run network diagnostics from network and sharing center , it says - DHCP is not enabled on LAN adapter.

    I have disabled IPv6 and there is single LAN adapter installed on AD , DNS , DHCP Sever.

     

    Please help on this problem as the current server is live in my LAN and unknowingly i don't want to make sudden changes.

     

    Regards,

    KLS


    Network Admin
    Friday, December 16, 2011 5:13 AM

Answers

  • Hi,

    remove these external DNS servers from IPv4 NIC's properties under DNS section (202.144.128.214, 202.144.128.228). In domain environment all servers/computers should use only internal DNS servers. For the Internet access (ISP DNS servers or any DNS servers available publicly) you need to configure on internal DNS server Forwarders. You have to specify those external DNS servers there.

    Also do not set up external DNS servers within DHCP server/scope options (depends on your configuration). Clients need to also use only the internal ones for DNS name resolution order. Option resoponsible for delivering DNS servers list to clients is option no. 006

    How to configure Forwarders, please check at
    http://technet.microsoft.com/en-us/library/cc754941.aspx

    simply saying, open DNS management console (dnsmgmt.msc), select DNS server name on the list and in the right pane at the bottom, you will see Forwarders. It's short cut to them. Double click on this node and put these IPs there 202.144.128.214, 202.144.128.228 or i.e. Gogle 8.8.8.8 and/or 8.8.4.4

    Clear DNS local cache on your DNS server and from now, it should work fine.


    Regards, Krzysztof ---- Visit my blog at http://kpytko.wordpress.com
    • Edited by iSiek Friday, December 16, 2011 9:13 AM
    • Proposed as answer by Tiger Li Monday, December 19, 2011 10:50 AM
    • Marked as answer by Tiger Li Tuesday, December 20, 2011 11:08 AM
    Friday, December 16, 2011 9:11 AM
  • Hi KLS,

     

    Thanks for posting here.

     

    Please do not disable IPv6 on server first !

    Meanwhile, set and allow the exceptions for the URL and IP address that mentioned in the TechNet article below on TMG to see if system will still determine it has no internet connectivity  :

     

    Appendix K: Network Connectivity Status Indicator and Resulting Internet Communication in Windows Vista

    http://technet.microsoft.com/en-us/library/cc766017(WS.10).aspx

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Tiger Li Tuesday, December 20, 2011 11:08 AM
    Monday, December 19, 2011 10:48 AM

All replies

  • Hi,

    remove these external DNS servers from IPv4 NIC's properties under DNS section (202.144.128.214, 202.144.128.228). In domain environment all servers/computers should use only internal DNS servers. For the Internet access (ISP DNS servers or any DNS servers available publicly) you need to configure on internal DNS server Forwarders. You have to specify those external DNS servers there.

    Also do not set up external DNS servers within DHCP server/scope options (depends on your configuration). Clients need to also use only the internal ones for DNS name resolution order. Option resoponsible for delivering DNS servers list to clients is option no. 006

    How to configure Forwarders, please check at
    http://technet.microsoft.com/en-us/library/cc754941.aspx

    simply saying, open DNS management console (dnsmgmt.msc), select DNS server name on the list and in the right pane at the bottom, you will see Forwarders. It's short cut to them. Double click on this node and put these IPs there 202.144.128.214, 202.144.128.228 or i.e. Gogle 8.8.8.8 and/or 8.8.4.4

    Clear DNS local cache on your DNS server and from now, it should work fine.


    Regards, Krzysztof ---- Visit my blog at http://kpytko.wordpress.com
    • Edited by iSiek Friday, December 16, 2011 9:13 AM
    • Proposed as answer by Tiger Li Monday, December 19, 2011 10:50 AM
    • Marked as answer by Tiger Li Tuesday, December 20, 2011 11:08 AM
    Friday, December 16, 2011 9:11 AM
  • Dear iSiek,

    Thanks a lot for your suggestions and i have done as you had instructed , but I see that TMG is blocking the internet access of the DHCP server and only as per default rule of firewall my company website is displayed in the browser and TMG restricts all other access.

    Any suggestions ??

     

    Regards,

    KLS


    Network Admin
    Friday, December 16, 2011 1:09 PM
  • Hi KLS,

     

    Thanks for posting here.

     

    Please do not disable IPv6 on server first !

    Meanwhile, set and allow the exceptions for the URL and IP address that mentioned in the TechNet article below on TMG to see if system will still determine it has no internet connectivity  :

     

    Appendix K: Network Connectivity Status Indicator and Resulting Internet Communication in Windows Vista

    http://technet.microsoft.com/en-us/library/cc766017(WS.10).aspx

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Tiger Li Tuesday, December 20, 2011 11:08 AM
    Monday, December 19, 2011 10:48 AM