none
removing raid1 on 2008r2

    Question

  • Hello.

    I have win2008r2 installed on hardware raid1 (intel ih10r). Now i need to use one of mirrored hdd in same server not in raid mode - ahci or ide. (P2V migrations cant work with mirror)

    If i switch in BIOS any option, but raid (as default been) - i get BSOD 0x7b.

    Is any way to boot this server not in raid? 



    Thursday, December 20, 2012 1:33 PM

Answers

All replies

  • Bug Check Code 0x7B: http://msdn.microsoft.com/en-gb/library/windows/hardware/ff559218(v=vs.85).aspx

    This bug check indicates that the Microsoft Windows operating system has lost access to the system partition during startup.

    As RAID is not configurable or managed at the OS level, you will need to contact your manufacturer Technical Support for assistance.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Thursday, December 20, 2012 1:55 PM
  • "has lost access to the system partition during startup" dye driver or some like that - hardware is ok. Its perfectly work as raid, and same like ahci.

    How configure windows to use default ahci driver but raid? 

    Thursday, December 20, 2012 2:06 PM
  • The OS does not recognize the driver, the raid is not listed the same in the OS. Maybe pre-install the driver before the operation, it's your only way out of that.

    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    Thursday, December 20, 2012 2:22 PM
    Moderator
  •  Maybe pre-install the driver before the operation, it's your only way out of that.

     How its make? w2k8 contains intel ahci - im pretty sure..
    Thursday, December 20, 2012 2:30 PM
  • The 0x07b is that the OS does not have it in it's store, so im pretty sure the OS does not recognize it.

    Device Driver Issues



    You may receive a "Stop 0x0000007B" error message in the following scenarios:
    • A device driver that  the  computer boot controller needs is not configured to start during the startup process.
    • A device driver that the  computer boot controller needs is corrupted.

    http://support.microsoft.com/kb/324103?wa=wsignin1.0


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/


    Thursday, December 20, 2012 2:35 PM
    Moderator
  • well. So how to make this? run intel_chipset_install again? not works.. ;(

    Thursday, December 20, 2012 2:37 PM
  • you need to make an advance install, and pre-install even if the hardware is not present in the OS at the moment. the install just install what it found.. like the raid controller...

    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/


    Thursday, December 20, 2012 2:39 PM
    Moderator
  • what p2v software you use ? i did a lot of p2v, and i never felt on a software that forced to to cancel a raid

    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    Thursday, December 20, 2012 2:55 PM
    Moderator
  • what p2v software you use ? i did a lot of p2v, and i never felt on a software that forced to to cancel a raid

    I use P2V from SCVMM (MS SC 2008) - it gives error "The bus location for the object %Servername% at (IDE, 0, 255) is not valid."

    Google sead - raid1 known issue. (example)

    Disk2VHD - cant makes image but its unbootable on Hyper-v


    Thursday, December 20, 2012 3:09 PM
  • ok, well can't help on p2v for hyper-v. but for your first question, try the driver, it's your only way out, or make the p2v in cold mode, booted with a cdrom, not in the OS.

    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    Thursday, December 20, 2012 3:30 PM
    Moderator
  • ok, well can't help on p2v for hyper-v. but for your first question, try the driver, it's your only way out, or make the p2v in cold mode, booted with a cdrom, not in the OS.

    "Cold boot" successfull idea.. But Hyper-V still cant boot it (searching give point - hyper-v cant work any device, exept ide simulation)

    Can u explain "adding drivers" step-by-step ? (i still cant undestand)

    Thursday, December 20, 2012 4:23 PM
  • download the driver, and manually select the .inf, and if lucky only one intel driver will be list. you add each intel driver before removing the raid1.

    OR, use vConverter cdrom to convert the physical server AND after use like SCCVM to import it http://social.technet.microsoft.com/Forums/en/winserverhyperv/thread/ef8c12f7-c45d-442e-9a30-c43cd87df3b3

    with vConverter you make it force to install the vmtool, so the driver for the vmware scsi will be there and loaded. after the hyper-v transfert should work.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    • Marked as answer by Alexey Sorokin Friday, December 21, 2012 9:09 AM
    Thursday, December 20, 2012 6:11 PM
    Moderator
  • Note; Keep in mind that a P2V for a DC is not supported too.

    The way I told earlier is when the P2V does not work well. We can call that a P2VV... I did that on some other hypervisor (xenserver) (used the vmware tool for that) because you are dependant on the P2V's tools. SCCVM seem able to import a lot of VM's type, so that should work.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    Thursday, December 20, 2012 8:51 PM
    Moderator