locked
Windows Server 2008 Remote Desktop problem

    Question

  • Hello everybody,

    I have two Servers- one DC and one Additional DC and 5 Windows XP Clients.

    The problem with the DC is that i am not able to access the Remote Desktop Connection from the client computers. I've checked almost everything including the port number, firewall etc, port scan utilities etc...

    The problem with my Additional DC is that i am able to access the desktop using RDC but when the other user logs on to server using RDC (from the client windows xp machines or workgroup laptop) it asks whether to disconnect the session. The actual error message is

    Windows Logon

    Select a user to disconnect so that you may login.

    <username>

    <username>

    <checkbox> Force disconnect user

    please help....

    Wednesday, April 22, 2009 9:21 AM

Answers

  • The issue rectified by importing the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp from a working system.

    I think i ran CCleaner prior to this problem... may he deleted the key....
    • Marked as answer by arunv707 Saturday, May 02, 2009 9:16 AM
    Saturday, May 02, 2009 9:16 AM

All replies

  • hi there,

    would like to know the architecture so that our troubleshooting will become easier.

    have you configured TS

    PS : only 2 sessions are possible for any mstsc session. for additional conections you need to configure the CACLS for TS which will allow more than 2 connections.


    sainath Windows Driver Development
    Wednesday, April 22, 2009 9:56 AM
  • Hello,

    I haven't configured TS in my Windows Server 2008 64bit Enterprise. First PC is DC and the second one is Additional DC. please help....
    Thursday, April 23, 2009 6:30 AM
  • Hi,
    Did you ever get this resolved? I'm having the same problem with remote desktop in x64. I'm in a trial version, does that matter?

    I've checked the ports, disabled firewall, everything I can think of except inspecting packets.

    Friday, April 24, 2009 12:28 PM
  • Sainath appears to be right.  If you are only using mstsc and not TS then you can only have 2 concurrent sessions.  You already have 2 connected and the message is asking you to disconnect one of these users before you can start a new session.  You need to setup TS.

    Tuesday, April 28, 2009 12:32 PM
  • no Brian, the issue still persists.
    Wednesday, April 29, 2009 4:15 AM
  • I was using this feature with more than 2 people taking instances from server. But one day it all got disabled....
    Wednesday, April 29, 2009 4:18 AM
  • Hi,

    I recomenc you to start the Firewall Service and put Firewall Status i "off".
    best regards,
    Antonio
    Eng.
    • Proposed as answer by Elisa Willman Thursday, April 30, 2009 11:24 PM
    Wednesday, April 29, 2009 3:07 PM
  • The issue rectified by importing the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp from a working system.

    I think i ran CCleaner prior to this problem... may he deleted the key....
    • Marked as answer by arunv707 Saturday, May 02, 2009 9:16 AM
    Saturday, May 02, 2009 9:16 AM
  • Hi Sainath Windows Driver Development,

    Could you please explain how to configure the CACLS for TS ?

    Thanks
    Tzu-Fang
    Thursday, June 04, 2009 3:24 AM