none
Server 2008 Disconnect

    Question

  • I'm using Remote Desktop Manager 2.2 from a Windows 7 Enterprise client to a Server 2008.  I can connect fine, but I want to start a process on the server that can sometimes take over an hour to complete.  So, I want to start the process, disconnect and let the process to continue to run.  I want to connect back at random times to check the progress.  Right now when I start the process then disconnect the process is stopped.  It's like I'm being logged off.  How do I do this?
    Monday, July 18, 2011 6:57 PM

Answers

  • Hi,

     

    Do you configure timeout and reconnection settings for Remote Desktop Services sessions?

     

    By default, Remote Desktop Services allows users to disconnect from a remote session without logging off and ending the session. When a session is in a disconnected state, running programs are kept active even though the user is no longer actively connected.

     

    You can limit the amount of time that active, disconnected, and idle (without user input) sessions remain on the server. This is useful because sessions that remain running indefinitely on the RD Session Host server continue to consume system resources.

     

    So, you must check the settings in Remote Desktop Session Host Configuration. Whether you have set Auto Disconnect and Auto Logoff Idle Sessions on Remote Desktop.

     

    To specify timeout and reconnection settings for a remote session

    1. Open Terminal Services Configuration. To open Terminal Services Configuration, click Start, point to Administrative Tools, point to Terminal Services, and then click Terminal Services Configuration.
    2. Under Connections, right-click the name of the connection, and then click Properties.
    3. In the Properties dialog box for the connection, click the Sessions tab.
    4. Click OK. Changes to timeout and reconnection settings are not applied to sessions that are connected when the change is made. The changes will take effect the next time the user establishes a new connection to the terminal server.

     

    If you have a domain controller, please check these settings in GPO.

     

    These Group Policy settings are located in the following locations:

    • Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits
    • User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

     

    More information:

    Session Time Limits

    http://technet.microsoft.com/en-us/library/cc753112(WS.10).aspx

     


    Technology changes life……
    • Proposed as answer by TP []MVP, Moderator Tuesday, July 19, 2011 4:46 PM
    • Marked as answer by ScottJM Tuesday, July 19, 2011 8:22 PM
    Tuesday, July 19, 2011 7:25 AM
    Moderator

All replies

  • Hi,

     

    Do you configure timeout and reconnection settings for Remote Desktop Services sessions?

     

    By default, Remote Desktop Services allows users to disconnect from a remote session without logging off and ending the session. When a session is in a disconnected state, running programs are kept active even though the user is no longer actively connected.

     

    You can limit the amount of time that active, disconnected, and idle (without user input) sessions remain on the server. This is useful because sessions that remain running indefinitely on the RD Session Host server continue to consume system resources.

     

    So, you must check the settings in Remote Desktop Session Host Configuration. Whether you have set Auto Disconnect and Auto Logoff Idle Sessions on Remote Desktop.

     

    To specify timeout and reconnection settings for a remote session

    1. Open Terminal Services Configuration. To open Terminal Services Configuration, click Start, point to Administrative Tools, point to Terminal Services, and then click Terminal Services Configuration.
    2. Under Connections, right-click the name of the connection, and then click Properties.
    3. In the Properties dialog box for the connection, click the Sessions tab.
    4. Click OK. Changes to timeout and reconnection settings are not applied to sessions that are connected when the change is made. The changes will take effect the next time the user establishes a new connection to the terminal server.

     

    If you have a domain controller, please check these settings in GPO.

     

    These Group Policy settings are located in the following locations:

    • Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits
    • User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

     

    More information:

    Session Time Limits

    http://technet.microsoft.com/en-us/library/cc753112(WS.10).aspx

     


    Technology changes life……
    • Proposed as answer by TP []MVP, Moderator Tuesday, July 19, 2011 4:46 PM
    • Marked as answer by ScottJM Tuesday, July 19, 2011 8:22 PM
    Tuesday, July 19, 2011 7:25 AM
    Moderator
  • As I said, I'm using Microsoft Remote Desktop Connection Manager 2.2.  However, I just tried the standard Remote Desktop Connection from Start, All Programs, Accessories and it ended with the same results.

    I also followed your instructions for setting the timeout,  On the "Sessions" tab:

    1. I checked the first box "Override user settings" but the "End a disconnected session" option remained disabled but reads "1 minute". So I'm guessing this setting is controlled by group policy or something. 
    2. The next option "Active Session Limit" is set at "Never".

    I then checked the group policy settings and found the session time limits set at 1 minute.  I changed the setting.  We'll see what happens now and if the policies are reconfigured automatically.

    Tuesday, July 19, 2011 2:31 PM
  • Looks like the Group Policy changes did the trick.  Thanks for the info.
    Tuesday, July 19, 2011 8:22 PM
  • Hi,

    Thank you for your feedback.


    Technology changes life……
    Wednesday, July 20, 2011 1:59 AM
    Moderator