none
Interactive Services Not Allowed

    Question

  • Hello Everyone,

    Thanks in advance for your time....

    We use GFI Languard to deploy patches to our servers, and starting today, we have one server running 2008 that is receiving errors messages that GFI Languard is an interactive service and the system is not configure to allow interactive services.

    We have been using GFI for a number of years, and this system has been patch before using this method.

    I should add that this particular server is not part of the domain, and it is configured in a stand alone environment.  Keep in mind that GFI allows us to set the user id and password to patch this system.

    I have looked on the internet for a solution, I have restarted the Interactive Desktop service and have even disabled the service, and still no luck.  The GFI service that is used to install the patch is not one that is installed on every system, it is deployed dynamically to each server as it needs to patch...so I am not able to always allow this service to interact.

    I am fresh out of ideas, and was hopeful that the community might have some ideas.

    Thanks again,

    CU

    Tuesday, June 21, 2011 5:52 PM

Answers

  • Issue has now been resolved.  It turns out the patches that were downloaded and to be installed on the 2008 Servers were corrupt.  Once the patches were downloaded again there were no further issues.

     

    Thanks to everyone for your help, much appreciated

    CU

    Tuesday, June 21, 2011 8:58 PM

All replies

  • check your GFI manual to see what permissions are required by the application (logon as a service, allow interactive logon, etc.) and check the local security policy of the 2008 server to verify the settings are correct.
    Tuesday, June 21, 2011 6:48 PM
  • Hi Roy,

    Thanks for the response..

    I am not sure that checking the settings for the application really matters as the agent that GFI uses is installed dynamically on the fly when the software is about to install.  There is nothing preloaded on the server, or even workstations for that matter.I

    Any other ideas?

    Tuesday, June 21, 2011 7:06 PM
  • do you have other win 08 servers that are updating?

    win 08 default security is tight. does the agent require and specific permissions?

    has this server ever updated or is this a new machine?




    Tuesday, June 21, 2011 7:20 PM
  • Issue has now been resolved.  It turns out the patches that were downloaded and to be installed on the 2008 Servers were corrupt.  Once the patches were downloaded again there were no further issues.

     

    Thanks to everyone for your help, much appreciated

    CU

    Tuesday, June 21, 2011 8:58 PM
  • you are welcome from everyone
    Tuesday, June 21, 2011 9:43 PM