none
Group Policy to Lock computer Windows 7

    Question

  • Hi All,

    I currently have a win2k3 domain with windows 7 clients. I've tried to create a GPO to lock computers after 5mins of inactivity.  From Administrator Templates I've enabled: Screen Saver, password protect the screen saver and screen saver timeout.

    However, after 5 mins of inactivity the windows 7 computers do not lock. Does anyone have an idea what I am doing wrong?

    Kind Regards

    Ant

    Monday, March 12, 2012 2:39 PM

Answers

  • Sorry if I am asking again, but are the following enabled, under Userconfig\Administrative Templates\control panel\personalization?

    1. Enable Screen Saver
    2. Force Specific Screen Saver
    3. Password Protect the Screen Saver
    4. Screen Saver timeout

    Is the group policy applying ? Can you do a gpresult /r on the client to see if it is applying?

    I understand you want to lock screen and not necessarily run a screensaver? If that's the case, in the setting 2 above, leave Specify the screensaver as blank.

    Hope it helps,

    • Marked as answer by Wellseytkd Tuesday, March 13, 2012 2:17 PM
    Monday, March 12, 2012 4:24 PM
  • Hi,


    Based on my test, everything is fine.


    Please run gpupdate /force at first.


    At the present situation, I'd like to suggest to use RSAT to deploy the policy setting as Nav_007 mentioned:


    Remote Server Administration Tools for Windows 7 with Service Pack 1 (SP1)
    http://www.microsoft.com/downloads/details.aspx?FamilyID=7D2F6AD7-656B-4313-A005-4E344E43997D&displaylang=zh-t&displaylang=en


    If the issue persist, please try to use gpmc.log and gpresult.log to verify the policy applied successfully:


    For details:

    GPMC.log
    ==================
    a.    On domain controller, click Start -> Run, type GPMC.MSC, it will load the GPMC console.
    b.    Right click on "Group Policy Result" and choose wizard to generate a report for the problematic computer and user account (please place appropriately). (Choose computer and select the proper user in the wizard)


    Collect gpresult output
    ==============
    1. Run the command gpresult /v >C:\gpresult.txt.


    In addition, there is a relate article for your reference:


    Troubleshooting Group Policy
    http://technet.microsoft.com/en-us/library/cc758608(v=WS.10).aspx


    Hope this helps!


    Best Regards
    Elytis Cheng


    Elytis Cheng

    TechNet Community Support

    • Marked as answer by Wellseytkd Tuesday, March 13, 2012 2:17 PM
    Tuesday, March 13, 2012 3:32 AM
    Moderator

All replies

  • Hello,

    You have to use "Force specific screen saver" parameter so that it works. More here: http://social.technet.microsoft.com/Forums/en/winserverGP/thread/5c2518d4-f531-471a-a649-0f5dd5495679



    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Monday, March 12, 2012 2:55 PM
  • Hi

    Sorry, in Win2k3 I've enabled Screen Save Executable Name with the location being C:\WINDOWS\system32\scrnsave.scr and still it doesnt work :( Any thoughts?

    Monday, March 12, 2012 3:14 PM
  • Sorry if I am asking again, but are the following enabled, under Userconfig\Administrative Templates\control panel\personalization?

    1. Enable Screen Saver
    2. Force Specific Screen Saver
    3. Password Protect the Screen Saver
    4. Screen Saver timeout

    Is the group policy applying ? Can you do a gpresult /r on the client to see if it is applying?

    I understand you want to lock screen and not necessarily run a screensaver? If that's the case, in the setting 2 above, leave Specify the screensaver as blank.

    Hope it helps,

    • Marked as answer by Wellseytkd Tuesday, March 13, 2012 2:17 PM
    Monday, March 12, 2012 4:24 PM
  • Hi,


    Based on my test, everything is fine.


    Please run gpupdate /force at first.


    At the present situation, I'd like to suggest to use RSAT to deploy the policy setting as Nav_007 mentioned:


    Remote Server Administration Tools for Windows 7 with Service Pack 1 (SP1)
    http://www.microsoft.com/downloads/details.aspx?FamilyID=7D2F6AD7-656B-4313-A005-4E344E43997D&displaylang=zh-t&displaylang=en


    If the issue persist, please try to use gpmc.log and gpresult.log to verify the policy applied successfully:


    For details:

    GPMC.log
    ==================
    a.    On domain controller, click Start -> Run, type GPMC.MSC, it will load the GPMC console.
    b.    Right click on "Group Policy Result" and choose wizard to generate a report for the problematic computer and user account (please place appropriately). (Choose computer and select the proper user in the wizard)


    Collect gpresult output
    ==============
    1. Run the command gpresult /v >C:\gpresult.txt.


    In addition, there is a relate article for your reference:


    Troubleshooting Group Policy
    http://technet.microsoft.com/en-us/library/cc758608(v=WS.10).aspx


    Hope this helps!


    Best Regards
    Elytis Cheng


    Elytis Cheng

    TechNet Community Support

    • Marked as answer by Wellseytkd Tuesday, March 13, 2012 2:17 PM
    Tuesday, March 13, 2012 3:32 AM
    Moderator