none
Keyboard key remapping on RDP to Windows Server 2008 R2

    Question

  • Hello dear colleagues,

    I am trying to remap certain key on Windows Server 2008 R2 for use with Remote Desktop Connection.

    The actual case: in Lithuanian (standard) keyboard layout, the numpad period "." key is substituted with coma ",". What I want to do - switch the coma back to period.

    So far I have tried setting "Scancode Map" key in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout" and "HKEY_CURRENT_USER\SYSTEM\CurrentControlSet\Control\Keyboard Layout" and "IgnoreRemoteKeyboardLayout". None of these options do work with RDS.

    Looking forward for your help. Thanks in advance!

    Thursday, October 25, 2012 6:41 PM

Answers

  • Hi,

    Whether your keyboard mapping incorrect in your terminal sessions. By default, the Terminal Services client will map the local keyboard layout to the Terminal Server in the session automatically.

    If you are using Windows XP & Vista for you client, you should install the RDC 7.0.

    Remote Desktop Connection 7.0

    http://support.microsoft.com/kb/969084/en-us

     

    Please also check the following Local Resources Keyboard Options in Remote Desktop Connection, you can modify the registry key in local client devices, then remap this settings to target server.

    • Click Options
    • Click 'Local Resources'
    • On the Keyboard Box change 'Apply windows key combinations' to 'On the local computer'

    Hope this helps.

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    Monday, October 29, 2012 7:14 AM
    Moderator