none
help please problems installing 4.5 installer on windows vista

    Question

  • Hi. I would really appreciate any answer. immediatly after downloading 6.0KB92288-v2-86.msu there's the standalone installer pop up asking permission and after granted another pop up says  does not apply to system

    I also tried server 2003 KB942288v4 x86.exe get a notification the operation needs elevation.

    my pc is an hp compaq presario

    windows vista

    service pack 2

    32 bit

    3.00 bg      obviously I know virtually nothing about what I'm doing right now but I'm trying really hard to learn. Any help would be very much appreciated.

    Monday, February 04, 2013 2:21 AM

Answers

  • Hi trobert,


    Please note that:


    Windows6.0-KB942288-v2-x86.msu applies to Windows Vista and Windows Vista Service Pack 1.


    WindowsServer2003-KB942288-v4-x86.exe applies to Windows Server 2003 Service Pack 1, Windows Server 2003 Service Pack 2 and Windows XP 64-bit Editions.


    See, Windows Installer 4.5 Redistributable


    As the Service Pack 2 of Windows Vista has Windows Installer 4.5 included, there is no need to install it again.


    See, Windows Installer 4.5 in Vista SP2 and Windows 2008 SP1


    If you would like to verify the version of the Windows Installer on your system, please check the version of MSI.DLL in the Windows\System 32 folder.


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Wednesday, February 06, 2013 7:44 AM
    Moderator

All replies

  • Start|Programs|Accessories, then right-click Command Prompt and Run as administrator. Then run the MSI from command line.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.


    Monday, February 04, 2013 2:30 AM
  • Hi trobert,


    Please note that:


    Windows6.0-KB942288-v2-x86.msu applies to Windows Vista and Windows Vista Service Pack 1.


    WindowsServer2003-KB942288-v4-x86.exe applies to Windows Server 2003 Service Pack 1, Windows Server 2003 Service Pack 2 and Windows XP 64-bit Editions.


    See, Windows Installer 4.5 Redistributable


    As the Service Pack 2 of Windows Vista has Windows Installer 4.5 included, there is no need to install it again.


    See, Windows Installer 4.5 in Vista SP2 and Windows 2008 SP1


    If you would like to verify the version of the Windows Installer on your system, please check the version of MSI.DLL in the Windows\System 32 folder.


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Wednesday, February 06, 2013 7:44 AM
    Moderator