none
Wallpaper via Group Policy and Windows 7

    Question

  • My organization has recently deployed Windows 7 Professional (RTM, VLK) to our two computer labs. Users who log onto these machines get a wallpaper that has my organizations name and logo, deployed via group policy. After the upgrade to Win7 Pro, the wallpaper does not apply correctly. I began troubleshooting whether this was a result of conflicting policies, but even after making a new user, and placing him in a test OU with only the wallpaper GPO applied, this still happens.

    Thursday, August 27, 2009 1:50 PM

Answers

  • Hi,

     

    Thank you for all updates.

     

    Based on our test, it seems the Registry key [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] is missing and caused this problem. To work around this issue, please create a String Value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] on client and try to set wallpaper.

     

    We can use Group Policy Preference->Registry to deploy this Registry key or use user logon script to deploy this Registry key.

     

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, August 31, 2009 10:00 AM
    Moderator

All replies

  • Hi,

    Let’s try the steps below to narrow down the cause of this issue:

    1. Run RSOP.MSC on client, make sure the wallpaper policy was applied.
    2. If the policy was applied, check the permission of the wallpaper folder. Make sure Authenticated User has Read Permission.
    3. Could you manually set the wallpaper?
    4. Run "gpresult /v >>c:\gp.txt" and use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the file and then give me the download address.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, August 28, 2009 9:19 AM
    Moderator
  • Cheeseman1208,

    Can I please clarify something?...

    We are also having problems with the wallpaper not applying...but...the Group Policy 'is' being applied.  In fact if you press the "Show Desktop" button (bottom right hand corner of the taskbar) the wallpaper is 'briefly' (VERY briefly) shown and then the wallpaper reverts to black.

    My view is that the wallpaper policies are being applied correctly, but the o/s isn't displaying it (for whatever reason).

    Lee
    Friday, August 28, 2009 10:56 AM
  • @Mervyn
    http://cid-f6ef651ce71192c8.skydrive.live.com/embedrowdetail.aspx/Technet/gp.txt
    The permissions are set to everyone: Full Control and Authenticated Users: Full Control.
    However, I cannot set the wallpaper manually. If I navigate to the network share, right click, and "Set as Desktop Wallpaper" (both as domain admin and as a normal user), nothing happens. Even if I copy the wallpaper locally and try, nothing happens.

    @Lee
    That is exactly what I'm experiencing. But if you go to "Personalize" and view the themes applied, it says the wallpaper is active! The only way I can get the wallpaper to show up is if I change the theme (from Unsaved Theme) to one of the Aero or Basic themes. If I try going back to the "Unsaved Theme", the wallpaper still shows up.
    Friday, August 28, 2009 3:00 PM
  • Interesting!

    I have had my wallpaper show correctly after I experienced these issues...but, if I'm honest, I don't know what I did to display the wallpaper correctly.

    A colleague of mine who has also rebuilt his workstation from Vista to Windows 7 (Clean Install) has also been experiencing the same issue.

    This is definately a problem; albeit a minor one (for us).

    Lee
    Friday, August 28, 2009 3:18 PM
  • @Kyle
    We have exactly the same problem with a new deployment of Windows 7 machines (they are Ultimate edition). All of the machines suffer the same problem which we've verified isn't a permission or policy problem (at least it's not that the policy isn't being set).

    Fantastic post though, detailing the problem perfectly as we see it here - I look forward to input from Microsoft on this one.
    Friday, August 28, 2009 3:55 PM
  • This is weird. A user just logged in, and for some reason it loaded a temporary profile. However, the deployed wallpaper came up fine under the temp profile. I'm starting to think that this is a profile issue more than a group policy issue.
    Friday, August 28, 2009 7:58 PM
  • Hi,

     

    Thank you for all updates.

     

    Based on our test, it seems the Registry key [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] is missing and caused this problem. To work around this issue, please create a String Value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] on client and try to set wallpaper.

     

    We can use Group Policy Preference->Registry to deploy this Registry key or use user logon script to deploy this Registry key.

     

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, August 31, 2009 10:00 AM
    Moderator
  • Thanks Mervyn!! That worked perfectly. It isn't as clean as I would like, but it works, and that's all that matters.
    Monday, August 31, 2009 2:46 PM
  • Hi,

    Glad to hear the suggestions worked. If you have other questions in the future, you’re welcomed to our forum.

    Thanks. 


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, September 01, 2009 1:16 AM
    Moderator
  • Do you put anythign in as value when you set this?
    Wednesday, September 16, 2009 4:36 PM
  • Hi,

    We have to input any path as the value, like C:\ is OK.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Phil Ciccone Friday, August 02, 2013 12:48 PM
    • Unproposed as answer by Phil Ciccone Friday, August 02, 2013 12:49 PM
    Thursday, September 17, 2009 1:47 AM
    Moderator
  • We have just started Windows 7 testing at our company too. We're using Windows 7 Enterprise 32-bit RTM MAK from Technet. We have the exact same problem. No wallpaper appears after a domain user logs on. Looking in the wallpaper panel shows the wallpaper in the preview and switching themes around does indeed cause the wallpaper to appear.

    Forgive the blunt, but I feel necessary question....

    If this registry key is required for the deployment of wallpaper via group policy to work, why on earth is it not created automatically by Windows itself when the user logs on for the first time? We should not have to be doing registry frigs to get a wallpaper group policy to work.

    Please correct me if I'm mis-reading the situation.
    Wednesday, September 30, 2009 11:16 AM
  • I'm also having this problem, but with Windows Server 2008 R2 (Remote Desktop Services).  Trying to set wallpaper but it's coming up blank, exactly as described by all above.

    With the solution offered by Mervyn, is the "Wallpaper" setting mentioned a registry "key" as written, or did you mean registry "value"?

    We have the Wallpaper value in the HKCU\Control Panel\Desktop key, but I'm reading you need to create a Wallpaper key as well under the Desktop key, is that right?

    If so, are you meant to just leave the (Default) with type REG_SZ as the root value of this new key?  Tried every which way I can think of, and still can't get the damn desktop background to apply.
    Monday, October 12, 2009 6:03 AM
  • I'm also having this problem, but with Windows Server 2008 R2 (Remote Desktop Services).  Trying to set wallpaper but it's coming up blank, exactly as described by all above.

    With the solution offered by Mervyn, is the "Wallpaper" setting mentioned a registry "key" as written, or did you mean registry "value"?

    We have the Wallpaper value in the HKCU\Control Panel\Desktop key, but I'm reading you need to create a Wallpaper key as well under the Desktop key, is that right?

    If so, are you meant to just leave the (Default) with type REG_SZ as the root value of this new key?  Tried every which way I can think of, and still can't get the damn desktop background to apply.

    I'm also seeing this on RDS sessions, did you find a solution?
    Monday, October 12, 2009 1:27 PM
  • Not yet.  I'll have another chop at it today.  But to be honest, I've already wasted far too much time trying to work around this bug in GP deployment.  Really surprises me that simple stuff like this gets through Beta and the RC of both Windows 7 and 2008 R2.
    Monday, October 12, 2009 8:55 PM
  • I was in the Techbeta program of Windows 7 and Server 2008 R2, but unfortunately I didn't have time to test any domain stuff regarding group policy... sorry we let this one slip through. Any comment please Microsoft? This is a blatant group policy bug and should be fixed asap please lest you annoy your corporate admins :)
    Monday, October 12, 2009 8:57 PM
  • lol, this corporate admin is already annoyed  :)
    Wednesday, October 14, 2009 2:50 AM
  • Yeah, I couldn't get this going in the end.  Will just have to make do with having no corporate background.

    It also seems that the desktop background GPO also doesn't apply properly to users.  Have had to manually change the HKEY_CURRENT_USER\Control Panel\Colors key to 0 0 0  to get a black background.

    There also doesn't seem to be any way to set up a default user profile that can then be applied automatically to new users on your RDS farm.  Microsoft point you to copying the profile using the unattend.xml and sysprep to set up a default profile, which doesn't really help us with an existing farm.

    It really feels like Microsoft RDS team has completely dropped the ball with R2.  Seems to be lots of people banging their heads against the wall to get the simplest things applying and working in a consistent manner.
    Thursday, October 15, 2009 6:58 AM
  • Guys I know this is an out of date topic really but as far as I can see there is no answer. I just had this issue on a customers site. I'm not really sure if this helps but I've found if you restart the themes service it works 100%. The areo theme seems to cause problems. This also changes the start menu to the "classic" style menu if the service is stopped.

    Adam.
    • Proposed as answer by Novosco Tuesday, November 24, 2009 2:47 PM
    Tuesday, November 24, 2009 2:47 PM
  • Guys I know this is an out of date topic really but as far as I can see there is no answer. I just had this issue on a customers site. I'm not really sure if this helps but I've found if you restart the themes service it works 100%. The areo theme seems to cause problems. This also changes the start menu to the "classic" style menu if the service is stopped.

    Adam.
    Sorry Novo, but that isn't an answer to the problem so please do not try to mark it as such. At best it's a workaround, and a poor one at that. As one of the hundreds (thousands?) of testers of Windows 7 I wonder how this particular issue made it through. Not being able to reliably deploy corporate wallpaper through group policy is a STONKER of a bug and needs addressing asap. Turning off themes isn't a solution.
    Tuesday, November 24, 2009 11:26 PM
  • I agree, this really should have been fixed in Beta/RC...
    Wednesday, November 25, 2009 10:33 AM
  • We are experiencing the same issue.

    Changing the wallpaper setting in the registry does nothing.  It reverts to a blank key as soon as you log off and back on.

    This is very frustrating and is not acceptable.
    Wednesday, November 25, 2009 11:16 PM
  • I've narrowed this down a bit.  It would appear that Aero is the crux of the problem.  If I choose the theme Windows Classic, High Contrast #1, High Contrast #2, High Contrast Black or High Contrast White and pick any solid background the settings stay.

    Any other settings including the theme Windows 7 Basic causes the system to revert to a black background.

    Thursday, November 26, 2009 12:33 AM
  • I have just run into the same problem after spending many hours trying to resolve it has been very frustrating. I totally agree this should not have made it through the BETA and RC releases.  I have also found login is delayed when this occurs as if the process is waiting for a timeout?  Are Microsoft working on a real fix for this?  If so we need it fast!

    Thursday, November 26, 2009 5:09 PM
  • Sorry for all the inconvenience this issue has brought. A hotfix is been tested internally. If there is any update, I will post here. Please try the workaround currently. Thank you for your patient.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, November 27, 2009 1:01 AM
    Moderator
  • Thanks Mervyn. Please be sure to let us know when this hotfix is available for testing. This is one of a handful of bugs holding us back from progressing the rollout of Windows 7 in our organisation.
    Friday, November 27, 2009 7:20 PM
  • We are having the same problems with the background in Windows 7. I found a work around for the time being.

    First you have to diable the background policy so that you can change it yourself on the workstation.
    Then i changed the background from black to the color that it has to have. Next i selected the right background logo and saved the settings.
    I gave the workstation an reboot an when i logged in the background and logo was still the right one.

    Then i changed the background policy again from diabled to enable.
    Gave the workstation in CMD promt the next command: gpupdate /force. Next i checked if the background setting on the workstation where in controle bij the systemadministrator (policy) and everything worked fine.

    This only worked for the user the setting has been made on. It looks like it is a setting that is set on the users profile. It is not a solution that you want to for your whole organisation but in my case it only for four systems so far.

    I hope this posting is helpfull for some of you as long as the fix in not ready for distribution.
    Monday, November 30, 2009 3:29 PM
  • Our situation is resolved.  It would appear that using any sort of remote management tool to access a test PC, renders Aero unusable.  At least this is our situation.  We were accessing our test boxes via RDP, Proxy and Dameware.

    The machines function fine when logged on locally.

    Hope this helps someone.
    Thursday, December 03, 2009 12:59 AM
  • Our situation is resolved.  It would appear that using any sort of remote management tool to access a test PC, renders Aero unusable.  At least this is our situation.  We were accessing our test boxes via RDP, Proxy and Dameware.

    The machines function fine when logged on locally.

    Hope this helps someone.
    Thanks for the topic contribution my friend, and no offence when I say this... but what has Aero being deactivated when you connect via RDP got to do with the topic of this thread? The topic is about group policy and wallpaper in Windows 7. It's not related to Aero or RDP.
    Saturday, December 05, 2009 9:29 AM
  • Sorry for all the inconvenience this issue has brought. A hotfix is been tested internally. If there is any update, I will post here. Please try the workaround currently. Thank you for your patient.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Has there been any forward progress on this? I have recently re-imaged a machine into a fresh OU that has the Desktop Wallpaper defined as well as pushed out the registry entry and still no wallpaper is being displayed.

    Thanks,

    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Tuesday, December 08, 2009 11:16 PM
  • I can't test a solution for this since it works perfectly fine on my network (Windows 7/Windows 2008 R2) without any registry modifications, although does the following command remedy the situation?

    RUNDLL32.EXE user32.dll,UpdatePerUserSystemParameters
    Wednesday, December 09, 2009 12:56 AM
  • I can't test a solution for this since it works perfectly fine on my network (Windows 7/Windows 2008 R2) without any registry modifications, although does the following command remedy the situation?

    RUNDLL32.EXE user32.dll,UpdatePerUserSystemParameters

    I run a Windows 2008 domain as well, and this occurs on all Windows 7 machines with wallpaper assigned via gpo, which is exclusively in the labs.

    What does that command do?
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Wednesday, December 09, 2009 2:01 PM
  • In XP the command would reinitialize all user settings including the wallpaper. However, I'm not sure if it still does so on Vista or 7, but it's worth a try.

    Here's a sample use:

    http://windowsitpro.com/article/articleid/93152/how-can-a-batch-script-alter-the-users-screen-saver-and-wallpaper-settings-and-become-effective-without-a-logoff-and-logon.html

    And through Powershell:

    invoke-wmimethod win32_process -name "create" -argumentlist "rundll32 user32, UpdatePerUserSystemParameters"

    http://download.microsoft.com/download/2/1/9/21970F09-A0DB-4EC1-A55B-3A3BAF41B5F5/UsingWindowsPowershellonEmbeddedDevices-Yong.pdf
    • Edited by Ryan Capp Thursday, December 10, 2009 3:49 AM Powershell
    Thursday, December 10, 2009 3:40 AM
  • The RUNDLL command didn't work for me on Windows 7 when removing the registry policy setting for the wallpaper. Although the Powershell command worked and reverted to the default Windows 7 wallpaper without a logoff/logon procedure.

    EDIT:  However, the wallpaper selector is still locked and shows the old image thumbnail.

    Thursday, December 10, 2009 6:52 AM
  • Does anyone know how to run a script ONLY once when a NEW user logs on?

    All a script would need to do is:

    1. When a New User Logs on for the first time
    2.  add a path in registry key HKLU\Control Panel\Desktop\Wallpaper  "%windir%\web\wallpaper\background.jpg
    3. Logoff The user

    Then when the user logs back on they will have the mandatory background. I just cant find how to add a script to only run when a new user logs on and run only  once. the runonce reg key wont work becouse it is only for the FIRST user to logon and not persistant for multiple users logging on.

    The only thing that would happen is the user would need to log back in again right away after they already loged on the first time.

    Man, I cant beleive this one. I am in an enterprise envirenment and this is a pretty standard requirement. Like 101 stuff here. How can the programers get away with missing such a simple thing like this?

    If a systems administrator say, went on vacation and accidentally left a TILTING bucket of water sitting on top of the server rack, it would be pretty much  the same thing as the programer who accidently forgot to allow users who logon for the first time to get assigned a mandatory corporate background!!!
    • Proposed as answer by One IT NZ Tuesday, April 19, 2011 11:56 PM
    Friday, December 11, 2009 6:00 AM
  • I started out trying to create a script to run at login to modify the reg key HKCU\Control Panel\Desktop\Wallpaper to point to a new location for the desktop background because I was getting the same black screen everyone else was. I was going to place the script in C:\Program Files\Scripts and create a link to that script in the startup folder of the default user profile. The script would modify the reg key and then delete the link in that users startup folder so it would only run the first time. I didn't end up having to do that. 

    I was able to set the reg key in a local account in my image. Before snapping the image I modified HKCU\Control Panel\Desktop\Wallpaper to point to another folder. In this case C:\Drivers\ because we already have a script that copies model specific drivers to the local machine from a server. I simply put the background image there in that folder. Once the reg key is modified copy the local account user folder to the default user folder.

    After I snapped the image and applied it to another machine the HKCU\Control Panel\Deskop\Wallpaper key is set to C:\Drivers\Background.jpg on all domain and local account that log in and the background shows up fine. Hope this helps someone.
    Wednesday, December 16, 2009 8:43 PM
  • Waiting for this hotfix. this is a ridiculous time consumer, our policy states must use a corp wallpaper, and i can't deploy these machines until this is sorted.

    C'mon MS.
    Thursday, December 17, 2009 10:42 AM
  • Yep, the delay is inexcusable. I too am not willing to deploy any Windows 7 machines until this is sorted.
    Thursday, December 17, 2009 6:00 PM
  • While it's not a good fix, you can certainly use the GPO Preferences to set the proper registry key for the background. This appears to the way to make it go, until some sort of fix is made that allows the actual policy to be applied.
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Thursday, December 17, 2009 8:45 PM
  • FYI, I just set the background via GPO Preference, and that works every single time.
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    • Proposed as answer by kevcomdude Friday, September 27, 2013 2:10 PM
    • Unproposed as answer by kevcomdude Friday, September 27, 2013 2:10 PM
    Thursday, December 17, 2009 8:47 PM
  • FYI, I just set the background via GPO Preference, and that works every single time.
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Thursday, December 17, 2009 8:47 PM
  • FYI, I just set the background via GPO Preference, and that works every single time.

    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Thursday, December 17, 2009 8:48 PM
  • Have you even tried setting the registry entry for backgrounds? I agree, it's lame, but it sets the wallpaper every single time. This allows you to work within your company policy. Worse case simply find whatever the default background is and replace it with your jpg in your image.
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Thursday, December 17, 2009 8:52 PM
  • Seriously? You're not going to deploy Windows 7 because you can't figure a work-around to displaying a custom desktop background? While annoying it's certainly no show stopper.
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Thursday, December 17, 2009 8:54 PM
  • Jeffrey - different companies have different polices, whilst i certainly don't agree with some of them, i must abide by them. To answer your question, yes i have applied the local reg hack to the laptops, which works in some cases, but no the GPO - i have yet to apply it - care to share your knowledge? is it the wallpaper key via a reg GPO? i assume.
    Friday, December 18, 2009 9:01 AM
  • Jeffery,

    Simply replacing the default image: c:\windows\web\wallpaper\windows\image0.jpg does not resolve the issue. I have created images replacing img0.jpg with our corporate background and only a black screen will appear the next time someone logs in.

    This certainly is the biggest annoyance with Microsofts Windows 7.  I have to wonder how the heck they let thier programers get away with the cr@p they do.  I am going to apply for a programing job at microsoft becouse you certainly dont need to be a good programer to work for them.


    There is NO accountability, and certainly very little quality controll when they release new products. All they are doing is RUSHING software out the door to keep ther dam software assurance cycle meeting the expectations of corporate users who pay double the price expecting new software every 3 years.

    Microsoft gets paid in ADVANCE using Software assurance and it forces them to push Cr@p out the door to provide the illusion of getting a new OS for your money. Heck, windows Vista should NEVER have been released. They should have waited from Windows XP to Windows 7 directly.

    If they would take thier time, provide REAL quality control, Microsoft would do alot better producing software that does not contain such major annoyances for the corporate envirenment.
    Thursday, December 24, 2009 9:00 AM
  • Jeffrey,

    What about the Machines that do not connect to the domain? We have users all over the globe. Singapore, Vietnam, Mallaysia, Australlia, etc... Some of them are so remote and they do not connect to our domain, however we ship them a laptop for use with remote desktop services that we host.

    It is corporate Policy to apply the standard corporate background. If a machine does not connect to the domain then you can not enfore group policy prefrences. We use SCCM to deploy images to all our machines.  We also Loan, contracters laptops that do not connect to our domain, however we enforce background and other policies.

    So yes , in SOME situations you are correct, however your solution does not cover ALL situations.
    Thursday, December 24, 2009 9:10 AM
  • Jeffrey,

    What about the Machines that do not connect to the domain? We have users all over the globe. Singapore, Vietnam, Mallaysia, Australlia, etc... Some of them are so remote and they do not connect to our domain, however we ship them a laptop for use with remote desktop services that we host.

    It is corporate Policy to apply the standard corporate background. If a machine does not connect to the domain then you can not enfore group policy prefrences. We use SCCM to deploy images to all our machines.  We also Loan, contracters laptops that do not connect to our domain, however we enforce background and other policies.

    So yes , in SOME situations you are correct, however your solution does not cover ALL situations.

    Actually we use sccm as well. We have a single base image for ALL computers, domain joined and un-joined. We can place our custom background into that image without any issue at all. So it WILL work, and I know this because I've done it.
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Thursday, December 24, 2009 2:00 PM
  • Jeffery,

    Simply replacing the default image: c:\windows\web\wallpaper\windows\image0.jpg does not resolve the issue. I have created images replacing img0.jpg with our corporate background and only a black screen will appear the next time someone logs in.

    This certainly is the biggest annoyance with Microsofts Windows 7.  I have to wonder how the heck they let thier programers get away with the cr@p they do.  I am going to apply for a programing job at microsoft becouse you certainly dont need to be a good programer to work for them.


    There is NO accountability, and certainly very little quality controll when they release new products. All they are doing is RUSHING software out the door to keep ther dam software assurance cycle meeting the expectations of corporate users who pay double the price expecting new software every 3 years.

    Microsoft gets paid in ADVANCE using Software assurance and it forces them to push Cr@p out the door to provide the illusion of getting a new OS for your money. Heck, windows Vista should NEVER have been released. They should have waited from Windows XP to Windows 7 directly.

    If they would take thier time, provide REAL quality control, Microsoft would do alot better producing software that does not contain such major annoyances for the corporate envirenment.

    Ok, so it sounds like this thread has turned into a ____ fest over something trivial, that can literally be worked around in at least two different ways. I hope you guys have a wonderful holiday if you celebrate it.
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Thursday, December 24, 2009 2:02 PM
  • Jeffrey - different companies have different polices, whilst i certainly don't agree with some of them, i must abide by them. To answer your question, yes i have applied the local reg hack to the laptops, which works in some cases, but no the GPO - i have yet to apply it - care to share your knowledge? is it the wallpaper key via a reg GPO? i assume.

    <Registry clsid="{9CD4B2F4-923D-47f5-A062-E897DD1DAD50}" name="WallPaper" status="WallPaper" image="6" changed="2009-12-08 23:29:37" uid="{CF16133E-ABF6-4511-B20E-2065F786F968}"><Properties action="R" displayDecimal="1" default="0" hive="HKEY_CURRENT_USER" key="Control Panel\Desktop" name="WallPaper" type="REG_SZ" value="\\path\to\your\background.jpg"/></Registry>

    That's literally the copy/paste from my User GPO Preference for our entire domain. We've noticed that in using System Center with this reg entry that the initial logon has the default SCCM background, but upon a reboot the background you specify is loaded.

    Happy Holidays!
    Jeffrey S. Patton Assistant Director of IT School of Engineering Computing Services University of Kansas 1520 West 15th Street Lawrence, KS. 66045-7621
    Thursday, December 24, 2009 2:05 PM
  • Hi all,

    I have been experiencing this issue on the new laptops that are joined to our network.

    I have added the registry entry as given above using GPO preferences.

    If I logon on one of the windows 7 laptops the mapped drives are being added correctly as per the mapped drive preference.

    The registry setting is there and has the server share location of the image.

    The jpg image is available when I browse to the share.

    When I right click the desktop>personalise the required wallpaper is shown as an unsaved theme and as the current background, though there is a small pause before it appears, it starts as a black rectangle.

    but I still get a black desktop =(

    Anyone have any ideas..?

    Thanks
    Tuesday, December 29, 2009 10:48 PM
  • Well, another option you can try on that problem is, New user account, we have checked on standalone machines and that's working fine and checked on may computer which were facing the same problem.

    This has something related to user account corruption, on some stand alone machine i have checked that wallpaper key is there but still we had the problem, only workaround on those machines we have found is new user account.


    Jatin
    • Proposed as answer by Jatin Gandhi Thursday, January 07, 2010 11:56 AM
    Thursday, January 07, 2010 11:53 AM
  • We have this issue as well - why in the world would this functionality not be available in GPO?  Will look at some of the work arounds but please repair or provide a hot fix.
    Monday, January 11, 2010 11:42 PM
  • Registry hacks may seem to be way but, it does not answer the main question, nor does it explain if it works on machines with mulitple profiles?

    We lock down the registry to prevent users accessing it, does this cater for that too?

    JT
    Sunday, January 24, 2010 9:09 AM
  • It was noted on the 27 Nov that there was a hotfix being tested internally by MS for this issue. Are there any further details on this? Surely something should be avaiable by now! I'm in the process of trying to demo Windows 7 (and all the advantages) to a large client, it doesn't look too good when simple things like the ability to set desktop background need to to be 'frigged' to get them working. If it's an acknowledged bug, I'd like a proper fix....

    Thanks,
    Stephen

    Monday, January 25, 2010 3:10 PM
  • I'd also like to know the status of the hotfix. We've been trying to figure this problem out since we started preparing our Windows 7 deployment a few months ago. All our users have no admin rights, and it seems that that is the only difference between the wallpaper working and not working.
    Monday, January 25, 2010 3:41 PM
  • I'm in the process of deploying Windows 7 Pre-pilot. We have been banging our heads on this one also, a permanent fix would be really good. Any further updates?
    Tuesday, February 02, 2010 3:56 AM
  • Add another to the list... testing internally for a Bank wide deployment and no joy. We are having issues with this along with loading custom themes. As others have stated, not sure how this made it through beta. Please update us on the status of the internal hotfix. This IS a big deal to some users and there is no reason we need to be pushing reg entries to take care of what is a GP bug.
    Thursday, February 04, 2010 6:00 PM
  • We are also seeing this problem, just for the record. I'll try pre-creating the Wallpaper REG_SZ and see if it helps...

    Monday, February 08, 2010 12:16 AM
  • For us, the Wallpaper value exists for a new logon. The %APPDATA%\Microsoft\Windows\Themes folder does not get created. If I manually set a theme at logon, it works, and this folder gets created and it contains a slideshow.ini and TranscodedWallpaper.jpg.

    If I logoff the user and delete this folder, they get the black desktop and "Unsaved Theme" back.

    I've tried pre-creating this folder via our logon script but it does not solve the problem. It could be a red-herring.

    Nothing I have tried in Group Policy has fixed this. We never used to have the problem, it just started one day and I can't think of anything in a GPO that would affect this that we might have changed. I have worked around it by detecting if the Wallpaper value is blank at logon. If so, the themes folder gets created and I copy the standard background from the areo.theme to TranscodedWallpaper.jpg and then call SystemParametersInfo from User32.dll to set the Wallpaper and update  the desktop. The user stills has an "Unsaved Theme" but at least the Desktop looks right again.

    Is there any news on the hotfix mentioned above?
    Monday, February 08, 2010 2:52 AM
  • Hi,

    As of today morning we have a fix available for this issue.

    You can download the Hotfix straight off the KB article page.

    The "Desktop Wallpaper" Group Policy setting is not applied in Windows 7 or in Windows Server 2008 R2
    http://support.microsoft.com/kb/977944

    • Proposed as answer by chrisav Monday, March 01, 2010 10:00 AM
    Tuesday, February 09, 2010 8:21 AM
  • Wonderful news, thank you.

    I shall test this tomorrow and let you know how I get on :)

    EDIT: One small detail. It appears the hotfix is only available for x86. Please advise when the x64 version will be available. Thanks.


    Tuesday, February 09, 2010 5:44 PM
  • Thanks for the update, GautamA. I've tested this and it does not fix our problem. We are not setting a theme or wallpaper via GPO, though, so perhaps our issue is different? If a user logs on for the first time, they used to get the default Windows 7 theme. Now they get a black desktop and an "unsaved theme" just like the images from Kyle on the original post. The wallpaper value exists but is blank. Pre-populating it does not fix the problem, either.

    I will continue to use my workaround of calling SystemParametersInfo. The user still gets the "unsaved theme" but they'll get this as soon as they change any personalisation setting anyway.
    Tuesday, February 09, 2010 6:32 PM
  • Ryster - the Hotfix download page detects your current OS and shows the hotfix download for that architecture only.

    To get a link for all architectures (x86/x64/ia64) click on the text link stating --> " Show hotfixes for all platforms and languages (3)"

    Cheers,
    GautamA
    Wednesday, February 10, 2010 2:06 AM
  • Rob I read through your issue in the 2 posts here and yours is definitely a different issue. Off hand I don’t know what could cause this but some of the things you could look at are:-

    1. gpresult /h gp.htm --> review this exported policy for any theme related setting being pushed down. There is a policy named "load a specific theme" which you can use to roll out a theme of your choice.
    2. a customized default user profile --> do you know of any customization done to the default user profile (c:\users\default).

    I was going to say open a support case since that's the 1 way I can directly assist you but then it looks like you already have a usable workaround. If you do want to pursue this, a separate post in this forum (since yours is a different issue than the one discussed in this post) with the problem details should get one of our TechNet moderators to assist you.

    Cheers,
    Gautam

    Wednesday, February 10, 2010 2:28 AM
  • Thanks, Gautam. The only setting I can see involving wallpaper or themes or appearance is this:

        KeyName:     Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop\NoChangingWallPaper
                    State:       disabled

    We've always had this set, though. I'll consider starting another thread as you suggest but it's not really a problem for us anymore.

    Cheers,

    Rob
    Friday, February 19, 2010 2:05 AM
  • Rob,
    The GP setting I was referring to is under
    User Configuration - Administrative Templates - Control Panel - Personalization - "Load a specific theme".

    You can now actually do a string search inside the Group Policy editor and dont have to hunt under the various trees under Administrative Templates to find the setting of your interest.

    See http://technet.microsoft.com/en-us/library/dd759097.aspx

    Give it a shot!

    Cheers, Gautam

    Sunday, February 21, 2010 2:46 AM
  • Hi - yep, I know about that setting and the very useful new filtering options, the setting I mentioned above is the only slightly relevant one that we do set. I am not setting "load a specific theme" and never have. I might try using it, though, to force the default theme to set in the future and perhaps remove my workaround if that works ok.

    Thanks for your help,

    Rob
    Monday, February 22, 2010 11:18 PM
  • Hi,

    As of today morning we have a fix available for this issue.

    You can download the Hotfix straight off the KB article page.

    The "Desktop Wallpaper" Group Policy setting is not applied in Windows 7 or in Windows Server 2008 R2
    http://support.microsoft.com/kb/977944


    Thanks GuatamA, the hotfix works perfectly in the scope of the wallpaper not loading from a GPO :-)
    Monday, March 01, 2010 10:01 AM
  • Good day Guys,

         Is there any related Hotfix available for Windows XP and Windows Server 2003 Ent. Ed. same scenario happens or the SP3 for Windows XP will fix this?

         Thanks and Regards,

         Cheers...

    Wednesday, March 03, 2010 11:55 AM
  • Hi guys.

    At our company we wanted to apply the same default wallpaper to all users via group policy for Windows 7 workstations.

    Group policy setting:
    User Configuration->Policies->Administrative Tempates->Desktop->Desktop->Desktop Wallpaper:
    Wallpaper Name: C:\test\wallpaper1.bmp


    We found two issues after applying this policy.
    1. New user logon time increased from 50secs to about 2mins.
    2. Windows wallpaper was black, but at logoff you could see the actual wallpaper1.bmp image show up briefly.

    I concluded that since the wallpaper1.bmp was displayed for a fraction of a second, that the group policy applied and worked, but there was something wrong with the way windows was applying it.

    I spent two days trying different options and finally found the solution.
    I cannot explain why this was happening and why the following fixed our issues.


    To have windows 7 showing wallpaper1.bmp file create a JPG file and place it here:
    C:\Users\default\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper.jpg

    Any new user that will login that does not have a profile will get this file copied from this location to his AppData.
    If you have already existing users profiles created on the workstations, you need to create a script to copy this file to their existing AppData folders.

    Note, and I find this strange, that windows will still ignore TranscodedWallpaper.jpg wallpaper file and use C:\test\wallpaper1.bmp image instead or whatever is set in group policy.
    Meaning that TranscodedWallpaper.jpg is not the actual image that is displayed in the background.
    I used two different pictures for testing purposes to confirm that. The fact that C:\Users\default\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper.jpg exists fixes the issue of the black background.


    The slow logon was fixed by creating the following registry key:

    [HKEY_USERS\def\Control Panel\Desktop]
    "Wallpaper"="c:\\test\\wallpaper2.bmp"

    "def" is the default registry hive for C:\Users\Default\NTUSER.DAT so any new created profile will get that setting.
    Obviously because we have a group policy in place, this setting will be overwritten, which is fine, but just the fact that this registry key exists fixed logon time issue.

    I'm courious to see if this solution works for others.. Let me know..

    • Proposed as answer by Paul.Jones Monday, February 07, 2011 2:16 PM
    Thursday, April 01, 2010 4:14 PM
  • hi there I am also facing the same problem just got a laptop win 7 and am non technical guy can you please help meout  by explaining to me what i need to do  C:\Users\default\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper.jpg  i tried using the path but there was no themes folder ther i created a new folder called themes and pasted it there and added a snap but still it didnt work so to be on the safer side i deleted the folder i created and mailing you all

    kindly mail me at vinod131@gmail.com

    Monday, April 19, 2010 7:42 AM
  • This patch has solved my issue thanks GuatamA, Its a pain that I have to make the effort to install this on my machines. this should have been pushed out by MS. The update was made in feb its now april and they still have not pushed it out??? 

    Come on MS I have loads of jobs as it is.

    http://support.microsoft.com/kb/977944

    Tuesday, April 27, 2010 10:47 AM
  •       I am facing same problem. I have checked with rsop policy is applied but wallpaper is still black. I have manually created "wallpaper" registry but no effect. Also apply Microsoft patch 977944 but still facing same problem. Our organization has just upgrade 400 systems with windows 7. All are geting black wallpaper.
    Jatin Purohit Ahmedabad-India
    Wednesday, April 28, 2010 10:49 AM
  • Also need set up following Group Policy Setting:

    User configuration - Administrative templates - Control Panel\Personalization\Prevent changing desktop background - "Enabled"

    Friday, April 30, 2010 5:36 AM
  • hi.

    i browse the net searching how to solve my problem about my desktop..im using window 7 starter 32 bit.my problem  is when i change my wallpaper and i restart again .it only appears black,no background,,but the icons okey..i decide to restore the default wallpaper.but i dont know how?

    please can you tell me how can i solve this problem..i know you have a lot knowledge about this.

    please tell me how..send me an email how can i solve this @ angleeds2002@yahoo.com

    edgar

    Friday, May 14, 2010 6:17 AM
  • hi

    my problem is im using window 7 starter 32 bit..there is no0 background or wallpaper but the icons is okey..

    how can i resolve this anyone!!

    Friday, May 14, 2010 6:18 AM
  • my problem is im using window 7 starter 32 bit..there is no0 background or wallpaper but the icons is okey..

    how can i resolve this anyone!!

    Friday, May 14, 2010 6:19 AM
  • my problem is im using window 7 starter 32 bit..there is no0 background or wallpaper but the icons is okey..

    how can i resolve this anyone!!

    Friday, May 14, 2010 6:19 AM
  • my problem is im using window 7 starter 32 bit..there is no0 background or wallpaper but the icons is okey..

    how can i resolve this anyone!!

    Friday, May 14, 2010 6:19 AM
    • Proposed as answer by bjp106 Friday, March 23, 2012 6:34 PM
    Friday, May 14, 2010 1:40 PM
  • Thanks this did the trick, much appreciated

    Saturday, May 15, 2010 4:57 PM
  • Thanks Mervyn

     

    the command gpresult did the trick, much appreciated

     

    Saturday, May 15, 2010 5:00 PM
  • Hi Mervyn,

    my wallpaper policy is not applied. there are two plus on that. how can i install this?

     

    • Proposed as answer by Dev Babu Thursday, May 27, 2010 6:41 AM
    Sunday, May 23, 2010 9:08 AM
  • Dears,

    I was facing the same issue. I have just tried restarting the "Desktop Window Manager Session Manager" then the wallpaper appears. i have found a relevant event on the client machine which lead me to restart the service.

    windows 7 Event log - "The Desktop Window Manager has exited with code (0x40010004)"

    - Log Name:      Application
    Source:        Desktop Window Manager
    Date:          27-May-2010 4:05:45 PM
    Event ID:      9009
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      localhost
    Description:
    The Desktop Window Manager has exited with code (0x40010004)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Desktop Window Manager" />
        <EventID Qualifiers="16384">9009</EventID>
        <Level>4</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-05-27T13:05:45.000000000Z" />
        <EventRecordID>2156</EventRecordID>
        <Channel>Application</Channel>
        <Computer>localhost</Computer>
        <Security />
      </System>
      <EventData>
        <Data>0x40010004</Data>
      </EventData>
    </Event>
     
     
    and from then i have solved it temp on my machine via having a batch file for restarting the service each time i logon.
    please advise if you have a final solution
    Saturday, May 29, 2010 10:05 PM
  • Yep this is now working for me.  Now, how do I get that out to all the machines for all the users on my domain???
    • Proposed as answer by Akmal Badie Wednesday, June 09, 2010 10:33 AM
    Wednesday, June 02, 2010 4:35 AM
  • Dear All,

               Best Solution for this issue to download the required hotfix from microsoft.

    http://hotfixv4.microsoft.com/Windows%207/WindowsServer%202008%20R2/sp1/Fix298733/7600/free/402813_intl_i386_zip.exe

    password is:     {pXui2f

    it is working 100%

    enjoy it

    Wednesday, June 09, 2010 10:39 AM
  • Dear All,

               Best Solution for this issue to download the required hotfix from microsoft.

    http://hotfixv4.microsoft.com/Windows%207/WindowsServer%202008%20R2/sp1/Fix298733/7600/free/402813_intl_i386_zip.exe

    password is:     {pXui2f

    it is working 100%

    enjoy it

    ??????????

    is this password correct as it does not work for me


    Saturday, June 19, 2010 6:04 PM
  • Hi.

    I have been struggling with this for weeks and wasted far too much time. However thanks to all the helpful posts here, it is now fixed! We want to give all new users a default Windows 7 Aero theme & background but allow them to change this after if they wish. Like the original poster, we may however also wish to enforce a background via GP at some point so wanted to get this all working correctly from the start.

    I found that when any user logged in for the first time onto a sysprep'ed Windows 7 imaged PC they incorrectly inherited the following path from the Default User profile: "HKEY_CURRENT_USER\Control Panel\Desktop\Wallpaper" = "C:\Users\*Administrator*\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper.jpg" - note the incorrect (and inaccesible) user profile referenced ...

    Presumably, Windows first time user desktop configuration (is this Active Setup?), not being able to access this wallpaper file, picked a default black TranscodedWallpaper.jpg background. The Themes GUI showed an 'Unsaved Theme' and black background tile. User could fix their registry path to point to a wallpaper path in their own profile by selecting an existing theme from the GUI but I did not want all new users to have to do this.

    Tried suggestion provided here: http://social.msdn.microsoft.com/Forums/en-US/windowsuidevelopment/thread/1703c3f4-a2ea-4c4a-a73f-a93e6d51b2bb to insert %USERNAME% into the registry of the Default User profile but this did not always work with results changing depending on whether/how a users AppData(Roaming) folder was being redirected. The solution was, as suggested above, to use a GPP registry action to set wallpaper path to an accesible file e.g. "HKEY_CURRENT_USER\Control Panel\Desktop\Wallpaper" = "C:\Windows\Web\Wallpaper\Windows\img0.jpg". This is automatically correctly updated at logon to: "<users_profile>\AppData(Roaming)\Microsoft\Windows\Themes\TranscodedWallpaper.jpg".

    However, the background was still black and the Themes GUI still an "Unsaved Theme" - however, the background tile in the GUI was now correct (Harmony) .... we were now into 'click "show desktop" and correct background shows for a second and during user logout' territory. Setting a background via Group Policy appeared to set it but it would not display. Interestingly, the background set *would* display when using a Virtual PC and I believe was due to the fact that a VM PC always runs with Aero disabled – so Aero was breaking it?

    I can now also confirm that installing the MS hotfix mentioned above (the password changes every so often so you will need to go download it from the URL given) fixes the issue. So, with hotfix installed and the GPP registry setting being applied, any new user now correctly gets the default pre-set Windows 7 Aero theme and background, and the Themes GUI shows that the theme in use and no "Unsaved Theme" - sorted :)

    Thanks. David Pentland, Edinburgh Napier University.

    Friday, July 02, 2010 8:09 PM
  • This hotfix works perfectly!

    Thanks!!

    Thursday, July 22, 2010 4:57 PM
  • Opened a ticket with Microsoft on this one. After several hours of trouble shooting, we found that our jpg was 8bit. We were able to see the wallpaper when viewing the personalization screen but could not set the wallpaper. Replaced with 24bit depth and it was fixed.

    1. Applied kb977944
    2. Also set prefrence (user configuration) wallpaper path to UNC.
    3. Changed jpg to 24 bit depth 56kb size

    8 bit works with Windows XP,

    • Edited by trstevens Friday, July 30, 2010 12:02 AM forgot xp statement
    Friday, July 30, 2010 12:01 AM
  • Forgive me... but who has 8 bit JPG wallpapers? I thought the whole point of JPG was to retain photo quality and low file sizes. 8 bit is not photo quality.

    Still, the fact that Windows cannot display 8 bit JPG files is of concern. Glad you figured it out.

    Regards, Ryan.

    Saturday, July 31, 2010 10:54 AM
  • Wow, this thread has been ongoing for a year now.  I too was experiencing problems getting the corp background to show up.  However, after spending a good hour reading this thread over and feeling your pain I was able to get it to work. For me the hotfix actually worked. I am using a jpg 24bit image at 1280x1024.  I am also using GPO.  Good luck to all still struggling.
    Wednesday, August 04, 2010 9:24 PM
  • Hi all!

    And so... wallpaper is not problem now. We have megafix. BUT how apply .theme via GPO ??? (win7/2008r2). Like basic.theme. Is it posible or not posible??? Plz answer. Thx comrads!

    • Proposed as answer by Arek.K Tuesday, August 24, 2010 7:08 PM
    Monday, August 16, 2010 4:12 PM
  • It seems like it's a resoultion issue. Our workstations that exhibit this problem default into very high screen resolution. Where the image is of my lower resolution. What worked for me is to make any change to the display (ie., change resolution, theme) and then the image is applied.

    Good Look

    Tuesday, August 24, 2010 7:11 PM
  • I need change theme (theme, not style!) via GPO. But its not working. Fix Windows6.1-KB980628-x86 not help. I use Russian win7. Maybe in this problem? Police was apply (change theme for all users in domain) but theme is not apply - apply only classic theme (98/2000) and set block to change theme/style. Whats problem doc?
    Wednesday, August 25, 2010 11:27 AM
  • By the way, this fix is included in SP1
    Wednesday, August 25, 2010 12:58 PM
  • SP1 for win7 ?????? SP1 was be released?
    Thursday, August 26, 2010 5:30 AM
  • SP1 for win7 ?????? SP1 was be released?

    Released? No. It is in Beta though.

     

    http://technet.microsoft.com/en-us/evalcenter/ff183870.aspx

    Thursday, August 26, 2010 6:34 PM
  • Well It took alot for me to do it, but I put GPO on the domain, & the domain control, do the same to both gpo's 

    u must enable the active desktop,

    make a folder in a drive, share it ( it must be shared!!  everyone (read only)) and then in the desktop wallpaper in the gpo use the UNC \\servername\sharedfolder\name.jpg

     

    I also installed the hotfix that microsoft did ( not sure if that was the prob because even with the fix it did what your talking about )

     

     and last but not least, incase i put the UNC in the reg as merlyn said ( yet that only really worked for the server desktop

     

    login and out and it should work, ive had this problem for the past days, ive had it working, then my comp crashed and redid it dindt know how to , it was luck last time, but i documented my steps this time

     

     hopefully it works for you too

     

    p.s. the gpupdate /force doenst work, it will take alittle of time for the policy to nulify

     

     

     

    Tuesday, October 26, 2010 6:25 PM
  • I have been trying to get this to work for a while now.  I have applied the Win7 Sp1 RC onto one of my machines, and as the last person suggested, turned on the active desktop.

    I have the wallpaper I want to show up entered as \\server\share\filename.jpg

    Its just not showing up........any suggestions????

    Wednesday, December 01, 2010 6:33 PM
  • We've had this working for several months now, but I just went to change the background picture and it stopped working, black background only. I copied the contents of the new .jpg I wanted to use into a new Paint file, saved as 24 bit bitmap, closed and opened and saved as .jpg, and now it works. In my case it was definitely the file that was the problem, not the GPO or Win 7.

    I haven't researched too thoroughly, but I noticed that for the ones that DIDN'T work, if you look at the file properties, Details tab, Image section, they don't show values for horizontal or vertical resolution.

    Thursday, December 02, 2010 8:26 PM
  • I have just a black background as well......nothing shows up.

    Are certain jpg's not going to show up?  What are the settings suppose to be?

    Thursday, December 02, 2010 8:49 PM
  • Most jpg's do work, I just had one that didn't. Try a variety of jpg's from different sources, or create your own with screen capture and mspaint, see what works and what doesn't.
    Friday, December 03, 2010 1:52 PM
  • Well, its odd, if I do a GPRESULT /V I am seeing the following info:

    GPO: COM-Conference Room PC
                    KeyName:     Software\Microsoft\Windows\CurrentVersion\Policies\System\Wallpaper
                    Value:       92, 0, 92, 0, 99, 0, 111, 0, 109, 0, 98, 0, 111, 0, 105, 0, 102, 0, 115, 0, 48, 0, 49, 0, 92, 0, 100, 0, 101, 0, 112, 0, 116, 0, 36, 0, 92, 0, 67, 0, 111, 0, 109, 0, 109, 0, 101, 0, 114, 0, 99, 0, 101, 0, 92, 0, 67, 0, 111, 0, 110, 0, 102, 0, 101, 0, 114, 0, 101, 0, 110, 0, 99, 0, 101, 0, 82, 0, 111, 0, 111, 0, 109, 0, 80, 0, 67, 0, 92, 0, 98, 0, 114, 0, 111, 0, 110, 0, 99, 0, 111, 0, 46, 0, 106, 0, 112, 0, 103, 0, 0, 0
                    State:       Enabled

    So I can see the the policy is being applied, but no image shows up......  I don't know what the value for the KeyName relates to, but if I go into RegEdit, and look under the WallPaper key, the value is empty......

    Am I missing something here?

    This is on a shared drive that I'm having the problem.  If its on a local drive, it appears to work just fine.

     

    Friday, December 03, 2010 3:22 PM
  • Hello Mervyn Zhang,

    I can't seem to enable my desktop features!! all i get is just a black screen with my icons in place

    Help!! Mervyn or anybody!!!

    when i try to change desktop and background from the control panel; it just shows the msg below,

    <This feature has been disabled - please contact your system administrator for detail>

     

    NB: i run a win7 OS <64bits>

    Saturday, December 04, 2010 4:35 PM
  • Hi,

    This Error occurs every now and then  almost to everyone using Windows 7 as Client and Windows Server 2008 as a Domain Controller.

    Microsoft has verified this and released a Fix for both 64 bit and 32 bit Operating Systems.

    Download the Fix and Apply to the Affected Systems.

    http://support.microsoft.com/kb/977944

    Hope this solves your issue.

    Thanks.

    Himayat Ullah Khan,

    Network Engineer,

    Pakistan.

    Friday, December 10, 2010 10:33 AM
  • I've used this via a group policy preference and this worked. But it did require two reboots

    Thanks

    Tuesday, February 01, 2011 4:03 PM
  • jpg wallpaper is working by using above mention hotfix. But still Same problem in html. We are using a html page as a wallpaper in our environment. In Windows XP it's work fine with html. But not in Windows 7.

    Jatin Purohit Ahmedabad-India
    • Proposed as answer by Ani.Ani Tuesday, September 13, 2011 7:48 AM
    • Unproposed as answer by Ani.Ani Tuesday, September 13, 2011 7:48 AM
    Saturday, April 23, 2011 1:07 PM
  • Here is the solution for this. This will work

     

    http://support.microsoft.com/kb/977944

     


    Ani
    Tuesday, September 13, 2011 7:49 AM
  • Sorry Ani.ani but I've tried that solution allready in June and didn't work at all! sigh sigh

    I'm starting to feel confused

    I'm having the same exact issue on Win 7 pro and Win 2008 r2, applied the hotfix in both x64 and x86 machines but with no resolution.

    Any advice would be apreciated

    Thanks in advance

    Monday, October 10, 2011 7:12 PM
  • I think I've got the mistake: My Active directory is 2003 mode; it seems that the only solution is to upgrade the AD to 2008 and all group policy for 7 2008 etc will be successfully installed.

    I hope to update You as soon as I've done the Adprep etc. for my domain.

    Cheers

    Thursday, October 13, 2011 9:17 PM
  •  

    Hello all,

     

    I.ve been trying to fix this problem for months now, the KB977944 doesn´t fix the problem, in my case and for many others

    you just get a Black screen and when you do log-off you see the jpeg image for half a second.

    Now a costumer of mine seemed to find a workaround but not the solution for shure.

    We were using .jpegs images and the whole problem seemns to be that Windows 7 doesn´t recognize the gpo that

    activates "active Desktop" now this active desktop apparently enables windows desktop to accept *.jpeg images.

    but in Win7  we have a bug and is not working properly , that´s my understanding of the problem. Now the solution found by accident

    is :  Use a *.BMP image in the format of 1024x768  24Bits ( convert and resize your jpeg image using "paint" ) in the 

    gpo use the spread image to adequate it to your desktop ).

    Please do this test and see if the paper is applied. If it works it indicates to MS that the problem lies in the "active desktop" sector.

    because using the old BMP format means we are using a pre-windows XP wallpaper. BMP will work but is not a complete solution, its a workaround.

     

    Dont forget to do a gpupdate /force prior to logoff / log on your test PC. Sometimes the wallpaper image doesn´t apply in the first 

    logoff / logon. keep trying.

     

    See if this helps and put your results  here, so you too can help others.

     

    Att. 

    mrgiller

     




    • Proposed as answer by qwerty7 Monday, October 17, 2011 2:01 PM
    • Edited by qwerty7 Monday, October 17, 2011 4:11 PM
    Monday, October 17, 2011 2:01 PM
  • Success!

    I've been frustrated by this issue since joining my current employer in April 2011.

    I inherited a Group Policy that set a whole raft of things on all clients and for all users. This GPO had components for wallpaper in two parts:

    1) Computer Configuration > Preferences > Windows Settings > Registry - where we set a registry item for:

    HKEY_CURRENT_USER, under Control Panel\Desktop, and item called "wallpaper" with a value of "\\server\share\wallpaper.jpg"

    2) User Configuration > Policies > Administrative Templates > Desktop > Desktop - where we set a value of "\\server\share\wallpaper.jpg" for the entry "Desktop Wallpaper", and a value of "stretch" for the wallpaper style.

    This worked perfectly for our Windows XP machines, but left us with the same thing that so many people have had on Vista and Win7 - namely a black desktop that can't be changed, with the wallpaper showing in a theme that can't be activated.

     

    Completely by chance, one of our directors requested that his XP laptop with a widescreen display should have a bespoke wallpaper, rather than the existing "stretched" standard wallpaper.

    I figured there was no way the existing GPO would cope with two different wallpapers, so I created two new GPOs - one with just the wallpaper for this user's machine, and the other for everyone else. Then I removed the wallpaper settings from the legacy GPO.

    The new GPOs have EXACTLY the same two settings described above, just different filenames for the two wallpaper files.

    Lo and behold! All my PC's, including the Windows 7 and Vista machines, now apply the wallpaper properly.

    WTF?!

     

    Monday, November 28, 2011 2:48 PM
  • My issue was solved as soon as I converted my desktop wallpaper image from jpg to bmp (It must have been an 8-bit jpg)

    I'm running SBS2011 with Windows 7 Pro clients

    Thursday, December 22, 2011 11:19 PM
  • Hi there,

    I have also applyed this fix and found positive result.

    Ahmed Ehtesham Zaedi

    Sunday, February 19, 2012 8:24 AM
  • This worked for me. Thanks!
    Friday, March 09, 2012 5:40 AM
  • Hi Mervyn,

    I suffer the same problem in our organization. They upgraded to Win 7 Professional from some Win 7 version and from then the wallpaper is black.

    The Registry key is missing and I've to mail the Admin, Team Lead, Project manager and Manager the reason for wallpaper change.

    So  could you provide me steps to create String value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper].

    Thanks,

    Yuvi.

    Thursday, March 15, 2012 3:53 PM

  • So  could you provide me steps to create String value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper].



    Your search engine is broken...



    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Thursday, March 15, 2012 8:50 PM
  • Your search engine is broken...

    Using search engine I came to the destination, again I don't wanna use search engine for "final destination."

    Thanks,

    Yuvi.


    Yuvi.

    Friday, March 16, 2012 6:47 AM
  •  
    > Using search engine I came to the destination, again I don't wanna
    > use search engine for "final destination."
    >
    >
     
    User Configuration - Preferences - Windows Settings - Registry. Here you
    may create whatever registry key or value you need.
     
    sincerely, Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Saturday, March 17, 2012 9:04 PM
  • Hi,

    Somehow I solved my problem. Thanks for the help.

    Thanks,

    Yuvi


    Yuvi.

    Monday, March 19, 2012 8:36 AM
  • hi Mervin,

    can u able to please tell me the String value that has to be applied..

    Regards,

    Salim Malik

    Tuesday, March 27, 2012 7:46 AM
  • Hi All,

    This is what I did & it worked.

    1, Copied desktop wallpaper as .bmp or .jpg to c:\windows.

    2, right mousclicked on desktop, personalize. at very bottom, click on desktop background, browse to location where wallpaper is located & apply.

    3, save this theme as 'corporatedesktop' for example.

    4, copy this theme from its stored location in your profile to c:\windows\resources\themes.

    5, apply this hotfix http://support.microsoft.com/kb/980628/en-us to fix the 'load specific theme' issue (causes theme not to be applied & you get black screen without it.

    6, edit GPO in user configuration\policies\administrative template\control panel\personalization & enable 'prevent changing desktop background' AND enable 'load a specific theme' and set path to theme file to %windir%\resources\themes\corporatedesktop.theme (or whatever your theme is called).

    7, edit GPO in user configuration\policies\administrative template\desktop\desktop & enable 'desktop wallpaper' set path to wallper as %systemroot%\corporatewallpaper.bmp or whatever your wallpaper is called.

    gpupdate /force & log in as a user.

    Works for me!

    Cheers



    • Edited by ShaddersUK Wednesday, April 04, 2012 10:40 AM
    Wednesday, April 04, 2012 10:00 AM
  • I get all the above, but I am trying to do something different.  I am trying to allow my users to select from a group of different "approved" wallpaper images (either .bmp or .jpg) from a central network location.  I have enabled the desktop wallpaper gpo to pole \\server\share\wallpaper\ and set the registry for the same location (above key).   I can see the images under the Personalization / Desktop Background, and select the image but the image is never applied to the desktop.  Is what I am trying to do even possible or am I just a dreamer?
    Wednesday, May 23, 2012 6:09 PM
  • Hi,

    Thank you for all updates.

    Based on our test, it seems the Registry key [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] is missing and caused this problem. To work around this issue, please create a String Value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] on client and try to set wallpaper.

    We can use Group Policy Preference->Registry to deploy this Registry key or use user logon script to deploy this Registry key.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Thanks!!! works
    Friday, March 15, 2013 10:14 AM
  • I think an important clarification should be made that this Group Policy option uses a "*.theme" not a "*.themepack" .  I still have the bruise from banging my head into that back in 2009.

    It is when using a "*.theme" prepared as ShaddersUK outlined, that the GPO for "Load a specific theme" works as intended.

    Create a default First Time Logon ".theme" (not a ".themepack") on a Sandbox System
    1. Copy <wallpaper>.bmp to a location all users will have READ access to (eg: "%windir%\web\wallpaper\" or  \\<domain>.local\netlogon\wallpapers or ...) 
    2. Create a Theme using wallpaper from location used in 1.
    3. Save the Theme as: <name>
    4. Backup "C:\users\<username>\appdata\local\microsoft\windows\themes\<themename>.theme"

    If "<themename>.theme" is deposited into "%windir%\resources\themes\" the theme will appear in the Personalization applet as an Installed Theme.

    Setting the First Time Logon ".theme"
    1. Using your preferred method, Push out or post "<wallpaper>.bmp" and "<themename>.theme" to the same location used to initially create the ".theme"2. Create a USER GPO assigned to the intended Domain\User accounts, or as a part of the LOCAL Policy for Local Accounts

    HKCU\Policies\Administrative Templates\Control Panel\Personalization\
    = Load a specific theme

    Enter for Path to theme file:  <path>\<themename>.theme
    Wednesday, April 03, 2013 6:43 PM
  • Dear all, I have tried to set all the parameters mentioned, without success. My domain is Windows 2008 R2 and my clients are Windows 7 Enterprise SP1, after application of GPO for desktop wallpaper I have read about the missed registry key " [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] " and I have set, in the GPO desktop wallpaper the Group Policy preferences to copy the Desktop pic from network share to a local path (c:\Users\public\pictures) with .jpg and .gif format and in the same time for set the registry key with local path parameters. The pictures is copied successful locally and the User can open it browsing the local path without problem, but unfortunatelly the desktop still remain black, I can see, as pictures above on the properties of the desktop the new image but this image cannot load from windows desktop.

    Please can you help me? I have missed something at this regard? 

    thanks


    Thursday, June 20, 2013 12:07 PM
  • I stumbled across this when trying to get around this issue.

    I hope this helps some others, but I managed to get around it by applying it to the local GP under admin templates for the user > desktop and disabling the wallpapers object, there are options in there to set a path for user's to be able to choose which desktop that are approved or one that you set?

    Surely everyone's issue is not as simple as this though, however i hope I helped someone!

    Cheers

    Jento

    Friday, August 02, 2013 8:45 AM
  • I have tried with Google Drive. It should work also with SkyDrive:

    In computer A, share the file via Google Drive in a folder like 'c:\Google Drive\Images'
    In computer B:
      1. I use this tool Bionix Wallpaper Changer (http://www.bionixwallpaper.com/) to manage my wallpapers. If you use this one too you need to first start it in computer B.
      2. a) If you have more than one image, activate the 'Lock on folder' feature. Bionix will look in that folder once per day or at a time interval you choose. This could help you to monitor better the folder where your images are. The folder to lock on is of course 'c:\Google Drive\Images'.
          b) If you have a single image just add the image into the playlist
      and 3. Set refresh interval to x minutes, where x is the time interval when person A uploads a new image.

    Hope this will help you.
    Monday, August 12, 2013 9:45 AM
  • hi. from where should i run the hotfix from? Server or Client???
    Monday, November 04, 2013 9:42 AM
  • Its fine But Just Installed the Hotfix for Providing Microsoft and Resolve your black screen issue in windows 7

    The "Desktop Wallpaper" Group Policy setting is not applied in Windows 7 or in Windows Server 2008 R2

     
    Wednesday, December 04, 2013 8:53 AM
  • This was the fix for me. I was using a .jpg formatted image and the problem resolved when I saved the file as a .bmp format. Silly Windoze.
    Monday, January 13, 2014 2:43 PM
  • I'm having the SAME EXACT ISSUE now on a huge school.. HELP ASAP please.
    Friday, September 05, 2014 3:12 AM
  • How can I use a logon script? I need this ASAP please as I'm having a huge issue with this deployment in a school -- school being tomorrow for them.

    Thank you SO MUCH!

    Friday, September 05, 2014 3:12 AM