none
WSUS problem

    Question

  • Hello,
     
    On my combined WSUS3.0 and SCCM2007 server I have WSUS running. WSUS for updating the servers and SCCM for updating the clients with updates.

    On all the servers I receive the following error in the WindowsUpdate.log:


    2009-02-13 10:59:39:078  800 8d4 PT WARNING: Cached cookie has expired or new PID is available
    2009-02-13 10:59:39:078  800 8d4 PT Initializing simple targeting cookie, clientId = c972c643-31c6-4dfc-977f-3d64290fe6cf, target group = Servers, DNS name = wjvntfs05.wjvmd01.local
    2009-02-13 10:59:39:078  800 8d4 PT   Server URL =
    http://wsus_sccm_server/SimpleAuthWebService/SimpleAuth.asmx
    2009-02-13 10:59:39:156  800 8d4 PT WARNING: GetAuthorizationCookie failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404
    2009-02-13 10:59:39:156  800 8d4 PT WARNING: Failed to initialize Simple Targeting Cookie: 0x80244019
    2009-02-13 10:59:39:156  800 8d4 PT WARNING: PopulateAuthCookies failed: 0x80244019
    2009-02-13 10:59:39:156  800 8d4 PT WARNING: RefreshCookie failed: 0x80244019
    2009-02-13 10:59:39:156  800 8d4 PT WARNING: RefreshPTState failed: 0x80244019
    2009-02-13 10:59:39:156  800 8d4 PT WARNING: PTError: 0x80244019
    2009-02-13 10:59:39:156  800 8d4 Report WARNING: Reporter failed to upload events with hr = 80244019.
    2009-02-13 10:59:39:156  800 8d4 Report WARNING: Discarding a batch of 1 events because they have expired.
    2009-02-13 10:59:39:250  800 8d4 PT WARNING: Cached cookie has expired or new PID is available
    2009-02-13 10:59:39:250  800 8d4 PT Initializing simple targeting cookie, clientId = c972c643-31c6-4dfc-977f-3d64290fe6cf, target group = Servers, DNS name = wjvntfs05.wjvmd01.local
    2009-02-13 10:59:39:250  800 8d4 PT   Server URL =
    http://wsus_sccm_server/SimpleAuthWebService/SimpleAuth.asmx
    2009-02-13 10:59:39:250  800 8d4 PT WARNING: GetAuthorizationCookie failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404
    2009-02-13 10:59:39:250  800 8d4 PT WARNING: Failed to initialize Simple Targeting Cookie: 0x80244019
    2009-02-13 10:59:39:250  800 8d4 PT WARNING: PopulateAuthCookies failed: 0x80244019
    2009-02-13 10:59:39:250  800 8d4 PT WARNING: RefreshCookie failed: 0x80244019
    2009-02-13 10:59:39:250  800 8d4 PT WARNING: RefreshPTState failed: 0x80244019
    2009-02-13 10:59:39:250  800 8d4 PT WARNING: PTError: 0x80244019
    2009-02-13 10:59:39:250  800 8d4 Report WARNING: Reporter failed to upload events with hr = 80244019.


    WSUS is doing correctly to SCCM for updates. Only not on the servers.

    In the eventvwr of a failing server I see the following error:

    Unable to Connect: Windows is unable to connect to the automatic updates service and therefore cannot download and install updates according to the set schedule. Windows will continue to try to establish a connection.

    What do I have to do to solve this issue?

    By the way: the combined SCCM and WSUS server is a W2003 x64 server

    With kind regards
    The Sting Pilot
    Friday, February 13, 2009 10:29 AM

Answers

  •  2009-02-13 10:59:39:078  800 8d4 PT   Server URL = http://wsus_sccm_server/SimpleAuthWebService/SimpleAuth.asmx
    2009-02-13 10:59:39:156  800 8d4 PT WARNING: GetAuthorizationCookie failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404

    This is an HTTP 404 error because the configured resource does not exist.

    Perhaps WSUS was actually installed on the alternate virtual server "WSUS Administration", in which case the correct URL to configure in policy should be http://wsus_sccm_server:8530.



    Lawrence Garvin, M.S., MCITP(x2), MCTS(x5), MCP(x7), MCBMSP
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2009)
    Monday, February 16, 2009 3:44 PM

All replies

  •  2009-02-13 10:59:39:078  800 8d4 PT   Server URL = http://wsus_sccm_server/SimpleAuthWebService/SimpleAuth.asmx
    2009-02-13 10:59:39:156  800 8d4 PT WARNING: GetAuthorizationCookie failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404

    This is an HTTP 404 error because the configured resource does not exist.

    Perhaps WSUS was actually installed on the alternate virtual server "WSUS Administration", in which case the correct URL to configure in policy should be http://wsus_sccm_server:8530.



    Lawrence Garvin, M.S., MCITP(x2), MCTS(x5), MCP(x7), MCBMSP
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2009)
    Monday, February 16, 2009 3:44 PM
  • Hello Lawrence,

    Thanks for your reply. In the policy I have modifed the 'Specify intranet Microsoft Update Service Location' property: the intranet service location refers to http://wsus_sccm_server:8530.

    Many many many thanks for your help!

    With kind regards,
    The Sting Pilot
    Monday, February 16, 2009 9:17 PM