none
Blocking Google Chrome through GPO

    Question

  • Hi all,
    I found an article on how to block the installation of Chrome throu GPO on Windows IT Pro:
    http://windowsitpro.com/article/articleid/102903)

    the only problem is they tell us to search the web for the correct CLSID, but the search only brings you back to that same article...
    How can I get the CLSID of the add-on without installing it?

    Thanks for the help!
    Wednesday, October 21, 2009 3:03 PM

Answers

  • Hi,

     

    To get the Class ID of an IE add-on, you need to ask the add-on’s manufacture or install to check the add on properties.

     

    I have tested on my test machine and the Class ID of ChromeFrame is {ECB3C477-1A0A-44BD-BB57-78F9EFE34FA7}. Hope this is helpful to you.

     

    Regards,

    Bruce

    • Marked as answer by Bruce-Liu Wednesday, October 28, 2009 7:24 AM
    Thursday, October 22, 2009 8:02 AM

All replies

  • Hi,

     

    To get the Class ID of an IE add-on, you need to ask the add-on’s manufacture or install to check the add on properties.

     

    I have tested on my test machine and the Class ID of ChromeFrame is {ECB3C477-1A0A-44BD-BB57-78F9EFE34FA7}. Hope this is helpful to you.

     

    Regards,

    Bruce

    • Marked as answer by Bruce-Liu Wednesday, October 28, 2009 7:24 AM
    Thursday, October 22, 2009 8:02 AM
  • Hai,

    Please follow the steps. It may be helpful
    1. Open the GPMC
    2. Create a GPO in this domain in your domain
    3. Name as Google Chrome and click OK.
    4. Right-click the policy you just created and click Edit
    5. Navigate to the folder User Configuration\Policies\Windows Settings\Security Settings\Software Restriction Policies
    6. Right-click Software Restriction Policies and select New Software Restriction Policies
    7. Right click Additional Rules and choose New Path Rule.
    8. In the Path field, type chromesetup.exe.
    9. In the Security level drop-down box, choose Disallowed and click OK.

    Repeat steps 7, 8,9 for the chrome.exe and gears-chrome-opt.msi files

    Repeat steps 7, 8,9 for the path C:\Users\%username%\AppData\Local\Google\Chrome\Application\chrome.exe for Vista machines or C:\Documents and Settings\%username%\Local Settings\Application Data\Google\Chrome\Application\chrome.exe for XP machines. You should include this rule in case some of your users have already installed the browser.
    After you implement the GPO and the Group Policy settings refresh on those users' local machines, they'll no longer be able to successfully run Google Chrome.

    Open a command-prompt window and run the command gpupdate /force to apply the new rules.
    Run the command gpresult /R in Vista SP1 or the command gpresult in XP and Vista (pre-SP1) to verify that the newly created GPO has successfully been applied.
    As a final test, attempt to run the installer from the Google Chrome website. If the policy is successful, you should see the error

    regards from www.windowsadmin.info


    ManuPhilip
    Thursday, October 22, 2009 10:14 AM
  • I followed the GPO steps from "ManU PhiliP" above. They did not prevent Chrome from installing but do prevent it from running once installed!

    Dont know if the install process or file names have changed since 2009 and further entires need to be added - will investigate further.

    Admittedly I am working with Server 2008 rather than Vista, but the user profile paths are the same and I cant see it making much difference.

    Tuesday, March 29, 2011 3:56 PM
  • Hi

    Google has renamed the setup file.

    Please repeat steps 7, 8 and 9 for chrome_installer.exe

    And if you are really annoyed at google constant updates

    Please repeat steps 7, 8 and 9 for GoogleUpdate.exe

     


    Regards Gudjon

    • Edited by Gudjon Wednesday, November 16, 2011 9:44 AM
    • Proposed as answer by EDM IT Wednesday, January 04, 2012 9:26 AM
    Wednesday, November 16, 2011 9:33 AM
  • Include "GoogleUpdate.exe" then users will not be able to download Chrome. Thx Gudjon

    Wave~Chaser

    Tuesday, June 19, 2012 10:37 PM