none
How do I change the network profile?

    Question

  • I know this is a silly question - I'm sure I've worked it out before - my apologies if I have missed something obvious.

    I have a single NIC in my server. I have just done a fresh install and the network profile is shown as "Public". I want to set it to "Private". I can't find how to do this - I'm sure that I've done it before.

    I'm pulling my hair out and there isn't that much of it!!

    Could someone please help me out?

    Thanks,

    Dave

    Friday, April 06, 2012 6:08 PM

Answers

All replies

  • Dear Dave,

    it appears Windows Server 8 Beta does not behave differently than Windows Server 2008 R2 in this matter.

    Please let me recommend the script posted in the Microsoft Script Center > Repository > Networking > Script to Change ‘Unidentified network’ from Public to Work in WS2K8 R2: http://gallery.technet.microsoft.com/scriptcenter/3812dd81-a8bd-4671-ab96-03b88708b8cc

    I haven't tried the script under Windows Server 8 Beta, as the single test server I've set up hasn't got the problem.

    Should the network connection in your scenario have another name the "Unidentified network" either adjust the script varialble definintion »$UNIDENTIFIED = "Unidentified network"« accordingly or simple remove the » -and ($Name -eq $UNIDENTIFIED))"« from the if statement.

    If you instead of "Private" want's the network connection to be seen as "Domain" then you'd need to either simply change the »$NLM_NETWORK_CATEGORY_PRIVATE = 0x01« to »$NLM_NETWORK_CATEGORY_PRIVATE = 0x02« as 0x02 corresponds to the NLM_NETWORK_CATEGORY enumeration "NLM_NETWORK_CATEGORY_DOMAIN_AUTHENTICATED". Of course the "more script logical gramatically correct" would be adding a »$NLM_NETWORK_CATEGORY_DOMAIN_AUTHENTICATED = 0x02« to the list of declared variables, and then changing the »$INetwork.SetCategory($NLM_NETWORK_CATEGORY_PRIVATE)« to »$INetwork.SetCategory($NLM_NETWORK_CATEGORY_DOMAIN_AUTHENTICATED)« - in either case it's the 0x02 that counts.

    The author of the script on http://gallery.technet.microsoft.com/scriptcenter/3812dd81-a8bd-4671-ab96-03b88708b8cc would appreciate if you'd leave a comment whether it works under Windows Server 8 Beta; and so would we all in this forum!

    Kind regards,

    Soren

    • Proposed as answer by Wojciech Nowak Friday, October 12, 2012 10:34 AM
    Saturday, April 07, 2012 4:03 PM
  • Hi Dave,

    Thanks for posting here.

    Please try also take look the reply Tim posted in the thread below:

    http://social.technet.microsoft.com/Forums/en-US/winserver8gen/thread/6e2863a6-c52c-4c1a-acd8-99bd31d1ea46/

    Thanks.

    Tiger Li


    Tiger Li

    TechNet Community Support

    • Marked as answer by Tiger Li Thursday, April 12, 2012 9:09 AM
    Monday, April 09, 2012 9:33 AM
  • The easiest answer is to go into Windows Firewall and turn the default Public policy off and turn on Private.  It labels things based on that.  It really doesn't affect any of the ports or services, but I didn't like the name Public being out there, either.  

    Tiger Li - your twice posted article is for a Desktop OS and not the Server OS.  Far too often, I see replies from individuals that have no direct experience using the product in the topic they are replying to.  May want to fix that.  

    Saturday, December 01, 2012 5:06 PM