none
Server 2012 RDS - Remote Desktop Connection Broker Client failed to redirect the user domain\username. Error: NULL

    Question

  • Seeing the error listed here.

    The Remote Desktop Connection Broker server could not enumerate the targets for the provider named NULL from the database.

    Pooled virtual desktop collection name: NULL
    Error: Error code: 0xFFFFFFFF.

    Broker and Hyper-V are on the same physical machine.

    Any ideas on where to start troubleshooting this?

    Used the happy wizard to create everything, and got no errors.
    I have created a small pool collection, and given rights to domain users. Everything "looks" good.
    • Edited by The_Ron Wednesday, September 05, 2012 4:57 PM Clarity
    Wednesday, September 05, 2012 2:47 PM

Answers

  • Solution:

    http://support.microsoft.com/kb/331951

    Adding the broker to "Windows Authorization Access Group"

    This is only needed if the Domain the system is connected to was setup with as Pre-Windows 2000 Compatible.

    • Marked as answer by The_Ron Friday, September 14, 2012 8:13 PM
    Friday, September 14, 2012 8:12 PM

All replies

  • Obvious issue appears to be the SessionBroker cannot access its own database. Anyone out there experienced this or know of a possible solution.

    I have removed all RD services and re-added them to the machine a couple times, but the result seems to be the same. Permissions issue obviously but I am at a loss. What is location of the database and what account is trying to access it?

    Thursday, September 06, 2012 1:54 PM
  • Ron,

    I have the same issue. Broker cannot logon to Windows Internal Database, but I haven't figured out where those credentials are. I do know that I have a group policy I think may be the culprit that relates to log on as a service settings. If possible you may try pausing your group policies or removing the server 2012 machine from the domain just as a test to see if this addresses the issue.

    Just guessing at this point though

    Thursday, September 06, 2012 3:56 PM
  • Ron,

    I have the same issue. Broker cannot logon to Windows Internal Database, but I haven't figured out where those credentials are. I do know that I have a group policy I think may be the culprit that relates to log on as a service settings. If possible you may try pausing your group policies or removing the server 2012 machine from the domain just as a test to see if this addresses the issue.

    Just guessing at this point though

    Download and install SQL Server Management Studio.

    Connect to local host with \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query  using domain admin credentials. If Credentials fail... then you're running the Windows Internal Database as the System account and not the Network Service.

    SSEE might have been replaced with SSIS... not 100% sure because I haven't setup an RDP Broker on mine yet.

    http://msdn.microsoft.com/en-us/sqlserver/cc511477.aspx

    Your databases should be stored in the C:\Windows\SYSMSI folder... in previous versions it looked similar to this.

    C:\Windows\SYSMSI\SSEE\MSSQL.2005\MSSQL\Data - should be 2008 or 2012 I assume for Server 2012.

    Also, see if this post helps with any guidance.  http://social.msdn.microsoft.com/Forums/en-US/sqltools/thread/d2735d0d-f593-40e5-bf7a-356704c3aaee

    Best Regards,


    Steve Kline
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Technology Specialist: Active Directory, Network Infrastructure, Application Platform, Windows 7
    Microsoft Certified Product Specialist & Network Product Specialist
    Red Hat Certified System Administrator
    Microsoft® Community Contributor Award 2011
    All opinions expressed on my own behalf and not that of my company.
    This posting is "as is" without warranties and confers no rights.


    • Edited by Steve Kline Thursday, September 06, 2012 4:14 PM
    Thursday, September 06, 2012 4:12 PM
  • The Broker is using an Internal Database location is "C:\Windows\rdcbDb".
    Thursday, September 06, 2012 6:29 PM
  • I blocked the parent GPOs and checked locally to be sure nothing was coming through. I removed the Roles and database folder; which it does not do after the role is removed. I then rebooted and reinstalled. Same results.

    Thinking it may be time to open a ticket on this.

    Thursday, September 06, 2012 6:32 PM
  • Hi,

    im also having the same problem, the connection broker says failed to redirect

    but whats weird is i can run and connect fine internaly in my domain from a domain pc

    but when i use a remote gateway outside my network, i get this error?

    any resolutions?


    • Edited by si458 Monday, September 10, 2012 8:22 PM
    Monday, September 10, 2012 8:22 PM
  • Are you using mstsc.exe or the web interface for internal or external?
    Monday, September 10, 2012 8:41 PM
  • Hi

    i have the same Problem internal and external , i use mstsc.

    always the same error :-(


    Jvo

    Tuesday, September 11, 2012 2:08 PM
  • Still working with MS on this, but the only thing I have confirmed with them is RDC 7 must be used. I'm not sure if that helps you, but I will report back when I get a solution.

    http://www.microsoft.com/en-us/download/details.aspx?id=29022

    Tuesday, September 11, 2012 2:21 PM
  • From MS (edited slightly to remove issues specific to my setup):

    You must use an RDC client that understands how to connect to the RDWeb feed, which can be accessed by logging on to RDWeb itself or through the “RemoteApp and Desktop Connections” control panel applet.  All Windows clients know how to do this, and even some thin clients that are running WES7 (Windows Embedded).

    Even the Microsoft RDC client does not have a way to enter this through the RDC UI, which is why we suggest you subscribe to the feed.  You can connect to a single RDSH server just fine, but unless it is based on at least RDC 6.1 you can’t run RemoteApps.  You could also connect directly to a VM via Remote Desktop, but the user would have no way of knowing which VM in the pool they are supposed to connect to unless the admin tells them.  There is nothing preventing you from setting up unmanaged collections, but you can’t do managed collections as with managed collections, only the Connection Broker knows which VMs can be connected to in the pool, there is no way for the user to know.

    Tuesday, September 11, 2012 7:41 PM
  • this would explain why i cant connect from my mac :) and also my ipad!

    i will give a try using windows

    Wednesday, September 12, 2012 8:39 AM
  • Solution:

    http://support.microsoft.com/kb/331951

    Adding the broker to "Windows Authorization Access Group"

    This is only needed if the Domain the system is connected to was setup with as Pre-Windows 2000 Compatible.

    • Marked as answer by The_Ron Friday, September 14, 2012 8:13 PM
    Friday, September 14, 2012 8:12 PM
  • Dear All,

    I got similar problem -- and I cannot open the broker DB file at C:\Windows\rdcbDb  because some other app is using it

    Has anyone been able to resolve this issue?

    Thanks,

    Leon Li

    Monday, April 01, 2013 3:32 AM
  • OK I resolved this myself, just or share:

    Solution: install SQL server, connect to Windows internal database, delete the rds.target and rds.pool with pool id = NULL

    Monday, April 01, 2013 5:24 AM
  • I have same problem How do you delete fields in database? How can i open/attach database?
    Thursday, April 18, 2013 1:20 PM
  • Salam,

    After you install the MSSQL management studio use this string "\\.\pipe\MICROSOFT##WID\tsql\query" to connect to Windows Server 2012 internal database (WID), also note you will need to run it as administrator even though if you've installed the WID with you account.

    I hope this helps.


    For every action, there is a reaction!

    Sunday, April 28, 2013 6:37 PM
  • I have the same problem.

    (Making this long hand for those who come after)
    I have installed SQl Management Studio Express 2012 SP1
    http://www.microsoft.com/en-us/download/details.aspx?id=29062 
    (You only need the one file "SQLManagementStudio_x64_ENU.exe")

    Ran this as Administrator 
    And typed in the Server Name field
    \\.\pipe\MICROSOFT##WID\tsql\query
    Then hit connect.

    Expanded Databases (+sign)
    Expanded RDCms 
    Expanded Tables

    Right Clicked on rds.target, select Edit top 200 rows
    Right Clicked and copied, then pasted this into a notepad file on the desktop (As a backup)

    Right Clicked and selected Delete to delete the row with the data in it (and PoolID was set to Null in this row)

    Did the same for rds.pool

    Manually added Remote Desktop server into the MEMBER OF tab of “Windows Authorization Access Group” via Active Directory Users and Computers. As this domain was Windows 2003 Native when the RDS server was first installed.

    Rebooted server and same issue>
    Checked SQL again and rows had come back.

    Is that what you meant by "delete the rds.target and rds.pool with pool id = NULL"?

    Not a SQL guru, so any help appreciated.

    Tuesday, September 17, 2013 4:20 PM
  • First run

    Set-Item WSMan:\localhost\Shell\MaxMemoryPerShellMB 1000",

    then run

    netsh winhttp reset proxy

    Thursday, November 07, 2013 6:47 AM