none
GPO-Solution for "You`ll need to provide administrator permissions to delete/copy this file

    Question

  • Hello,

    on many windows servers i have the following message when i try to create/delete/copy a file to c:\

    I have tried to fix this by changing the UAC to lowest level AND changing the EnableLUA-registry-key.

    I am trying to find a GPO-solution for all my servers and future machines.

    What can be done with Group Policy to eliminate the message?

    Thx

    Friday, February 01, 2013 12:51 PM

Answers

  • If you want to get rid of that message, there's 2 solutions:
     
    a) Adjust NTFS Acls, so that a given Group gets write access.
    b) Disable UAC (not recommended though...)
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Saturday, February 02, 2013 4:31 PM
  •  
    > A) Can this be done by GPO for all servers
    >
     
    Yes, but it is tricky because of NTFS inheritance... I would recommend
    asking yourself "why do I need to copy files to the system drive root
    folder?" ;-)
     
    > B) What is the best way to do this by GPO?
    >
     
    Computer configuration - Windows settings - Security settings - File
    system. But if you do wrong, you will destroy your servers...
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Sunday, February 03, 2013 2:20 PM

All replies

  • If you want to get rid of that message, there's 2 solutions:
     
    a) Adjust NTFS Acls, so that a given Group gets write access.
    b) Disable UAC (not recommended though...)
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Saturday, February 02, 2013 4:31 PM
  • Hello Martin,

    A) Can this be done by GPO for all servers

    B) What is the best way to do this by GPO?

    Thx

    Sunday, February 03, 2013 10:56 AM
  •  
    > A) Can this be done by GPO for all servers
    >
     
    Yes, but it is tricky because of NTFS inheritance... I would recommend
    asking yourself "why do I need to copy files to the system drive root
    folder?" ;-)
     
    > B) What is the best way to do this by GPO?
    >
     
    Computer configuration - Windows settings - Security settings - File
    system. But if you do wrong, you will destroy your servers...
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Sunday, February 03, 2013 2:20 PM
  • I understand what you mean Martin ;-)

    What is the best way to do this by gpo ? (this is for a lab-environment).

    Thx

    Monday, February 04, 2013 7:42 AM
  •  
    > What is the best way to do this by gpo ? (this is for a lab-environment).
     
    I already mentioned the GPO setting. So, just try and put ACLs in place,
    disable inheritance, make sure "this folder only" and go ahead ;-.)
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Monday, February 04, 2013 6:54 PM