none
Remote desktop host on 2008 server domain controller

    Question

  • I’m trying to set up Remote Desktop host on a Windows 2008 server domain controller.

     

    When I try to log on from the client I get this error message:  “This computer can’t connect to the remote computer.  Try connecting again.  If the problem continues, contact the owner of the remote computer or your network administrator.”

     

    I have several XP and Vista workstations set up as Remote Desktop hosts and they work fine. 

     

    Here’s my server configurations for the Remote Desktop host.

     

    I will be using Port 3395 for Remote Desktop.

    I have set the Hkey_local_machine\system\currentcontrolset\contro\terminalserver\winstations\rdp-tcp\portnumber to 3395

    I have allowed port 3395 to pass through in the Windows firewall setting.  I have turned off the Windows firewall.

    I have set my router to allow tcp port 3395 to go to the IP number of the server.

    I have turned Remote desktop on in system properties to “Allow connections from computers running any version of Remote Desktop”

    I did not deploy terminal service role services as I understand it is not needed for remote administration purposes.

    The server does not have IIS installed, which I do have on the clients.

    I have not rebooted the server since I made the configuration changes.

     

    What am I doing wrong? 

     

    I think it is not having IIS running but if this is the case, would deploying terminal service role services preclude me from installing IIS?  I would rather have terminal services rather than IIS to on this server.

    Tuesday, August 02, 2011 6:27 PM

Answers

  • Hi,

    You need to restart the server in order for the updated port number to take effect.  As an alternative I believe you could simply restart the Terminal Services service, but I have not tested this.

    -TP

    Tuesday, August 02, 2011 8:05 PM

All replies

  • Andy,

    I am having the same issue but if it helps, it appears that IIS was only for 'Remote Desktop Web', hence the need for IIS to manage it as a site. I don't think this is where the answer is for RDP activation for simple basic connection.

    Is yours in the domain ? I am coming across articles that mention domain necessity and or connection to a Terminal Server setup. 

    Anxious for a solution with you.

     

    Tuesday, August 02, 2011 7:02 PM
  • Mine is a domain.  I picked up the IIS requirement from some of my old notes from several years ago and looking at the current client hosts, it appears not to be needed.   The remote host I'm trying to configure is a Windows 2008 (not R2) server domain controller.  from the client I can log into the other remote hosts but not to the server.  With the server I get the error.

    One tip I got was if the computer had more than one network card, to specifically pint to that one in tscc.mcc /s.  I have two cards, one not active,  I did this and it did not solve the problem.

    Any help from anyone is appreciated.

    Tuesday, August 02, 2011 7:24 PM
  • I narrowed it down somewhat.  I had been trying to static external IP number with the port of the host like so 123.12.123.123:3395 from within the next work but out to the internet and back again.  This did not connect to the server but would connect to the other remote hosts by substituting the appropriate port number for 3395.

    I tried the Remote desktop using the internal ip number of the Server instead of the above number and this allowed me to connect.  The problem then must be with the pass through security settings of the router, the registry settings on the server regarding port 3395 and remote desktop, or some other blockage on the server preventing the external call.  I'm pretty sure it's not the router as the settings there are simple and they are set the same as the other hosts, except with the different numbers.

    I'll check further but any help is appreciated.

     

    Tuesday, August 02, 2011 7:57 PM
  • Hi,

    You need to restart the server in order for the updated port number to take effect.  As an alternative I believe you could simply restart the Terminal Services service, but I have not tested this.

    -TP

    Tuesday, August 02, 2011 8:05 PM
  • You are 100% correct.  I rebooted the server and the Remote desktop connection to the server over the internet now works.  Thanks.
    Tuesday, August 02, 2011 8:33 PM