none
Outlook Add-in

    Question

  • Hi

    I would like to edit the following registry setting "HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook\LoadBehaviour"

    Can this be controlled via GPO ? Ive had a look in the latest Outlook ADMs but cant see this setting. Any thoughts ?


    Thanks in advance.
    Monday, July 20, 2009 10:53 AM

Answers

  • Hi,

     

    Thanks for the post.

     

    From your description, I understand that you want to edit the registry setting "HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook\LoadBehaviour” via GPO.

     

    In this case, I have included an ADM file to change this registry value below.

     

    Here is the ADM file:

    =====================

    CLASS MACHINE

    CATEGORY !!categoryname

    KEYNAME "HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook"

    POLICY !!policyname

    EXPLAIN !!explaintext

    PART !!labeltext DROPDOWNLIST REQUIRED

    VALUENAME "LoadBehaviour"

    ITEMLIST

    NAME "Do not load automatically (Unloaded)" VALUE "0"

    NAME "Do not load automatically (Loaded)" VALUE "1"

    NAME "Load at startup (Unloaded)" VALUE "2"

    NAME "Load at startup (Loaded)" VALUE "3"

    NAME "Load on demand (Unloaded)" VALUE "8"

    NAME "Load on demand (Loaded)" VALUE "9"

    NAME "Load first time, then load on demand (Loaded)" VALUE "16"

    END ITEMLIST

    END PART

    END POLICY

    END CATEGORY

    [strings]

    categoryname="Outlook Add-Ins Options"

    policyname="Change the PDF LoadBehavior"

    explaintext="This policy sets the LoadBehavior for PDF Add-Ins"

    labeltext="Choose LoadBehavior"

    =====================

     

    For more information about LoadBehavior Values

    http://msdn.microsoft.com/en-us/library/bb386106.aspx#LoadBehavior

     

    To load your .adm file into Group Policy Object Editor

    1. Open Group Policy Object Editor.
    2. Under either Computer Configuration or User Configuration, right-click Administrative Templates, and then click Add/Remove Templates.
    3. In the Add/Remove Templates dialog box, click Add.
    4. Navigate to the folder containing the .adm file that you would like to add. Select the file, and then click Open.

     

    After that, the “Outlook Add-Ins Options” item will be shown in Administrative Templates, now expand to the “Change the PDF LoadBehavior” item and you could change the relevant setting.

     

    Note: If the Change the PDF LoadBehavior” item is now shown up, please right click the Outlook Add-Ins Options” item and select View->Filtering. In the prompted window, uncheck the “Only show configured policy settings” and “Only show policy settings that can be fully managed” if any of them is checked.

     

    Hope this helps.

    • Marked as answer by ste29 Tuesday, July 21, 2009 12:20 PM
    Tuesday, July 21, 2009 7:03 AM
    Moderator

All replies

  • I cannot tell if the originally provided Outlook ADM files contain that setting, but if not, you have these options:

    1. Create your own custom adm file: it is quite simple:
    http://support.microsoft.com/kb/225087/en-us
    http://technet.microsoft.com/en-us/library/cc759364(WS.10).aspx
    http://support.microsoft.com/kb/816662/en-us

    2. Use GP Preferences (this would by my choice)
    You can simply create a "Registry" Item (in this case computer based) and specify target key and value.
    Of course you need some prerequisites (at least one Vista or Winows 2008 for management and
    the GPP CSE on each target machine):
    http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=42E30E3F-6F01-4610-9D6E-F6E0FB7A0790&displaylang=en
    http://technet.microsoft.com/en-us/library/cc731892(WS.10).aspx


    Patrick
    Monday, July 20, 2009 8:27 PM
  • Hi,

     

    Thanks for the post.

     

    From your description, I understand that you want to edit the registry setting "HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook\LoadBehaviour” via GPO.

     

    In this case, I have included an ADM file to change this registry value below.

     

    Here is the ADM file:

    =====================

    CLASS MACHINE

    CATEGORY !!categoryname

    KEYNAME "HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook"

    POLICY !!policyname

    EXPLAIN !!explaintext

    PART !!labeltext DROPDOWNLIST REQUIRED

    VALUENAME "LoadBehaviour"

    ITEMLIST

    NAME "Do not load automatically (Unloaded)" VALUE "0"

    NAME "Do not load automatically (Loaded)" VALUE "1"

    NAME "Load at startup (Unloaded)" VALUE "2"

    NAME "Load at startup (Loaded)" VALUE "3"

    NAME "Load on demand (Unloaded)" VALUE "8"

    NAME "Load on demand (Loaded)" VALUE "9"

    NAME "Load first time, then load on demand (Loaded)" VALUE "16"

    END ITEMLIST

    END PART

    END POLICY

    END CATEGORY

    [strings]

    categoryname="Outlook Add-Ins Options"

    policyname="Change the PDF LoadBehavior"

    explaintext="This policy sets the LoadBehavior for PDF Add-Ins"

    labeltext="Choose LoadBehavior"

    =====================

     

    For more information about LoadBehavior Values

    http://msdn.microsoft.com/en-us/library/bb386106.aspx#LoadBehavior

     

    To load your .adm file into Group Policy Object Editor

    1. Open Group Policy Object Editor.
    2. Under either Computer Configuration or User Configuration, right-click Administrative Templates, and then click Add/Remove Templates.
    3. In the Add/Remove Templates dialog box, click Add.
    4. Navigate to the folder containing the .adm file that you would like to add. Select the file, and then click Open.

     

    After that, the “Outlook Add-Ins Options” item will be shown in Administrative Templates, now expand to the “Change the PDF LoadBehavior” item and you could change the relevant setting.

     

    Note: If the Change the PDF LoadBehavior” item is now shown up, please right click the Outlook Add-Ins Options” item and select View->Filtering. In the prompted window, uncheck the “Only show configured policy settings” and “Only show policy settings that can be fully managed” if any of them is checked.

     

    Hope this helps.

    • Marked as answer by ste29 Tuesday, July 21, 2009 12:20 PM
    Tuesday, July 21, 2009 7:03 AM
    Moderator
  • Perfect ! Thanks very much
    • Marked as answer by ste29 Tuesday, July 21, 2009 12:20 PM
    • Unmarked as answer by ste29 Tuesday, July 21, 2009 12:21 PM
    Tuesday, July 21, 2009 12:20 PM
  • Just one thing with your adm: Shouldnt the KEYNAME be "Software\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook" and not "HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook"
    Tuesday, July 21, 2009 12:55 PM
  • Hi ste29,

    Thanks for your correction.

    I am glad to hear that the information was helpful to you.

    Hope you will enjoy our TechNet Forum.

    Thanks,

    Miles

    Wednesday, July 22, 2009 1:12 AM
    Moderator