none
TSWEB access Error "remote desktop cannot find the remote computer" After IP conversion No access from interent

    Question

  • Hell All, First question posted ever.  WHY?  Becauase this is the first time I have not been able to find an answer.  I thought there has to be someone who ran into this but I have not found anything that helped.  Closest post was.

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/6b037a9e-d9a6-48a4-a21a-e96f686e0894/

    But no luck.  All settings were correct.

     

    So here is the setup. 

    Tsweb Farm, 1 gateway, 1 connection broker, 1 session host.

    external address https://tsweb.company.com

    We recently had an IP conversion and after the conversion we are unable to access our sessions from the internet.  Internally everything works as it did.  All dns, certificatesm, ips, firewall, etc all updated everywhere we can possible think of.  This is just for one of our sites.  Our other site, tsweb.company2.com also had an ip conversion but is a single tsweb server and not a farm.  And we have no problems exernally or interneally with that machine. 

    it's really mind boggling. And we are all stumped! If all else fails we will be creating a new farm.  Which is really something we do not want to do.  Since authenication and firewall seems fine.  It appears that after gettting to the Remote Apps page and clicking Remoted Desktop icon. We are getting the error "remote desktop cannot find the remote computer."  Internally that RD icon would trigger the Conenction broker to assign the host.  I would asume the same is still being done externally.  So it would appear externally we are failing at the connection broker.  Does this make since?  Any help/suggestions are greatly appreciated.

     

    MK

     

     

     

     

    Thursday, December 15, 2011 12:41 AM

Answers

  • Hello,

     

    It’s may due to RD Gateway does not have a valid certificate which can be used. Client users would be unable to obtain either a local certificate from a CA or a third party certificate in the external.

     

    Please try to disable RD Gateway. Configuring RD WebAccess to use the public  IP under session host properties to see if it’s worked or not.

     

    Monday, December 19, 2011 10:49 AM