none
Disable creation of thumbs.db file

    Question

  • I have looked at other posts and have searched google for a while now and cannot seem to disable the creation of thumbs.db on server 2008 R2. I have created a group policy according to other posts I have read and it still seems to be creating the file on network shared folders. Does anyone know how to permanently remove the creation of this file?

    Thanks.


    Chad Guiney

    Monday, March 12, 2012 8:23 PM

All replies

  • Hello Chad, set the regkey "DisableThumbnailCache" = 1

    HKEY_CURRENT_USER Software Microsoft Windows CurrentVersion Explorer Advanced

    Regards

    Nino

    • Proposed as answer by Bill - MCSE Monday, March 12, 2012 11:57 PM
    Monday, March 12, 2012 9:42 PM
  • Hello,


    Which group policy have you applied?  Have you tried the one as below?


    User Configuration\Administrative Templates\Windows Components\Windows Explorer\ -
     
    "Turn off the display of thumbnails and only display icons on network folders"


    Thanks
    ZHANG

    Tuesday, March 13, 2012 6:23 AM
    Moderator
  • Thanks Nino I didnt have this Regkey but created it and will see if that makes a difference.


    Chad Guiney

    Tuesday, March 13, 2012 1:58 PM
  • Thanks for the reply Zhang but I have implemented this policy

    User Configuration\Administrative Templates\Windows Components\Windows Explorer\ -Turn off caching of thumbnail pictures
    Turn off the caching of thumbnails in hidden thumbs.db files
    Turn off the display of thumbnails and only display icons on network folders
    Turn off the display of thumbnails and only display icons

    verified via gpresult /Z and thumbnail.db is still showing up.


    Chad Guiney

    Tuesday, March 13, 2012 2:03 PM
  • Hi Chad,

    Please refer to the following steps:

    Method  one

    1. Open the Registry Editor (regedit.exe). 
    2. Navigate to 
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced. 
    3. Double-click the DisableThumbnailCache value, or go to Edit -> New -> DWORD value to create a new value by that name. 
    4. Enter 1 for its value. 
    5. Click Ok and close the Registry Editor when you're done; you'll have to log off and then log back on for this to take effect. 

    Method Two

    Enable the following policy setting on clients that connect to the tomcat server:
    Policy Path User Configuration\Administrative Templates\Windows Components\Windows Explorer
    Policy Setting "Turn off the display of thumbnails and only display icons on network folders"
    Policy Value Enabled 

    Method Three

    Denied creation of thumbs.db using option "File screening" in “File Server Resource Manager” feature. 
    http://www.microsoft.com/download/en/details.aspx?id=19759 


    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Friday, March 16, 2012 6:38 AM