none
Access Based Enumeration in Windows 2008 R2 is driving me nuts

    Question

  • For whatever reason I cannot get this to work.  I create a share, enable ABE, set the permissions, and users can still see every folder whether they have access to the folder or not.  What am I missing?  I am about to the point of calling Microsoft, (feeling very defeated at this point) and getting out the credit card to get this resolved.

    Share permissions are:

    Domain Admins - Full Control

    Domain Users - Full Control

    Administrators - Full Control

    NTFS Permissions on the share are:

    Domain Users - Read / Read & Execute / List Folder Contents

    Domain Administrators - Full Control

    Within the share are multiple folders each with thier own access rights.  Users need to only see folders within the share that they have access to and right now, each user can see every folder whether they can access the folder or not.

    Thanks for any help.


    Thursday, May 16, 2013 4:44 PM

Answers

  • on the ntfs permissions at the share level what do you have the Domains users set to;

    This Folder, subfolders and files
    This Folder only
    This Folder and Sub Folders
    Subfolders and FIles only
    Subfolders only
    or
    Files only?

    i think you will need to have it set to

    "This folder only"


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. If you find an answer helpful then please "Vote As Helpful"

    Friday, May 17, 2013 10:50 AM

All replies

  • on the ntfs permissions at the share level what do you have the Domains users set to;

    This Folder, subfolders and files
    This Folder only
    This Folder and Sub Folders
    Subfolders and FIles only
    Subfolders only
    or
    Files only?

    i think you will need to have it set to

    "This folder only"


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. If you find an answer helpful then please "Vote As Helpful"

    Friday, May 17, 2013 10:50 AM
  • Hi Shaon Shan,

    I have same problem with Brokenspoke.

    Share Permission: Authen user: Modify

    NTFS: Authen user: READ, special permission: This folder.

    But when I enable ABE (2008 R2) users still see all share folder structure, they also can walk-in sub-folder but they cannot see files, folder inside.

    I also have Stop & re-share again, but not success..

    Any ideas to help me out?

    Tuesday, October 15, 2013 1:30 AM
  • hi BrokenSpoke,

    How're you? how you o fix it?


    Tuesday, October 15, 2013 1:34 AM
  • Tuan Anh Do -

    Never did get it to work.

    Wednesday, October 16, 2013 6:55 PM