none
How to configure Windows 2012 Server Remote Desktop Session Host to Utilize Local RD License Server

    Question

  • Hello,

    I have installed RDS within Windows 2012. I have installed the license manager locally on the server (Installed RDS Per User Cal) and have successfully activated the license server. However , I am unable to configure Remote Desktop services to utilize the license server residing locally on the server.  For some unexplained reason, I am unable to install the Connection Broker (fails about 50% of the way during the install) and have spent a considerable amount of time attempting to locate a doc that outlines the procedures for successfully configure RD services to utilize the locally configured license server.  The doc referenced below looked promising. Unfortunately, the command on Step 4 errors out when I attempt to enter the command as directed.

    "Guidelines for installing the Remote Desktop Session Host role service on a computer running Windows Server 2012 without the Remote Desktop Connection Broker role service"

    4. Run the following command to replace the machine name with License Server:

    $obj.SetSpecifiedLicenseServerList("LicServer")

    Any help/guidance would be appreciated. 

    Tuesday, July 09, 2013 5:42 PM

Answers

  • Hi,

    1. Is this server a Domain Controller?  Installing RD Connection Broker on a DC does not work at this time.

    2. Does this server have KB2821895 update installed?  If yes, you need to re-install from scratch, this time without installing KB2821895 update.

    3. You may configure the Licensing mode and Specify the RD Licensing server name using group policy.  For example, open gpedit.msc and the settings are located under:

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Licensing

    -TP

    Thursday, July 11, 2013 11:49 AM
    Moderator
  • I went into the local group policy under "Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Licensing"

    Enter the License Server FQDN and mode. Do a "gpupdate /force"

    Monday, July 15, 2013 11:42 AM

All replies

  • Hi,

    1. Is this server a Domain Controller?  Installing RD Connection Broker on a DC does not work at this time.

    2. Does this server have KB2821895 update installed?  If yes, you need to re-install from scratch, this time without installing KB2821895 update.

    3. You may configure the Licensing mode and Specify the RD Licensing server name using group policy.  For example, open gpedit.msc and the settings are located under:

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Licensing

    -TP

    Thursday, July 11, 2013 11:49 AM
    Moderator
  • I went into the local group policy under "Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Licensing"

    Enter the License Server FQDN and mode. Do a "gpupdate /force"

    Monday, July 15, 2013 11:42 AM
  • Hello,

    I have installed RDS within Windows 2012. I have installed the license manager locally on the server (Installed RDS Per User Cal) and have successfully activated the license server. However , I am unable to configure Remote Desktop services to utilize the license server residing locally on the server.  For some unexplained reason, I am unable to install the Connection Broker (fails about 50% of the way during the install) and have spent a considerable amount of time attempting to locate a doc that outlines the procedures for successfully configure RD services to utilize the locally configured license server.  The doc referenced below looked promising. Unfortunately, the command on Step 4 errors out when I attempt to enter the command as directed.

    "Guidelines for installing the Remote Desktop Session Host role service on a computer running Windows Server 2012 without the Remote Desktop Connection Broker role service"

    4. Run the following command to replace the machine name with License Server:

    $obj.SetSpecifiedLicenseServerList("LicServer")

    Any help/guidance would be appreciated. 

    "LicServer" is a placeholder... You have to replace it with the name/IP of your License Server

    Monday, August 26, 2013 2:28 PM