none
Internet Explorer 9 not showing as not installed when using Windows Update - Error: Code 9C48 Windows Update encountered an unknown error.

    Question

  • I built a few new Windows Server 2008 R2 with SP1 VMs today and ran into a problem where Windows Update is not detecting the fact that Internet Explorer 9 is already installed. Internet Explorer 9 keeps showing up as an available update when using Windows Update. When I try to install it as a test I get the error message: Code 9C48 Windows Update encountered an unknown error.

    My normal build procedures include applying all the patches for the OS prior to any other work on the servers. The way I like to do the patching is to do every update other then IE9 in the begininng and once all the other updates have been completed, install IE9 and then patch it if there are updates available. I followed this procedure on every build for the last year and I have not run into any issues until today. The only difference today is the latest patches that were released yesterday April 10th, 2012. To test the theory that it may be one of the latest patches, I reinstalled Windows from scratch making sure to format the disks and then I installed IE9 right after the OS install without any other updates. Once the server was rebooted, I checked Windows Update and Internet Explorer 9 still showed up as update (Not the Cumulative Update which normally shows up after an IE9 install) and yes, I did make sure to click the 'Check for Updates' link before I looked just in case. My next test was to patch a couple of the servers I had built prior to April 10th, 2012. Those servers did not have any issues with the latest updates and they are not experiencing the same behavior as the newly built servers.

    I ended up comparing the IE9 Version on the cleanly install OS (No updates were installed except IE9) and the servers I built last week which were patched. The versions are exactly the same.

    My findings above lead me to believe that there is a problem with the latest IE9 install package (which includes the latest cumulative update) and the Windows Update detection component.

    I guess I am looking for someone to report this up the chain to get this fixed so no one else runs into this problem. I know in some cases we may not be able to see additional IE9 updates until this is resolved.

    Wednesday, April 11, 2012 10:56 PM

Answers

All replies

  • I noticed this as well. After all these years of success installing and re-installing Windows, learning patches and tips and tricks...YOU DON'T SUPPOSE that perhaps someone at Microsoft accidentally programmed Windows Update to not recognize or update Internet Explorer 9 on people's computers do you? {laugh}. Because if you don't I do! I have not bothered to tell Microsoft about it. Only a dunce could let such a blunder happen. And although I love Windows THIS is inexcusable. PLEASE fix the Windows Update site if possible!

    And just so you know this is the first time since I have been using Windows 7 that this error message 9C48 has appeared. I suppose it doesn't have anything to do either with the fact of my NEW Intel Second Generation Core I7 laptop either. This is unbelievable.
    • Proposed as answer by User Here Thursday, April 12, 2012 5:26 AM
    • Edited by User Here Thursday, April 12, 2012 5:32 AM Added data.
    Thursday, April 12, 2012 5:25 AM
  • Having the same problem with IE 9 and the same error code 9C48 in Windows Update - this is on a Windows 7 32-bit Home Premium install in a Virtual Machine.
    Thursday, April 12, 2012 8:07 AM
  • I just started having the same problem.

    I was creating a new VM in Vsphere from our 2008 R2 SP1 image and it hasn't been updated and repacked in a while, so i have to install about 60 updates, including IE9.

    I went through my normal setup as i had just created 2 VMs and updated them on Monday with no problem.

    I got the same error code as you. The install looks like it installed IE9, but the update is still showing up as available in Windows Update.

    I deleted the VM, created a new one, chose all updates except IE, then did that and it still shows up again.

    Then i deleted the VM, installed just IE 9 and it still shows up as available on reboot.

    I have a script that i can use to reset/clear WSUS cache on the computer, (Software distribution folder, and the windows update log, and recreates a certificate), so i tried that and then rebooted and it still showed up.

    I then decide ok, maybe the Image got messed up somehow, so i started creating a new 2008 R2 install from scratch last night and chose to update just IE9 as the first install. I did that, rebooted and it didn't show up in Windows Updates, so i though GREAT. I proceed to kick off the 100+ downloads needed before i left and left the console up.

    When i got in to work this morning, the updater seemed stuck on 31 of 102 updates, this one in particular: KB288516. I rebooted the computer, because it wouldn't stop and just seemed stuck since last night, which these updates should only have taken about an hour to install at most. I log back in and sure enough, it now shows Internet Explorer 9 at the bottom of the update list as being needed for install.

    I believe this is Patch Tuesday week, so maybe they screwed up something with the Windows Update detection engine, because it worked fine on Monday when i had to update IE9 on 2 VMs that i created.

    Thursday, April 12, 2012 1:28 PM
  • Having the same problem here on a Dell Latitude E6420 with Windows 7 Professional x64. I installed a clean Windows 7 using Dell OEM installation DVD. Installed IE9 right after installing Windows. After running windows update a few times I am stuck with the same error Code 9C48. I am using a WSUS server. All my other machines that are older have no problems at all. Only this machine I created after the last patch Tuesday.
    Thursday, April 12, 2012 2:31 PM
  • I might have a workaround. Goto "Control Panel", "Programs and Features", "Installed Updates". Scroll down to the "Microsoft Windows Updates" and uninstall "Windows Internet Explorer 9". Reboot and you should have IE8 again. Now run Windows Update again and install IE9 from Windows Update. Restart and apply all patches and restart a few times.

    Maybe the IE9 version from WSUS/WU is different than the version I installed. I checked on the Micorosft Website and the last version of IE9 for Windows 7 was released in April 2011.

    Thursday, April 12, 2012 2:47 PM
  • I'm getting the same thing after replacing a bad HD on a dell 780 desktop.

    I did try removing and reinstalling it from windows uppdates as well as installing ie9 from download.

    looks like it is a detection error with windows updates, hopefully everyone posting on here will help them to get it fixed.


    -Jim

    Thursday, April 12, 2012 3:22 PM
  • Maybe they are fixing it right now, because I can't seem to be able to download anything from the Windows Update site for the past 30 minutes on the server with the issue or my desktop with the latest set of patches.
    Thursday, April 12, 2012 3:22 PM
  • The workaround above does not work. I tried it as a test earlier and still had the same problem.
    • Edited by Roger_Szulc Thursday, April 12, 2012 4:57 PM
    Thursday, April 12, 2012 4:55 PM
  • Same problem here. Win7 HP x86.
    Thursday, April 12, 2012 7:48 PM
  • Same here Win7 Dell x86
    Thursday, April 12, 2012 8:19 PM
  • The workaround above does not work. I tried it as a test earlier and still had the same problem.

    Yeap, i tried that during one of my many VM test builds and it didn't help.

    I just created a new TestVM 2008 R2 with IE8, installed IE9 only from the Windows Update site and rebooted. It still picks up IE 9 as an available update upon reboot and checking with Windows Update.

    I just called Microsoft and have a case number, so if they can fix it, i will let you know.

    Thursday, April 12, 2012 8:31 PM
  • Having the same problem with Windows update showing IE9 as optional update even though IE 9 is already installed. Error code 9C48 is generated when trying to install that optional update. This is on a clean reinstall Windows 7 64-bit Home Premium on an HP Pavilion DM4. Just to make sure it is not an error on my laptop, I uninstalled IE9 and windows update reinstalled IE9 without error but then again Windows update keeps showing IE9 as an available optional update. Can't get rid of that even after trying Microsoft troubleshooter and Microsoft Fix It utilities. Agree with @Roger_Szulc that it must be a problem at Microsoft's level. 
    Thursday, April 12, 2012 8:55 PM
  • Same issue here with an HP Windows 7 Enterprise 64-bit. Tried removing IE9 through 'View installed updates' and re-installing it. IE9 still shows up under optional updates. Attempting to install it fails with Code 9C48. The Windows Update troubleshooter runs and says that it fixed a problem but no change.
    Thursday, April 12, 2012 11:38 PM
  • +1

    Just did a WIN7 Pro reinstall yesterday and am also seeing IE9 listed as an optional update after it has already been installed. Ditto on the workaround not fixing this. Also ran the Fix It which did not help either. This was a clean install on a Dell Latitude. My OS disk was pre-Service Pack One.

    Glad I found this thread or I would have been screwing with this for hours trying to figure it out. 

    Finally decided to just hide the update until MS figures out a fix. 
    • Edited by gveets Friday, April 13, 2012 1:22 AM
    Friday, April 13, 2012 1:10 AM
  • +1 Also..   Two installations of Windows Server 2008 R2 and one Windows Server 2008 with this issue in the last week.
    Friday, April 13, 2012 3:03 AM
  • I might have a workaround. Goto "Control Panel", "Programs and Features", "Installed Updates". Scroll down to the "Microsoft Windows Updates" and uninstall "Windows Internet Explorer 9". Reboot and you should have IE8 again. Now run Windows Update again and install IE9 from Windows Update. Restart and apply all patches and restart a few times.

    Maybe the IE9 version from WSUS/WU is different than the version I installed. I checked on the Micorosft Website and the last version of IE9 for Windows 7 was released in April 2011.

    Worked for me on 2 different systems. Had issues on 2 systems, one 32bit with WSUS (IE9 was shown when checking online for updates), one 64bit without WSUS configured. IE9 originally installed using offline installer with silent switch. Fixed both by removing the IE9 update, then letting it install through WU.

    Edit: installs fine through WU, but after reboot and recheck it shows it again as an available update.
    • Edited by Bob4242 Friday, April 13, 2012 8:06 AM spoke to soon
    Friday, April 13, 2012 8:02 AM
  • Same problem here in Norway, this problem comes on every new PC I installs with Win 7 Pro 64 bit now.

    Also on older computers that are reinstalled now.

    Started 2 days ago, and the problem is not on older computers that were installed earlyer.

    So clearly some bugs in the IE 9 installer that is used on WinUpd now.

    Hoperfulle the solution will be solved in Windows Update, and that we dont have to uninstall every IE 9 from now on, to install a new one without the problem.

    Friday, April 13, 2012 11:24 AM
  • I am having the same problem as well.  On an OEM install of Windows 7 Pro x64 SP1, I ran Windows Update and installed all important and recommended updates (including IE9), rebooted, and IE9 was installed but also still available as a recommended update.  When I try to install, I get an error.

    Since this was a clean install and I hadn't really done anything yet, I figured I would try again so I reinstalled Windows, and this time installed IE9 first using the standalone redistributable package instead.  I rebooted, ran Windows Update, and there the IE9 update was again, even though IE9 was already installed.

    I agree that this seems to be a Windows Update problem with detecting IE9 properly, and I also agree that it doesn't seem to be a problem on existing computers, just fresh installs after this most recent patch Tuesday.

    Microsoft, are you listening?  I'm wasting precious write cycles on my SSD reinstalling Windows!

    Friday, April 13, 2012 12:59 PM
  • This same problem was reported and diagnosed on this thread:

    http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/2c252dbe-c833-424d-9b75-4948bb8fb816

    Basically, the current IE9 binaries are bad, and you need to install IE9 using the older version without updates or internet connectivity.

    Friday, April 13, 2012 2:16 PM
  • Just an update on the case i submitted to them:

    They said someone was supposed to call me back within 8 hours yesterday ( i called around 330pm Central), but i never heard back. Hopefully, they now realize there is a problem and are working on it though.

    I mentioned the thread here to the lady that took my case as well.

    Friday, April 13, 2012 2:20 PM
  • Same issue here.

    Restoring a Dell Vostro 460 Windows 7 32bit, with Dell's crappy restore media that didn't include the NIC driver, but thats another rant.

    - IE 9 is currently installed

    - Windows Updates shows the optioal update "Windows Internet Explorer 9 for Windows 7" Download size: 19.3 MB

    - click to install and it results in error code 9C48

    - decided to hide the update until MS fixes their problem

    Friday, April 13, 2012 3:07 PM
  • Ok, a technician called me and i explained to her the problem we are all having and she said it looks like a problem with the Windows Update detection.

    She is forwarding the issue to the Windows Update group and they will contact me today or Monday.

    If other people are viewing this thread and have the same issue, i encourage you to sign up or at least confirm if you have the issue or not.

    Friday, April 13, 2012 3:13 PM
  • Just finished up a new build of SBS2011 and have the same problem.  Glad MS is aware of it, hopefully the fix comes soon.
    Friday, April 13, 2012 7:00 PM
  • Hi Eth0,,

    I Just had the same issue and your tip resolved it.

    I think this occurs because, during the setup of my system (clean install and subsequant Windows Updates and reboots), I was presented with the "Browser Choice" icon on my desktop.  I used it to install IE9 before the windows updates sessions had marked Internet Explorer for an update.  Therefore, when the time came for Windows Update to update IE9, it was already there.This issue could be serious because it stops IE9 updates from being detected.

    After uninstalling IE9, then running windows update and installing IE9 from there, Windows Update prompts me to install some IE 9 updates.

    Top Tip: Do not use the Browser Choice app to install IE9, use Windows update instead.

    Thanks again.

    Agrodude


    • Edited by agrodude Saturday, April 14, 2012 10:38 AM
    Saturday, April 14, 2012 10:36 AM
  • Have exactly the same problem - new install win 7 pro x64 - nothing in Installed Updates to remove so will have to wait for solution.  Can IE9 be updated in this state?
    Saturday, April 14, 2012 7:59 PM
  • The Microsoft person replied back yesterday and said they were unable to reproduce the problem.

    I told him i would retest this morning.

    I logged in to my current Test VM Server which already had IE9 installed but still would see the update available.

    I rebooted it this morning, and did a Windows Update check and IE9 finally did not show up.

    I just rebooted after running a remaining update and still no IE9 prompt, so i think someone over there finally fixed it.

    Let me know if anyone else is ok now.

    I am going to build the 2 VM Servers i was originally supposed to and let you know how those go in about an hour or so.

    Tuesday, April 17, 2012 1:15 PM
  • Ok, i just built my 2 VM Windows 2008 R2 IE8 servers, installed all the updates, including IE9 and after several reboots and additional patches, the IE9 prompt has finally gone away.

    Looks like they fixed it.

    Tuesday, April 17, 2012 2:34 PM
  • Ok, i just built my 2 VM Windows 2008 R2 IE8 servers, installed all the updates, including IE9 and after several reboots and additional patches, the IE9 prompt has finally gone away.

    Looks like they fixed it.

    I agree.  I took my Win7 Pro SP1 x64 machine that had this same problem and checked for updates this morning and the IE9 update no longer shows up.  I think they fixed whatever detection problem Windows Update was having with IE9.
    Tuesday, April 17, 2012 3:00 PM
  • It is confirmed that Microsoft has fixed the issue now.
    • Edited by Roger_Szulc Tuesday, April 17, 2012 7:21 PM
    • Marked as answer by Roger_Szulc Tuesday, April 17, 2012 9:34 PM
    Tuesday, April 17, 2012 7:18 PM
  • I'm having an even worse problem it seems.....

    I can't update IE9 like all of you, and I'm running on a Dell Inspiron 1750 with Windows 7 Home Premium. When I got to update, it gives me the Code 9C48, and when I try auto detection from windows update to troubleshoot it, it always fixes the same 4 things:

    Potential Windows  Update Database error detected 0x80070002  -Fixed

    Windows Update Components must be repaired   -Fixed

    Problem with BITS   -Fixed

    Security files are not registered   -Fixed

    It fixes these same things every time I run the Troubleshooter after the IE9 update fails. I can't even uninstall IE9!!! I tells me that "An error has occurred. Not all of the updates could successfully be uninstalled." I can't update it, I can't get rid of it! Even upon opening IE9 to browse, I get the "Internet Explorer has stopped working" and no solution to that either by troubleshooting it. Lucky I switched over to Chrome now.   

    Friday, November 23, 2012 5:56 PM
  • I am having the exact same problem as Deez_E53. Toshiba Satellite A355 with Windows 7 Home Premium.

    IE9 is installed but Windows Update keeps trying to install IE9 & I get Code 9C48. When I try to uninstall the existing IE9 I get could not uninstall.

    Friday, December 28, 2012 9:24 PM
  • what if ie9 does not show in the installed updates. I have been getting the error 9C48 but i can't find ie9 to uninstall it  any suggestions anyone.

    I have Windows Vista 64bit  home premuim.
    • Edited by Chadie Thursday, January 23, 2014 12:55 PM
    Thursday, January 23, 2014 12:53 PM
  • On Thu, 23 Jan 2014 12:53:53 +0000, Chadie wrote:

    I have Windows Vista 64bit  home premuim.

    This forum is for Windows Server security related issues. Please repost
    your question to the appropriate forum:

    http://answers.microsoft.com/en-us


    Paul Adare - FIM CM MVP
    The programmer's national anthem is 'AAAAAAAAHHHHHHHH'. -- Weinberg, p.152

    Thursday, January 23, 2014 3:29 PM