none
RemoteApp on MAC

    Question

  • Hi,

     

    I've successufully installed TS 2008 with RemoteApp, so users are able to start applications from TS server through RDP tunnel. Problem apprears on MAC laptops: they are able to open file share with .rdp applications, but when they select it it opens Remote Desktop, not RemoteApp.

     

    How to publish any applications for MAC users? Maybe publish it through Web Access? If yes - how I can do this?

     

    Thnx!

    Thursday, April 24, 2008 1:14 PM

Answers

  • Hello,

    Tthe MAC client supports RemoteApp connections.

    However you can post your question here to confirm :https://connect.microsoft.com/macrdc/content/content.aspx?ContentID=5893&wa=wsignin1.0

     

    Friday, April 25, 2008 4:47 PM
  •  

    "The MAC client supports RemoteApp connections."

     

     

    How? When I started something.rdp (published application through Terminal Services 2008) MAC opened RDP, not application...

     

     

    Saturday, April 26, 2008 8:01 AM

All replies

  • Hello,

    Tthe MAC client supports RemoteApp connections.

    However you can post your question here to confirm :https://connect.microsoft.com/macrdc/content/content.aspx?ContentID=5893&wa=wsignin1.0

     

    Friday, April 25, 2008 4:47 PM
  •  

    "The MAC client supports RemoteApp connections."

     

     

    How? When I started something.rdp (published application through Terminal Services 2008) MAC opened RDP, not application...

     

     

    Saturday, April 26, 2008 8:01 AM
  • Hi James
    I know this is backtracking slightly but I am currently using TS 2008 and with Web Access for our PCs it works perfectly but I cannot get the Macs to connect at all! You mentioned that anything you try to open for the macs it opens in Remote Desktop. How can you get it to do this?
    For myself on a mac I get nothing at all appearing

    Any help would be very much appreciated!

    Many Thanks
    Mike Donaldson
    • Proposed as answer by Fravocado Tuesday, July 07, 2009 4:43 PM
    Thursday, May 14, 2009 12:41 PM
  • Hi James,

    I ran into the same issue as well, the remoteapp worked fine on the Windows side but would load the desktop for the MACs.  I found that if you edit the .rdp session with the Mac .rdp client that you can find the Applications portion of the edit and put the path where the packaged program is: ex: c:\program files\ packaged programs.

    Now when you launch the .rdp session it will just open the app you want instead of load a desktop session.

    Hope this is what you were looking for.

    Thanks,
    Avocado
    Tuesday, July 07, 2009 4:49 PM


  • Fravocado,
    My organization has been trying to get RemoteApp to work for our Mac clients but have so far been unsuccessful.  We have tried editing the .RDP file with numerous paths to the applications we want but it always loads the full desktop session.  Would it be possible for you to copy/paste that section of your .RDP file so we can see what exact syntax you are using?  Also was there any other special settings you had to use on the server itself?  Any help would be greatly appreciated!

    Thank you so much!

    Reeves122
     

    Monday, August 17, 2009 8:53 PM
  • Hi Reeves,

    I got it to work this way: I created the .rdp from the remote app that I desired. create your .rdp as normal and test with your PC, it should only open that app.  Now take the .rdp from C:\program files\packaged programs and copy and paste it to your mac to edit and test.  Open RDC 2.0 on the mac and go to File > Edit a Connection. Point it to the .rdp file and it will open a screen showing you what you can edit. Now click the applications portion of the menu and check the box that says "start only the following windows applications" the rest should be fine. You can also specify the domain if you are using domain logins. Save it and test.

    Hope this helps!
    • Proposed as answer by Sam540CPI Thursday, October 14, 2010 6:16 PM
    Tuesday, August 18, 2009 5:41 AM
  • Wow that worked perfectly!  Thank you so much for your help!!! =D

    Reeves122
    Tuesday, August 18, 2009 12:40 PM
  • Wow that worked perfectly!  Thank you so much for your help!!! =D

    Reeves122
    Yes it Works, but I still have it in the RDP window with an emty background. Is it also possible to get it without the background like a stand alone app?
    Sunday, September 13, 2009 8:25 AM
  • I tried to do this today and could not get it to work.  Says it cannot open the file. 
    Thursday, January 07, 2010 4:23 PM
  • it works and save my life ;)
    Thursday, August 26, 2010 12:03 AM
  • Hi,

     

    Has anyone else had success getting TS RemoteApp to work for Macintoshes?


    Travis L. Grundke Ashton Technology Solutions, Inc.
    Friday, October 22, 2010 1:11 PM
  • we have our remoteapp servers clustered how would this work to connect via rdp to them that way?
    Wednesday, December 01, 2010 3:48 PM
  • I think the big problem is when you have a TS Gateway: the Mac RDP client cannot navigate it successfully at this time.  I've posted to several forums and contacted MS, but haven't heard any response to the question yet.
    Travis L. Grundke Ashton Technology Solutions, Inc.
    Monday, December 06, 2010 6:38 PM
  • Hi,

    That works for me but, as you said, I've  also a background; on my Windows PC I don't have it. Do you have resolved this ?

     

    Thanks a lot and receive from FRANCE a merry Christmas and happy new year 2011.

    Wednesday, December 29, 2010 2:36 PM
  • Hi,

     

    In a same manner, I want to list a directory and the files inside. I put a program in remoteApp which is c:\windows\explorer.exe. This works with a PC but with my MAC (rdp file) I receive an error "Access denied". I don't know why. If you have the solution.....

     

    Thanks a lot,

     

    Vaclar

    Monday, January 03, 2011 6:34 PM
  • I reply to myself: I have found a software (name: FreeCommander); it works, files are listed in a window but the problem is the "copy/paste". I can select a file and click on "copy" on this windows; after I click on the desktop of my MAC but the command "paste" doesn't appear in the context. If I try this on my PC, the command "paste" appears and I can "paste" the file onto my PC......

    I think it's not possible to do a "copy/paste" on the MAC. Any idea for a "miracle" program ?

    Thanks you very much.

    Regards,

    Vaclar

    Monday, January 03, 2011 9:43 PM
  • Hi Vaclar

    I think what your problem is, is that you need to change the preferences of the RDP file on your Mac to map local folder or hard disk. Its been a while since I set this up on a Mac so I'm not sure of the actual option but if you look in the RDP File preferences you'll see an option to share your local drive or folder. 

    I suggest selecting folder and then either creating a new folder on the desktop and sharing that or share you Mac Documents folder.

     

    Monday, March 14, 2011 10:54 PM
  •  

    If by "a background" you mean that if a user closes the app, but does not close their Mac RDC Window, they are stuck with an empty blue background, I may developed a workaround that I am currently testing.

    The main problem I have been experiencing is that a user can leave a disconnected session on the server that has no valid shell (meaning neither the remoteApp process nor explorer.exe). If you do not have disconnection timers that immediately log off disconnected users, then your users can reconnect to the "blue window", which is essentially a shell-less session.

    In my environment,  I cannot set my disconnection timers to be low enough to alleviate this problem, so I have developed a work-around (again, still in testing) with Powershell. The workaround requires the installation of the PS modules -- RDSRemoteApp and PSTerminalServices -- both freely available from MSDN.

    Basically, the script looks for disconnected sessions, and then, if the session is running neither explorer.exe, nor an executable associated with a RemoteApp, it logs the user off.  This way, legitimate disconnected sessions can remain open on the server, while those Mac users who would otherwise be stuck with an empty blue window, will be correctly logged off.

    The PS script should be run from Task Scheduler, and your Task Scheduler trigger should execute on "On remote disconnect from any user session".

    Like I said, I'm still testing this, so buyer beware. I'd be interested in any feedback, suggestions, or observations on how this performs in a more heavily-used production environment.

    Hope this helps anyone struggling to get the Mac RDC client to behave a little more like RemoteApp on Windows.

    =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

    # Import required PS modules 

    Import-Module PSTerminalServices
    Import-Module RDSRemoteApp

    # query RemoteApp to find processes associated with each published application

    $array_array_remote_app_processes = @()

    $remote_apps = get-rdsRemoteApp | select path

    # grab executable name from each remoteApp path

    foreach ($_ in $remote_apps) {

    $array_remote_app_processes += $_.path.substring($_.path.lastIndexOf("\") + 1)

    }

    # add explorer.exe to our list of processes, as this represents a user running a full TS desktop

    $array_remote_app_processes += "explorer.exe"

    # get a list of all disconnected sessions on the server

    $disconnected_sessions = get-tssession | where {$_.state -eq "Disconnected"} | select sessionID

    # inspect each disconnected session

    foreach ($disconnected_session in $disconnected_sessions) {

    # exclude session zero from our processing

    if ($disconnected_session.sessionID -ne 0 ) {

    # set the disconnect user flag to 'yes'. we will override this later

    $disconnect_user = "yes"

    # grab a list of running processes for the disconnected session

    $rds_user_processes = get-tsprocess | where {$_.sessionID -eq $disconnected_session.sessionID }

    foreach ($process in $rds_user_processes) {

    # check to see if any of the running processes for the user's session match a remote app process

    if ($array_remote_app_processes -contains $process.processName) {

    # if the disconnected user is still running a remote app process, don't log them off

    $disconnect_user = "no"

    }

    }

    # otherwise log user off

    if ($disconnect_user -eq "yes") {

    logoff $disconnected_session.sessionID

    }

    }

    }




    Monday, March 21, 2011 11:46 AM
  • Hi Reeves,

    I got it to work this way: I created the .rdp from the remote app that I desired. create your .rdp as normal and test with your PC, it should only open that app.  Now take the .rdp from C:\program files\packaged programs and copy and paste it to your mac to edit and test.  Open RDC 2.0 on the mac and go to File > Edit a Connection. Point it to the .rdp file and it will open a screen showing you what you can edit. Now click the applications portion of the menu and check the box that says "start only the following windows applications" the rest should be fine. You can also specify the domain if you are using domain logins. Save it and test.

    Hope this helps!

    I tried this and still am having no luck. I have a working RDP file (well, working on Windows 7). I copy that to Mac, edit the file as described, and I still get a logon to a normal session on the 2008 TS Server. Any other tips? I would love to see a WORKING MAC RDP File code, to see if I've got something wrong. Thanks!
    Tuesday, July 26, 2011 8:49 PM
  • Did this ever get solved?

    Tuesday, September 25, 2012 9:32 AM
  • Basically, MS RDC on MAC does't support RemtoeApp. Right now the only solution is using Spark View:

    http://www.remotespark.com/html5.html

    Spark View is a HTML5 solution which can run on all platforms, including iOS, Android, BlackBerry, Window 8 RT etc. The best is it's even faster than native RDP clients, it's absolutely faster than MS RDC on MAC.

    Walter (from Remote Spark)


    Monday, June 10, 2013 4:17 PM
  • Hi James,

    I ran into the same issue as well, the remoteapp worked fine on the Windows side but would load the desktop for the MACs.  I found that if you edit the .rdp session with the Mac .rdp client that you can find the Applications portion of the edit and put the path where the packaged program is: ex: c:\program files\ packaged programs.

    Now when you launch the .rdp session it will just open the app you want instead of load a desktop session.

    Hope this is what you were looking for.

    Thanks,
    Avocado

    This worked for me.  Thanks a lot.
    Thursday, September 12, 2013 9:55 AM
  • so has anyone got this to work on a mac when you are using a TS gateway? we have a gateway that points to 3 RemoteApp servers for load balancing.

    thanks,

    Buddy

    Friday, September 13, 2013 8:40 PM
  • Got the same question. The RDP client on the Windows machines have the option to start a remote program.

    You can find this under the Programs TAB. I can't find this option in the Mac client. Since I connect to a third party SaaS enviorement I can't control the server side.

    The Program option (see screeenshot) works fine with a PC and with the discontinued iTap application (RDP client). But I can't find the get this to work with the Mac RDP client.

     

    Monday, March 03, 2014 10:28 AM