none
network load balancing and remote desktop services with outlook

    Question

  • Here is my scenerio

    I have 2 virtual machines (hyperv) running RDS.

    They both have outlook 2010 loaded with all service packs/patches via windows update.

    The servers are 2008r2 fully patched.

    Our exchange server is exchange 2010 fully patched.

    I have both RDS servers in a windows NLB cluster running multicast.

    Outlook takes forever to open and sometimes you have to click retry for it to open. THis is a new installation with no users on the system. Fresh outlook profile.

    If i remove the NLB cluster or remove host from the cluster outlook opens almost instantly (like it is supposed to).

    I am out of ideas. I have checked autodiscover and that is fine. If i open up a /rpcdiag in outlook the connection times are really high but no errors

    Monday, June 25, 2012 6:46 PM

All replies

  • Hi,

    Thanks for your post.

    Given this situation, I would recommend that we follow the below detailed steps to setup NLB with terminal server and install outlook 2010.

    Network Load Balancing Step-by-Step Guide: Configuring Network Load Balancing with Terminal Services

    http://technet.microsoft.com/en-us/library/cc771300(v=ws.10).aspx

    How to enable Office Professional Plus 2010 to run on a terminal server

    http://support.microsoft.com/kb/983443

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    Friday, June 29, 2012 2:37 AM
  • Hi,

    Thanks for your post.

    Given this situation, I would recommend that we follow the below detailed steps to setup NLB with terminal server and install outlook 2010.

    Network Load Balancing Step-by-Step Guide: Configuring Network Load Balancing with Terminal Services

    http://technet.microsoft.com/en-us/library/cc771300(v=ws.10).aspx

    How to enable Office Professional Plus 2010 to run on a terminal server

    http://support.microsoft.com/kb/983443

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support


    So according to the article above, you are suppose to use Unicast? Is there any way to get this to work properly with Multicast? i am not using session broker...just straight  RDS and NLB. Everything appears to work fine however when i setup the NLB cluster the guest ip binds to the clustername and at that point once it has joined the cluster, opening outlook is slow and we get the retry button alot.
    Friday, June 29, 2012 2:13 PM
  • i have also tried putting the rds servers on their own nic (virtual switch), deleting and recreating the NLB cluster, updating the NIC drivers on the host machine, all of which produce the same results. No NLB outlook opens instantly.......ADD RDS servers to NLB and Outlook slows down or fails to open and gives the retry option (to which it finally will open).

    I have even loaded up 2 fresh RDS servers and office and gotten the same result. IM starting to wonder if it is a hardware issue of so type with these NICS or perhaps this server model.

    Friday, June 29, 2012 2:26 PM
  • i just moved/exported all the vms (exchange, ts, dns, etc) to a new freshly built hyperv server. Same result.

    Prior to doing this, i had setup a brand new ad, exchange and pair of NLB terminal servers and it worked just fine.

    IT is somthing to do with the configuration of exchange or NLB at this point. Not sure what it would be though.

    Im really running out of ideas.

    Wednesday, July 11, 2012 3:48 PM
  • well....

    I took the terminal server vms that were having an issue with NLB.....joined them to my test domain, re-ip'd them and tried setting up NLB  on them and connected to my test exchange server. Worked just fine like it is supposed to.

    Put them back in the original domain they way they were and they don't work with NLB enabled. one will respond fine and the other will show Avg Response times at 21041 which is extremely high.

    you get the retry box at least once opening outlook from this server. All other functions appear fine.

    The only thing I can see that is different between my test environment and this production environment is that the production has "require encryption" turned off due to outlook 2003 clients. I tried to turn this back on and got the same result.

    Also this behavior happens in both outlook 2003 and 2010 so I figured that wasn't it.

    So here is what I know

    my test environment works fine with NLB

    moving the offending TS machines over to my test environment, setting up nlb and connecting to my test exchange server works just fine

    It has nothing to do with the "require encryption" option in outlook as it is affected no matter which way it is set.

    what else can I try? I am out of ideas.

    This almost tells me that it is something with either EXCHANGE 2010 or AD in my current environment.

    Its the damnest thing.

    ts01 works

    ts02 works

    NLB both servers and 1 will open outlook just fine...the other will be really slow and you have to hit retry at least once.

    Everything here is in HyperV and virtual

    I have never seen this before and I have setup quite a few like this using NLB

    Wednesday, July 11, 2012 7:48 PM
  • well li have found out a bit more.

    If i remove the ipv6 address of the exchange server from DNS and then go to my RDS servers and flushdns, both servers work and respond as i would expect using NLB.

    As soon as the exchange server registers its ipv6 address with DNS, the RDS servers start to act up and outlook performs poorly again.  I tried removing and reinstalling the nic in the exchange server. This did not work.

    I can go into the advanced properties of the nic and choose not to register the connection with dns but that also disables ipv4 from registering in dns. Obviously i want my server to register with the DNS server.

    Anyone have any ideas? IM positive that i want to leave ipv6 enabled as it creates problems with exchange 2010 when you remove it via the registry. (i assume it does. IT is needed for installation so i assume you need it and not to remove it).

    Thursday, July 12, 2012 6:39 PM