none
Windows Key "stuck"

    Question

  • Periodically, the RDP 6.0 client seems to think that the Windows key is being pressed (outside of the RDP, it is not; rebooting the host doesn't fix).  At least one other person has experienced this: MS Terminal Services blog.  As noted there, pressing the Windows key a few times fixes it for a while.  Anyone know of a real solution or if this is known by MS?

    Thanks

    Monday, December 18, 2006 10:51 PM

Answers

  • If you are using Win Key + L to lock your desktop, this is a known issue.  We have completed work on a fix that should prevent the problem in the future; to my knowledge it is due to be released with Vista SP1.

    The bug arises most frequently when you use Win+L to lock your desktop while the Remote Desktop window has focus.  It is caused by a synchronization issue between client and server that only arises on a subset of machines, possibly due to a driver or 3rd party software conflict that messes up the timing of the Remote Desktop client.  There are a few ways to avoid this:

    1. Don't use Win+L to lock your local desktop.  Either lock your machine through the start menu or, if your machine is configured for it, Ctrl-Alt-Del and select Lock Desktop.

    2. Make sure a different window has focus before locking your desktop.

    If you have already encountered the problem, the "workaround" is much as you described:

    1. Remove focus from the Remote Desktop window, by selecting another window on your machine, or minimizing and clicking the desktop of the local machine

    2. Strike the Ctrl key 6-12 times. You mentioned the win key which probably works as well, but if you have somehow encountered this error on a machine that doesn't have a Win key, Ctrl should work as well.

    3. Go back to the Remote Desktop window; the problem should be resolved.

    If any of you are *not* using Win-L to lock your desktop, please speak up.  The fix we have in place actually addresses two different aspects of the fault, one specific to Win-L locking, and another related to general synchronization, so it should fix the problem regardless, but I'd like to know if this issue is occurring by other means.

    Thursday, January 25, 2007 11:40 PM

All replies

  • I'm having the same problem. I replaced my keyboard today, to no avail. Any help is appreciated.
    Friday, December 29, 2006 6:39 PM
  • This happens to me as well, as well as a few of my co-workers. Very frustrating. Tapping the Windows key isn't an option because IBM Thinkpads don't have them. I've seen alot of posts about this issue on various forums from users experiencing it, but no solutions or workarounds.
    Thursday, January 18, 2007 5:09 PM
  • I'm having the same problem!!!

    I need help also.<

    Thanx

    Tuesday, January 23, 2007 8:39 PM
  • If you are using Win Key + L to lock your desktop, this is a known issue.  We have completed work on a fix that should prevent the problem in the future; to my knowledge it is due to be released with Vista SP1.

    The bug arises most frequently when you use Win+L to lock your desktop while the Remote Desktop window has focus.  It is caused by a synchronization issue between client and server that only arises on a subset of machines, possibly due to a driver or 3rd party software conflict that messes up the timing of the Remote Desktop client.  There are a few ways to avoid this:

    1. Don't use Win+L to lock your local desktop.  Either lock your machine through the start menu or, if your machine is configured for it, Ctrl-Alt-Del and select Lock Desktop.

    2. Make sure a different window has focus before locking your desktop.

    If you have already encountered the problem, the "workaround" is much as you described:

    1. Remove focus from the Remote Desktop window, by selecting another window on your machine, or minimizing and clicking the desktop of the local machine

    2. Strike the Ctrl key 6-12 times. You mentioned the win key which probably works as well, but if you have somehow encountered this error on a machine that doesn't have a Win key, Ctrl should work as well.

    3. Go back to the Remote Desktop window; the problem should be resolved.

    If any of you are *not* using Win-L to lock your desktop, please speak up.  The fix we have in place actually addresses two different aspects of the fault, one specific to Win-L locking, and another related to general synchronization, so it should fix the problem regardless, but I'd like to know if this issue is occurring by other means.

    Thursday, January 25, 2007 11:40 PM
  • You asked for information on this situation not related to Win-L.  I have never used Win-L to lock my machines.  I encountered this problem earlier today when connected from my home to my office using two identical machines running XP Pro.  While using Remote Desktop, the office machine suddenly started acting as if the Windows key were depressed.  Rebooting, disconnecting and reconnecting, etc., several times didn't help.  After reading this forum, I disconnected from the office machine and simply pressed the Windows key on the home machine multiple times.  When I reconnected, the problem was fixed. I appreciate the information.
    Friday, February 02, 2007 10:32 PM
  • I do use WIN+L to lock my machine but the workaround described does not seem to resolve the issue.  I am using an XP SP2 machine with mstsc.exe version 6.0.6000.16386 to connect to a W2K3 EE server.

    Any suggestions?
    Wednesday, February 07, 2007 8:20 PM
  • Thanks for the info, Josh.  I'm curious why this wasn't listed at the KB or if I just missed it.  Avoiding Win-L does seem to help (it's so instinctive and I often have the other RDP open, so I can't be completely sure, but when I've paid attention there seems to be a direct correlation--with Win-L and the RDP open, the problem occurs and without both it doesn't).  And, as I found elsewhere, the Win key corrects it for me; and I've actually been doing it from within the RDP.  FYI, for whatever it might be worth, my host machine is a laptop and the client is 64-bit, both running XP Pro (prefer the 64-bit and it has the better graphics but I RDP into the laptop for Novell and a few other incompatibles).

    Again, thanks.
    Thursday, February 08, 2007 7:27 PM
  • Hi,

    Experienced this issue today.  Here is my scenario:

    Logged on to remote system from a desktop with a Windows Key keyboard.  Locked screen with Win-L (I now know that is bad).  Then connected to the remote desktop from a Thinkpad with no Windows Key.  Was unable to turn off the locked Windows keys from the Thinkpad using any of the techniques above or some other things.  I finally plugged a USB keyboard into the Thinkpad with a Windows Key and was able to toggle it off in the RDP session.

    Tuesday, February 27, 2007 7:15 PM
  • I had this problem today and found this thread on it.  I'm using Remote Desktop, and have Win XP Pro on the local and the remote.  I do use Windows-L to lock my local PC.  However, I've been using Remote Desktop from the same PC to the same remote PC every day for months, and only today did I get this problem.  For what it's worth, I'm also using Synergy (keyboard/mouse sharing software between PCs), but again, this hasn't caused a problem till today.

    Repeatedly tapping the Windows key or the Control key didn't fix anything.  Nor did rebooting the local PC.

    Eventually, rebooting the remote PC resolved the problem (at least for the moment).  I don't know that rebooting the remote PC is an option for everybody, but it's worth a shot if you're free to do it.

    (The "Windows Security" option on the Start menu gave me access to the Task Manager, and I was able to reboot the remote machine from there.)
    Wednesday, February 28, 2007 6:38 PM
  • We are experiencing this issue on WYSE Terminals logging into Windows Server 2003 using RDP.

    The "press the Ctrl or Alt or Windows" Key a few times works well, but it would be nice to have a more permanent fix for this problem.

     

    Friday, March 09, 2007 3:05 AM
  • Solution for me was simple;

    1: Open 'on screen' keyboard which is in the accessories/accessibility menu.

    2: Press the 'on screen windows key'.

    Problem solved.

    • Proposed as answer by Dextacy Wednesday, July 01, 2009 10:44 AM
    Tuesday, March 20, 2007 5:15 PM
  • A bunch of us at work just started having this problem, and I haven't found anything that fixes it even temporarily.

    Anyone got a REAL solution?  We use RDP pretty extensively here, and this problem is killing our productivity.  VNC works just fine, but it's SLOW, and it's another layer to have running.

    Anyone?
    Tuesday, March 20, 2007 10:56 PM
  • Any chance this will improve the situation?

     

    http://support.microsoft.com/kb/925876

     

    -Jack

    Monday, April 02, 2007 4:13 PM
  • Any chance KB925876 (released today, April 2) addresses either of the issues?  Or is this just a belated April Fool's joke?
    Monday, April 02, 2007 4:16 PM
  • So there is the normal solution. The same problem.  This impression Vista does not support.
    Wednesday, April 11, 2007 5:17 AM
  • I work in a large enterprise - we just deployed RDP 6.0 a few weeks ago.  We have had several users report a stuck windows key (several users = 30 or so) when RDP'ed into a PC, but not a server - so far.  Non of them use the Win+L to lock their PC's.  Tapping the windows key seems to work, also messing with the keyboard setting under local resources (in RDP) seems to give temporary relief.  It's normally set to In full screen only mode, but if they set it to one of the other 2 options, it will fix it. 

     

    Then....something interesting happened.  I hardly ever use RDP but RDP'd into on of their PC's to see if I could recreate the problem.  I did temporarily, but it then went away.  I went to lunch and when I came back from lunch, the windows key seemed to be stuck on my PC!  I was not RDP'd into anything, RDP wasn't even open.  If I hit "R", the run line would pop up, etc.  After I hit the windows key several times, the condition went away.  (btw, I use Win+L to lock my laptop)

     

    Just wanted to make you aware of this new symptom.  Anyone else experience something similar?

     

     

    Wednesday, April 18, 2007 7:27 PM
  • Frank, that worked for me when I did that in the remote desktop session.  The "l" key no longer behaves like it does as if the Windows key were pressed.  Thanks for the tip.
    Wednesday, April 25, 2007 12:36 PM
  • No KB925876 does not address the Windows key stuck issue. This KB simply makes Remoce DEsktop Connection 6.0 available for WS03 SP2 as well.
    Monday, April 30, 2007 12:36 AM
  • If the Windows key got stuck on a machine which was not RDP-ed into, that has nothing to do with RDP.  The fault in the RDP client can only affect the remote machine.  It is possible for the key to get stuck during a remote session, and remain stuck if the session is subsequently logged into locally, but that is it.

    Monday, April 30, 2007 5:52 PM
  • KBMN, have you tried any of the numerous workarounds posted?  There will be a fix for these problems in Vista SP1, and a matching downlevel release of the client for WinXP and Server 2003.  In the mean time, the workarounds mentioned are the only option.
    • Proposed as answer by Adrian Raduti Thursday, March 18, 2010 9:16 AM
    Monday, April 30, 2007 6:03 PM
  • Hi,

    I've just upgraded to Vista am now having this problem with the winkey.  I've tried rebotting both PCs and haven't gone near winkey L.  I tried the on screen keyboard which allows me to enter two letters and then it starts misbehaving again.

    When I was using XP a few weeks ago I never had this problem.

    Any other solutions to this because it is becoming very frustrating having to use notepaf to type first and then paste into the remote desktop!

    Thanks

    Dan
    Monday, May 21, 2007 9:57 AM
  • I am not using RDP, but this happens in XP Pro on some computers but not on others. In my situation it happens with Dell keyboards on a Dell computer, but only if I plug the USB in the back of the computer. If I use the front ports the problem goes away, when I use another brand keyboard the problem goes away as well.

     

    Since I'm seeing a lot of RDP related issues I thought I might add to the overall problem symptoms, it might be related to RDP but in that case the same symptoms also appear on normal computers.

    Wednesday, May 23, 2007 2:39 PM
  • SP1?  Pretty major item to let slide.
    Thursday, May 24, 2007 12:47 AM
  • I don't use Win-L to lock the desktop and I've been having all kinds of problems like this - all new to RDC 6.0.  I am typically running RDC on a WinXPSP2 machine and connecting to a WinXP-64SP1 machine. 

     

    Please, please tell me of some magic that I can do prevent this from occuring.

    Thursday, May 24, 2007 9:02 PM
  • This happens to me all the time. I do use Win-L to lock my machine (it's very convenient) and  most of the time, when I return to my machine, the Windows key is stuck on. This appears to have nothing to do with RDP because it happens whether I'm connected to a host or not. I am able to get it to stop by hitting the Windows key a bunch of times. It's not a MAJOR problem but it happens several times a day and gets pretty annoying.
    Monday, June 25, 2007 3:05 PM
  • So, Microsoft, when is the fix coming?  We've lost productivity on this issue for months.
    Tuesday, July 17, 2007 12:59 PM
  • Same happens to me when I use MS Virtual PC 2007 on my Vista machine.
    If I press Win + L when VPC window is active it still locks my main machine, yet after I unlock it the Win key is stuck.

    Creo

    Monday, July 30, 2007 9:33 PM
  •  

    I still have not sound a fix for this..  Is there one available yet?  Since the problem sticks around until reboot, this is causing a big head ach on servers we can not reboot until after hours.
    Tuesday, August 14, 2007 2:54 PM
  • Franks suggestion worked for me. Thanks Frank!

    Friday, August 24, 2007 8:38 PM
  • This link offers programs to disable or enable the Windows Key.

    I tried the left Windows Key disable and enable programs and they work.

    http://johnhaller.com/jh/useful_stuff/disable_windows_key/

     

    My situation is a Dell 6800 with XP Home recently upgraded to SP2 in the last 30 days mysteriously developed the same systems described in the threads to this form. The behavior manifested itself just in the last 3 days. 

     

    The behavior was as though the Windows Key was Locked in the active state like the CAPS KEY controls the keyboard keys' functional modes.

    • When Windows was running Normal/SafeMode, all Microsoft Key shortcuts were active, making typing on the keyboard a very slow process. I could work around it clumsely by hitting the CAPS LOCK key and holding down the shift key while typing. This seemed to disable the shortcuts.  
    • With Windows OS not running, the symptoms did not happen.
    • Given the symptoms when the problem is occuring, and he behavior of the programs located at the above link, my hypothesis is some outside agent changed the Microsoft Key software settings in the Registry to be locked in the ACTIVE state.
    • Does this hypothesis make sense?
    • If it does, is there a process for repairing the Registry that controls the internal keyboard response?
    • There is upside that the programs at the above links may help moving forward to find the root cause. They would have to be tried
    • Comments?

    /dkmorgan

    /dave

    Tuesday, September 11, 2007 8:45 PM
  • This thread is probably dead by now, but, I've just recently updated to the RDP6 client (via the MS Update site) on a couple of XP machines, and now I encounter the "stuck windows key" issue.  If the local machine does have a windows key, I can get out of being stuck, but on local machines that don't have a windows key, the CTRL approach (remote or local) doesn't help, nor does the virtual keyboard.  Is this an issue that is still being looked into, or am I just going to have to reboot the remote machine everytime it sticks?


    Tuesday, September 18, 2007 3:48 PM
  • i noticed this as well. it happened after the RDC update. it's happening to me daily now on all my machines.

     

    there needs to be a hotfix or something provided by microsoft. the windows key isn't used in RDC anyway (is it?)

     

    can a fix be made for RDC sessions to disable the windows key? i am not sure if a script can be assigned to run (like a .reg import for that disable windows key thing) but then needs to be undone on a local login... i use the windows key to lock my machines. although, i guess if it was disabled, i could go force myself to back to doing control-alt-delete all the time.

     

    anyway updating something should not wind up making it harder to use. this is pretty weak. i'm so glad it's a verified issue and i'm not insane...

     

    Wednesday, September 19, 2007 7:35 PM
  • I can also confirm this same exact problem when using Virtual PC 2007.
    Thursday, September 20, 2007 3:43 AM
  • I was having trouble with my Control key being stuck while using Synergy to control two computers with one mouse/keyboard. I found an answer from http://answers.google.com/answers/threadview?id=729744 ::
    Try pressing both the left and right CTRL keys at the same time and
    see if that releases CTRL.


    This worked for me. Hope it helps.

    Monday, September 24, 2007 7:56 PM
  •  

    So is the idea that we only need to do Frank's workaround ONCE ever? Or every time after locking a machine?

     

    I'm finding that I only get the "stuck windows key" when I have an RDP session open from the locked machine to another one.  In other words in the evening, when the PC locks itself after not being in use for a while, and I unlock it to carry on surfing...  then the windows key isn't stuck.

    Tuesday, October 09, 2007 3:45 PM
  • The problem seem that windows is not recieve the keyup command from the keyboard or believe that windows logo key is depress even if none exists.  I believe Ctfmon.exe controls this and runs in the background. You can disable Windows logo key using this article MSKB 216893.  Hope this help.

    Wednesday, October 10, 2007 11:08 PM
  • Opening the On-Screen Keyboard and pressing the windows key on the remote system worked for me.

    Thursday, October 11, 2007 10:13 PM

  • You're great dude! My prob solved!  tnx. Smile
    Sunday, October 14, 2007 4:33 PM
  •  

    With all due respect this and other suggestions are WORKAROUNDS, right?  The one I currently use is to tap the windows key a couple of time, that works, and I've also tried disabling the Windows key (left Win key) entirely.

     

     

    When will the problem be fixed by Microsoft?  Do we have to wait for Vista SP 1, and/or Win XP SP 3?

    Thursday, October 25, 2007 5:36 PM
  • I think the fact that we are almost a year past the first opening post and there is not even a technet article is sufficient enough to show you how much they care about this problem.

     

    They don't.

    Thursday, October 25, 2007 5:43 PM
  • *Symptom*
    Log into server with mstsc, hit windows L and it locks your local computer. Unlock your local computer and close mstsc using the x on the yellow bar. Log back into the server and the windows key is stuck. Simply press the L key on the server and your server session is locked.

    *SOLVED*
    Under mstsc hit options and file to your Local Resources tab. Under keyboard where it states "Apply Windows key combinations" select "On the local computer" instead of "In full screen mode only".


    Can people post there results please, as we have not rolled this out into production yet.

    Thursday, November 08, 2007 4:25 PM

  • The "apply windows key combinations" did not solve the problem for me. I can "release" the winkey using the screen-keyboard, but the problem keeps reappearing.
    Thursday, December 06, 2007 12:34 PM
  • This is happening to me as well on Vista x64 and VirtualPC 2007.  The bad news is that I have the SP1 preview installed and the bug is still there.  Hmm, the first post in this thread is nearly a year old and we're still dealing with this problem?  How rediculous!!  I real fix instead of a workaround would be nice.

    Wednesday, December 19, 2007 3:02 PM
  • Just thought I'd drop a line and thank you for your solution.  It worked for me.  I tried the other solutions of tapping either the Ctlr or the Win key multiple times to no avail.
    Friday, December 28, 2007 5:07 AM
  • Josh, you asked for comments from non-Win-L users -- that's me. This thread has been going a long time now but I've only experienced the "stuck win key" thing recently and was really puzzled until I found this discussion. However, I've never used Win-L and the problem occurred across a variety of unrelated applications.

    I think in my case it happened because I triggered the Sticky key feature by banging the shift (or maybe some other key) rapidly 5+ times for some reason (probably related to some other frustration <g>). True, there is a confirmation dialog re. enabling Sticky keys but it is easy to accept this when atention is on the keyboard instead of the screen and Enter is pressed.

    You probably know that Sticky keys (among other things) converts the Win key action to a toggle so voila! -- suddenly l = lock, r = run, u = utilman, d = desktop, etc...

    The temporary solution is to toggle Winkey off, or permanent solution is to turn Sticky keys off via the Accessibility settings or some other way.

    Hope this helps other frusrated users who have been banging their Shift keys 5+ times.

     

     

     

    Thursday, January 03, 2008 11:26 AM
  •  Josh Rosenberg - MSFT wrote:

    If you are using Win Key + L to lock your desktop, this is a known issue.  We have completed work on a fix that should prevent the problem in the future; to my knowledge it is due to be released with Vista SP1.

    The bug arises most frequently when you use Win+L to lock your desktop while the Remote Desktop window has focus.  It is caused by a synchronization issue between client and server that only arises on a subset of machines, possibly due to a driver or 3rd party software conflict that messes up the timing of the Remote Desktop client.  There are a few ways to avoid this:

    1. Don't use Win+L to lock your local desktop.  Either lock your machine through the start menu or, if your machine is configured for it, Ctrl-Alt-Del and select Lock Desktop.

    2. Make sure a different window has focus before locking your desktop.

    If you have already encountered the problem, the "workaround" is much as you described:

    1. Remove focus from the Remote Desktop window, by selecting another window on your machine, or minimizing and clicking the desktop of the local machine

    2. Strike the Ctrl key 6-12 times. You mentioned the win key which probably works as well, but if you have somehow encountered this error on a machine that doesn't have a Win key, Ctrl should work as well.

    3. Go back to the Remote Desktop window; the problem should be resolved.

    If any of you are *not* using Win-L to lock your desktop, please speak up.  The fix we have in place actually addresses two different aspects of the fault, one specific to Win-L locking, and another related to general synchronization, so it should fix the problem regardless, but I'd like to know if this issue is occurring by other means.



    Thanks so much. This was a great annoyance for me. Hitting the Windows key 6-12 times worked like a charm!

    Again, Thanks!!

    Scott
    Friday, January 11, 2008 2:12 PM
  • This is pretty lame that the behavior changed.

     

    It wasn't like this before, I think (for XP) it was the newer version of the RDC client or something. It happened to start right around then.

     

    Please issue a fix for this that includes XP. I've disabled the windows keys on some machines but then I lose out on other functionality, and it's pretty stupid to have a feature like Winkey-L shortcuts designed to make life easier and then tell people "don't use it" without some sort of fix. I don't think it can be -that- hard, just have something inside of an RDC session to detect the Windows key being stuck or something. Microsoft -made- the clients and servers, so you guys can do something to make it run differently too..

     

    Thanks Smile

     

    Friday, January 11, 2008 9:01 PM
  •  

    None of these solutions have worked for me yet.  Hopefully Microsoft will fix this issue in XP SP3.  Its been a real pain for me since my username contains a D a few Es and an L and I can't take it anymore. Just trying to log into remote hosts I end up with the Desktop a bunch of Windows Explorer windows and the screen locking on me before I can even connect to a host...Really annoying.  And people acting like the cause of the problem is you hitting Win-L key.  It's not and we didn't. We just hit the L key and for some reason while in mstsc it acts as if the windows key has been pressed too and ends up opening the Deskop and shrinking all your open programs (win-D function), or locking the local host (win-L function)  or opening Explorer windows (the.win-E function) 

     

    Please Mr Gates get your boys on this will ya.

     

    Friday, January 18, 2008 5:08 AM
  • Josh,

     

    I think you're confused as to what is really happening. We aren't really hitting Win-L to lock the system. We are in fact just in the middle of logging onto another client, or simply typing something and we use the letter "L", "D", "E" ,"R", or "U" and it detects the WIN combination of these characters as if we had actually hit the Windows key in combination with these characters. As if the Windows key is stuck. 

     

    Clicking the Windows key a few time does temporarily stop this behavior but this is an annoying work-a-round.

     

    Has anyone discovered an actual fix.  I've tried all of the suggestions in this thread and still getting the same behaviour intermittently.  I believe I didn't start having this problem until after the RDP update was installed.. I spend my days remoted into several XP, and Vista clients as well as Windows NT & 2003 servers. The local client that I use for most of these connections is an XP pro client.  Absolutely no problems connecting to remote Mac clients from my Mac.

     

    Please say there's a real fix finally! 

    Friday, January 18, 2008 5:23 AM
  • Hi there

     

    I am getting the same issues that folks are describing in this thread, but with the Alt key, not the Windows key.

    I can be in the middle of a Word document or email and then typing letters has the same effect as holding the Alt key and typing the same letter. For example, pressing the S key in an email this morning sent the email because Windows Mail interpreted an Alt-S.

    I am on Vista. It is not a hardware issue, as I have ran through all the checks with Dell.

    It doesn't do it all the time, it does it once in a while which makes it a hard problem to solve.

    Pressing the Alt key twice seems to work for me but it doesn't solve the problem.

    Any ideas out there?

     

    Steve

     

    Sunday, January 20, 2008 12:26 PM
  • Still no ideas for this one?

    Friday, February 01, 2008 12:29 PM
  •  Oncealpha wrote:

    Hi there

     

    I am getting the same issues that folks are describing in this thread, but with the Alt key, not the Windows key.

    I can be in the middle of a Word document or email and then typing letters has the same effect as holding the Alt key and typing the same letter. For example, pressing the S key in an email this morning sent the email because Windows Mail interpreted an Alt-S.

    I am on Vista. It is not a hardware issue, as I have ran through all the checks with Dell.

    It doesn't do it all the time, it does it once in a while which makes it a hard problem to solve.

    Pressing the Alt key twice seems to work for me but it doesn't solve the problem.

    Any ideas out there?

     

    Steve

     



    Sadly no. I'm a programmer, and I program exclusively via RDP. I've been "living" with this problem for about a year now. It's incredibly frustrating. I usually see the shift key being stuck.
    Wednesday, February 27, 2008 3:54 PM
  • I've been having this as well with the Windows Key getting stuck over the last few months.  It's starting to get REALLY annoying.  Please Microsoft, fix this ASAP! 

    Wednesday, February 27, 2008 7:27 PM
  • Hi,

    We have tried getting this issue to repro. However it seems to only happen in certain situations and perhaps with specific hardware?

     

    Josh explained once of the specific scenarios that we have fixed in Vista SP1.

    If you are being impacted in other scenarios, your best bet for getting this fixed would be to contact Microsoft Product Support Services to actually reproduce the problem so that it can be investigated systematically. 

     

    Thanks for your help with this issue.

    Friday, February 29, 2008 3:23 AM
  • Ayesha:

     

    I got to:  http://support.microsoft.com/default.aspx?scid=/support/contact/default.asp

     

    I click on Submit an Incident Online and it gives me a 404.  Can you please provide me the link to submit this problem online?  Thanks.

    Tuesday, March 25, 2008 1:41 PM
  • This looks like an old thread, I'll just put this out there:

    I also get the stuck modifier key every now and then. Sometimes it's the Super (Win) key, sometimes Ctrl, and sometimes Alt. I haven't seen anyone else mention this case: I'm using Linux and rdesktop to login to a Windows Terminal Server.

    I'm logging in from a Linux machine (Scientific Linux 5) to Windows 2003 Enterprise Edition. I've also seen the same bug when logging into my Windows XP Pro home computer.
    Thursday, April 24, 2008 9:50 PM
  •  

    I don't use the Windows key + L combination to lock the computer while using RDP but I have been frustrated daily by this issue on every Windows XP computer I sit at in this company.

     

    Is a fix planned for XP Pro?  

    Friday, April 25, 2008 5:03 PM
  • This is getting frustrating.

    Me and my colleagues are administrating a large number of Windows servers via RDP - I have the "locked win key" issue constantly - whenever I lock my workstation and unlock it again.

    Why on earth has this not been resolved yet - or should we simply rely on 3. party software for remote administration rather than RDP - or leave our workstation logged in when we leave them ?!?

    I could understand classifying this as a low-priority issue if this was some seldom used component - but it's RDP for Christ sake !

    Setup:

    Windows XP Pro with SP3 and latest Remote Desktop Client.
    • Edited by Callesen Tuesday, June 17, 2008 8:48 AM Added setup info.
    Tuesday, June 17, 2008 8:46 AM
  • Hi,

    Just to clarify the situation, you have XP SP3 on your client machine, which has the latest RDP Client, correct?  What Server are you connecting to when you have the problem?

    Also, you have this issue all the time when you press 'WIN+L'?  do you also have this problem if you press CTRL-ALT-DEL then select 'Lock this computer'?

    This might sound like a strange question, but what video driver to you have installed? 

    Thanks,
    Drew

    Tuesday, June 17, 2008 5:55 PM
  • I have the same problem, this is very annoying trouble, we would like to have a fix and not just way to skip the problem.
    Thanks
    Thursday, July 03, 2008 5:04 PM
  • Drew,

    I just got this error after logging back into my pc from last night.  I am running vista x64 sp1.  Last night I had an XP sp3 vpc up (Virtual PC version 6.0.192.0).  I closed it, saved state, merged drive changes.  I probably hit win+l to lock my pc while the merging was going on - I can't remember exactly. 

    Also, I was using remote desktop on the xp vpc to remote in to my vista x64 sp1 workstation at the office.  It may have nothing to do with the problem, but it involved vpc and rdp so I who knows.

    My video card is an ati 3650 - catalyst drivers are at version: 2008.0602.2243.38732.  My remote desktop is at version 6.0.6001.     I'll try and repro this later and respond back.
    Friday, July 25, 2008 1:02 AM
  • I was able to reproduce the problem in Vista x64 SP1 with Virtual PC 2007 sp1 - running XP sp3.  Hitting Win+L to lock the Vista pc made the windows key stick.  I guess the patch did not make it into SP1.

    The work around did work.
    Friday, July 25, 2008 1:51 AM
  • The best workaround that always works for me is:

    1. Close the RD window
    2. Open new RD but make sure the "Apply Windows key Combinations" is set to "On the remote computer"
    3. Now press the Ctrl+Alt+End and lock the computer
    4. Log in again and it should work.

    amirhp
    /'L'\mir
    Sunday, August 10, 2008 3:12 PM
  • For what its worth, I'm having this problem today (aug 13, 2008).
    I've got a WinXP x32 machine (SP2), running Synergy 1.3.1 to share my keyboard/mouse as host.
    The client for Synergy 1.3.1 is a WinXP x64 machine (SP2).

    Using MSFT-L to lock the screen.  Pressing MSFT key multple times gets the client 'unstuck'.  I cannot have the focus OFF of the client, because I need to lock that machine.  So I'll try using ctrl-alt-del (or the ctrl-alt-brk equivalent in synergy) and see if that resolves my problem.
    Wednesday, August 13, 2008 7:32 PM
  • I'm still getting the Windows-Key stuck symptom.

    Vista Business SP1, fully up to date. Very standard system.
    LogMeIn free, latest.

    1. Logged into a remote system (XP SP2), I press Windows-L. This locks the screen on both the remote and the local system.

    2. Logon to local system. From now on, keyboard behaves as tho the Windows key is being held down; until...

    3. Tap Windows key twice (I always do it quite rapidly, don't know it that is necessary) always fixes it. Reboot always fixed too it on the few times I tried that.

    The apparent sticking of the Windows key happens EVERY time I use the above steps.
    • Edited by Kookaburra2 Tuesday, August 26, 2008 11:36 PM more info
    Thursday, August 21, 2008 2:58 AM
  • I am having a similar issue, running Vista 32 Business SP1, fully updated. I use Win+L to lock my computer, but the last couple of days its my left arrow key that is getting "stuck"


    Any solutions yet?



    Thanks.
    Tuesday, August 26, 2008 2:14 PM
  • I'm not aware of any solutions. Workaround for me: the Windows key unsticks when I tap it a few times.
    Tuesday, August 26, 2008 11:34 PM
  • For me its the left arrow key. I tried tapping it a bunch and that didn't unstick it. 
    Tuesday, August 26, 2008 11:41 PM
  • Hello,

    in our company we have Windows2000 SP4 clients which connect to Servers running Windows Server 2003 SP2 and Citrix Presentation Server 4.5 using Citrix ICA Client 9.230. There are about 300 potential users and there are about 2-3 cases per week. Our temporary solution is to logoff from the terminal server and log on again. And of course we could not find out what the user did before this happens.

    It seems that this behaviour is not only related to RDP6.0.....

    Any news regarding this issue?

    br, Gregor.
    • Edited by Budgreg Friday, September 05, 2008 3:33 PM typo
    Friday, September 05, 2008 3:32 PM
  • I too am running across this issue.

    Windows 2003 SP2 R2 servers. Some physical some VMWare boxes.

    I had this issue on a Windows XP Laptop and now my Vista Business Edition Laptop. I do use Win+L. I'm a network administrator asking me not to is like asking me to give up a finger.

    I'm in and out of remote desktop constantly. The issue comes up most when Remote Desktop software is up at the login screen. I don' have to have an active session. PLEASE FIX IT before I go insane!
    Tuesday, October 07, 2008 6:46 PM
  • The best workaround that always works for me is:

    1. Close the RD window
    2. Open new RD but make sure the "Apply Windows key Combinations" is set to "On the remote computer"
    3. Now press the Ctrl+Alt+End and lock the computer
    4. Log in again and it should work.

    This is what's suggested by Amirhp thanks Amir for that ... it works really well.

    I've just tried Ctrl+Alt+End on Remote and then unlock the computer again it worked for me ....

    Tuesday, October 14, 2008 12:30 PM
  • This worked for me... Thanks.
    Wednesday, October 29, 2008 3:36 PM
  • I work in tech support at a business that supports well over 1,000 users.  Many of which use RDP constantly and are seeing this issue pop up ever since we "upgraded" to RDP 6.  All PC's and Laptops use XP Pro.  I see a fix was suppose to be issued for XP SP3, and we have since upgraded all computers to SP3.  But we have not seen a decline in tickets produced having to do with this windows key being stuck issue.  For users that have a windows key we just have them hit the key several times for a workaround.  We also have users with IBM Thinkpad T42's and T43's which don't have windows keys, for them unfortunately we have them reboot the vm, which can take a bit and cut into productivity quite a bit.  I see this has been an issue for almost 2 YEARS...how is that possible?  I can see it being a low priority, but even low priority incidents should be escalated every so often, and certainly never be open for 2 years.  I see Drew was wanting to know what video card driver was being used, we use Intel Q965/Q963 Express Chipset Family on our desktops; which by the way is digitally signed by Microsoft Windows Hardware Compatibility Publisher.  For our T42 and T43 laptops we use ATI Mobility Radeon 7500, which is also digitally signed by Microsoft Windows Hardware Compatibility Publisher.  As for what the users are doing to actually have the issue pop up, they usually are locking their workstation, whether it's by using Windows+L or ctrl+alt+del it does not matter.  An actual fix would be appreciated, we know all the workarounds and use them already.

    Monday, November 10, 2008 5:23 PM
  • This thread might be dead but our Company is experiencing this problem. We use Windows Server 2003 and run a Terminal server for "Thin Clients" i started seeing this sticking key a while ago and went to investigate it but in the end we moved the user onto a desktop, then it arose for a different user for a while it seems that the problem is the terminal server might see the "windows key" being pressed when in fact its not i have tested it and all the keyboard shortcuts for the Windows key work without pressing the win key so i tested the Thin clients and then the keyboards and worked thought trouble shooting until i figured it must be the Terminal Server which has a program fault somewhere or a program that's open is causing this anomaly after a few restarts the problem disappears for that user but then it moves onto another user after some time we have got our 3 IT officers looking into problems that could cause it in their spare time but we have all come out with nothing except that it  may be a program error in Terminal Server any suggestions or help to fix it would be appreciated

    Just thought i would add my users don't lock their computers using Win-L
    Wednesday, November 26, 2008 11:29 PM
  • I use RDP on Vista x64, connecting to XP pro, but only rarely experience the sticky logo key while doing it.
    But several times each day I experience sticky logo key while writing e.g. emails on my Vista. It may happen at any time. E.g. after 50 characters, so the problem is definitely not related to opening or closing applications.
    By the way - Using 10 finger writing actually throw a lot of sh!t on the screen when logo key get stucked. Sometimes I accidently start up applications before a stop message arrive at my fingertips ;-P
    So I really look forward to the year? where we see a solution.

    By the way
    - I have tested with both a PS2 (Microsoft Natural Keyboard Elite) and a USB keyboard (HP standard)
    - The labtop was running fine on W2000 with the above keyboards. The sticky Logo key problem occured one of the first days after update to Vista x64.
    - Last time I saw the problem was at 3rd character in the password during login to this site :-~


    Thanks
    Thursday, November 27, 2008 8:15 AM
  • I get the control key stuck about once a week.  Im doing something like I was video editing tonight and BAM the control key was stuck on and I didnt even press it.  The only thing that works to unstick it is a complete reboot of the PC.  Im Using XP Media Center 2004 SP3.

    Monday, December 15, 2008 8:11 AM
  • Hi Josh,

    2 years ago you wrote "The fix we have in place...". I am not sure I fully understand if you knew about a real solution that was comming up, or you just referred to the bug work arounds you listed. If you (or anyone else) know about a "real solution" like thread starter Joel MW asked for. PLEASE LET THE COMMUNITY KNOW ABOUT IT.

    Thanks
    Thursday, January 15, 2009 2:10 PM
  • I've just discovered this problem on Vista SP1 running VMWare 2.0!

    Saw this thread and I (as someone who thought he'd seen everything when it comes to Microsoft's incompetence and had become completely de-sensitised to it over the years) was so stunned that this issue is still not resolved after what, 2 years? that I had to break my own rule and post a flame up about it! Wow, this is really impressive, MS, even for you guys.

    The ironic thing is, I only installed VMWare and created an XP image to get round some issues I was having with various Vista incompatibilities. I was mightily impressed by VMWare and how well my XP image was performing, until I realised it was causing, er, yet another Vista issue... figures...

    Hitting the Windows key at least once does seem to resolve it in my case though.

    Friday, February 06, 2009 5:30 PM
  • I was having the same windows key stuck problem. Which led me to this site. One workaround that has worked for me, was to:

    1) ctrl-alt-del after logging into your rdp.
    2) lock the computer
    3) unlock it
    4) problem should be fixed...
    Friday, March 27, 2009 6:10 AM
  • I have a similar issue whereby the guest machine (running Win 2008 Server) simply does not react when Ctrl + Alt + End is selected, and, this issue has occurred all of a sudden on a saved machine.  I usually use Ctrl + Alt + Del to lock the host (running Win 2008 Server), and, log on directly to the machine (i.e. no RDP) from the keyboard and mouse attached to them.

    Any ideas?
    Tuesday, May 05, 2009 6:46 PM
  • It is sad - 3½ years without a real solution :-(
    Anyone in here that knows how to get the attention of mr. Gates?

    In general I use the Logo key a lot, so I hate to use the "Ctrl + Alt + Del" workaround

    A little hint for those who haven't found out yet. If you want to change RDP window from windowed to full screen or reverse - Just press "Ctrl + Alt + Break". This shortcut is also part of why I don't like "Ctrl + Alt + Del". If I use it, I use the wrong combination about every second time :-(
    Tuesday, May 19, 2009 12:12 PM
  • I too am having this problem with Windows XP SP3 and RDP Client 6.0.6001.  I also have a problem where ATL-Tab and all Windows Key combinations are performed on the hosting desktop not the RDP session.  I currently have the Windows Key combinations option in the RDP client set to 'On Remote Computer'. 

    If anyone has any thoughts on this secondary issue, I'd be glad to hear them.

    Thanks
    Thursday, May 21, 2009 1:49 PM
  • When this happens, Click Left Shift + Microsoft Key, and this will resolve the problem on a one off basis.
    Wednesday, June 10, 2009 2:46 PM
  • I started to randomly get this about 4 months ago. I use RDC 6.0.6001 on XP SP3, Vista SP1 and SP2.

    Funny how this supposedly should have been fixed already, but I've come to expect this from MS.
    Tuesday, June 16, 2009 7:30 PM
  • Same here on W7

    ms Fix this one! this one is REALLY irritating the _____ out of me!
    Friday, June 19, 2009 2:25 PM
  • *begins waiting for it to be fix in W8* :V
    Friday, June 19, 2009 11:10 PM
  • My laptop thinks the control key is being held down. Every mouse click and key press responds as though I am holding down the control key.  The actual Control key on the keyboard appears to be working fine (i.e. it is not stuck and springs up just like any key).  I have pressed it multiple times hoping to get it to release but nothing happens. When I press ctrl+ left +right it unlocks for about 1 minute. Please help. 

     

    Saturday, June 27, 2009 10:30 PM
  • THANK YOU, THANK YOU, THANK YOU!!!!!! This worked for me too :)
    Monday, June 29, 2009 2:31 PM
  • The resolutions here has half worked for me, now it appears my windows key isn't stuck, but my ctrl key appears stuck. 

    The machine I want to get to is a Vista Virtual PC running on a Windows Server 2008 Server.  I usually connect to my Vista (non virtual)PC from my Windows XP Pro laptop and then connect to the Virtual PC using RDP from my Vista (non virtual) PC. 

    xp laptop --RDP--->vista non virtual pc --RDP---> vista virtual pc

    If I connect using Remote Desktop to virtual machine this way I get the issue, however If I Remote Desktop from my Vista (non virtual) PC to the Server 2008 machine and then access the Virtual PC the issue does not appear.

    xp laptop --RDP--->vista non virtual pc --RDP---> Server 2008 > Virtual PC


    Wednesday, July 01, 2009 12:59 PM
  • I've had the same problem for weeks but seem to have it sorted,
    So far I've tried
    New keyboard
    Uninstall/reinstall keyboard
    Change memory
    Flash Bios
    USB and PS2 keyboards
    On screen keyboard has same fault
    I got so pissed off that I formatted and reinstalled a different copy of windows
    None of the above worked

    Now to my solution





    I got hold of an old Hewlett Packard key board that does not have the windows keys, plugged it in and guess what, the problem was still there.
    Then uninstall keyboard in device manager, let windows reboot with the old non windows key keyboard connected and The problem is gone.
    I will try a new keyboard later with the current driver. after the joy of being able to type freely again wears off lol 

    Let me know if this works for you

    Manchap.

    • Edited by manchap Friday, August 07, 2009 2:04 PM
    Friday, August 07, 2009 2:03 PM
  • Same issue with RDP 6.0 except I have an apparent "Windows" key stuck down.

    Like most of you - this drives me berserk - you are wailing away on the KB an suddenly your "U" keys are bringing up the utility manager and "E" gives you multiple explorer windows.

    I .....seem..... to get it fixed by banging both the windows keys at once I can't guarantee that this is permanent.

    One thing I notice is that the issue appears about 5 minutes after the RDP session starts.

    Hope this helps someone.


    Update - it ain't permanent but going back to RDP 5.2 seems to be.
    Monday, August 10, 2009 1:02 AM
  • We have many users on our network who have reported this issue and most of them swear they have not used the Window-L key combination. All of our users are using Windows XP SP2 with the 6.06000 RDP client. Is the hinted at patch/hotfix available for this issue.

             Thank You,
                   Greg
    Friday, August 14, 2009 5:35 PM
  • Using the Win key to "loose the stuck win key" is not a solution: When the "stuck key" situation happens, it may cause accidents and you might not find out until it is too late. For example: If you are writing on a chat window, on a document, etc and the "stuck key" problem happens right in that moment, you may cause your system to close windows, send messages, and do all sort of operations that you don't want to do. For example, it has happened to me several times that I'm talking to a client using Yahoo messenger when the stuck key problem arises and I end up calling (yahoo voice: winkey+Y, Enter) somebody I didn't want to call. I have windows Vista with SP1 and the problem is still there.
    Jelgab
    Thursday, August 20, 2009 8:24 PM
  • I have RDP 6.0 client on my Windows XP SP3 machine. And I have the same problem. I have read most of replies. And usage of On-Screen keyboard in TS 2003 session is helpful for me.

    Has anyone try to use XP SP3 with RDP 6.0 client to connect to Windows Server 2008 TS? Is the problem persists?
    If there will be no such a problem, the cause is either completely in Windows Server 2003 or in some incompatibilities between Windows Server 2003 and RDP client 6.0.

    Application to programmers:

    Can anyone create a script which do the following, please?
    - Tracks the state of Winkey (constantly pressed or not at all regarding to the WS2003 TS session) and if it is pressed for more than 2 seconds (for instance) then press and depress the Winkey again. (Using some system call as On-Screen keybord does or something else).
    We could then put such a script to autorun on per user basis.

    Please programmers help us!

    Thanks in advance!
    Friday, August 21, 2009 5:16 PM
  • It appears that this is an issue with Windows 7 as well.  It's been happening to me all day.  And as luck would have it, I have been using WIN+L to lock the screen in when in RD.
    Tuesday, August 25, 2009 11:23 PM
  • I am having the same problem in Windows 7 Ultimate 64-bit. I am not using Win-L, however I am using a virtual desktop manager called DeskSpace and I configured it to use WIN+ALT+<arrow> keys to switch between desktops. This is a very frustrating issue.
    Friday, August 28, 2009 7:04 AM
  • We too have be experiencing a similar/same issue. We have a Windows 2003/XP network and have recently implemented Citrix. We use the Web Interface to have out users log in. We have noticed our users having the issue when they are logged into their Citrix desktop. Also, after they log out and it brings them back to the Web Page Log In, the U and L keys are not working at all. I haven't tried some of the other keys mentioned. This has primarily been hapening on this clients as well, and I am not sure if those shortcuts are available on them. This is really a pain and it is very disspointing that this thread has been going on for years and a solution hasn't been found.
    Tuesday, September 01, 2009 2:42 PM
  • I am also having this problem.  I've Lenovo Thinkpad, with Win XP SP3.  I do not use Win+L to lock the screen.

    I reiterate the sentiment in the posting above "is very disspointing that this thread has been going on for years and a solution hasn't been found."
    Thursday, September 03, 2009 7:37 PM
  • Clearly this issue still persists.  This has been an issue for almost 3 years!!!  Whats worse is that it has carried over from XP to Vista and now to Windows 7.

    This is unacceptable.  I will try these work-arounds, but I cannot believe that no real resolution exists.
    Friday, October 02, 2009 7:03 PM


  • After reading through about 2 or 3 years worth of replies I have found a few of the work arounds work. Such as the opening the on screen keyboard and hitting the windows key few times then it frees it up.

    However this is irritating the ____ out of me, why should we have to do this every 5 or 10minutes if im lucky in order to type on RDP. And yes im so use to locking my PC that i do end up locking it sometimes while im RDPed into my home PC. But im sure Microsoft should be trying to create a hotfix for this by now cause it is still happening with me and im rdping from Windows XP to Windows 7

    Please FIX THIS
    Monday, October 05, 2009 9:31 PM
  • TEST CASE for reproducing this fault:

    This "stuck WINDOWS key" bug happens every 5-10 minutes when I am using Synergy v1.3.1 to share keyboard between two Windows computers.  I am using XP SP3 as it happens, but the same behavior happens when I tested it under Vista 32 as well.  The "stuck WINDOWS key" only occurs on the computer that is running the Synergy server, it never occurs on a companion computer that is running the Synergy client.  The bug is made prevalent when using Ctrl+C to copy text from the computer running Synergy server, followed by Ctrl+V to paste the text to the computer running Synergy client.

    When the "stuck WINDOWS key" occurs on the computer running Synergy server, you can move the focus to the Synergy client computer and the "stuck WINDOWS key" is not stuck on the client computer.  So it's nowt to do with the keyboard.  However as soon as you move the focus back to the server computer, the "stuck WINDOWS key" is still stuck.  Quitting the Synergy server does not clear the "stuck WINDOWS key"

    Pressing the Ctrl button 6 to 12 times in rapid succession (with the mouse focus on the computer running the Synergy server) does clear the problem temporarily, but it will recur again within 5-10 minutes especially while continuing to use Synergy across multiple computers.

    Meantime my message to everyone experiencing this - "don't go buy a new keyboard".

    Thanks,
    Rob
    Tuesday, October 06, 2009 5:24 PM
  • When my WYSE thin client gets stuck like this, I just press the Windows Key + L to lock the computer, then log back on.  It seems to unstick it once I do that.

    Wednesday, October 07, 2009 6:40 PM
  • I've had a case open with Microsoft for about a year on this issue and have finally been able to readily reproduce on their end.  If network connectivity is lost or disrupted (even while target is idle\disconnected) to the target machine you'll see this problem every time.  Microsoft is in the process of building a fix.  After a fix is found I anticipate there being quite a bit of regression testing before it is public -- I would not expect a formal fix soon (but it is at least being worked on).

     
    Tuesday, October 20, 2009 3:19 PM
  • I also have sen this behavior on a couple of HP Thin Clients running Citrix 10.200.2650 client.
    After a while the U and L keys are not working anymore.
    Rebooting the Thin Client and it starts working for some time...

    Very strange...maybe something to do with the screensaver ?????
    Wednesday, October 28, 2009 9:56 PM
  • ATTENTION MICROSOFT: The RDP 6.0 client is seriously f*cked up. Your testers should be fired (assuming you even bothered to test). Fix this NOW!

    My team supports nearly 800 servers and 10,000 PCs across the country. We access computers with and without keyboards, with and without the Windows key. Some computers are locked with WIN+L, some are not. Sometimes the Windows key sticks, sometimes the CTRL key, sometimes both. RDP'ing to another computer within an RDP session is a common practice.

    We have tried every solution listed here. Sometimes they work; sometimes they don't.

    Try to resolve an emergency situation 2,000 miles away with the damn keys stuck!

    BEWARE: DO NOT UPGRADE TO THE RDP 6.0 CLIENT UNTIL MICROSOFT GETS OFF ITS A** AND FIXES THIS EXTREMELY SERIOUS PROBLEM!
    Saturday, November 28, 2009 4:54 PM
  • I have had this problem many times in the past. I have been following the "don't use the win-l key" suggestion.

    I just ran into this problem not related to the win-l key. i am on win xp pro 5.1.2600 sp 2.

    I was working via remote desktop on another machine. everything is fine until all of a sudden, the win key is locked. i was typing, normally, in oracle sql developer at the time and doing nothing else. in the middle of typing word, the r key pulled up regedit and the e key pulled up windows explorer. for sure, i did not type any special key.

    Perhaps the issue is with the local screen saver. since i was working for  a long time on the remote box, it is possible the local screen saver tried to kick in and lock the local machine somehow sending the win key

    disconnecting and reconeecting to the remote computer did not solve the problem
    pressing the ctl key 13 times did not solve the problem
    rebootting the local machine did not solve the problem
    i had to reboot the remote machine to solve the problem

    i hope this info helps you to fix this problem.
    Friday, December 04, 2009 8:53 PM
  • For those of you experiencing this issue (many apparently), there is a hotfix out for Vista-based machines that will remedy this issue:

    http://support.microsoft.com/kb/938080/en-us


    Granted, it leaves us XP-based users out in the cold, but at least it's a start. For us, the On-Screen keyboard winkey+e (or other favorite winkey shortcut) will solve the problem temporarily. There is the option of disabling the winkey on the TS Server, but that's an exercise for the reader on how that want to do that based on your environment.

    What's wrong? Basically, when a windows shortcut keystroke is used, (ctrl+alt+delete or winkey+e, etc) some of the shortcut keys may remain active. I personally attribute this to network and UI lag, since I've mostly only seen this over a VPN or with a potentially laggy UI situation (multi-depth RDP sessions or "exotic" remote connections [think VNC+RDP at the same time from different clients, etc]).

    For misc other stuck keys, such as ctrl, alt, etc, I have a feeling it is related to the same issue, but just punching the keys in all sorts of rapid strokes seems to "unstick" them for me.

    Cheers.
    Monday, December 07, 2009 9:13 PM
  • This problem IS STILL PRESENT in WINDOWS 7.

    I am running Windows 7 Professional and Ultimate across several machines, and use RDP to remote into the machines.

    It is December 9, 2009. This problem has followed me from Vista, after a clean install, to Windows 7.
    Enough is enough! Please fix this issue.

    Kindly note: refraining from using WindowsKey+L to log off, is not a workaround. It's a cop-out solution.

    Video of the problem that just occured now :
    http://www.youtube.com/watch?v=5hI2akIA8qs

    More details:
    - sticky keys disabled across all machines.
    - Latest RDP client from windows update used to log into windows XP, Vista, 7, 2003 Server, 2008 Server R2 machines.

    Digg it up:
    Digg link

    Wednesday, December 09, 2009 7:42 PM
  • I am running Windows 7 and am having the same problem. I use LogMeIn remote access software and use Win L to lock the remote PC at the end of the remote session. I notice that Win L locks both the remote computer and the local computer on Windows 7. Under Windows XP, Win L locked only the remote PC. This might be a clue for troubleshooting the problem. Sure wish Microsoft would fix this. I think about buying a Mac every day.
    • Proposed as answer by Guillemw Saturday, December 19, 2009 6:38 PM
    Friday, December 18, 2009 8:54 AM
  • Have a similar issue with Dell FX160 Running Windows XP Embedded. The users will start using a device an notice the"l" and "u" keys do not work. The funny thing is that if they hold the shift key down and type "u" or "l" the CAPS version of the letter appears. If they let go of the shift, the keys become inactive again, and bring up either the virtual keyboard or magnifier. The only way they can get out of this key dilemma without rebooting the device is to hold Windows Key+U. Something is triggering the virtual keyboard and I can't figure out what it is that screws up the keys.
    If I could easily induce the problem I could at least warn the users how to avoid the issue. I at least have the recovery for our environment.
    Saturday, December 19, 2009 6:54 PM
  • I am evaluating Windows Server 2008 R2 and had that machine setup so I could connect to it via remote desktop.  I have noticed when I'm logged in at the console, then lock it by pressing Windows+L, and then connect to that session via remote desktop, the Windows key is sometimes stuck on the remote desktop server.

    If the remote desktop client is running in full screen and set to capture all the special keys, pressing the Windows key will unstick it.  If the remote desktop client is running as a window and/or does not capture all the special keys, pressing the Windows key will open the start menu on the remote machine and have no effect on the server or unsticking the Windows key.

    Pressing Alt+Home on the remote machine causes the remote desktop client to send a Windows-key key press to the server which also seems to unstick it.
    Tuesday, December 22, 2009 8:30 PM
  • I am having similar issues, but mine seem a bit different.

    If I RDP in to a remote machine (Server 2003 or XP Desktop) from a Windows XP desktop with tne RDP update (WindowsXP-KB952155-x86-ENU.exe) installed, and the machine I remote in to switches to the screen saver or I lock my local machine with Win-L.   That open RDP session acts as if the Windows key is pressed down on the remote server/workstation so if I press the M key it minimizes everything or any other Windows hot key it will perform the hot key action.  It will continue to do this until I close the session and either wait for the session to time out prior to re establishing a connection or use terminal services manager to remotely kill the session.

    This has been the most frustrating update I have EVER dealt with.  We have 1500 servers and I can't RDP in to any of them without worrying about them going to screen saver when I leave my machine for 10 minutes and making my life ____ because I can't even type M / P / L without it locking the server / minimizing all open windows or some other hot key screwing up my session.  As it is I have to keep notepad handy to type / cut & paste things in to any RDP session where the server with the open RDP session has gone to the screen saver.

    I have had hav very little if any luck with your suggestion of removing the focus and pressing Ctrl 6-12 times.
    Thursday, December 31, 2009 2:43 PM
  • Same as tcd3 for me, it only happens when I have a web page open with a LogMeIn session running (LogMeIn Free for me). I'm running Windows 7 Pro, 64 bit and always use Win+L to lock. I hope this helps Microsoft fix it.
    Tuesday, January 12, 2010 2:54 PM
  • After a little experimenting, here's a solution while we wait for a fix. If you are running Log Me In, just ensure that the Log Me In session does not have the focus when you hit Win+L. This ensures you are only locking your PC, not the remote one, and prevents the sticky key when you unlock.
    • Proposed as answer by Rick Eveleigh Friday, January 15, 2010 10:56 AM
    Friday, January 15, 2010 10:56 AM
  • The Vista version of the hotfix is now officially released and publically available:

    http://support.microsoft.com/kb/978829

    XP\2003 fix expected in April.

    Wednesday, February 10, 2010 6:36 PM
  • The well-known problem regarding "stuck" CTRL+ALT key sequence has now been officially fixed for Vista and Server 2008/R2 client systems.
    KB978829 has been published and addresses the fix in more detail.
    The hotfix can be downloaded via the following URL:
    http://support.microsoft.com/kb/978829

    This problem manifests itself under the following conditions:
    1. when connecting via Windows Remote Desktop Connection to a remote system (physical or virtual)
    2. Locking the host machine (machine from which you are connecting) with CTRL+ALT+DEL sequence
    3. Transient network disconnection occurs
    4. Unlocking the host machine thereafter

    Users find that typing the DEL key on the target machine (such as in a Word or notepad document) causes the target session to be locked as though CTRL+ALT+DEL had been typed.

    This should not be confused with the "stuck" WIN key invoked by WIN-L as addressed by Josh Rosenberg in this thread.

    Wednesday, February 10, 2010 7:29 PM
  • Will this also be fixed for WIndows 7? I am not using WIN-L, see my previous post in this thread.
    Wednesday, February 10, 2010 7:48 PM
  • This problem IS STILL PRESENT in WINDOWS 7.

    I am running Windows 7 Professional and Ultimate across several machines, and use RDP to remote into the machines.

    It is December 9, 2009. This problem has followed me from Vista, after a clean install, to Windows 7.
    Enough is enough! Please fix this issue.

    Kindly note: refraining from using WindowsKey+L to log off, is not a workaround. It's a cop-out solution.

    Video of the problem that just occured now :
    http://www.youtube.com/watch?v=5hI2akIA8qs

    More details:
    - sticky keys disabled across all machines.
    - Latest RDP client from windows update used to log into windows XP, Vista, 7, 2003 Server, 2008 Server R2 machines.

    Digg it up:
    Digg link


    I didn't have this problem in Windows Vista, SP1 or SP2 I moved to Windows 7 because I was told it was more stable, what a crock!

    So far none of the the work rounds have worked for me, to think Microsoft have know about this problem for over 3 years now is just a joke.

    Why should I spend the next hour on the phone to Microsoft to fix a silly little problem like the Windows key is "stuck" on my RDP client is beyond me.  Hey Bill here's another Billion for wasting my time! :-p

     

    Monday, March 22, 2010 9:23 AM
  • delete dafult.rdp from your my documents folder and reboot.
    Tuesday, April 20, 2010 6:19 PM
  • I've had this problem for a while also with the winkey being stuck. It seems to happen when I use the winkey + D combo to view my desktop. But I found a solution that works for me...

    Try pressing the winkey + ALT then release. Since I found this trick it has worked every time the problem has come up again. Let me know if this works for all of you!

    Wednesday, April 21, 2010 6:34 PM
  • This is not just about the Win key.  On a Dell Laptop with Win7 we also lose the following keys:

    Right Arrow

    Delete Key

    End

    Again it occurs when using RDP and Locking Windows.

    These make using RDP impossible, users can't edit documents and the loss of these keys is not just in RDP but back in the Win7 session too.

    The Windows key seems to stick on P key so users can't log back in.  Pressing WinKey+7 a few times clears it but the other keys remain lost.

    This thread has gone back years, can't believe this is still present in Win7

    Any ideas?

     

     

    Friday, April 23, 2010 8:13 PM
  • Hi,

    Will there be a hotfix for server 2003?

    Thank you,

    John

    Tuesday, April 27, 2010 2:01 PM
  • Say this behavior for the first time on one of our programmer's workstation.  He programs on a remote win2008 server box in a co-lo in town.  He's running WinXP w/sp3 and the updated RDP.  He ran into the stuck windows key issue.  He does use win+L to lock the workstation and had been fine until today.  The work around doesn't work for him.  Turning off win key combinations are not a good solution for him.

    What I find interesting is that this thread started at the end of 06 and here it is mid 2010 and ppl are still having issues with this.  No patch has fixed this issue so it is either forgotten or not an easy fix (ie: problem so ingrained into the method that it would take an entire re-write of RDP).

    Thursday, April 29, 2010 7:46 PM
  • I work at a hospital where we use Terminal Services extensively.  This problem recently started happening with our OptiPlex 380 machines.  The machines are running WinXp and the server is running Windows 2003.  Most of the time having the users reboot their machine fixes the issue, but not always.  This is becoming a major annoyance and causing lost productivity.  A real solution would be greatly appreciated.
    Monday, May 10, 2010 1:12 PM
  • Let me add another one to the list.

    I manage 10 sites; 100% Dell shop, most of the hardware is various revisions of the Optiplex line.  I have ONE user out of almost 200 with this problem.  The user RD's to a WinSvr 2k3r2 SP2 box daily.  Prior, the symptom was isolated to the RDP connection.  However, today it affected the local PC and remained after RD was closed.  A subsequent logoff/logon corrected the problem.  That was before I stumbled upon this thread...

    Perhaps try a BIOS/MB Driver Update?

                   Cheers,

     


    -M
    Tuesday, May 11, 2010 10:06 PM
  • yes works. but the error appears so often (every5-10 keystrokes) that it is still un workable. the cobo caps_lock and shift works though< only not for the letter between l and n in the alfabet>

    ray

    Wednesday, May 26, 2010 8:56 PM
  • delete dafult.rdp from your my documents folder and reboot.

    Problem: Stuck Windows key

    Using RDP version 6.0.6001.18000, WinXP Pro SP3 on local & remote machines, all fully patched. First time this has happened and have been using RDP for many years. As mentioned by others, it is incredibly frustrating .

    Further details: These things did not work: Logging off & on, rebooting remote machine, logging on as another user, multiple key presses (Win key, Alt, Esc, Ctrl), logging on from another local machine, using the on screen keyboard. I did not try locking/unlocking, never have used that feature. (ie it did not trigger the problem)

    Finally I restored the remote machine to an earlier restore point USING ANOTHER LOCAL MACHINE, the problem seemed fixed. But when I logged on from the original local machine the problem reappeared immediately.

    I used the second local machine to restore the remote machine again, on the original local machine I deleted the RDP cache (bcache22.bmc), default.rdp & and myuser.rdp file (the one that was used when the problem first appeared.) & rebooted the original local machine.

    For now the problem has gone away, from 2 local machines can logon to the remote machine as 4 different users without problem.

    Microsoft support, please fix this problem, I am looking forward to the patch!

    • Proposed as answer by JBossA Tuesday, June 08, 2010 10:15 AM
    Sunday, May 30, 2010 12:47 AM
  • I have the stuck winkey on Windows 7 ultimate every once in a while, a reboot has always fixed it.   I tried the Ctrl hit 8-10 times this morning and it did not seem to work, but a few minutes later I hit the Ctrl Winkey Alt key combo a bunch of times (all three pressed down) and it seems to have turned off the stuck winkey.  Unless is was a delayed reaction to the Ctrl 8-10 times. 

    What a pain.  I do use Winkey-L to lock my workstation all the time, and I do RDP to other machines from there all the time so they are probably in the foreground a lot.  When will MS fix this?  -Bill

    Thursday, June 03, 2010 1:46 PM
  • Hi guys,

     

     

    Ive had the same problem, and ive fixed it on my RDP session using a (on-sreen keyboard)
    While lookin at the on-screen keyboard the RIGHT windows key was circkeld red. press CTRL on the right side and it should work !!

     

    Good luck,

     

    Greetz

     

    Jareth

    Tuesday, June 08, 2010 10:17 AM
  • I am also experiencing this problem. Now I know it's caused by RDP I can easily reproduce it.

    I am using Windows 7 (no service pack) with mstsc.exe version 6.1.7600.16385.

    To reproduce

    • Make a remote desktop connection
    • Make sure the RDP window has focus
    • Press Win+L to lock the desktop (The host system locks)
    • Unlock the desktop
    • Give focus back to the host machine
    • The Win+ shortcuts are now on by default. (e.g. typing "e" opens explorer)
    To undo this effect I press the Win key 7 times.

    This is really frustrating. I have a second monitor that I use to display all my RDP sessions. It is very easy to loose track of what window has focus. It is also worrying to see that a known bug from previous versions of windows/mstsc has come back in the later versions. 

    Any news on a hotfix?

    Tuesday, June 29, 2010 9:07 AM
  • I am facing the same issues.

    I am connecting to XP desktop from XP machine. Whenever i press r it opens run dialog, m minimizes the window i am working upon e opens explorer

    RDC version is 6.0.6001

     

    Any fix for this??

     

    Wednesday, July 07, 2010 6:56 AM
  • Do't know it will work for everyone but pressing windows+r, windows + e on local keyboard opens the run and explorer respect. Again pressing r and e types the word correctly on remote machne.

     

    thanks

    Wednesday, July 07, 2010 7:05 AM
  • I had same Issue,

    Solution Proposed by Frank van Ship worked, for me

    1: Open 'on screen' keyboard which is in the accessories/accessibility menu.

    2: Press the 'on screen windows key'.

     

    • Proposed as answer by JPK101 Friday, August 06, 2010 2:46 PM
    Thursday, July 08, 2010 11:57 PM
  • We are suffering with the same problem. Our server is 2008R2, the fix from KB978829 does not apply to 2008 R2 according to the installer. The KB article references 2008 SP2 but but not 2008 R2. It is the x64 version that we have downloaded.

    Have I missed something somewhere, is there a fix for R2, or are we all waiting on the same thing?

    Friday, August 06, 2010 3:00 PM
  • Solution Proposed by Frank van Ship worked, for me too.  We RDP using Wyse thin clients.  The users do not use Win+L, however, they do periodically experience this issue.  I did the following:

    1: Open 'on screen' keyboard which is in the accessories/accessibility menu.

    2: Press the 'on screen windows key'.

    That worked.

    Monday, August 09, 2010 9:39 PM
  • Supposedly fixed here for XP clients. : http://support.microsoft.com/kb/936970/en-us

    I will try it on Monday!

    Friday, September 24, 2010 11:47 AM
  • I think this will be helpful to note: I am running Win 7 Home Premium (neither XP nor Vista), using CITRIX client (CitrixICA Client Engine (Win32), *not* RDP) to log into a university medical record system. I have the problem that when I'm typing, I intermittently get the "L" and "U" keys interpreted as Win+L and Win+U. The Win+L problem is infuriating as it locks the workstation and I cannot log in as it requires administrative privileges.

    Is CitrixICA using RDP or is this just a similar problem to the RDP problem??

    Saturday, September 25, 2010 4:32 PM
  • Well, I can add to that information.

    I use Windows 7 Professional 64-bit and get this sticky Windows key every now and then when using RDP to desktop on Windows Server 2003, Windows Server 2008 R2 and when using Citrix.

    It's four years now since the initial post. Has really no one come up with a solution to stop this from happening, eliminating the need for workarounds? This is really weird!

    At least I would like to know what is causing the problem.

     

    Wednesday, October 13, 2010 12:28 PM
  • So, I've spend hours reading on this post and others, and I have this problem:

    I have a Lenove Ideapad running Vista 64bit.  I turned it on this morning, and bam, it's like all the hot keys keep flickering, and it's impossible to type.  None of the above solutions work.  I'm frustrated - lost a day's work already! Can SOMEBODY please tell me what it is?

    Monday, October 18, 2010 8:17 PM
  • Lunan is right on target, both from a problem description (RDP), and with the absurdity the problem is still around.

    Pressing the windows key a boatload of times unsticks it.  Doing the same with the control key does not.

     

    Thursday, October 21, 2010 2:55 PM
  • Any update on when this will be fixed? I have the issue on my windows 7 machine (fully up to date as of this post).
    Sunday, November 07, 2010 1:03 PM
  • Same issues here - one user is getting the error of Ctrl+Alt being stuck, another gets either Ctrl or Alt, but rarely both.

    users are connecting to a windows server 2008 R2 Hyper-V server using RDP as provided in Windows® Embedded Standard 2009 from an HP T5740 thinclient. a solution to this problem would be much appreciated, the multiple pressing of the keys is functional as a workaround but not appropriate for a solution.

    Thursday, November 18, 2010 4:28 PM
  • This solution worked for me for the time being :

    1: Open 'on screen' keyboard which is in the accessories/accessibility menu.

    2: Try writing some characters on a notepad using this on screen keyboard.

    3. Close the on-screen-keyboard

    • Proposed as answer by voodoodude Thursday, December 30, 2010 3:39 PM
    Friday, December 03, 2010 2:28 PM
  • I don't know if this will help anyone, but checking out our only computer that was doing this I noticed that it was using an nforce 410 (or 430) chipset motherboard.

     

    When I did a windows update, it found a network card update. Installed the update, and it seems to have solved the problem. The thought someone had in this thread that the console hadn't quite logged in all the way may have been on the mark.

     

    Try checking your drivers! Fixed things for me and this has been bugging me for a week or so. Good luck!

    Thursday, December 30, 2010 3:43 PM
  • I recently encountered this problem.

    I do not remotely access my desktop and do not use CTRL+L to lock the desktop.

    I am using a Dell Inspiron (my roommate's old laptop) 6400 with XP home. I noticed that the popup menu seemed to be most active when I move the mouse-- a Microsoft wireless infrared mouse with a usb and keyboard split hookup thingy. Restarting didn't solve the problem, but unplugging the mouse from the USB slot and then restarting did.

    I had been using the mouse for a week or more before the problem occurred, but now it recurs each time I plug in the mouse, and does not resolve until I unplug the mouse again and then restart.

    Wednesday, January 05, 2011 8:16 PM
  • Has the responsible support team really let this issue rot for five years? For heavy terminal service users, this issue is crippling. For those of us who run into this while attempting to do our job, it's rage-inducing.

     

    I understand, you have a big team, no one individual gives two sh**ts until someone important enough bitches loud enough to your boss.

     

    There have been enough constructive posts on this topic. To the individuals on the team that let this drop:

     

    I hope the grocers in your vicinity run out of bacon, milk and eggs. I hope the stoplight sensors on your way to work cease to function. I hope your wife has a "headache" tonight. I hope your home router dies. I hope your mother-in-law decides to stay for the summer.

     

    May your grass die in patches, and your conveniently located Starbucks close up shop. Jerks.

    • Proposed as answer by Angry Monkey Wednesday, January 12, 2011 7:13 PM
    • Edited by Angry Monkey Wednesday, January 12, 2011 7:19 PM Edited for rage-induced errors.
    Wednesday, January 12, 2011 7:07 PM
  • Infuriatingly this keeps happening to me in a Citrix session. Pressing the "L" or the "U" keys act as if I was holding the CTRL or ALT keys. I'm not sure because I can't reproduce it when its not happening. It just locks the Citrix session. I have to unlock it  then it starts running the Text to Speech settings (as if I had selected them which i haven't). I then cancel out of these ensuring nothing is ticked on. Then I can exit all Citrix apps and exit the Citrix Session completely. Going back in all seems OK for a while - how long you ask, wish I knew, 5mins, 1 hour, days then it comes back like a "possesion" of the PC to Haunt me. I'm going MAD!!!

    The PC is running XP SP3. The Citrix client is the Online Plugin 12, we are just trying this but it has happened in the past with Xen App 11.

    It seems to have nothing to do with locking the PC "Windows +L". The FAT PC is unaffected. Its just the Citrix.

    • Proposed as answer by Bishop-360 Wednesday, February 02, 2011 8:17 PM
    Monday, January 31, 2011 12:28 PM
  • TRY winkey + m

    Thursday, March 17, 2011 7:45 AM
  • Hello guys,

    this post started in 2007 and its now 2011, and still we are facing problem even with the latest OS launched by microsoft

    1. I am using windows 7 and taking RDP of windows 2008 server.

    2. I am not using windows + L to lock my PC.

    3. also work on RDP of windows 2003 servers but no issues there

    4. sometimes win+r opens run windows otherwise win+l only bothers me.

    5. and if the server is locked i can't enter my correct password as it contains 'l' in it :( (i have disconnect and reconnect as i have saved password).

    do we really have any fix of the issue bugging around for last 4 years. or does microsoft thinks that they can keep launching bugged OS without taking care of problems faced by end user.

    this is crap...

    Friday, April 22, 2011 9:02 AM
  • I have faced the same issue while accessing remote server (windows xp). Some time the windows key looks like stuck. And whenever pressing ‘e’ windows explorer will open and pressing r will open run command. I am able to resolve this issue by doing as given below 1. Connect to the remote terminal. 2. open the onscreen keyboard of the remote server (Start Menu\Programs\Accessories\Accessibility\On-Screen Keyboard) 3. Select Windows key in the on-screen keyboard of the remote server 4. Select ‘r’ two three time in the on-screen keyboard.
    Thursday, June 02, 2011 12:17 PM
  • Over 4 years and yet MS has failed to fix this. It still exist on Win7.
    Wednesday, June 15, 2011 7:08 AM
  • Hello,

    I have one user on a windows xp machine and i followed Tyler Durden's suggestions

    first I didn't talk about fight club, then I still didn't talk about fight  club....

     

    But really here is the solution

     

    delete dafult.rdp from your my documents folder and reboot.

    What Tyler failed to mention is this is a hidden file, so you may need to go to the tools menu, choose folder options, then choose the view tab, and select show hidden files and folders.

    Don't forget to switch that back to don't show... when your done.

     

    Friday, June 17, 2011 4:14 PM
  • Pressing control key 6-12 times didn't help me.  This solution did.

    Thanks Frank!

    Friday, June 24, 2011 1:20 AM
  • Works for me ... but the issue still exists on Win7 and SP1 .. when will you fix this ?
    Friday, August 12, 2011 7:33 PM
  • My problem is that when my dell laptop is docked and I am rdp into an windows 2008 server, this ease of access thing comes up with the stuck key.

    I found a solution to this:

    The problem is in RDP, it thinks the windows key is stuck.

    So this website has  a registry setting you can download to disable both windows keys

    http://johnhaller.com/jh/useful_stuff/disable_windows_key/

    Select this one:

    Disable Caps Lock and both Windows keys: disable_caps_lock_and_both_windows_keys.reg

    Logout of your rdp session and relogon....

    Worked for me.


    Thursday, September 15, 2011 5:58 PM
  • managed to get virus scanning on the network, and then installed Avira Network Bundle, after that the problem never happened again!

    my problem: http://social.technet.microsoft.com/forums/en-us/winservergen/thread/1C27FA96-EA01-4769-BDA8-D8F49360B176


    _______________________________ Tiago Dal Toé Westrup www.help1.com.br
    Saturday, September 17, 2011 12:24 AM
  • Does the registry fix permanently disable the Windows Keys?  I am remote controlling my Windows 7 PC at work through a VPN and I definitely do not want to disable the Windows key.

    Does anyone know what the root cause is?  It's not a stuck key on my local (remote) PC.  The RDP session believes it's a stuck key - but its not.

    Deleting the local Default.RDP file and restarting the session doesn't work.  Pressing Control or Win key 6-12 times doesn't work.

    How do we tell RDP to turn it's sh$t off?

    Thursday, October 13, 2011 10:21 AM
  • I had this issue recently using RDC from Windows 7 Professional x64 to several other machines on my network running Windows XP, Server 2003, Server 2008, and Server 2008 R2. The issue started when I installed the Synergy mouse/keyboard sharing server. Disabling/uninstalling this program solved it. It doesn't seem like this is relevant to anyone else's software configuration on this thread, but I figured it wouldn't hurt to pass along.

    Thursday, October 27, 2011 5:43 PM
  • I have this issue as well using MSTSC with Win 7 Pro x64
    Monday, October 31, 2011 8:25 PM
  • ok so after FIVE YEARS you would think there would be a permanent fix for this. we have this issue with: xp sp3 to server 2008 and server 2008 R2 win7 x64 to server 2008 and server 2008 R2 vista x32 and x64 to server 2008 and server 2008 R2 it is VERY annoying and hard to get any real work done when you can't type half of the letters on the keyboard without some random feature enacting itself. FIVE YEARS guys - please - put one of the script monkeys on this and bang out a hotfix.
    Sunday, November 06, 2011 1:44 AM
  • Is it possible that the onscreen keyboard is the problem.

    Because when I call the onscreen keyboard the WinKey is selected..

    But according my installation we don't have a onscreen keyboard.

    Is there a way to test that by uninstallin the onscreenKeyboard.

    Because that's a keyboard who uses sticky keys.

    Because you can't click on 2 buttons at the same time..

    So MS let you use sticky keys..

    And it doesn't remove the setting.

    So We want to try to uninstall the keyboard but it can't

     

    Frits

    Wednesday, November 09, 2011 4:38 PM
  • Thanks !!!! You made my day.

    Since mine was a live server, I wasn't able to reboot it since didnt want to stop the services.

    Going on Start -> Programs -> Accessories -> Accessibility menu I run the "on-screen keyboard" and clicked on the "windows keyboard" 3-4 times until it changed from non-bold to bold and then back to not-bold.

    All the other methods did not work.

    Wednesday, December 14, 2011 10:38 AM
  • What did Josh leave the sinking ship called Microsoft? Is that why he does not want to explain why this issue still exists and how sucky Windows is? "Has the responsible support team really let this issue rot for five years? For heavy terminal service users, this issue is crippling. For those of us who run into this while attempting to do our job, it's rage-inducing." Rage inducing. Of course since MS is an illegal monopoly, why would they care? Oh; they do not care. Just pay (a much higher price, since they are a monopoly) and shut up (since we are a monopoly we have no incentive to care about you anyway) you have no alternative (you landed on our monopoly, and now we win the game. Have you not played before? Are you stupid? We think you are stupid since Microsoft is the best and the brightest and you must just be some Apple user.) But of course this is certainly NOT why the stock price keeps dropping....
    • Proposed as answer by BillyRay Jobs Wednesday, January 18, 2012 11:00 PM
    Wednesday, January 18, 2012 10:59 PM
  • On 2008 R2 fully patched So none of the solutions posted in this worked for me. I was able to bring up the on screen keyboard and by hitting the windows key a few times I was able to get it to toggle on/off but it was still stuck If I hit e it would open explorer but and the windows key on on screen keyboard would untogle, next time I hit e it would type e But no matter what whenever I hit l the screen locked, and since my password has a l I could not unlock... Final solution was to log directly into the server at the box and mash the windows key a few times on the actual keyboard.
    Thursday, January 26, 2012 5:39 AM
  • I also had "locked" WIN button on my virtual keyboard.

    My solution is:

    1. Open virtual keyboard on remote desktop with a problem.

    2. Pressing simultaneously WIN keys on your virtual and physical keyboards. (May be many times)

    - AxyHoB
    • Edited by AxyHoB Wednesday, February 08, 2012 7:55 AM
    Wednesday, February 08, 2012 7:37 AM
  • What I find to always work is by simultaneously pressing SHIFT-CTRL-Windows Key together.
    • Proposed as answer by EliezerChicago Tuesday, March 06, 2012 4:53 PM
    Tuesday, March 06, 2012 4:53 PM
  • This always works for me: pressing windows key+D key twice (to minimize, then restore all windows)
    Tuesday, March 20, 2012 10:48 PM
  • I'm using Windows 7 (full patched) on the client end, and both Win7 and Server 2008R2 (again, fully patched) on the server ends. I'm still getting this issue, and I'm not locking the computer using Win-L (the computer does auto-lock however). 

    I'm astounded that this is still a problem after some 5 years. 

    Friday, June 15, 2012 1:37 AM
  • Windows 7 64 fully patched this problem still exists.  It's things like this that are bringing Microsoft down.  The "company" can't save itself.  The employees have to care enough to make a difference.  Shame on whoever is passing this buck.
    • Proposed as answer by reaplo Saturday, June 23, 2012 8:30 PM
    Saturday, June 23, 2012 8:30 PM
  • 5 years later, still an issue.  I have Windows 7 Home Premium, fully patched.  Doesn't seem to matter if I lock my computer with Win Key + L, "Lock" key on keyboard, ctrl+alt+del then enter, or let the screen saver activate and lock it, or if I currently have an RDS session in focus, minimized, or even no RDS connection.  Next RDS session will be locked.  Tapping the windows key a couple of times does fix it, but meanwhile all kinds of things happen, so that's a work-around, not a fix.  Isn't there someone somewhere working on fixing this issue?

    Wednesday, August 15, 2012 10:44 PM
  • Still having this issue also - daily, on multiple, fully-patched machines. This is pretty ridiculous...
    Monday, September 10, 2012 2:50 PM
  • I tried I think most of the suggestions on this thread, but the following worked for me:

    I was RDPing within a window (as I usually do) when the problem happened.

    Disconnect from that RDP session. 

    Now reconnect, but in full screen.

    Now press the windows key (the start menu will open).

    This seems to have unstuck it.

    Thursday, September 20, 2012 9:38 AM
  • Unfortunate to report, this is still an issue on Windows Server 2012. In fact, mine is occurring in a Hyper-V terminal window, not a remote desktop session. As some others have reported, I did not use Win+L. I just hit the Win key to open my start menu. It appears to be reliably reproducible for me.
    Monday, October 15, 2012 8:16 PM
  • Alright. Does it still occur in regular Remote Desktop sessions? There were some changes in the RDP 8.0 client that should cause this bug to occur less frequently if at all, but they may not apply to VM connection windows. Nonetheless, it would help to know: is Server 2012 the host OS, the guest VM OS, or both? Are the Hyper-V integration components installed?

    Wednesday, October 24, 2012 1:29 AM
  • Happening to me on a fully patched Windows 7, connecting to a WinXP.

    Glad to see it's a known issue -- sad to see that it is 5 years old.

    Tuesday, November 13, 2012 4:45 PM
  • I too can reproduce this on a fully patched Windows 7 Professional 64-bit with mstsc.  Greatly frustrating!  Hoping for a update that will fix it for good.

    Tuesday, December 04, 2012 3:17 PM
  • In my case, my windows 7 via RDP was stuck with windows keys.(arrow-up maximizes app, arrow-down minimizes app, etc. etc)

    So striking windows-key 12 time inside the RDP session(not focusing on any apps in host system) worked for me.

    • Proposed as answer by Doh Choi Wednesday, January 02, 2013 7:48 PM
    Wednesday, January 02, 2013 7:48 PM
  • Old thread but now I can be sure that this is a bug that became too obvious to me after switching to Windows 8.

    The remote desktop sessions are being heavily impacted since October for debugging code in test machines. I use both Hyper-V 2008R2 and HyperV 2012 as well as windows Server 2012 and 2008R2.

    However the worse is that I cannot even remotely connect to my desktop PC from my laptop (Windows 8 x64 both) ! It is everywhere the same. In all combinations, after pressing the SHIFT key (for typing in a parenthesis or a capital letter), it is more than 50% that it will stay pressed.

    Is there any real solution to this ? Nothing around in the net that one can easily find is even related to the topic!

    Saturday, March 16, 2013 7:05 PM
  • If you are using Win Key + L to lock your desktop, this is a known issue.  We have completed work on a fix that should prevent the problem in the future; to my knowledge it is due to be released with Vista SP1.

    The bug arises most frequently when you use Win+L to lock your desktop while the Remote Desktop window has focus.  It is caused by a synchronization issue between client and server that only arises on a subset of machines, possibly due to a driver or 3rd party software conflict that messes up the timing of the Remote Desktop client.  There are a few ways to avoid this:

    1. Don't use Win+L to lock your local desktop.  Either lock your machine through the start menu or, if your machine is configured for it, Ctrl-Alt-Del and select Lock Desktop.

    2. Make sure a different window has focus before locking your desktop.

    If you have already encountered the problem, the "workaround" is much as you described:

    1. Remove focus from the Remote Desktop window, by selecting another window on your machine, or minimizing and clicking the desktop of the local machine

    2. Strike the Ctrl key 6-12 times. You mentioned the win key which probably works as well, but if you have somehow encountered this error on a machine that doesn't have a Win key, Ctrl should work as well.

    3. Go back to the Remote Desktop window; the problem should be resolved.

    If any of you are *not* using Win-L to lock your desktop, please speak up.  The fix we have in place actually addresses two different aspects of the fault, one specific to Win-L locking, and another related to general synchronization, so it should fix the problem regardless, but I'd like to know if this issue is occurring by other means.

    This is a regular annoyance for me and I use the work around. Its currently 2013, this is a 16 year old bug that still exists.
    Friday, May 03, 2013 4:25 PM
  • If any of you are *not* using Win-L to lock your desktop, please speak up.  The fix we have in place actually addresses two different aspects of the fault, one specific to Win-L locking, and another related to general synchronization, so it should fix the problem regardless, but I'd like to know if this issue is occurring by other means.

    Never use any Windows keys to lock the desktop. Only two things are different since this problem appeared for me. 

    1. Installed smart card driver

    2. Using rdesktop as client on Mac, since there is no smart card redirection in Microsofts RDP Client.

    Problem once started seems to propagate from a stuck Windows key, which as soon as you type an "L" locks the desktop, which makes it impossible to log in until you know what the problem is because the windows key is stuck.

    I also note "sticky keys" has been very keen to pop up if I hold a modifier key, which I thought required repeated keypresses and not autorepeat.

    Have had the problem for a few days any trying to provoke it today but can't yet. Have disabled sticky keys.

    UPDATE:
    It appears the problem is similar with rdesktop and Windows Remote Desktop Connection. Using <command-Q> to quit X11 seems to leave the Windows Key toggled on on the server RDP session. So when logging in again, best option to debug is to turn on the virtual keyboard. Working on stopping Windows key passthrough on the RDP client....
    • Edited by cheongi Saturday, May 11, 2013 10:27 PM update
    Monday, May 06, 2013 9:39 PM
  • I have just experienced this problem... I do not use the ctl+L to lock the desktop

    I was on my win7 laptop at home connected to my win7 x64 pc at work and things all of a sudden started acting weird - when in Outlook and using the arrow keys, the Outlook window would maximise (up arrow) or minimise (down arrow). On attempting to write an email, as soon as I pressed the "e" key, then the explorer window popped up - I now knew it was the "Windows key" related. Got to work and my work PC acts normally using the keyboard. RDPed to a server and it was now acting exactly the same stuck key way .

    Thinking it was my PC that had the issue, used my laptop to connect to the same server and the exact same problem - pressing "e" causes explorer window to open. This is truly a wtf moment. Since I had work to do, I guessed i needed a virtual keyboard (it was a W2k3 VM) and downloaded one called FreeVK for my Windows 7 PC (window 2003 sever includes one in the accessories/accessibility). Hit the windows key twice in virtual keyboard and all OK - pressing "e" produces the "e" character. Went to my laptop and RDPed to my work PC, fired off the FreeVK pressed the Windows key twice and this now worked OK.

    No idea what triggered this series of events and was looking on the internet to see if there is a real fix for this and found this thread. Can believe that this is been going on for 7 yrs.

    To anyone readig this, I hope you find this workaround useful. In reading previous replies, I did bang on the key multiple times, but I guess it needed one more hit before I gave up.

    I leave the FreeVK icon on their desktops of all the servers I access via RDP - just in case.

    Chris

    Friday, May 17, 2013 2:24 PM
  • I also had same issue but solved it with uninstalling application like synergy (for using desktop from another computer as own desktop extension) Maybe you have installed ultravnc or smth like that. I suggest to remove these applications which has own "shortcuts". 

    Monday, July 15, 2013 7:12 AM
  • Thanks Frank, It worked for me as well :)
    Thursday, July 25, 2013 8:24 AM
  • The "onscreen" keyboard solution works. Just for me the key that was pressed was the numlock key. I unpressed it and everything worked smoothly. If it happens again I 'll post the solution. For now problem solved.

    Ps. For me the problem occured when connecting from a WinXp Sp2 machine to a WinXp Sp3 machine :)

    Friday, July 26, 2013 6:18 PM
  • Onscreen keyboard appears to have Windows key depressed even when pressing the Windows key onscreen and on the keyboard.

    I can't get any work done like this sometimes it comes sometimes it goes.

    Gatto

    Saturday, August 03, 2013 3:57 AM
  • This is not purely a RDP/terminal services issue.

    I have a Clients Dell XPS windows 7 machine, here (upgraded from vista) and it for no apparent reason locks the windows key on. Several different keyboards have been tried, and even blue tooth was disabled.  At first i thought it was a prank program installed, but a full scan for such nonsence comes up clear. Issue appeared inexplcably a week ago.  A system restore seems to ease the issue, but then it reoccurs a day later. Which says to me, it is a windows update causing the issue.

    They dont use RDP or windows key shortcuts at all, and in fact installed a microsoft tool to disable it entirely, and it still occurs.  It even plays up in "on screen keyboard"

    From what i read this has been an issue since XP days, but other than the generic "dont use window-L" in rdp responce, nobody seems to have examined the issue seriously for any other scenario. Especially not Microsoft who just dismiss it as a known glitch in RDP - ignoring the fact that a large portion of people having this issue, dont use screen sharing or rdp at all.

    This machine in particular is used only for printing, accounting and checking email.  This issue has crippled their business. They cannot enter their accounting information and are quite overdue to submit their paperwork but cannot as the issue reoccurs within minutes of them starting up their PC.

    Apperently the issue also occurs in Windows 8, from my google searches.  Not really suprising since Vista, Windows 7 and Windows 8, area all essentially the same program with explorer.exe and a few registry settings altered - so they can scam people into buying the "new" version of windows.  I've even confirmed this myself by running tests on all the OS's on the same PC.  They all come up performance wise within 10 points of each other in a scale of 50,000.  In fact Xp came up as about 5000 points faster... with less ram. Irony.

    In any event it is pitiful that Microsoft has allowed an issue which in this case may result in a company going into liquidation purely becuase they are unable to access their accounting now.   Pure Insanity.  Stop releasing made up pretend new windows versions and how about you fix the old ones first. 

    Friday, August 09, 2013 1:16 AM
  • 7.5 years later...

    I have a client with Windows XP SP3 fully patched connecting to a Citrix XenApp 6.5 server running on a fully-patched, virtual Windows 2008R2 server.  No one else in the company is having the problem. She's on a Dell Optiplex 380. The server hardware is running XenServer 6.0.2.

    When she connects, her session acts as though the Windows key is stuck and like Joel originally posted, hitting the Windows key a few times fixes it.

    Just chiming in that this is one of the longest-running serious issues I've ever seen. Like others have posted, this problem has made her lose most of the day in productivity. I can't imagine if this was company-wide!

    Hope to see a fix someday.

    -KK

    Monday, August 12, 2013 7:04 PM
  • The fix from 2007 really doesn't seem to be a fix.  I have this on Windows 7 x64 when connected to Windows Server 2008R2.  Unlock my desktop, go to type an email, and all sorts of fun things happen.  Then, turning it off triggers Sticky Keys (didn't I turn that off two or three times already?)  In the past, other meta keys could get stuck, such as Ctrl, Alt, or Shift.  At least now, it's just the windows key.

    The suggestion that we work around the issue by simply not using the keyboard for various functions is annoying.  Many of us use the keyboard for so much input that pulling a hand away to mouse around is a usability problem.  This is not the only suggestion to do so:  The Ctrl-Alt-Del menu has dropped keyboard accelerators, which is an encumbrance when opening Task Manager.

    I think what's happening is that local keyboard handler sees RDP has the windows key down, and marks it down locally.  The RDP client sees the key marked down, and sets it remotely.  Then it loops.

    The fix would be simple for our use cases.  If the console disconnects, or the RDP client loses focus, then the RDP client should releae all meta keys, and trigger the OS to re-scan the keyboard.  Do we really need to maintain that level of keyboard state such that the remote host can have different meta combinations than the local host when there is only one console attached to the RDP session?

    If the same happens with multiple users, then whenever a user drops focus or disconnects, their keyboard state should stop asserting itself on the RDP session.  Only focussed users should be a part of that loop.

    Lastly, the OS should reset ALL meta keys to current keyboard state if any combination of meta keys is toggled 6-12 times without any non-meta key being input from the same device.

    The irony of my post is that while typing, Windows decided to turn on filter keys and sticky keys, and filtered out ALL keyboard input.  I closed my RDP session, hit all of my keys multiple times, even switched user... Only by picking a different user was I even able to enter a password, but once I was back in, keyboard input was turned off.  External keyboard plug-in didn't help.  I found the filter keys icon in my tray and had to turn off a slew of "Ease of Access" options just to be able to finish this post.

    Again, it seems that the RDP client caused a keyboard feedback loop which turned on these features, because I was just typing US English characters.

    Anyway, I don't suspect this is a serious enough problem to get resolved.  There are just not enough dollars complaining for it to be high priority.  We would need a large enterprise to complain to their Microsoft account rep.  Simply switching to another OS doesn't get the message across - MS responds by breaking interoperability and going to war.  This takes concerted effort by those who control the purse strings.

    Tuesday, August 13, 2013 5:31 PM

  • 2. Strike the Ctrl key 6-12 times. You mentioned the win key which probably works as well, but if you have somehow encountered this error on a machine that doesn't have a Win key, Ctrl should work as well.

    This work for me in my ASUS X501A... thank you so much :)

    Thursday, September 05, 2013 3:06 PM
  • my delete key is stuck unresponsive
    Sunday, October 13, 2013 12:35 AM
  • So sad an obvious, visible problem like this isn't corrected. Especially 7.5 years after the problem is revealed.  All windows has to do is untoggle the toggled windows key when Win+L is used to lock the screen.  In fact, the problem was LESS of an issue in XP.  

    It is quite annoying after you've locked out your account a couple of times.

    Friday, October 18, 2013 3:14 PM
  • I ha9ve literaly just encountered this problem, as you can see when i press the V key it also presses 9 to make 9v or V( (V. this only happened after i had changed some settings on Itunes...i believ9e itunes is the route of my problem and i shall try reinstalling it.

    none ofthe adv9ice on here sol9ved it, i hav9e all the other problems with G B E etc

    Saturday, November 23, 2013 8:58 PM