none
Schedultask Status "Completed Successfully " But the expected output not happening

    Question

  • Schedultask Status "Completed Successfully " But the expected output not happening .  I have scheduled a task which starts a batch file ,but the expected output not happening .At the same time  if  i run  from the command prompt it works fine . What is the problem ?. (Which run under system account )
    Tuesday, March 06, 2012 3:56 PM

All replies

  • Hi,

    What is the result code associated with the task following its completion? does this say 0x0?

    How is your scheduled task configured? as a direct call on a batch file? or a call to cmd.exe passing in the batch file name as an argument?

    If it is a direct call on a batch file have you set the "start in" parameter to the directory containing the batch file?

    Cheers
    Chris

    Tuesday, March 06, 2012 9:23 PM
  • Hello,


    As the batch files works manually but fails in Task Scheduler, then it’s very likely some kind of permission related issue or involving a mapped network drive. Please note that when a script is run in Task Scheduler, it is typically run under service account which possibly cannot access your configuration.


    Try go to Task Library and highlight the task, go to Properties tab. Under When running this task, Use the following user account, select your account. Hope it helps.


    Thanks
    ZHANG

    Wednesday, March 07, 2012 5:52 AM
    Moderator
  • Hi Chris

    What is the result code associated with the task following its completion? does this say 0x0?

    Yes

    How is your scheduled task configured? as a direct call on a batch file? or a call to cmd.exe passing in the batch file name as an argument?

    Direct call

    If it is a direct call on a batch file have you set the "start in" parameter to the directory containing the batch file?

    Yes

    --------------------------------------------------------

    Hi Zhang

    Try go to Task Library and highlight the task, go to Properties tab. Under When running this task, Use the following user account, select your account

    Done , but no result

    Is there a way to  run the schedule tasks  in  verbose mode or something like that

    Please  help

    OS is windows 2008 enterprise

    And i tried to run under system account also

    Wednesday, March 07, 2012 2:47 PM