none
LDAP Import Error states "The server is not willing to handle directory requests"

    Question

  • Hi,

    I have the following architecture and problem:

    Windows Server 2008 R2
    Windows XP SP3 Clients.
    Windows 7 Clients.

    I am using an LDAP Editor to update user attrbutes in my Domain Controller.  I am using a product named LDAP Administrator version 2012.2  I have installed LDAP Adminsitrator on a Windows XP SP3 machine. I am able to successfully connect with LDAP Administrator to my Windows Server 2008 R2 Domain Controller.  I am using the Domain Administrator account for all functions.

    I exported the "Users" from my Domain Controller to a CSV file.  When exporting I chose to exclude "SAM Attributes" and I unchecked "Export RAW Values".
    When I try to import the CSV file I get an error stating "The server is not willing to handle directory requests.".

    Can you please assist me with resolving this.

    Regards,

    JD

    Thursday, April 18, 2013 6:28 AM

Answers

  • Hi,

    Thanks for the replies.  My test environment does not work, but when I executed the import in our production environment it successfully worked.  The test environment is in a virtual environment and the production is a physical server.  I'm thinking this may have something to do with the virtual architecture.  The virtual DC was copied to the virtual environment. 

    I'll keep you posted.

    Thanks,

    JD

    • Marked as answer by jdjd99 Tuesday, April 23, 2013 8:57 PM
    Tuesday, April 23, 2013 8:56 PM

All replies

  • Hi,

    You might get some help in ladap administrator forum

    http://www.ldapadministrator.com/forum/general-discussion-f4.html?sid=77b3dfec045e4512e4c83cd5675b7cee


    Regards, Santosh

    I do not represent the organisation I work for, all the opinions expressed here are my own.

    This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    Whenever you see a helpful reply, click on Alternate Text Vote As Helpful & click on Alternate Text Mark As Answer if a post answers your question.


    Thursday, April 18, 2013 7:13 AM
    Moderator
  • Thanks for the reply.  I have already contacted them. From my research I saw postings in developer forums stating the domain password policy may be the reason for the error.  Apparently it occurs for many items. Thought someone may know the reason in this forum.

    Thanks,

    JD

    Friday, April 19, 2013 5:26 AM
  • Hello,

    When you export data using LDAP Administrator, and you want to import the data back, you must:

    • Check the Exclude SAM attributes option
    • Check the Export raw values option

    If at least one option is unchecked, it'll be impossible to import data to AD.

    Friday, April 19, 2013 11:41 AM
  • Hi,

    Thanks for the replies.  My test environment does not work, but when I executed the import in our production environment it successfully worked.  The test environment is in a virtual environment and the production is a physical server.  I'm thinking this may have something to do with the virtual architecture.  The virtual DC was copied to the virtual environment. 

    I'll keep you posted.

    Thanks,

    JD

    • Marked as answer by jdjd99 Tuesday, April 23, 2013 8:57 PM
    Tuesday, April 23, 2013 8:56 PM