none
Windows Server 2008 & Windows Installer

    Question

  • Attempting to install SQL Server 2008 onto Windows Server 2008. Install tells me I need to update to .NET framework 3.5 and Installer 4.5. .NET Framework install is okay, however when I try to install Windows  Installer 4.5, I get the error "Not enough free storage to complete this operation", and obviously there is, I have 150GB free HDD and 2GB free RAM. I tried to download the Installer package manually and get the same error. I am currently logged in as administrator with full rights and access, but Windows will not let me move/rename/delete the msiexec file, thought I would try that first, but I dont have access?!?! Any ideas? 

    EDIT: Downloaded Windows6.0-KB942288-v2-x86.msu as directed by the Microsoft Website:
    Download the file that is appropriate for your operating system version and platform.

    For Windows Vista, Windows Vista Service Pack 1 and Windows Server 2008:
    x86 Platform: Windows6.0-KB942288-v2-x86.msu
    x64 Platform: Windows6.0-KB942288-v2-x64.msu
    IA64 Platform: Windows6.0-KB942288-v2-ia64.msu

    When I try to install it I get the error message "This update does not apply to your system." Even though thats the update it tells me to get. Vista and Server 2008 seem to be more trouble then they are worth.
    • Edited by Mazter Jedi Thursday, October 30, 2008 4:56 PM
    Thursday, October 30, 2008 4:49 PM

Answers

  • Hello, 
     

    According to the error message "the update does not apply to your system", it seems that the wrong update package was installed to the system. Could you please verify that the version of the updated package is identical to the operation system?

    Please follow the steps to test if it works for you.

    Method 1:  Unregister and re-register the Windows Installer

    1. Click Start, click Run, type MSIEXEC /UNREGISTER , and then click OK.

    2. Click Start, click Run, type MSIEXEC /REGSERVER , and then click OK.

    3. Try the following msiexec command:

    msiexec /a  Windows6.0-KB942288-v2-x86.msu /lv C:\Test\KB942288.log


    Method 2:  Give Full Control permission to the SYSTEM account

    1. Start Windows Explorer, right-click the computer's root hard drive, and then click Properties.

    2. Click the Security tab, and then click Add.

    3. In the Select Users, Computers, or Groups dialog box, click the SYSTEM account, click Add , and then click OK.

    4. Under Allow, click to select the Full Control check box, and then click OK.

    5. Click the TEMP folder and then verify that the SYSTEM account has full control.


    If the issue still exists, please refer to the following steps to perform a clean boot and then check if the package can be installed.


    Step: Perform a Clean Boot
     

    1. Click "Start", go to "Run", and type "msconfig" in the open box to start the System Configuration Utility.

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4.  Restart your computer. When the "System Configuration Utility" window appears, please check the box and click "OK".

    If possible, you may send the log to tfwst@microsoft.com

    Hope it helps.


    David Shen - MSFT
    • Edited by David Shen Wednesday, November 05, 2008 1:31 AM modify
    • Marked as answer by David Shen Thursday, November 06, 2008 1:51 AM
    Tuesday, November 04, 2008 6:49 AM
  • Hi,

    Are you running x86 or x64 Windows Server 2008?
    I see no reason not to install x64 versions og Windows Server and SQL.

    It seems that you are running x64 because of the fault installing the x86 version of the update.
    Please verify the OS version and download the correct version.

    Jens Ole Kragh
    • Proposed as answer by David Shen Monday, November 03, 2008 9:36 AM
    • Marked as answer by David Shen Thursday, November 06, 2008 1:51 AM
    Friday, October 31, 2008 9:40 AM

All replies

  • Hi,

    Are you running x86 or x64 Windows Server 2008?
    I see no reason not to install x64 versions og Windows Server and SQL.

    It seems that you are running x64 because of the fault installing the x86 version of the update.
    Please verify the OS version and download the correct version.

    Jens Ole Kragh
    • Proposed as answer by David Shen Monday, November 03, 2008 9:36 AM
    • Marked as answer by David Shen Thursday, November 06, 2008 1:51 AM
    Friday, October 31, 2008 9:40 AM
  • It is for sure the 32bit version (x86). Even tried running the 64bit update just for kicks and giggle and course I get the same error. Still stuck.
    Monday, November 03, 2008 1:40 PM
  • Hello, 
     

    According to the error message "the update does not apply to your system", it seems that the wrong update package was installed to the system. Could you please verify that the version of the updated package is identical to the operation system?

    Please follow the steps to test if it works for you.

    Method 1:  Unregister and re-register the Windows Installer

    1. Click Start, click Run, type MSIEXEC /UNREGISTER , and then click OK.

    2. Click Start, click Run, type MSIEXEC /REGSERVER , and then click OK.

    3. Try the following msiexec command:

    msiexec /a  Windows6.0-KB942288-v2-x86.msu /lv C:\Test\KB942288.log


    Method 2:  Give Full Control permission to the SYSTEM account

    1. Start Windows Explorer, right-click the computer's root hard drive, and then click Properties.

    2. Click the Security tab, and then click Add.

    3. In the Select Users, Computers, or Groups dialog box, click the SYSTEM account, click Add , and then click OK.

    4. Under Allow, click to select the Full Control check box, and then click OK.

    5. Click the TEMP folder and then verify that the SYSTEM account has full control.


    If the issue still exists, please refer to the following steps to perform a clean boot and then check if the package can be installed.


    Step: Perform a Clean Boot
     

    1. Click "Start", go to "Run", and type "msconfig" in the open box to start the System Configuration Utility.

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4.  Restart your computer. When the "System Configuration Utility" window appears, please check the box and click "OK".

    If possible, you may send the log to tfwst@microsoft.com

    Hope it helps.


    David Shen - MSFT
    • Edited by David Shen Wednesday, November 05, 2008 1:31 AM modify
    • Marked as answer by David Shen Thursday, November 06, 2008 1:51 AM
    Tuesday, November 04, 2008 6:49 AM
  • Thanks for the reply and the valuable information. I went ahead and installed SQL Server 2005 since I was familiar with it, although I wanted to get to know SQL 2008. I will keep this post in mind for when I do have to use SQL 2008. Thanks again!
    Thursday, November 06, 2008 2:15 PM