none
Some settings are managed by your system administrator

    Question

  • In Internet Explorer 7, the Security tab of the Internet Options dialog box displays the following message to indicate that settings are managed by the system administrator:
    Some settings are managed by your system administrator
    I am the system administrator but don't know how to remove this message "Some settings are managed by your system administrator".Can someone teach me?
     
    Wednesday, March 04, 2009 6:50 AM

Answers

  • hi TOH

    tim is absolutely correct, and i would like to provide you the explanation abou the erroro 

    IE7 "Some settings are managed by your system administrator"

    With Internet Explorer 6.0 troubleshooting zones could be problematic if the administrator you are working with forgets to inform you that they have implemented "Security Zones: Use only machine settings" via GPO or a direct registry change.

    Location: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings

    Name: Security_HKLM_only

    Type: REG_DWORD

    Value: 1 <-Enabled 0 <-Disabled

    By default the value is not present and thus is disabled by default.

    With Internet Explorer 7.0 the UI has been updated to reflect the presences of Security_HKLM_only and if the feature is ENABLED. The visual notification is a big win for IE7 troubleshooting.

    Note the yellow bar at the bottom of the dialog. "Some settings are managed by your system administrator". This is your clue that you are dealing with Security_HKLM_only. The bonus is you can not make modifications to any of the zones, note the Custom level, Default level, and the Reset all zones to default level are grayed out.

    Clicking the link labeled "settings" brings up the help file with the following:

    Why won't Windows allow me to change a system setting?

    If your computer is part of a network at an organization such as a school or a business, your organization's system administrator might have disabled or even removed certain settings by using Group Policy. Group Policy is a feature of Windows that lets system administrators manage users' access to Windows features. If you suspect that Group Policy is preventing you from changing a setting that you need to access, contact your system administrator.

    For more information about Group Policy settings, visit the Microsoft TechNet (http://technet.microsoft.com) website.

    LINK: KB182569 Description of Internet Explorer security zones registry entries


    sainath Windows Driver Development
    Thursday, March 05, 2009 5:26 AM
  •  

    H,

     

    Please try blow:

     

    1.    Click Start, type gpedit.msc and press Enter.

    2.    Locate to Computer Configuration -> Administrative Templates -> Windows Components -> Internet Explorer.

    3.    Double-click “Security Zones: Do not allow users to change policies” on the right pane

    4.    Choose “Not Configured” and click OK.

    5.    Restart the computer and test the result.

     

    You can also delete the registry key “Security_HKLM_only” under HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet

    Settings directly.

     

    If the issue persists, I would like to confirm when this issue began to occur. Have any changes been made on your computer recently? Is your computer in a domain?

     

    Tim Quan - MSFT

     

    Thursday, March 05, 2009 2:49 AM
    Moderator

All replies

  •  

    H,

     

    Please try blow:

     

    1.    Click Start, type gpedit.msc and press Enter.

    2.    Locate to Computer Configuration -> Administrative Templates -> Windows Components -> Internet Explorer.

    3.    Double-click “Security Zones: Do not allow users to change policies” on the right pane

    4.    Choose “Not Configured” and click OK.

    5.    Restart the computer and test the result.

     

    You can also delete the registry key “Security_HKLM_only” under HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet

    Settings directly.

     

    If the issue persists, I would like to confirm when this issue began to occur. Have any changes been made on your computer recently? Is your computer in a domain?

     

    Tim Quan - MSFT

     

    Thursday, March 05, 2009 2:49 AM
    Moderator
  • hi TOH

    tim is absolutely correct, and i would like to provide you the explanation abou the erroro 

    IE7 "Some settings are managed by your system administrator"

    With Internet Explorer 6.0 troubleshooting zones could be problematic if the administrator you are working with forgets to inform you that they have implemented "Security Zones: Use only machine settings" via GPO or a direct registry change.

    Location: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings

    Name: Security_HKLM_only

    Type: REG_DWORD

    Value: 1 <-Enabled 0 <-Disabled

    By default the value is not present and thus is disabled by default.

    With Internet Explorer 7.0 the UI has been updated to reflect the presences of Security_HKLM_only and if the feature is ENABLED. The visual notification is a big win for IE7 troubleshooting.

    Note the yellow bar at the bottom of the dialog. "Some settings are managed by your system administrator". This is your clue that you are dealing with Security_HKLM_only. The bonus is you can not make modifications to any of the zones, note the Custom level, Default level, and the Reset all zones to default level are grayed out.

    Clicking the link labeled "settings" brings up the help file with the following:

    Why won't Windows allow me to change a system setting?

    If your computer is part of a network at an organization such as a school or a business, your organization's system administrator might have disabled or even removed certain settings by using Group Policy. Group Policy is a feature of Windows that lets system administrators manage users' access to Windows features. If you suspect that Group Policy is preventing you from changing a setting that you need to access, contact your system administrator.

    For more information about Group Policy settings, visit the Microsoft TechNet (http://technet.microsoft.com) website.

    LINK: KB182569 Description of Internet Explorer security zones registry entries


    sainath Windows Driver Development
    Thursday, March 05, 2009 5:26 AM
  • I have the same problem which started when I installed IE 8.  It is on one computer on a workgroup network.  The 6 computers use MS OneCare administrered in two Circles.  I tried Tim's solution but the setting was already set to "disabled".  My problem appears two ways: 1.  In IE8, I click on Tools\Internet Options I get a message "This operation has been cancelled due to restrictions in effect on this computer.  Please contact your system administrator."  2. When I click on Internet Options in Control Panel, I at least see the Internet Properties window but it has the message "Some settings are managed by your system administrator." There is no indication that any of the settings on any of the Tabs are restricted. 
    Sunday, April 05, 2009 3:13 PM
  • hi TOH,

            when i upgrade my IE 6 to IE 8 , in my internet option always i found the message " Some settings are managed by your system administrator" so i follwed your steps to remove the message but
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows after this i cannot able to find current version under the windows so how i can found  security_HKLM_only, tell me how to remove this message.
                       
    Monday, October 19, 2009 3:15 AM
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings]
    "ProxySettingsPerUser"=dword:00000001

    try this
    • Proposed as answer by Dani Erlich Wednesday, December 16, 2009 9:10 AM
    Tuesday, December 08, 2009 5:12 PM
  • Close.

    Hi everyone, I had this problem and I managed to solve it !!!!

    After upgrading Windows XP Pro to service pack 3 and upgrading internet explorer 8 I also couldn't nothing with the annoying announcement "some setting are managed by your system administrator" !!!

    Well...
    It goes like this
    In gpedit you dont need to enter, its no use.

    You need to enter RUN - 'REGEDIT'

    In regedit go to:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel

    In control panel you need to change all the keys to 0 !!!
    I know 0 should do disabled but that what I did and it works :D
    No restart is needed, just do it and close REGEDIT

    If somebody want some help you can contact me on - danierlich@gmail.com

    Yours.
    Computer Tech
    Dani Erlich, Israel.
    • Proposed as answer by Ali kalakech Tuesday, May 04, 2010 5:43 PM
    Wednesday, December 16, 2009 9:23 AM
  • I resolved the problem.  But it had nothing to do with IE or Microsoft.  I had a setting in SpyBot "Tools", "IE Tweaks" that was blocking access.
    Wednesday, December 16, 2009 7:32 PM
  • I have the same problem but this one is in a company domain. Somehow all the computers have this problem. I can't find it in the group policy, all the settings are set to not configured but still something blocks.

     

    Thanks in advance for your help.

    Kuby

    • Proposed as answer by Ali kalakech Tuesday, May 04, 2010 5:42 PM
    Friday, March 26, 2010 12:24 AM
  • Close.

    Hi everyone, I had this problem and I managed to solve it !!!!

    After upgrading Windows XP Pro to service pack 3 and upgrading internet explorer 8 I also couldn't nothing with the annoying announcement "some setting are managed by your system administrator" !!!

    Well...
    It goes like this
    In gpedit you dont need to enter, its no use.

    You need to enter RUN - 'REGEDIT'

    In regedit go to:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel

    In control panel you need to change all the keys to 0 !!!
    I know 0 should do disabled but that what I did and it works :D
    No restart is needed, just do it and close REGEDIT

    If somebody want some help you can contact me on - danierlich@gmail.com

    Yours.
    Computer Tech
    Dani Erlich, Israel.

    This workt well thanks.....
    Monday, August 16, 2010 12:09 AM
  • Yes Thanks so much.

     

    On my work windows xp sp3 machine that I have administrator rights to, this indeed works.

     

    "You need to enter RUN - 'REGEDIT'
    In regedit go to:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
    In control panel you need to change all the keys to 0 !!!
    I know 0 should do disabled but that what I did and it works :D
    No restart is needed, just do it and close REGEDIT"

     

    If I only set the advanced tab to zero, I could see the tab and all the settings, but not edit them.

    I realize that for Microsoft Moderators etc.., that this is a gray area telling someone to change something that possibly a computer policy administration group setup.

    However:

    1. If someone is searching for it, they (myself included) will have a good reason and be tenacious enough to get it resolved, thus withholding information is stifling someones ability to do their job possibly.  In my case, I'm a senior software developer and I was granted administrator access, but the tab was missing. I was using Firefox to debug Visual Studio C#...  Problem with that was :

    a:  not policy to use firefox
    b. 99% of users are on IE7
    c. Some previous developer wrote prototype ajax code that did not work in firefox and only IE, and for me to place breakpoints in Visual Studio was pointless if I used IE, as IE advanced tab had debugging turned off.  Thus this severely impacted the ability to do my job.  Without breakpoints and stepping through my code, I might as well be doing PHP or Coldfusion.....  ughhh
    d.  If I need to place the code in a batch file and schedule it to run daily in case group policies get pushed daily then that is what I will do. 

    e.  Sometimes in order to get our jobs done my have to bend or break the rules...  I found out that at work there is an exceptions list, but it will take a least a few weeks or more to get approved etc..

    f. It is sad that the Microsoft folks have answers that do not work, or that ask us to ask our sys. admins   .  Let us the users deal with the fallout of our work or home registry setting changes.

     

    Thanks Dani Erilich!

     

     

     

     

     

    Tuesday, December 28, 2010 5:35 PM
  • Thank you, it also work on IE8. 

     

    Saturday, February 12, 2011 2:44 AM
  • Yes, I made changes from Workgroup to Domain, from then this does not work. I have Windows 7 Enterprise with SP1 on my machine.
    Monday, February 28, 2011 9:56 AM
  • thanks alot

    it works very well

    Friday, July 29, 2011 8:34 AM
  • I have Windows XP Home edition with service pack 3 installed and have the same problem.

    The following registry entries do NOT exist:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings

    So what else can be causing it?

    Tuesday, July 17, 2012 6:24 AM
  • To tell you the truth when i had the computer i jumped in with two feet and can remember putting domain somewhere,but cannot seem to find it now,really dont know what i am doing most of the time and have my head in my hands more hours in the day than usuall all down to this computer which i wanted very much at the time,now it's just head in hands all the time
    Monday, August 06, 2012 1:56 PM
  • The solution from Dani does solve many problems but not all of them are removed for me when I follow Dani,

    Tab "Security" still has "Site" button disabled

    Tab "Programs" the button "Make default" and "Manage add-ons" are disabled

    But my problem with changing connections is working so thanks to Dani.

    Friday, April 26, 2013 10:21 AM
  • I am not seeing any program or editor named as "gpedi.msc"
    What to do please tell me..
    Thursday, May 02, 2013 9:47 AM
  • I am only watching cache in internet settings.
    Not seeing security_HKLM_only
    What to do..?

    Thursday, May 02, 2013 9:50 AM
  • I am not seeing any program or editor named as "gpedi.msc"
    What to do please tell me..

    I think you mean gpediT.msc
    Thursday, June 06, 2013 9:06 AM
  • Type gpedit.msc in Run(Ctrl+R)

    HTH..


    Thanks, Satish Bommideni "Success usually comes to those who are too busy to be looking for it."

    Thursday, August 01, 2013 7:56 AM
  • This solves the issue on non-Pro systems (XP home, Vista home, etc). Thanks for your help!
    Saturday, August 31, 2013 3:50 PM
  • This worked but the setting is under HKLM  not Current user in Vista home prem.

    I also set HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet

    to 0

    Thanks

    Wednesday, September 25, 2013 7:29 PM
  • I did this and it worked like a charm.  Of all the things I've tried today this is the only one that took the message out of the settings for IE!  Thanks for the help you just made my day!
    Wednesday, May 21, 2014 4:19 PM