none
Cannot connect to Server 2003 using RDP after installing updates

    Question

  • For a variety of reasons which I won't bore you with, I have Automatic Updates turned off on my servers and periodically run Microsoft Updates manually. Yesterday, I updated two of my Windows 2003 servers with all critical updates. After installing the updates and restarting the servers, I can no longer connect to either server using a Remote Desktop Connection. I have tried unsuccessfully to connect from my desktop PC (WinXPSP3), one of the servers that was updated and one of the servers that was NOT updated. The Terminal Services service is running on the two updated servers. I can successfully connect from my desktop to any of my other servers that I have not updated.

    Any suggestions would be appreciated.

    Kenny Goodson
    Director of Computer Services
    Northeast Texas Community College
    Wednesday, September 24, 2008 3:33 PM

Answers

  • What happens if you reboot a second time, does it come back?  You could also take a look at this from Vera's site:

    Q: My Terminal Server does not respond after a reboot. How do I solve this?
    Last modified: August 10, 2008

    A: First of all, make sure that the server really performed a reboot (you can check this in the EventLog). If it didn't, and you tried to perform the reboot through a remote session, you are probably suffering of the issue described here:

    930045 - A Windows Server 2003-based computer stops responding when you shut down the computer in a remote console session

    But if the server did reboot, it could be that there is a race condition between the TermService service and TermDD. This happens sometimes when servers are patched or new software is installed and the startup sequence changes. When the TermService service starts up before TermDD, the listener seems to be working but it doesn't. The workaround for this is to add TermDD to the list of dependencies in

       HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\DependOnService
    so the list becomes RPCSS followed by TermDD.

    You can remotely reboot the server from the command line with:

       shutdown.exe /m \\RemoteServer /r /t 00 /f

    Wednesday, September 24, 2008 5:26 PM
  • My reply was not supposed to bee posted as "proposed Answer"
    But I have now found the problem, and somtimes the solution is mutch easyer than we think......

    Right  Clik My Computer
    Select System Properties
    Select Remote, an select Enable Remote Desktop on this computer
    And then reboot.

    I guess this option was removed during my uppgrade....


    Why din't I think of that when i worked untid 04:30 last night.........

    Saturday, October 11, 2008 6:48 PM

All replies

  • What happens if you reboot a second time, does it come back?  You could also take a look at this from Vera's site:

    Q: My Terminal Server does not respond after a reboot. How do I solve this?
    Last modified: August 10, 2008

    A: First of all, make sure that the server really performed a reboot (you can check this in the EventLog). If it didn't, and you tried to perform the reboot through a remote session, you are probably suffering of the issue described here:

    930045 - A Windows Server 2003-based computer stops responding when you shut down the computer in a remote console session

    But if the server did reboot, it could be that there is a race condition between the TermService service and TermDD. This happens sometimes when servers are patched or new software is installed and the startup sequence changes. When the TermService service starts up before TermDD, the listener seems to be working but it doesn't. The workaround for this is to add TermDD to the list of dependencies in

       HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\DependOnService
    so the list becomes RPCSS followed by TermDD.

    You can remotely reboot the server from the command line with:

       shutdown.exe /m \\RemoteServer /r /t 00 /f

    Wednesday, September 24, 2008 5:26 PM
  • I have the same problem, and i tried what you proposed Jeff.
    But it still don't work.
    OS: Win2003 std. edition 32bit. with sp2
    After installing SP2, MPIO 3.0 and MS patch KB940467.
    I rebooted betwen installing this patces, but i did it remote with shutdown /m \\computername /f /r
    And now i am not able to connect to the computer with RDP.
    There are no error messages in the event log.
    The Terminal services service is running.
    And i have rebooted several times.
    By running nbtstat i can see that the server is not listening on the RDP port.
    The firewall service is dissabled.

    The 2 servers that i have this problem with is web servers, and they are working properly (exept RDP)....

    Anny one have anny sugestions ??
    • Proposed as answer by jbra Saturday, October 11, 2008 6:40 PM
    • Edited by jbra Saturday, October 11, 2008 6:41 PM
    Saturday, October 11, 2008 6:11 PM
  • My reply was not supposed to bee posted as "proposed Answer"
    But I have now found the problem, and somtimes the solution is mutch easyer than we think......

    Right  Clik My Computer
    Select System Properties
    Select Remote, an select Enable Remote Desktop on this computer
    And then reboot.

    I guess this option was removed during my uppgrade....


    Why din't I think of that when i worked untid 04:30 last night.........

    Saturday, October 11, 2008 6:48 PM
  • That was exactly the problem, thank you very much for providing the solution!  Some servers only needed another reboot, but the Exchange server was not playing nice...
    Tuesday, September 11, 2012 6:35 PM