none
RemoteFX Windows Server 2012 RC - None of the GPUs on this computer support RemoteFX

    Question

  • No matter what I've tried, I cannot enable RemoteFX on Server 2012. When I open Hyper-V Manager, right-click on Hyper-V Settings, and click on Physical GPUs, I see the message:

    "None of the physical graphics processing units (GPUs) on this computer support RemoteFX. Use of RemoteFX 3D adapter requires at lease one physical GPU that supports RemoteFX."

    I'm using a computer with an i7 processor, 6GB RAM, and a Nvidia Quadro FX 4800. Also, I have an ASUS motherboard with no on-board video. Here are some of the things I've done:

    • Installed RDS using Quick Start, Virtual-desktop install
    • Installed the latest Windows 8 drivers of Quadro 4800. (Also tried the Server 2008 drivers at one point.)
    • Installed the Remote Desktop Session Host (which for some reason doesn't install when you use the RDS wizard)
    • I've tried reinstalling the OS numerous times.
    • Tried a different graphic card (Nvidia GeForce 260). The card is ~4 years old, but I got it working with RemoteFX on Server 2008. Once I tried it with Server 2012, it didn't work.

    One more observation:

    • An article I read says that server must support VM Monitor Mode Extensions, SLAT extensions, virtualization enabled and DEP which can be found in the System Information app. When I first install the OS, these fields are marked as Yes, but once I install Hyper-V (separately or using the RDS install wizard), these fields disappear and are replaced by the text: A hypervisor has been detected. Features required for Hyper-V will not be displayed. In the article, it says this text is usually an indication that the machine that the OS is installed on is virtual. Not sure if this is actually an issue.

    I feel like I'm missing something really simple. Like I said, I've gotten RemoteFX working on Server 2008.

    Thanks.






    Tuesday, July 31, 2012 4:02 AM

Answers

  • This seems like a driver problem, as you are all using NVidia cards.  If you have an ATI card, can you try swapping out the card and see if that changes the message?

    Also, to clarify a few things on DX10 vs DX11.  Windows Server 2008 R2 RemoteFX required only DX10 and would work with DX11.  Windows Server 2012 now requires a DX11 card.


    Don Geddes - SR Support Escalation Engineer - Remote Desktop Services - Printing and Imaging

    • Marked as answer by lepstein2007 Wednesday, August 01, 2012 7:11 PM
    Wednesday, August 01, 2012 5:21 PM

All replies

  • Lepstein, 

    I think Nvidia is still catching up on the remote extensions for Windows 8 drivers.  I would expect to have to wait for an upcoming set of drivers or a server patch to fix the issue (although this is just my speculation).  As far as I know the only requirement of the video card is that it needs to be DX 11 compatible.  Check against dxdiag just to make sure.  Also check your device manager to make sure there are no 'unknown devices'.  Also what type of OS is on the VM, is it Windows 8 RC?


    My Blog: http://www.montavesta.net

    Tuesday, July 31, 2012 4:09 PM
  • Hi David,

    When I run dxdiag, it says the DirectX version is DirectX 11. (I thought the Quadro FX 4800 was one of the "officially" supported cards that is supposed to work with RemoteFX, so I would assume its DX11 compatible as well.)

    There is one "Other Device" in Device Manager but it's a Bluetooth device that doesn't have Windows 8/2012 drivers yet. I doubt this should mess up RemoteFX functionality, but I'll disconnect it when I get a chance.

    I've installed 2 VMs. One was a Windows 8 machine found here: http://windows.microsoft.com/en-US/windows-8/download. And the other was a Windows 7 Ultimate machine. I did hear that you need a specific version (Enterprise) of Windows 8 for RemoteFX to work. But I'm not even getting to the point of enabling RemoteFX on the VMs, since Hyper-V won't recognize my GPU in Hyper-V Settings as being RemoteFX compatible. (I.e. RemoteFX is greyed out on the VM Settings menu.) Please let me know if I'm being unclear.

    Thanks

    Tuesday, July 31, 2012 6:19 PM
  • Hi Lepstein,

    I have the same problem here. Got a FX3700, GT220 and a GS4000 but I can't get it to work. Same message, grayed out. I used these cards in w2k8r2 without any problems. The driver 302.82 is using the WDDM1.20 and SLAT etc is available. Also dxdiag.exe shows no problems.

    Greetz
    Peter

    Wednesday, August 01, 2012 4:31 PM
  • This seems like a driver problem, as you are all using NVidia cards.  If you have an ATI card, can you try swapping out the card and see if that changes the message?

    Also, to clarify a few things on DX10 vs DX11.  Windows Server 2008 R2 RemoteFX required only DX10 and would work with DX11.  Windows Server 2012 now requires a DX11 card.


    Don Geddes - SR Support Escalation Engineer - Remote Desktop Services - Printing and Imaging

    • Marked as answer by lepstein2007 Wednesday, August 01, 2012 7:11 PM
    Wednesday, August 01, 2012 5:21 PM
  • I think the DirectX version might be the issue. Nvidia's specs on the Quadro FX 4800 say the card supports up to DX10.
    Wednesday, August 01, 2012 7:16 PM
  • Well it seems that none of my cards support directx11....ppff...ty Microsoft...buying new card....
    Wednesday, August 01, 2012 7:38 PM
  • the card is dx11 compatible and has been for the last 6-7 months

    Driver for NVidia Quadro FX 4800

    * Support for newly announced Quadro 6000, Quadro 5000 and Quadro 4000. 
    * Adds support for CUDA 3.1 for improved performance in GPU Computing applications. See www.nvidia.co.uk/cuda for more details. 
    * Adds support for OpenGL 4.0 
    * Adds support for DirectX 11 
    * ECC State 
    o New page for GPUs that support ECC (error correction code). The page lets you 
    1. Change the Error Correction Code (ECC) state for GPUs. 
    2. View GPU memory details. 

    Sunday, December 02, 2012 5:56 AM
  • Same problem here with Quadro 5000 who is DX11!
    Remote FX was well working under Server 2008 R2 but no more with Server 2012.
    When installing the quadrodriver the GPU is selected under Hyper-V settings but greyed under VM, and when reboot there is no GPU listed anymore in Hyper-V settings. 

    Sunday, February 03, 2013 3:31 PM
  • Hi,

    To use RemoteFX I have following setting presents :
    --DirectX 11 capable graphics card
    --Windows 2012 64-bit WDDM v1.20 driver
    --Remote Desktop Virtualization Host role service must be installed (to enable RemoteFX).
    --Enable the GPU for RemoteFX

    I have added the RemoteFX 3d Video Adapter in Virtual Machine settings too.

    This is working fine when I am doing it on Windows 8 enterprise as a Virtual Machine Server .

    same is not working on Windows 2012 standard version as a virtual machine server.

    In device manager under display adapter it is not showing RemoteFX 3D Video Adapter.. it shows basic microsoft driver.

    can any one please suggest me what should I have to do??

    Thanks,

    Sharad

    Friday, April 12, 2013 5:39 AM
  • I have exactly the same Problem with my Installation.

    Have a AMD Radeon HD 6450 DX11 Ready and 1GB dedicated Memory.

    Installed the driver fine, but get the message that none of the GPU's support RemoteFX

    Tried the Driver only (inf files) and also with the whole catalyst set, but nothing helped so far.

    Very frustrating since i bought that Grafixcard only to enable RemoteFX.

    Thursday, October 17, 2013 6:33 AM
  • OK i could fix the Problem by using the Driver from here:

    http://msdn.microsoft.com/de-de/library/windows/apps/dn344644.aspx

    You have to use IE to download from the Windows Update Catalog.

    Basically you have to use at least WDDM 1.2 Drivers for your Graphic Card!

    Thursday, October 17, 2013 6:53 AM
  • When installing the quadrodriver the GPU is selected under Hyper-V settings but greyed under VM, and when reboot there is no GPU listed anymore in Hyper-V settings

    Ever find a resolution to this? I am having same symptoms. Have tried multiple drivers, powershell import commands.. Been searching this for weeks!!

    AMD FX-8120

    m5a88-v evo

    asus 6570-2gd3-l


    • Edited by nstobbe Wednesday, February 19, 2014 4:33 AM
    Wednesday, February 19, 2014 4:16 AM