none
Unable to print from windows 2008 R2 terminal server

    Question

  • Windows 2008 R2 terminal server configure as a workgroup is unble to print.

    I have multiple windows7 clients on a windows 2008 domain connecting with RDP client 6.1.76 to a windows 2008 r2 terminal server configure as a workgroup.

    Install .net framework 3.5.1. and I see the printers get redirected from the client to the server but all printers fail to print. I get error "test page fail to print. Would you like to view the print troubleshooter for assistance?" the print troubleshooter also fails.

    i have also install 64bit driver for Brother MFC 8480DN on the server.

    i have no clue what is missing....HELP! 

    Thank you in advance

     

    Friday, April 29, 2011 7:23 PM

Answers

  • Thank you for your reply.

     I disable the printer redirection and installed the network printers on the server.


    Dan Rodriguez
    • Marked as answer by dan1717 Tuesday, May 10, 2011 6:30 PM
    Tuesday, May 10, 2011 6:30 PM

All replies

  • Hi,

     

    RDS server first tries to use the Terminal Services Easy Print driver. If the client computer does not support this driver, the terminal server looks for a matching printer driver installed on the terminal server. You can either install a matching printer driver on the terminal server, or you can create a custom printer mapping file.

     

    If you choose the EasyPrint, please check the following items:

     

    1.       Group Policy must be correctly set to enable Easy Print on the Server. The policy location is “Computer Configuration -> Administrative templates -Windows Components -> Remote Desktop Services > Remote Desktop Session Host -> Printer Redirection”. The setting “Use Remote Desktop Easy Print printer driver first” must be set to “Enabled” for Easy Print redirection, and it has to be “Disabled” for Legacy Print. For “Not configured”, Easy Print is chosen by default.

    2.       Ensure that the spooler service is running on both the RDP client and Server.

    3.       If you connect over RD Gateway, ensure that the policy that disables printer redirection is turned off.

     

    If everything listed so far is correct and you still have a redirection problem, please check the event logs in the client and Server. Please post here, thanks.

     


    Technology changes life……
    • Marked as answer by dan1717 Tuesday, May 10, 2011 6:28 PM
    • Unmarked as answer by dan1717 Tuesday, May 10, 2011 6:28 PM
    Tuesday, May 10, 2011 3:34 AM
  • Thank you for your reply.

     I disable the printer redirection and installed the network printers on the server.


    Dan Rodriguez
    • Marked as answer by dan1717 Tuesday, May 10, 2011 6:30 PM
    Tuesday, May 10, 2011 6:30 PM