none
Changing Server Name in Inter site topology Generator

    Question

  • Dear All,

    I have done with the complete migration from one DC to another DC. the only problem residing is that the server name under the NTDS of site in Inter Site Topology Generator is same as server1(i.e old server name).

    I need to change the server name in Inter Site Topology generator as Server2 (i.e New server name).

    How Can i fix it? due to this i am facing replication issues.

    Please suggest.

    Thanks & Regards,

    Rashid Ali

    Friday, April 13, 2012 9:53 AM

Answers

  • Please see a similar discussion about this topic: http://social.technet.microsoft.com/Forums/eu/winserverDS/thread/df5c9360-cd66-4f49-bde4-76b11cb6b5cb


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Friday, April 13, 2012 9:57 AM
  • But you mentioned in the previous post that old server exist in the n/w?

    However if the server is removed from n/w as mentioned before if demotion was not graceful instances of old server will be present you need to run metadata cleanup to remove the same.

    Complete Step by Step Guideline to Remove an Orphaned Domain controller (including seizing FSMOs, running a metadata cleanup, and more)
    http://msmvps.com/blogs/acefekay/archive/2010/10/05/complete-step-by-step-to-remove-an-orphaned-domain-controller.aspx

    Also I would recommend to install the support tool and post the log as mentioned before.

    Hope this helps


    Best Regards,

    Sandesh Dubey.

    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator | My Blog

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, April 13, 2012 2:37 PM

All replies

  • Please see a similar discussion about this topic: http://social.technet.microsoft.com/Forums/eu/winserverDS/thread/df5c9360-cd66-4f49-bde4-76b11cb6b5cb


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Friday, April 13, 2012 9:57 AM
  • Hello,

    beside this ISTG part and if this is a single DC environment you have also to transfer the FSMO roles and reconfigure the time service on the old/new PDCEmulator DC. It is recommended to have at least 2 DC/DNS/GC per domain.


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Friday, April 13, 2012 10:13 AM
  • Additionally ,

     You can refer below link which might help you to narrow down the problem

    http://social.technet.microsoft.com/Forums/en-US/winserverDS/thread/52ac918a-b296-4c12-9eb1-1a11b3486429

    Regards,

    _Prashant_


    MCSA|MCITP SA|Microsoft Exchange 2003 Blog - http://prashant1987.wordpress.com Disclaimer: This posting is provided AS-IS with no warranties/guarantees and confers no rights. Email-giteepag@yahoo.co.in

    Friday, April 13, 2012 10:22 AM
  • As you mentioned that you migrated from one DC to another DC.Is that the old DC is removed from n/w and instances are present.Have you demoted the old DC and was the demotion graceful or foreceful?

    If the old server was demoted forcefully you need to run metadata cleanup to remove the instances from AD database,DNS,Ad sites and services.
    http://sandeshdubey.wordpress.com/2011/10/12/metadata-cleanup-of-a-domain-controller/

    If the old DC is not removed and you are seing server connection object same force the relication and check.KCC will create required topology or you can delete the connection object and run repadmin /kcc * and also run repadmin /syncall /AdeP to force the replication wait for someetime and see is the required topology created.


    I would also recommend to check the health of DC for any errors or warning.Check the event log and also run dcdiag /q and repadmin /replsum.

    Hope this helps


    Best Regards,

    Sandesh Dubey.

    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator | My Blog

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, April 13, 2012 10:35 AM
  • Thanks for all of you,

    I haven't yet demote the Old DC. and i had 2 DC's in the domain, i am a child domain in the world wide forest of our company.

    i want to demote the server after i configure the new DC completely.

    Sandesh i cannot run the given commands in cmd repadmin /kcc *  and  repadmin /syncall /AdeP.

     Please suggest.

    Regards, Rashid

    Friday, April 13, 2012 11:00 AM
  • So you have two DC in child domain and both Server as old server connection correct me if I am wrong.If possible can you post the screenshot of AD sites and services to get clear picture.

    Also the above command will not cause any issue,you can execute the same the choice is yours.What about the helath of DC after promotion also post the log of dcdiag and repadmin.


    Best Regards,

    Sandesh Dubey.

    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator | My Blog

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, April 13, 2012 11:12 AM
  • Sandesh,

    u are correct, i have the same situation. i dont install the support tools on my new server yet.

    i have removed the old server from the network already.

    Friday, April 13, 2012 2:34 PM
  • But you mentioned in the previous post that old server exist in the n/w?

    However if the server is removed from n/w as mentioned before if demotion was not graceful instances of old server will be present you need to run metadata cleanup to remove the same.

    Complete Step by Step Guideline to Remove an Orphaned Domain controller (including seizing FSMOs, running a metadata cleanup, and more)
    http://msmvps.com/blogs/acefekay/archive/2010/10/05/complete-step-by-step-to-remove-an-orphaned-domain-controller.aspx

    Also I would recommend to install the support tool and post the log as mentioned before.

    Hope this helps


    Best Regards,

    Sandesh Dubey.

    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator | My Blog

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, April 13, 2012 2:37 PM
  • Sandesh,

    u are correct, i have the same situation. i dont install the support tools on my new server yet.

    i have removed the old server from the network already.

    Hello Rashid.Ali,

    it would be nice if you can stick to one thread as you basically ask about the same domain change in multiple ones now.

    This is confusing and doubles the answers/questions asked from us more or less the same as in the other threads. So please close one thread if it is done and THEN go on with the next topic/problem.


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Saturday, April 14, 2012 11:42 AM
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.
     
    BTW, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.
     
    Best Regards
     
    Kevin


    TechNet Community Support

    Wednesday, April 18, 2012 1:31 AM
  • hi weber,

    I have tick the answers that suits for my scenario already. i think i have had the same thread in different exchange fourm by mistake but it has been answered here in windows forum.

    kevin,

    issue has really been resolved using same solutions that have been marked as answer. and it is always been helpful here on technet forums.

    Regards,

    Rashid

    Thursday, April 19, 2012 2:12 PM
  • Hi Rashid,

    Thanks for the feedback.

    Please feel free to create new thread if you encounter new problem in the future.

    Best Regards
     
    Kevin


    TechNet Community Support

    Friday, April 20, 2012 2:02 AM