none
Automatic discovery of DNS does not return my static IP address

    Question

  • How do I get the workstation's automatic DNS address to be the static IP address assigned on the server?  (Please see the description below for my issue - thanks )

    I have a development environment consisting of

    • 1 physical server (newly installed Windows Server 2012)
    • 1 physical workstation (Windows 7)

    The Windows Server performs the following roles:

    • AD DS
    • DHCP
    • DNS
    • File and Storage Services
    • Hyper-V
    • IIS

    I have assigned a static IP address (Let’s call it IP-1) to the server by changing the IPv4 properties of the Hyper-V Ethernet Adapter (via the Change Adapter Settings in Network and Sharing Center).

    However if the workstation is configured to obtain the DNS automatically then IP-2 is assigned instead of my expected IP-1

    (I have extracts of IPCONFIG /ALL done on both the server and workstation below showing my problem)

    In the DHCP Manager window (on the server) the explorer panel displays only 1 server BUT instead of the server’s name it displays the IP-2  address!  (This address was presumably assigned by the DHCP role wizard?)

    Question:

    How can I get the workstation to receive the static IP-1 address to be assigned dynamically?

     

     The following is from ipconfig /all  performed on the server

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter #2

       Physical Address. . . . . . . . . :

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : <some default address>(Preferred)

       IPv4 Address. . . . . . . . . . . : IP-1(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . :

       DHCPv6 IAID . . . . . . . . . . . :

       DHCPv6 Client DUID. . . . . . . . :

    The following is from ipconfig /all performed on the workstation

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : SURECOM EP-320X-R 100/10M PCI Adapter

       Physical Address. . . . . . . . . :

       DHCP Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : <same as on the server>(Preferred)

       IPv4 Address. . . . . . . . . . . : <assigned correctly by DHCP>(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Lease Obtained. . . . . . . . . . :

       Lease Expires . . . . . . . . . . :

       Default Gateway . . . . . . . . . :<assigned correctly by DHCP>

       DHCP Server . . . . . . . . . . . : <IP-1> as expected

       DHCPv6 IAID . . . . . . . . . . . :

       DHCPv6 Client DUID. . . . . . . . :

       DNS Servers . . . . . . . . . . . : <IP-2> NOT EXPECTED  This is causing me connectivity issues!

       Primary WINS Server . . . . . . . : <IP-1> NOT EXPECTED

       NetBIOS over Tcpip. . . . . . . . : Enabled

    Thursday, February 07, 2013 11:23 PM

Answers

  • Hi,

    I'm not sure what you mean by the explorer panel in the DHCP console displaying the wrong address instead of the server name. According to the workstation, the DHCP server is correct (indicated by the ipconfig you posted).

    You need to modify the DHCP scope to configure the DNS "option" settings. You probably clicked through this when you got to that page in the wizard, but it's easy to go back and change it.

    Open the DHCP console and expand the scope until you see the Scope Options container.


    Double-click on 006 DNS Servers.


    Under IP address, highlight the address you want to remove and click Remove. Then type the address you want and click Add. Click OK when you are done.

    Now go to the client and from an elevated command prompt issue an ipconfig/release and then ipconfig/renew. That should do it.

    -Greg

    P.S. Click option 44 and delete the WINS server if you don't want that. You can just right-click and then click Delete.

    P.S.S. If you add the DHCP server role before you configure a static IP address on the server, the only address the server will know about is the loopback address, which is 127.0.0.1 for IPv4 and ::1 for IPv6. This address can be added to the DHCP scope as a DNS server and cause problems if you don't notice it when going through the wizard. DHCP clients will then be told to use 127.0.0.1 for DNS, which in this case is their own loopback interface. To prevent this, configure a static address on the server first before installing role services like DNS and DHCP.


    Friday, February 08, 2013 1:35 AM

All replies

  • .. I missed the DNS information in the IPCONFIG /ALL extract for the server, so here is the extract again with the missing information:

     The following is from ipconfig /all  performed on the server

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter #2

       Physical Address. . . . . . . . . :

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : <some default address>(Preferred)

       IPv4 Address. . . . . . . . . . . : IP-1(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . :

       DHCPv6 IAID . . . . . . . . . . . :

       DHCPv6 Client DUID. . . . . . . . :

       DNS Servers . . . . . . . . . . . : ::1

                                           127.0.0.1

       NetBIOS over Tcpip. . . . . . . . : Enabled

    Thursday, February 07, 2013 11:31 PM
  • Hi,

    I'm not sure what you mean by the explorer panel in the DHCP console displaying the wrong address instead of the server name. According to the workstation, the DHCP server is correct (indicated by the ipconfig you posted).

    You need to modify the DHCP scope to configure the DNS "option" settings. You probably clicked through this when you got to that page in the wizard, but it's easy to go back and change it.

    Open the DHCP console and expand the scope until you see the Scope Options container.


    Double-click on 006 DNS Servers.


    Under IP address, highlight the address you want to remove and click Remove. Then type the address you want and click Add. Click OK when you are done.

    Now go to the client and from an elevated command prompt issue an ipconfig/release and then ipconfig/renew. That should do it.

    -Greg

    P.S. Click option 44 and delete the WINS server if you don't want that. You can just right-click and then click Delete.

    P.S.S. If you add the DHCP server role before you configure a static IP address on the server, the only address the server will know about is the loopback address, which is 127.0.0.1 for IPv4 and ::1 for IPv6. This address can be added to the DHCP scope as a DNS server and cause problems if you don't notice it when going through the wizard. DHCP clients will then be told to use 127.0.0.1 for DNS, which in this case is their own loopback interface. To prevent this, configure a static address on the server first before installing role services like DNS and DHCP.


    Friday, February 08, 2013 1:35 AM
  • Thanks Greg that was just what I needed !!
    Friday, February 08, 2013 2:24 AM