none
Corrupt User profile win 7

    Question

  • I have a user with a win 7 pro machine on a windows 2003 roaming profiles network the profile got corrupt and I had to recreated the user in AD I put the profile in the spot where it goes in ad of the user profile tab pointed to the user profile share. Well when i log on to the users station with the user new profile. I get the message "You have been logged on with a temp profile" Why wont this work?? any help is greatly appreciated in advance

     

    Ehunt

    Saturday, October 29, 2011 3:15 AM

Answers

  • It seems to be the permission issue.Have you upgraded the PC to windows7.If this is the case,users did not have adequate permissions on the profile share root folder.Check is the userid.v2 profiles is created and have sufficient rights.

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    • Marked as answer by MI32 Sunday, October 30, 2011 7:29 PM
    Saturday, October 29, 2011 3:27 AM
  • If you have recreated the user in AD then you need to follow below step as well.

    1. Restart your PC to release the locks on your profiles.
    2. Log on with another administrative account.
    3. Delete C:\Users\%username%
    4. Delete C:\Users\TEMP
    5. Delete the registry key matching your SID from
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\ProfileList. Check the value ProfileImagePath to make sure you pick your own profile.
    6. Restart once again and then you are done!

    Note kindly take the backup of registry and profile before you proceed.

    Hope this helps.

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    • Marked as answer by MI32 Sunday, October 30, 2011 7:29 PM
    Saturday, October 29, 2011 3:36 AM
  • Try to take the ownership of the root folder or root drive, it seems that the ownership of the drive is with trusted installer service.

    Note:In the Windows Server® 2008 and Windows Vista® operating systems, most of the operating system files are owned by the TrustedInstaller security identifier (SID), which is the only SID that has full control over them. The purpose is to prevent a process that is running as an administrator or under the LocalSystem account from automatically replacing the operating system files. To delete an operating system file, you need to take ownership of the file and then add an access control entry (ACE) on the file that permits you to delete it.

    Reference KB:http://technet.microsoft.com/en-us/library/cc731677(WS.10).aspx

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    • Marked as answer by MI32 Sunday, October 30, 2011 7:29 PM
    Sunday, October 30, 2011 2:18 AM

All replies

  • It seems to be the permission issue.Have you upgraded the PC to windows7.If this is the case,users did not have adequate permissions on the profile share root folder.Check is the userid.v2 profiles is created and have sufficient rights.

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    • Marked as answer by MI32 Sunday, October 30, 2011 7:29 PM
    Saturday, October 29, 2011 3:27 AM
  • Hi,

    As this is a roaming profile, please clear the roaming part of the profile on server.

    On the client computer please also check the Registry branch which is mentioned in below KB.

    Did you try the steps in blow article?
    http://support.microsoft.com/kb/947215

    Also check this: http://blog.hpxn.net/2011/02/23/windows-7-corrupted-user-profile/

    Regards,
    Abhijit Waikar.
    -------------------------------
    MCSA|MCSA:Messaging|MCTS|MCITP:SA
    My Blog: http://abhijitw.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.


    Saturday, October 29, 2011 3:28 AM
  • Ensure that the user is the OWNER of the their profile folder and domain users will need full control of the root folder so that a new folder can be created.

    If you are migrating exisiting XP users, there will be a new profile folder created because windows vista and above use new user profile configs that are <username>.V2 on the server.

    For instance, in our network we have a network share \\server\user.profiles$ and then all users have a subfolder under here.  The Domain Users group has full control on the \\server\user.profiles$ folder and then they have full control and are the owner of their \\server\user.profiles$\username and \\server\user.profiles$\username.v2

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    Saturday, October 29, 2011 3:29 AM
  • If you have recreated the user in AD then you need to follow below step as well.

    1. Restart your PC to release the locks on your profiles.
    2. Log on with another administrative account.
    3. Delete C:\Users\%username%
    4. Delete C:\Users\TEMP
    5. Delete the registry key matching your SID from
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\ProfileList. Check the value ProfileImagePath to make sure you pick your own profile.
    6. Restart once again and then you are done!

    Note kindly take the backup of registry and profile before you proceed.

    Hope this helps.

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    • Marked as answer by MI32 Sunday, October 30, 2011 7:29 PM
    Saturday, October 29, 2011 3:36 AM
  • Try this KB article:

    http://support.microsoft.com/kb/947215

    Since this question is more related to Windows 7, you may want post this question in the Windows 7 Forum:

    http://social.technet.microsoft.com/Forums/en/category/w7itpro


    Santhosh Sivarajan | MCTS, MCSE (W2K3/W2K/NT4), MCSA (W2K3/W2K/MSG), CCNA, Network+| Houston, TX
    Blogs - http://blogs.sivarajan.com/

    FaceBook Twitter LinkedIn SS Tech Forum

    This posting is provided AS IS with no warranties,and confers no rights.
    Saturday, October 29, 2011 7:20 PM
  • Okay everyone first off thank you all for your time and help. I have gone to the registry and removed the SID. I removed the old corrupt profile on the users machine and rebooted and still get the same message I posted about. Do I need to create a user account on the users local machine in user accounts? and then log off as admin and then log on as user and it will create the profile? I am confused ...also when I go on the server and go to the share drive for the user profiles and try to access the .v2 folder for this user it says access denied??? as with all the folders I am the domain admin? I took this network over from the last guy that left and its a mess ...

    Also Abhijit Waiker  you said As this is a roaming profile, please clear the roaming part of the profile on server. I am not sure how to do this in windows 2003 can you please elaborate....thanks

    Thanks Ehunt


    • Edited by MI32 Saturday, October 29, 2011 9:03 PM
    Saturday, October 29, 2011 8:34 PM
  • The v2 extension was added after vista came out

    google "Managing Roaming User Data Deployment Guide" that white paper has a lot more info on the v2 profiles.

    More info here http://blogs.msdn.com/spatdsg/archive/2007/03/15/vista-and-mandatory-profiles.aspx

     ...so it is normal and has changed per Microsoft.

    On server 2008, the .v2 profile is created because your roaming profile points to a folder that already exists.

    In 2003, you might have had c:\users\usernames because that made sense.

    But in 2008 (and vista and 7) C:\users already exists, and is where "documents and settings" was moved to.

    so your roaming profile is trying to co-exist in the middle of a system-default profile location. here, the permissions are so screwed up, it creates a .v2 folder. you'll see this if you try to browse around a users profile as a domain admin, all kinds of "you don't have permission" junk.

    Your best bet is to move all your roaming profiles to something OTHER than c:\users.... call it like, c:\profiles instead. Refer below for more details: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_27265559.html

    Reference article for roaming profile:http://www.grouppolicy.biz/2010/08/best-practice-roaming-profiles-and-folder-redirection-a-k-a-user-virtualization/ 

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    Sunday, October 30, 2011 12:54 AM
  • Sandesh,

         Thanks for your reply but how do i get this users profile working not that I have followed the steps recommended?

    and it still doesnt work
    • Edited by MI32 Sunday, October 30, 2011 1:27 AM
    Sunday, October 30, 2011 1:18 AM
  • You need to take the ownership of the folder and explicitly add the userid and administrator id with full permission since you are getting access diened issue while acessing the user profile on the server.

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    Sunday, October 30, 2011 1:24 AM
  • If i cant get access to the \\server\userprofile\username folder because it is denied then when i go into the sharing and security to change the permission and take ownership it doesnt let me....so i am stuck
    Sunday, October 30, 2011 1:30 AM
  • Try to take the ownership of the root folder or root drive, it seems that the ownership of the drive is with trusted installer service.

    Note:In the Windows Server® 2008 and Windows Vista® operating systems, most of the operating system files are owned by the TrustedInstaller security identifier (SID), which is the only SID that has full control over them. The purpose is to prevent a process that is running as an administrator or under the LocalSystem account from automatically replacing the operating system files. To delete an operating system file, you need to take ownership of the file and then add an access control entry (ACE) on the file that permits you to delete it.

    Reference KB:http://technet.microsoft.com/en-us/library/cc731677(WS.10).aspx

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    • Marked as answer by MI32 Sunday, October 30, 2011 7:29 PM
    Sunday, October 30, 2011 2:18 AM
  • Hi MI32,

    As you already performed the registry settings and still issue persist. So as santosh suggested above, the question is more related to Windows 7, please post this question in the Windows 7 Forum:

    http://social.technet.microsoft.com/Forums/en/category/w7itpro

    Regards,
    Abhijit Waikar.
     -------------------------------
    MCSA|MCSA:Messaging|MCTS|MCITP:SA
    My Blog: http://abhijitw.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

     

     

    Sunday, October 30, 2011 4:14 AM
  • i had this issue. the solution which i found was logging in to the roaming profile user credentials and restart the system . you have to do this sevaral times. ( Login and restart  )
    Monday, October 31, 2011 5:47 AM
  • VM thanks for your reply.....how do you log into the roaming profile? can you please explain an little bit more indepth I am have  a brain fart...

     

    Thanks for your time and help

    ehunt

    Tuesday, November 01, 2011 11:29 PM
  • there is northing difference in loging from roaming and normal user profile. you can login as same as normal user profile.

    that is by giving the below credential format

     

    username: domain.com\username

    password: **********

     

    after you login.. it will take long time for the first time you login. and you can make sure that roaming profile is working.

    Friday, November 04, 2011 4:10 AM