none
x64 Win 2008 SP2: Only Legacy NIC works

    Question

  • Have a HP Pro Liant ML 370 Hyper-V Host with a HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter, running on x64 Windows Server 2008 SP2 Core installation, Enterprise Edition.

    Have created a new virtual machine and installed x64 Windows Server 2008 standard with integrated SP2 (Volume Licence, MSDN download DVD). The installation worked fine, the virtual machine gets an IP address, but IP v4  connectivity is limited: Can only ping the VM itself and the Hyper-V Host where the VM is running on, but no other machines.
    - Have reinstalled the integration services, same problem.
    - Have created a new VM with Windows XP SP3. This machine has no connectivity problems at all with a Standard Hyper-V NIC.
    - Have removed the network adapter from the W2008 VM, added a "legacy network adapter", and the connectivity problem was solved!
    - Have removed the "legacy network adapter", added a standard network adapter. After starting the W2008 VM, the machined detected a "Microsoft virtuakl machine bus network adapter #2", and the connectivity problem is here again!
    - Have verified the eventlogs of the hyper-v host and of the Windows 2008 server guest. There is absolutely no hints why the guest has no connectivity.

    My questions:
    - Has anyone an idea why only a legacy network adapter is working on a x64 Windows 2008 server with sp2 VM?
    - Before posting this, I googeled and found that problems like this can arise when "TCP offloading" features are enabled on a hyper-v host. Has anyone a hint how to disable TCP offloading on a hyper-v host that is running on server core?

    Thank you all in advance for any help.
    Franz
    Thursday, July 16, 2009 8:55 AM

Answers

  • Thank you all for your help, your assumptions where right, it's a NIC issue. Have installed a two year old HP NIC (HP NC 360T) and removed the NIC that was preinstalled and delivered with the brand new ML370 G6 System (HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter) and the Hyper-V guests run fine with the standard network adapter, with all offloading options enabled.

    Franz
    Tuesday, July 21, 2009 2:53 PM

All replies

  • Hi Franz,

    Can you disable NIC teaming and retry if the problem still persist?

    Here is some info that i found:-

    You can only enable/disable the TCP-IP Chimney Offloading settings per host, not per interface.
    The following command disables it:

    netsh interface tcp set global chimney=disabled
       

     

    Alternatively you can make a REG_DWORD registry value named EnableTCPChimney in HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters. The data for this registry entry would read 1 by default, which would mean enabled. Removing the value returns it to enabled. To disable TCP Chimney Offloading change the data to 0, which resembles disabled. When setting TCP-IP Chimney offloading through registry you need to reboot your Server Core box to make your registry changes take effect.

      
    It is recommended not to change this setting on Hyper-V hosts.
    You can change the setting when you experience problems or when you want to enable backward compatible networking.

    Hope this info is useful.


    laiys
    Thursday, July 16, 2009 1:37 PM
  • Hello,

    I would disable TCP Offloading and also any other offloading on the NIC.  Examples include receive side scaling, large send offload, etc.  This was the cause of the issue in another post:

    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/480f739a-b091-4694-b3bd-3f16e0f212e4

    Thanks,

    Nathan Lasnoski
    Thursday, July 16, 2009 2:30 PM
  • Hi laiys

    Thank you for your help.

    I have a server core installation, automatically created with HP Smartstart V8.25. I nearly sure that teaming is disabled: when running "netsh interface show interfaces", i'm getting the following output:

    Admin State    State          Type             Interface Name
    ----------------------------------------------------------------------
    Enabled        Disconnected   Dedicated        Local Area Connection
    Enabled        Disconnected   Dedicated        Local Area Connection 2
    Enabled        Disconnected   Dedicated        Local Area Connection 3
    Enabled        Connected      Dedicated        Local Area Connection 4
    Enabled        Connected      Dedicated        Local Area Connection 6

    I suppose that there would be a "HP teaming adpater" or something similar when teamin is enabled. IF teaming would be enabled, there is no way to reomve it from a server core installation, according to HP: http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01663264/c01663264.pdf

    Have now run "netsh interface tcp set global chimney=disabled", have got "OK", rebooted the hyper-v host.

    Unfortunately, no change: Only "Legacy NIC's" are working. In the opposite of my initial post, the Windows XP machine doesn't work as well without a Legacy NIC (the machine was initially configured with a legacy NIC). Altought it's not exactly the same: in the Windows XP guest, I can ping another machine, but an SMB connection to another machine doesn't work.

    Don't think that this is a HP problem, our System, an ML 370 G6 seems one of the most sold server these days.

    Thank you all in advance for any more help.
    Franz
    Thursday, July 16, 2009 2:49 PM
  • Definately validate teaming is not active in any way.  Also, go into the actual properties of the adapter and check offloading as well.

    Thursday, July 16, 2009 2:54 PM
  • That post from Sander is very useful in regards to Chimney (which is an R2 feature), however.. 

    Chimney and the TCPOffloading that we are referring to is not the same thing.  The cases where Chimney actually kicks in are really pretty small, the vast majority of the time it is never touched.

    Leaving Chimney on very rarely has a negative impact.

    TCPOffloading (checksum, large send, etc.) can cause problems.  As it does more to affect how packets flow.

    Check this out:
    http://social.technet.microsoft.com/Forums/en-US/winservercore/thread/d0c55df9-a27c-4876-bc5a-8ac7f1b46462
    http://msdn.microsoft.com/en-us/library/aa938424.aspx


    Brian Ehlert (hopefully you have found this useful)
    Thursday, July 16, 2009 3:22 PM
  • Thank you all for your help!

    Unfortunately, the problem is still here.

    - Have changed all *TCPChecksumOffloadIPv4 Parameters fof all physical NIC's rom 3 to 0 (although the Keys "(HKLM\System\CurrentControlSet\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\00<Index>" that are mentioned in the post above don't exist, have found them at HKLM\System\CurrentControlSet\Control\Class.. on our hyper-v host).
    - Have changed the Key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters\DisableTaskOffload from the initial value 255 (decimal) to 1 (according http://msdn.microsoft.com/en-us/library/aa938424.aspx: "Setting this value to one disables all of the task offloads from the TCP/IP transport. Setting this value to zero enables all of the task offloads. "
    - Rebooted the system (cold boot)

    After these configuration changes, I have the following situation:

    - A Windows XP SP3 VM has now full connectivity with the standard hyper-v network adpater
    - A x64 Windows 2008 Server still does only work with the legacy NIC.

    Thank you all in advance for any further help! Have to find a solution for this problem, the legacy NIC is about 20 times slower (file copy) than a copy operation from the same server directly to the hyper-v host.

    Franz
    Friday, July 17, 2009 10:28 AM
  • Hi Frank,

    Pls refer to http://h71028.www7.hp.com/enterprise/cache/458915-0-0-0-121.html to check compatibility with Hyper V. If you're using ML370, then some model is not supported for Hyper V.

    Pls check the above link for compatibility as you did not mention your machine belong to which ML370 G <no> ? 

    Thanks
    laiys
    Friday, July 17, 2009 2:01 PM
  • Hi Laiys

    Our System is even certified for Windows Server 2008, X64: http://www.windowsservercatalog.com/item.aspx?idItem=571b8468-1faa-60e6-aba0-6f37ced8edc9&bCatID=1282 
    Friday, July 17, 2009 2:28 PM
  • Have you installed any of the HP maangement agents or NIC drivers or NIC teaming software?

    These can cause issues depending of hte support for Hyper-V as well as the capabilities of the hardware (the NIC) itself.

    Most likely, removing any teaming or other 3rd party drivers is worth a shot.
    Brian Ehlert (hopefully you have found this useful)
    Friday, July 17, 2009 2:58 PM
  • I have a server core installation, automatically created with HP Smartstart V8.25. I nearly sure that teaming is disabled: when running "netsh interface show interfaces", i'm getting the following output:

    Admin State    State          Type             Interface Name
    ----------------------------------------------------------------------
    Enabled        Disconnected   Dedicated        Local Area Connection
    Enabled        Disconnected   Dedicated        Local Area Connection 2
    Enabled        Disconnected   Dedicated        Local Area Connection 3
    Enabled        Connected      Dedicated        Local Area Connection 4
    Enabled        Connected      Dedicated        Local Area Connection 6

    I suppose that there would be a "HP teaming adpater" or something similar when teamin is enabled. IF teaming would be enabled, there is no way to reomve it from a server core installation, according to HP: http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01663264/c01663264.pdf

    - Can anyone tell me if the output above indicates clearly that teaming SW is not installed?
    - If the output doesn't prove that teaming software is not installed: How do I verify on a server core installation that teamin SW is not installed?

    Thank you all in advance for your help
    Friday, July 17, 2009 3:08 PM
  • If you go into the adapter properties do you see the offloading is enabled (as well as receive side scaling)?  It's not just the TCP offloading, but the other offloading as well.  Also, the HP network configuration utility can be removed, which can eliminate a factor.

    Nathan Lasnoski
    Friday, July 17, 2009 6:34 PM
  • Hi Nathan, would be very grateful if you can tell me how to edit the "network adapter properties" on server 2008 core. Have disabled "receive side scaling" with the command "netsh int tcp set global rss = disabled". Unfortunately, it doesn't help.

    Franz
    Monday, July 20, 2009 12:19 PM
  • Go to:

    Select "Start" => right click "Network" => "properties"
    Select "Change Adapter Settings"
    Right click the network card and select "properties"
    Select "configure" on the NIC
    Select "advanced"

    There you can turn off any offloading

    Thank you,

    Nathan Lasnoski

    Monday, July 20, 2009 1:36 PM
  • I have Windows Server 2008 Core installation (no start button, no task bar, no desktop, just a command window).
    Monday, July 20, 2009 1:47 PM
  • Thank you Nathan, the link above is very helpful!
    Monday, July 20, 2009 2:50 PM
  • Thank you all for your help, your assumptions where right, it's a NIC issue. Have installed a two year old HP NIC (HP NC 360T) and removed the NIC that was preinstalled and delivered with the brand new ML370 G6 System (HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter) and the Hyper-V guests run fine with the standard network adapter, with all offloading options enabled.

    Franz
    Tuesday, July 21, 2009 2:53 PM
  • Hi to all

    Some additional information (hoping that some folks can save the hours that we have spent for solving this issue):

    - the NC375i Quad Port NIC that is automatically delivered with new HP ML 370 G6 systems does NOT work with Hyper-V. This NIC is also missing in the list of supported NIC's in the Whitepapers of HP concerning Hyper-V and Windows Server 2008 with SP2: http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01516156/c01516156.pdf und http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00710606/c00710606.pdf.

    - Have opened a HP support call for this issue. HP confirmed that this NIC does not work (explication from HP: Most people are using VMWare for virtualization). After telling that we are very disappointed that a brand new HP server does not work with Windows server 2008 x64 with SP2 and Hyper-V, we have got a NC364T Quad port NIC for free. This NIC works without any problems with Hyper-V, and is also listened in the HP Whitepapers that I mentioned above.

    Franz

    Thursday, August 13, 2009 9:28 AM
  • Hello to you all,

     

    First of all: HP tells on it specs (Belgium site)that the server is compatible for Windows® Server Hyper-V

    http://h10010.www1.hp.com/wwpc/be/nl/sm/WF06a/15351-15351-241434-241477-241477-3884310.html

    So it’s a shame that this is not the case in reality.

     

    However, after being on the Phone with HP for a whole day an doing (a lot) research ourselves, we did find a workaround for  the NC375i issue. (HP refused giving me another/compatible NIC)

     

    On every interface you did create a virtual network, you must go to the advanced settings and disable 3 things:

    -ipv4 Checksum offload

    -TCP Checksum offload IPV4

    -TCP Connection offload

     

    !!!Remark:

    -Used driver= 4.0.406.0  or  4.0.505.0. The latest 4.0.505.12405 gives trouble again.

    -We do not install the "HP Network Configuration Utility"

     

     

    With this config we have several ML/DL370G6(NC375i) in production running Hyper_v with only some performance issues so far.

     

    What terrifies me is that the latest driver (posted 2 months after reporting the issue) is also giving problems with this workaround L So it seems that HP does not take this issue seriously.

     

    Update (september 29): It seems we getting replacements(NC364T) for our NC375i from HP after all.

     
    Ivan Henderix

     

     

     

     

    • Edited by Ivanhoe007 Tuesday, September 29, 2009 9:41 AM update
    Wednesday, September 23, 2009 11:49 AM
  • Ivanhoe007.

    Did you get your NC364T's installed and working? I'm having the exact same problems as described in this thread and have done everything possible regarding disabled Offloading, RSS etc.

    The kicker, everything was working fine in 2008. We recently upgraded the Hyper-V server to 2008 R2 and these problems have arisen.
    Sunday, December 06, 2009 7:54 PM
  • I have had the exact same problem with NC375 Integrated Quad Port Multifunction Gigabit Server Adapter on a Proliant ML370 G6 running Window Server 2008 R2 with Hyper-V installed as a Role.

    Long story short, after about 36 hours of troubleshooting and after opening incidents with Microsoft and HP the solution was to install the latest drivers for this NIC from HP's website. The drivers are not listed uner W2k8R2 but under W2k8 x64, and that's why I didn't see them.You can find them under http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=ca&prodTypeId=15351&prodSeriesId=3884310&prodNameId=3884311&swEnvOID=4024&swLang=13&mode=2&taskId=135&swItem=MTX-0002a4c0d0554582a856a73917

    They are called HP NC-Series QLogic nx3 Multifunction Driver for Windows Server 2008 x64 Editions  4.0.520.13471 dated 8 Feb 2010.

    Under the Fixes tab it says: This driver addresses an issue where virtual machine networks were not communicating on some ports of NC375x devices.

    It sure worked for me.

    tx,
    Mircea
    Saturday, March 06, 2010 10:07 PM