none
RDP issues after window 7 security updates

    Question

  • I am having problems connecting remotely to my work computer but this used to work up to 2.5  weeks ago. The only change I can think of is the series of recent security updates for remote login vulnerability. The bizzare thing is that while I can connect  from some computers, I cannot connect from 2 others (one from home + one from another office) which I normally use before now.

    The security update note says "A security issue has been identified that could allow an unauthenticated remote attacker ...... How is the unauthenticated remote attacker identified as it seems I am being treated as one. Is there a group for this on my computer? The problems is that it doesn't even allow me to get to the stage at which I will put in my credentials.

    Version - Windows 7 Enterprise

    Friday, March 23, 2012 3:14 PM

Answers

All replies

  • Install the latest windows updates, then, to test under system properties under remote allow connections running any "version of remote desktop".

    Saturday, March 24, 2012 2:15 PM
  • Hi,

    Thanks for your posting.

    Please check your Remote setting at your work computer: Computer-->Properties-->Remote settings-->Remote Desktop

    Which checkbox have you selected?

    If the Allow connections only from computers running Remote Desktop with Network Level Authentication checkbox is selected and is enabled, only computer that support Network Level Authentication can establish a remote desktop connection.

    To use Network Level Authentication, you must meet the following requirements:

    • The client computer must be using at least Remote Desktop Connection 6.0.
    • The client computer must be using an operating system, such as Windows 7, Windows Vista, or Windows XP with Service Pack 3, that supports the Credential Security Support Provider (CredSSP) protocol.
    • The RD Session Host server must be running Windows Server 2008 R2 or Windows Server 2008.

    To determine whether a computer is running a version of Remote Desktop Connection that supports Network Level Authentication, start Remote Desktop Connection, click the icon in the upper-left corner of the Remote Desktop Connection dialog box, and then click About. Look for the phrase Network Level Authentication supported in the About Remote Desktop Connection dialog box.

    For more information please refer to following MS articles:

    Configure Network Level Authentication for Remote Desktop Services Connections
    http://technet.microsoft.com/en-us/library/cc732713.aspx
    Using Remote Desktop
    http://technet.microsoft.com/en-us/library/cc742816.aspx


    Lawrence

    TechNet Community Support

    Monday, March 26, 2012 5:33 AM
    Moderator
  • Thanks for your replies.

    I have not changed any system settings and checking again now, the only selected option under remote setting is - Allow connections from computers running any version of  Remote Desktop (less secure).

    I believe it has been like this ever since. Will the option to use Network Level Authentication make any difference?

    Is the windows security update able to change any of this settings?

    The ultimate question.....as I stated above, is there a group I have to be put to not to be treated as an "unauthenticated remote attacker"?

    Monday, March 26, 2012 12:20 PM
  • Hi,

    Did you try below mentioned KB's?

    http://www.microsoft.com/download/en/details.aspx?id=11625

    Regards,

    _Prashant_


    MCSA|MCITP SA|Microsoft Exchange 2003 Blog - http://prashant1987.wordpress.com Disclaimer: This posting is provided AS-IS with no warranties/guarantees and confers no rights.

    Monday, March 26, 2012 12:32 PM
  • Thanks..but the link is for download of another update. Do you mean to say the update could resolve my inability to RDP to my PC?

    Again, it was released last year July but I have installed updates this year and I believe they will 'supersede' the one from last year

    Can I also say I am on Windows 7 and not XP
    • Edited by dapogbite Monday, March 26, 2012 2:03 PM
    Monday, March 26, 2012 12:53 PM
  • I have traced this to lots of updates that happened on 15/03/2012 because the last time I was able to connect without issues was on the 14th . I tried to remove the security updates and tried RDP connection but no luck.

    As I am 98% certain it was caused by the updates on the 15th (or those on 26th), I might have to uninstall all the updates for all products for that day ( about 33 of them)

    Monday, March 26, 2012 1:40 PM
  •  I would think the best thing to do would be to bring the system fully up to date with ALL of the latest patches and then continue troubleshooting.

    RDP works great in windows 7 I use it on a daily basis. I bet your entering the wrong login credentials or there's a cached credential that is causing the inability to login.


    Regards, Bill

    Tuesday, March 27, 2012 4:14 AM
  • I have all windows updates installed as I always install them once they are released. I am going to have to think twice and 'examine' all updates manually from now because of  this issue and the bad thing is that I haven't got a backup to restore to.

    I am 100% certain I am entering the correct credentials but by the way, how do I clear any cached details etc.

    I can see on here that people have been able to resolve issues like this in the past by deleting the updates and once it works, installing them one by one to find the one causing problems

    Tuesday, March 27, 2012 8:32 AM
  • Thanks all for your inputs.

    This has now being resolved. For some reasons, the computer starts getting into standby mode thereby making me not able to RDP to it while some people can.

    Tuesday, March 27, 2012 12:27 PM
  • Hi,


    Thanks for your update. Glad to hear that the issue has been resolved.

    Have a nice day.



    Lawrence

    TechNet Community Support

    Wednesday, March 28, 2012 2:29 AM
    Moderator