none
Excahnge Server 2003 - VPN mail not working

    General discussion

  • We have Exchange 2003.  In the past the OWA didnt work. So for people to pick up their email we set up a vpn connection. When users pick up their email via vpn what they are essentionally doing is creating network between their phone and the E. server and then pick up their email becasue they are physically connected to the network.  To VPN we create an account for them on our linux computer so they can connect to the network. They come in via the linux get an IP address from our DHCP on a windows2003 server and thats it.

    Recently we got OWA to work.  When the OWA started working I think the users who in the past used their Iphone or other devices to vpn in and pick up their mail stopped working. Part of the process to get the OWA working was to use ProxyPass to get through the back door to the exchange server inside the network. Here is the code we use. I provide it just to be thorough below. BTW. a.b.c.d. is to be replaced with my internal IP address. The linux is SME/Esmith linux. Its kind of a appliance that does certain things, firewall, mail filtering and so on.

    IM not that sure what the proxy pass does in detail accept it allows people to come to https://myserver.com/exchange and it moves people from their to the exchange server owa.

    Im wondering if some how setting up proxy pass has mess with the way the mail is picked up so that the iphone's cannot pick up their email. I just dont now. I do believe that the the vpn connection is making a connection to the linux comptuer. I verify this by creating a vpn connection with the same pw etc that the phone users use then browsing to an internal web page. This works which means that the vpn is making a connection to the linux computer and connecting up.

    Can anyone provide any feedback on this. Why after I got OWA working (with Proxy Pass)  did my vpn/emal pickup stop working.

    Thanks.

    -----------------------------------

    mkdir -p /etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf
    cd /etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf
    echo '# ProxyPass Support for Internal Exchange Server
    ProxyPreserveHost On

    #OWA % character in email subject fix
    RewriteEngine On
    RewriteMap percentsubject int:escape
    RewriteCond $1 ^/exchange/.*\%.*$
    RewriteRule (/exchange/.*) ${percentsubject:$1} [P]

    #OWA
    ProxyPass /exchange https://a.b.c.d/exchange
    ProxyPassReverse /exchange https://a.b.c.d/exchange
    ProxyPass /Exchange https://a.b.c.d/exchange
    ProxyPassReverse /Exchange https://a.b.c.d/exchange
    ProxyPass /exchweb https://a.b.c.d/exchweb
    ProxyPassReverse /exchweb https://a.b.c.d/exchweb
    ProxyPass /public https://a.b.c.d/public
    ProxyPassReverse /public https://a.b.c.d/public
    ProxyPass /iisadmpwd https://a.b.c.d/iisadmpwd
    ProxyPassReverse /iisadmpwd https://a.b.c.d/iisadmpwd

    #OMA
    ProxyPass /oma https://a.b.c.d/oma
    ProxyPassReverse /oma https://a.b.c.d/oma

    #ActiveSync (for WM5+ devices)
    ProxyPass /Microsoft-Server-ActiveSync https://a.b.c.d/Microsoft-Server-ActiveSync
    ProxyPassReverse /Microsoft-Server-ActiveSync https://a.b.c.d/Microsoft-Server-ActiveSync

    #Force 'RequestHeader' in order to get IE to work
    # End of Exchange settings
    ' > 91ProxyPassOWA
    expand-template /etc/httpd/conf/httpd.conf
    sv restart httpd-e-smith

    -----------------------------------------------------------

    Sunday, June 16, 2013 10:21 AM

All replies