none
WSUS installed on Windows server 2012: Clients won't be able to access server

    Question

  • Hello,

    after installing wsus on a server 2012 the clients are not able anymore to connect to wsus:

    2013-02-07 09:51:58:257 1376 6e8 AU AU received policy change subscription event
    2013-02-07 09:52:28:412 1376 7ac AU Triggering AU detection through DetectNow API
    2013-02-07 09:52:28:412 1376 7ac AU Triggering Online detection (non-interactive)
    2013-02-07 09:52:28:412 1376 6e8 AU #############
    2013-02-07 09:52:28:412 1376 6e8 AU ## START ##  AU: Search for updates
    2013-02-07 09:52:28:412 1376 6e8 AU #########
    2013-02-07 09:52:28:412 1376 6e8 AU <<## SUBMITTED ## AU: Search for updates [CallId = {FA5F45C5-2E72-4C29-8A55-631A10159803}]
    2013-02-07 09:52:28:412 1376 189c Agent *************
    2013-02-07 09:52:28:412 1376 189c Agent ** START **  Agent: Finding updates [CallerId = AutomaticUpdates]
    2013-02-07 09:52:28:412 1376 189c Agent *********
    2013-02-07 09:52:28:412 1376 189c Agent   * Online = Yes; Ignore download priority = No
    2013-02-07 09:52:28:412 1376 189c Agent   * Criteria = "IsHidden=0 and IsInstalled=0 and DeploymentAction='Installation' and IsAssigned=1 or IsHidden=0 and IsPresent=1 and DeploymentAction='Uninstallation' and IsAssigned=1 or IsHidden=0 and IsInstalled=1 and DeploymentAction='Installation' and IsAssigned=1 and RebootRequired=1 or IsHidden=0 and IsInstalled=0 and DeploymentAction='Uninstallation' and IsAssigned=1 and RebootRequired=1"
    2013-02-07 09:52:28:412 1376 189c Agent   * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7} Managed
    2013-02-07 09:52:28:412 1376 189c Agent   * Search Scope = {Machine}
    2013-02-07 09:52:29:099 1376 189c Misc Validating signature for C:\WINNT\SoftwareDistribution\SelfUpdate\Default\wuident.cab:
    2013-02-07 09:52:29:193 1376 189c Misc  Microsoft signed: Yes
    2013-02-07 09:52:29:334 1376 189c Misc WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80190194
    2013-02-07 09:52:29:334 1376 189c Misc WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80190194
    2013-02-07 09:52:29:334 1376 189c Misc WARNING: DownloadFileInternal failed for http://hostname/selfupdate/wuident.cab: error 0x80190194
    2013-02-07 09:52:29:334 1376 189c Setup FATAL: IsUpdateRequired failed with error 0x80244019
    2013-02-07 09:52:29:349 1376 189c Setup WARNING: SelfUpdate: Default Service: IsUpdateRequired failed: 0x80244019
    2013-02-07 09:52:29:349 1376 189c Setup WARNING: SelfUpdate: Default Service: IsUpdateRequired failed, error = 0x80244019
    2013-02-07 09:52:29:349 1376 189c Agent   * WARNING: Skipping scan, self-update check returned 0x80244019
    2013-02-07 09:52:29:787 1376 189c Agent   * WARNING: Exit code = 0x80244019
    2013-02-07 09:52:29:787 1376 189c Agent *********
    2013-02-07 09:52:29:787 1376 189c Agent **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
    2013-02-07 09:52:29:787 1376 189c Agent *************
    2013-02-07 09:52:29:787 1376 189c Agent WARNING: WU client failed Searching for update with error 0x80244019

    And the following links are not working from the browser:

    • http://hostname/iuident.cab
    • http://hostname/selfupdate/iuident.cab
    • http://hostname/SimpleAuthWebService/SimpleAuth.asmx

    any hints?

    Thursday, February 07, 2013 10:27 AM

Answers

  • Uff, that simple! But what is the reason, microsoft changed the port?

    And that's the question of the decade.
    Right now I did not find any document, what the advantage and what way to go..
    So, originally, WSUS was configured to support installation on port 80 because the legacy Automatic Updates client, that shipped with Windows 2000 and early versions of Windows XP, could only communicate on port 80. However, installing WSUS on port 8530 is a much more secure option (anything not installed on port 80 is more secure by definition). However, because of the legacy AU client quesiton, portions of WSUS were always replicated to port 80. With the introduction of WSUS v6 on Windows Server 2012, and the elimination of the need to support pre-XPSP3 clients, there is no longer any need for any portion of WSUS to be installed on port 80, so my *GUESS* is that the WSUS product team just imposed their "best security practices" philosophy on Win2012 users and defaulted the installation to port 8530. This also completely eliminates a number of other 'conflicts' that many WSUS admins had to deal with concerning other products (Symantec Endpoint Protection, along with a number of which install their own Apache server) that did not play so well together on port 80 - including Microsoft's own Windows Sharepoint Services.

    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Friday, February 08, 2013 12:19 AM
    Moderator
  • 0x80244019 - WU_E_PT_HTTP_STATUS_NOT_FOUND - Same as HTTP status 404 – The server cannot find the requested URI (Uniform Resource Identifier).

    Check that you change your WSUS host name in GP and GP successfully applied to your clients. Also check that if you use 8530port it also presented in GP settings


    Maxim Sinel'nikov


    Thursday, February 07, 2013 12:02 PM

All replies

  • additonal info:

    wsus admin console works, updates are avaiable.. but no clients in the list

    :-(

    Thursday, February 07, 2013 10:52 AM
  • 0x80244019 - WU_E_PT_HTTP_STATUS_NOT_FOUND - Same as HTTP status 404 – The server cannot find the requested URI (Uniform Resource Identifier).

    Check that you change your WSUS host name in GP and GP successfully applied to your clients. Also check that if you use 8530port it also presented in GP settings


    Maxim Sinel'nikov


    Thursday, February 07, 2013 12:02 PM
  • Uff, that simple! But what is the reason, microsoft changed the port? There are descriptions to change it back to port 80. Right now I did not find any document, what the advantage and what way to go..

    Cheers,

    sto


    • Edited by mtstocker Thursday, February 07, 2013 4:31 PM
    Thursday, February 07, 2013 4:18 PM
  • Uff, that simple! But what is the reason, microsoft changed the port?

    And that's the question of the decade.
    Right now I did not find any document, what the advantage and what way to go..
    So, originally, WSUS was configured to support installation on port 80 because the legacy Automatic Updates client, that shipped with Windows 2000 and early versions of Windows XP, could only communicate on port 80. However, installing WSUS on port 8530 is a much more secure option (anything not installed on port 80 is more secure by definition). However, because of the legacy AU client quesiton, portions of WSUS were always replicated to port 80. With the introduction of WSUS v6 on Windows Server 2012, and the elimination of the need to support pre-XPSP3 clients, there is no longer any need for any portion of WSUS to be installed on port 80, so my *GUESS* is that the WSUS product team just imposed their "best security practices" philosophy on Win2012 users and defaulted the installation to port 8530. This also completely eliminates a number of other 'conflicts' that many WSUS admins had to deal with concerning other products (Symantec Endpoint Protection, along with a number of which install their own Apache server) that did not play so well together on port 80 - including Microsoft's own Windows Sharepoint Services.

    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Friday, February 08, 2013 12:19 AM
    Moderator
  • This works, 8530 must be added in group policy as the new port number of the WSUS server!
    Thursday, May 16, 2013 2:50 PM