none
Can't connect to Server 2012 RC remotely using server manager

    Question

  • Installed RSAT for Windows 8 RC on my Windows 8 Machine.

    Installed Windows Server 2012 Core on another.

    First found out i couldn't see Server 2012 through server manager.

    Tried to follow this guide to add Server 2012:

    http://technet.microsoft.com/en-us/library/hh831453.aspx

    Get the following error when i run the command even when running in admin mode: 

    set-item wsman:\localhost\Client\TrustedHosts -value "$curValue, Server01"
    set-item : WinRM cannot process the configuration request. The hostname pattern is invalid: "" Hostname patterns must
    contain one or more patterns. A pattern can contain at most one wildcard ("*"). The special pattern "<local>" can be
    used to indicate all hostnames that do not have a '.'. To trust all hosts use "*" as the only pattern.
    At line:1 char:1
    + set-item wsman:\localhost\Client\TrustedHosts -value "$curValue, Server2012"
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Set-Item], InvalidOperationException
        + FullyQualifiedErrorId : System.InvalidOperationException,Microsoft.PowerShell.Commands.SetItemCommand

    I tried to run the following erroring command again after running: 

    New-ItemProperty -Name LocalAccountTokenFilterPolicy -path HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System -propertyType DWord -value 1

    and i still got the error.

    Both machines are in the same private network. I tried to connect using both the IP & Computer name and neither work. I can't ping the Server2012 box but i think this is a security precaution.

    Any help would be appreciated.

    Sunday, June 17, 2012 5:26 AM

All replies

  • Are both RSAT and ServerCore machines in same domain? If yes, you can use "Add Servers" option in ServerManager console, available in RSAT machine, to manage your ServerCore.

    Regarding the error you getting when running the powershell cmdlet "Set-Item" - can you just simply type $curValue in a powershell window and update what is the value shown?

    Tuesday, June 19, 2012 7:22 PM
  • Well in the same workgroup not a domain (i run a workgroup not a domain). I tried to add the server with both the IP address & machine name and both fail. I can get the exact error message when i get home if you would like.  Do you have to open the firewall to allow a remote machine to connect with server manager or is it setup to allow this by default on a private network? I noticed i couldn't even ping the Server 2012 machine which according to this is probably a security feature:

    http://techpunch.wordpress.com/2008/11/17/windows-server-2008-cant-ping-the-server/

    I was trying the powershell commands above because it wasn't working. Do i really need to run them? I would think connecting with server manager remotely should be straight forward but it hasn't been so far.

    Tuesday, June 19, 2012 7:54 PM
  • Hello Choclabs74

    For a workgroup machine managing another, you need to configure the trusted host setting as mentioned in http://technet.microsoft.com/en-us/library/hh831453.aspx (I see you already tried that)

    Can you post the details of following commands from the machine running your Server Manager console?

    get-item wsman:\localhost\Client\TrustedHosts


    Wednesday, June 20, 2012 4:24 PM
  • The command you're using is designed to prevent existing entries in the TrustedHosts list from being wiped out or overwritten.  If you don't have existing entries in the TrustedHosts list, then errors might occur because the command is looking for the current values.

    Try this command instead.  I have updated the Help topic in the TechNet Library with this, too.

    Set-Item wsman:\localhost\Client\TrustedHosts ServerName -Concatenate -Force

    The preceding command will also add values to an existing list, but it should not fail if there are no existing entries in the TrustedHosts list yet.

    Wednesday, June 20, 2012 11:36 PM
  • Thanks everyone for the replies. Unfortuanely i had something else i had to concentrate on. So to start the conversation again here is my TrustedHost:

       WSManConfig: Microsoft.WSMan.Management\WSMan::localhost\Client

    Type            Name                           SourceOfValue   Value
    ----            ----                           -------------   -----
    System.String   TrustedHosts                                   Server2012

    I verified Server2012 is pickup up the correct ip/subnet. Do you think its the firewall on Server2012 that could be blocking?

    Thursday, July 05, 2012 3:14 PM
  • This is what i'm getting:

    Thursday, July 05, 2012 3:21 PM
  • Anyone? Its been over a week since i had a reply.
    Friday, July 13, 2012 5:29 PM
  • Hi,

    You are trying to add the server by DNS name but you local machine is not seeing this resolve to an IP address. In a CMD/PS window what does ping server2012 resolve to.  You can put the IP address of the server directly into this field and it should work.

    Cheers,
    Al


    -- Free AV for WHSv1 : http://whsclamav.sourceforge.net/ ---- The add-in won't work on WHS 2011/2

    Thursday, September 27, 2012 11:39 PM