none
Deleting "Desktop Gadget Gallery" from All User Program group

    Question

  • I want to delete this shortcut as well as the Windows Media Center one from the Start Menu|Programs location via GPP.

    I have done this successfully with the Anytime Upgrade, XPS Viewer, Fax and Scan, and DVD Maker shortcuts, but these two do not respond to any of the three options (File System Object, URL, or Shell Object). GPP action is set to "Delete".

    • Anytime Upgrade - Shell
    • XPS - Shell
    • Fax and Scan - File System
    • DVD Maker - File System

    I have tried all three choice for the Gallery and Media Center shortcut with no change. Any idea's?

    Friday, July 06, 2012 1:53 PM

Answers

All replies

    • To Disable desktop gadget Gallery:Either you can go for user/computer settings.
    1. Navigate to User Configuration > Policies > Administrative templates > windows components >Desktop Gadgets>Turn off desktop gadgets>enable. 
    2. Navigate to Computer Configuration > Policies > Administrative templates > windows components >Desktop Gadgets>Turn off desktop gadgets>enable.

    • To Disable Windows Media Center: Either you can go for user/computer settings.
    1. Navigate to User Configuration > Policies > Administrative templates > windows components >Windows Media Center>Do not allow Windows Media Center to run>Enable.
    2. Navigate to Computer Configuration > Policies > Administrative templates > windows components >Windows Media Center>Do not allow Windows Media Center to run>enable 


    Regards, Ravikumar P


    Saturday, July 07, 2012 8:30 AM
  • Hi,

    > I have done this successfully with the Anytime Upgrade, XPS Viewer, Fax and Scan, and DVD Maker
    > shortcuts, but these two do not respond to any of the three options (File System Object, URL, or Shell
    > Object). GPP action is set to "Delete".

    According to your description, you use group policy preference shortcut extension to delete “Windows Media Center” and “Desktop Gadget Gallery” shortcut.

    These two shortcuts located in “C:\ProgramData\Microsoft\Windows\Start Menu\Programs” by default with other shortcuts, but seem these two are different from other shortcuts. Since from address bar, after I type “C:\ProgramData\Microsoft\Windows\Start Menu\Programs\” I can see files listed in the folder, except these two shortcuts.

    As you mentioned, these two do not respond to any of the three options. So I think why not delete these two shortcut files using GPP file extension.

    You can deploy it in both Computer Configuration and User Configuration\Preferences\Windows Settings\Files\New File\Active: Delete\Delete file\ input the delete file path

    For more information please refer to following MS articles:

    Configure a File Item
    http://technet.microsoft.com/en-us/library/cc772536.aspx


    Lawrence

    TechNet Community Support

    Monday, July 09, 2012 7:14 AM
  • I've tried this, and still nothing. I have also turned off Desktop Gallery and Media Center via GPO policy, but that doesn't work either. This is a real head-scratcher.
    Saturday, July 14, 2012 12:44 PM
  • Did you run gpupdate/force command at DC command prompt, once you configured GPO?

    Regards, Ravikumar P

    Saturday, July 14, 2012 12:59 PM
  • Sure. I've also set up brand new computers with the policies in place. And of course, since the policies have been active for a week or so now, lots of computers have gone through multiple GPO refreshes and reboots. I think my next task will be to strip the existing GPO of these two removal targets and create a new GPO for the express purpose of figuring this out. I can create a Removal GPP for every possible method, one by one, until one or none of them prove to work.

    The thing that bother's me most is that when looking at these two shortcuts, they seem to be just regular dang file objects! 

    Saturday, July 14, 2012 1:06 PM

  • I have tried all three choice for the Gallery and Media Center shortcut with no change. Any idea's?

    The lnk file for the Gallery is called "sidebar.lnk". It shows up as "Desktop Gadgets Gallery" because of the desktop.ini file in the programs folder:

    [.ShellClassInfo]
    LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21782
    [LocalizedFileNames]
    Windows Fax and Scan.lnk=@%SystemRoot%\system32\FXSRESM.dll,-114
    Sidebar.lnk=@%ProgramFiles%\Windows Sidebar\sidebar.exe,-1005
    XPS Viewer.lnk=@%systemroot%\system32\XpsRchVw.exe,-102
    Windows Media Player.lnk=@%SystemRoot%\system32\unregmp2.exe,-4
    Windows DVD Maker.lnk=@%ProgramFiles%\DVD Maker\DVDMaker.exe,-61403
    Media Center.lnk=@%systemroot%\ehome\ehres.dll,-100

    This "desktop.ini mechanism" is heavily used in localized versions of Windows - the shortcuts all have the same names in all languages, but the display names in explorer are modified through language specific versions of the resources in shell32.dll/sidebar.exe and so on.

    This works only whe the containing folder (here: "Programs") has the attribute "Readonly" set. If you remove this attribute and restart explorer, the start menu will show the "real" file system names of the shortcuts.

    regards, Martin


    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Sunday, July 15, 2012 9:59 AM
  • Rav

    This might disable the applications from running but it does not remove the shortcuts from the start menu.

    • Edited by TCBS Thursday, June 12, 2014 8:49 AM
    Thursday, June 12, 2014 8:48 AM