none
How to reduce the Physical memory usage in windows server 2008 r2?

    Question

  • I am using Windows server 2008 r2, i am using a software COMSOL . whenever i run a model, my workstation utilizes all the physical memory i.e. 64GB but my CPU usage is just 2% at that time. How can i synchronise my physical memory and cpu so that my workstation utilizes 50% of physical memory and 50% CPU usage.
    Thursday, July 08, 2010 3:04 PM

Answers

  • Hello Mohd Abdullah Azeem,

    You could use WSRM   (Windows System Resource Manager).

    On the Memory tab, select either Use maximum committed memory for each process or Use maximum working set limit for each process, and type a number for the limit (in MB).

    For more information about memory allocations, see Understanding Memory Management in Windows System Resource Manager.

    Add or Edit Resource Allocation Dialog Box
    http://technet.microsoft.com/en-us/library/cc725852.aspx

    Best regards,
    Harry

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, July 08, 2010 3:23 PM

All replies

  • Hello Mohd Abdullah Azeem,

    You could use WSRM   (Windows System Resource Manager).

    On the Memory tab, select either Use maximum committed memory for each process or Use maximum working set limit for each process, and type a number for the limit (in MB).

    For more information about memory allocations, see Understanding Memory Management in Windows System Resource Manager.

    Add or Edit Resource Allocation Dialog Box
    http://technet.microsoft.com/en-us/library/cc725852.aspx

    Best regards,
    Harry

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, July 08, 2010 3:23 PM
  • Thank You i will try that . Is there a way i can increase the virtual memory and associate that memory with my ram so that my software can use it.
    Thursday, July 08, 2010 7:58 PM
  • Hi,

    You can change the size of Virtual Memory by right click Computer, choose Properties, click on Advanced System Properties, Advanced tab, click Settings under Performances, Go to Advanced tab, click Change, uncheck the box input the Min and Max number, click Set to apply.


    Shaon Shan| TechNet Subscriber Support in forum| If you have any feedback on our support, please contact tngfb@microsoft.com
    Friday, July 09, 2010 7:20 AM
    Moderator